« first day (3148 days earlier)      last day (1862 days later) » 

12:52 AM
Why won't this work? I need to see \prevdepth of a box (or a line in a paragraph).

\fbox{hello world}\the\prevdepth
%hello world\the\prevdepth % WON'T WORK EITHER
@bp2017 \prevdepth is not valid in horizontal mode (as \prevgraf is zero, like in your other question). \prevdepth will only have a value after a \par: \fbox{hello world}\par\the\prevdepth
OK, this worked as \parbox{40mm}{\prevdepth hello world} but outputs not quite what I was expecting. Why is it -1000pt? I was looking to get the depth of the previous horizontal box (or line).
@PhelypeOleinik, thank you.
@bp2017 That prints the same as \vbox{\the\prevdepth hello world}. I have no idea why, though... Anyone?
@bp2017 (and myself): -1000pt is a "magic" value at the beginning of the main vertical list and of a \vbox: tex.stackexchange.com/a/219089/134574
1:11 AM
@PhelypeOleinik, what do they mean by "magic"? A default?
@bp2017 Basically, yes. It's a place where \prevdepth is not invalid, as in the middle of a paragraph, but it's not valid either, so an absurd value is used as a kind of a flag.
@PhelypeOleinik, thank you.
How do you call a scratch integer register similar to \dimen255? Is it \count255, or is \count for counters?
I mean, what command is for integer registers.
@bp2017 Yes, \dimens and \counts are very similar in usage. \count255 is generally used as a scratch integer. LaTeX defines \countdef\count@=255, so \count@ is the same as \count255.
@PhelypeOleinik, thank you.
@bp2017 You're welcome!
Going to bed now. Good night!
1:29 AM
@PhelypeOleinik, good night!

Why \z generates error but \show\z doesn't?

\def\z{\z \dimen0}
%\show\z % WORKS
@bp2017 Because when you say \def\z{\z...} you are trying to recursively define \z which is not possible. But this only happens when the \z is actually expanded, which it's not if you use the primitive \show. You could also have written \noexpand\z in your document (which would have done nothing, but produced no error either.)
1 hour later…
2:53 AM
@AlanMunn, thank you. Then I wonder why the piece of code below contains (\noexpand\zpshape) equivalent to \noexpand\z from above example but yet appears to work because when that part is commented-out the output changes:

{ \the\numexpr#1+1\relax
{ \the\dimexpr#2+\zzindent
{ \the\dimexpr#3-\zzindent
{ #4#2#3%
{ #1#4

@DavidCarlisle, and what I find strange is that although \zcurrentshape is globally defined, it is never expanded anywhere but at
back to basics (reading TeX reference in hopes to clear things up)
@bp2017 Because that is a macro that is defined using \edef which expands its input at definition time. The \noexpand there prevents \zpshape to be expanded at that time; it will be expanded when the macro is used. You may want to read TeX by Topic (part of TeX Live) or the TeX Book (a real book you need to buy) for more information on these sorts of things.
@bp2017 For example, if you do \def\z{foo}\edef\z{\z foo}\z you will get foofoo as the output. So this is not recursive, since \z inside the \edef gets expanded to foo before the (new) \z is defined. On the other hand, if you do \def\z{foo}\edef\z{\noexpand\z foo}\z you will again get the error, since this is the same as saying \def\z{\z foo}, since the \noexpand prevents the expansion of \z in the \edef.
3 hours later…
5:44 AM
@AlanMunn, thank you.
6:13 AM
YouTube comment: The video is pizza. And the music is pineapple on top of it. I hate it.
@Dr.ManuelKuehner I think it happened due to this unexplained downvote: tex.meta.stackexchange.com/a/8327/101651. (Sorry if I have unwillingly contributed to @Mico decision)
@Dr.ManuelKuehner The downvote is not mine, I could have contributed with my comment
6:48 AM
@AlanMunn Very appropriate comment!
7:01 AM
@CarLaTeX I don't understand the comment at all. Perhaps it was mis-translated into English.
7:16 AM
@CarLaTeX but this said by someone who doesn't like pizza
@UlrikeFischer I understood it was said by someone who hates pineapple on pizza :)
@DavidCarlisle :P
7:44 AM
wohoo :)
@Marijn that's no palindrome.
@Skillmon true but I still like it :)
@Marijn joking aside: congratulations on reaching 10k.
8:11 AM
@UlrikeFischer fixed the css on that button:-)
@DavidCarlisle changed it to show a duck?
@UlrikeFischer for some reason they have removed the aria labelling (accessibility no longer important?) I used to have div[aria-label="ask new question"]{ display: none !important;} but now it needs div.pl8.aside-cta.grid--cell {display:none; !important}
@UlrikeFischer ^
@DavidCarlisle I need the button so that I can ask question that I can accept in the right moment ;-). But thinking about it a row of ducks or tikzlings with question marks instead of the dumb button would be nice.
@UlrikeFischer I don't just make that button go: also #newsletter-add and .add-container go (partly as I didn't want them but mostly as they have fixed-width stuff and I narrowed the sidebar so they no longer fitted....
8:36 AM
@DavidCarlisle which one are these? The "watched tag" box?
@UlrikeFischer can't remember really it was all done at the time of the change, one is a custom box just used for the stackexchange newsletter, the other is the community adds thing
8:50 AM
@DavidCarlisle I significantly reduced the width of that column in my setup:
9:09 AM
@Skillmon yes I wondered about making it narrower but actually usually I'm on a wide screen anyway and so once I'd got the main column as I wanted it I wasn't too bothered about the sidebar width, I changed the background colour as the ghost of the tex example images was too annoying with almost zero contrast:-)
1 hour later…
10:12 AM
@PauloCereda /*rabbit sounds*/
@Skillmon ooh rabbit sounds
@Skillmon hi mr. rabbit!
@AlanMunn ^^ :)
10:29 AM
@PauloCereda hi mr. duck!
10:42 AM
@CarLaTeX Thanks for the explanation. Let's try to keep him here.
1 hour later…
11:52 AM
I have something like: \begin{theorem}\itshape \bfseries\end{theorem}, but then my tag in \begin{equation}.. (under \theorem) is bold. I would like it to make it normal (regular). Can someone help me what to do? Thank you
@Cortizol by default it wouldn't be (as the default layout applies \normalfont to the equation number) so the answer is don't do whatever you are doing that makes \bfseries apply. Hard to guess what that is with no example....
12:07 PM
@DavidCarlisle I am writing my phd thesis, so I don't have concrete example. Basically, I have definition for theoremes, which is \begin{theorem}\itshape\bfseries\end{theorem}, and when I am typing some theorem and have equation in it (and some \label in equation), that label (tag) will be bold and italic in theorem (but in \eqref{} it is normal font). I don't know does it make it clearer.
@DavidCarlisle I see now this question: tex.stackexchange.com/questions/2381/…, so probably I can try something like that (i will see)
@Cortizol the problem statement was clear but as I say, that would not happen normally so you must have some local redefinitions (it is of course bad style to have \itshape\bfseries within the document but that is probably not relevant and you would see the same even if the font change was part of the theorem style.)
@DavidCarlisle All right, I will see my definitions again. Thanks
@Cortizol basically you must have redefined (broken) \@eqnum and/or \maketag@@@ somewhere.
12:34 PM
Why is \z zero? I would expect it to be 33.

\count255 3
@bp2017 You're getting an error with that, aren't you?
@PhelypeOleinik, no, I don't.
@bp2017 You are defining z to be \the\count 2553
@bp2017 Oh, ignore me. I was using tex, not pdftex.
@UlrikeFischer, no, I'm not.
@UlrikeFischer, or maybe, I am. But it works otherwise. Give me a second.
12:38 PM
@bp2017 yes you are. Try:

\count255 3
\count2553 7654

@bp2017 yes you are...
@bp2017 Yes you are! (just adding to the crowd :) Try also: \edef\z{\z\space\the\count255}
@UlrikeFischer good choice of variable name, I'd have expected \y from you.....
@DavidCarlisle I cringed a bit but greater ones should be faster so I hadn't the time to change to \blub.
@bp2017 you probably wanted \edef in both cases.
@bp2017 a more complete example:

\count255 1
\count2553 7654
\count255 3

7654: \z

\count255 1
\count2553 7654
\count255 3

33: \z

\count255 1
\count2553 7654
\count255 3

3 3: \z

\count255 1
\count2553 7654
\count255 3

13: \z

\count255 1
\count2553 7654
12:53 PM
@UlrikeFischer, I am sorry for being full of myself. Thank you.
@DavidCarlisle, thank you.
Now I need time to digest all of this (seems confusing).
@bp2017 you just need to remember that tex is a macro expansion language, there are no integers or strings, just lists of tokens that get replaced in line by their replacement texts, so if \the\count255 is going to expand to 3 then \the\count255\the\count255 is going to expand (first) to \the\count2553 and then to the value of that register, which is 7654 here.
@DavidCarlisle @bp2017 To add a crucial detail: When TeX reads the number after \count to figure out what counter register is being referred to, it reads with macro expansion until it finds a non-digit. That is why the second \the\count255 gets expanded first.
1:09 PM
Perfect place for \relax after the first \the\count255.
@bp2017 If you want z to be 33 instead of 3\relax 3 then use \space instead of \relax. But yes, that's one of the uses of \relax.
@bp2017 if you use \relax you can't use the \z in a \csname, \space is normally better.
Biblatex question: Can se use two different citation styles in the same document? I have a user where the requirement for a grant application that in some parts of the application, citations should be in footnotes, full text in the footnote. Then a section with "normal" citations (I currently do not know what normal is in this case, at least it is not in footnotes and presumably not full cite) and then back to footnotes again. (very strange requirement)
For the footnotes they are currently running style=verbose-ibid and using autocite.
@bp2017 no, not in general
@daleif You can use different \cite commands, like \footcite, \fullcite, \textcite .... And it is always possible to define a custom \cite command.
1:18 PM
@bp2017 general advice is never to use numbered registers like this in code, it is a common source of bugs. Use allocated registers, so \count@ is in fact \count255 but you do not need to know this and tex does not have to parse ahead for a following number to know it either. in classic tex it was good to re-use \count@ to avoid \newcount (as there are only 256 count registers) but with etex there are 32768 of them so it isn't an issue,
you could have used \newcount\zcount then replaced all \count255 by \zcount and had perhaps less surprising results
@UlrikeFischer, there is a scenario where space won't do, but I doubt anyone would use \relax after \z instead of after \the\count255 in the first definition:

\def\z{\the\count255} % space would work here
\edef\z{\z\relax\the\count255} % of course, \relax should've been in the line above, but still (space won't work here)
@bp2017 basically don't do \def\z{\the\count255} that is just a bug waiting to happen
@bp2017 \space will work but you need \space\space , as I showed in one of the examples above.
1:45 PM
@UlrikeFischer turned out \fullsite seemed independent of the style, so we just changed the overall style and used \footnote+\fullcite. works ok.
I'm not sure if one could actually switch from say numeric to aythor-year and back mid document
@daleif you could, assuming that there are numbers in the bib you can refer too -- with an unnumbered bib it wouldn't make much sense ;-)
2:14 PM
I thought that the way to user \DeclareMathOperator is \DeclareMathOperator{\Aut}{Aut}. Now I've seen \DeclareMathOperator{Aut}{Aut} in some posts on Stack Exchange. This is specific to MathJax, it does not work in LaTeX, right?
@MartinSleziak does it work or is it just silently ignored (in mathjax) ? (it doesn't work in latex
This question is an example: Automorphism group of ${\bf Z}_p$.
It has $\DeclareMathOperator{Aut}{Aut}\Aut(\bf Z_p) = (\bf Z_p)^\times =\bf Z_{p-1}$ in the (MathJax) source.
And to me it seems rendered just fine.
In fact, it seems that \newcommand works in the same way in MathJax (i.e., without backslash): math.meta.stackexchange.com/revisions/22127/16
I have just tried $\DeclareMathOperator{Aut}{Aut}$ $\Aut(X)$ and $\newcommand{Lim}{\operatorname{Lim}}$ $\Lim x_n$ in the linked sandbox.
@MartinSleziak there is a reason we don't have mathjax rendering enabled here, it isn't tex:-)
I am not saying that MathJax should be enabled on this site (or in this room).
@MartinSleziak I know, I just mean "differences are expected" (although I don't think I had noticed that one before)
2:27 PM
I was just surprised when I noticed the use of \DeclareMathOperator in this way in some post on Mathematics. (And only then it occurred to me to try also \newcommand.)
@MartinSleziak I sort of doubt it is intentional. It's relatively harmless, though, except if people get used to it on mathjax and then expect it to work in latex, they'll be disappointed.
2:59 PM
I'd say that there is a mixed view on this, but some users consider Mathematics Stack Exchange as a good place where they can teach LaTeX "by example". So there are a few people who edit the posts when there is something which words in MathJax but it is a bad practice in LaTeX. (Even if something works in LaTeX, but it's not recommended.)
BTW are these minor differences between MathJax and LaTeX (like the example above) collected somewhere?
@MartinSleziak not really, and how big the differences are depends a lot on your tex use. For many common document uses the syntax is similar enough that you can forget about it, but for the vast majority of the tex coding that comes up on this site, it doesn't apply at all to mathax as there is no tex there, so they just appear completely different and so documenting the differences is not really an aim.
3:16 PM
@MartinSleziak Ahoj Martin. No, not as far as I know.
And it's apparently not even mentioned in the documentation to mathjax
Any glossaries / persian experts for tex.stackexchange.com/q/495390/15925 My guess is makeglossaries / xindy need some specific language options.
3:36 PM
Why can't a "TeX for web" standard be developed, so that browsers would support it as a standard feature? Where TeX code can be written in a webpage and the browser would render the output based on that code like TeX renders a pdf file. But, unlike mathjax, would look exactly like pdf typeset with TeX.

Or at least it would've been great for browsers to have built-in TeX parser to support TeX code in web pages, so that the code would generate SVGs in the output. But I'm not sure how close SVG output is to PDF in terms of similarity (it should be as close as possible). I think it would've be
@bp2017 why? (there is texlive.js but it's more of a fun toy than actually anything anyone uses)
@daleif You can do this if the bibliographies are separated with e.g. refsegment.
@bp2017 Mathjax is already a highly non-trivial (and quite successful) project. What you suggest seems an order of a magnitude harder.
@DavidCarlisle, a mere .js file won't do it (that's what mathjax does and fails in comparison with TeX). I want browsers to typeset some kind of output which is identical to pdf that TeX outputs. The only problem is that pdf itself acts as an object in a webpage and will never be widely supported like simple text or svg images.
@bp2017 have you seem tex.js it is the tex source code (and bibtex source code) compiled to javascript, not an emulation
3:41 PM
@bp2017 One big problem: A typical TeX run produces output for a fixed width. But on the web, browsers come in a bazillion different widths and capabilities. Different needs, different tools.
@DavidCarlisle, I'll take a look some time (I doubt it generates output to a webpage that is identical to pdf generated with TeX on your desktop).
Not only I doubt it, I know it can't (because it's not TeX engine).
@bp2017 as you have commented on some of your previous questions the box models of tex and css differ fundamentally so tex does not make a good input syntax for client side parsing on the web platform.
@bp2017 well you'd be wrong.
@bp2017 why isn't it a tex engine? it is the tex source code just pushed through a non-standard compile chain, via javascript rather than C.
@bp2017 but the end result is the same as serving the tex-generated pdf file so in 9999 out of 10000 cases it is simpler and quicker to generate pdf and serve that, if that is the output you want.
For result to be the same, webpage javascript must support same functionality as C (which it doesn't?). But I'll take your word for it (although with a grain of salt).
@bp2017 I think it just needs to pass the trip test.
4:06 PM
@bp2017 well no it only has to be able to support the limited part of pascal that's in the web sources.
@bp2017 but getting good native (as opposed to javascript) rendering on browsers is stalled on much simpler goals than full tex rendering. we are still trying to get chrome to allow brackets to extend to be as tall as their contents (like \left(...\right) ) firefox has been able to do that from before it was called firefox but chrome still can not.
@DavidCarlisle Chrome likes the brackets small so that it can spy on the contents. :)
@HaraldHanche-Olsen, width of 300px is same in any browser (it scales appropriately to screen resolution, like a tex document with width of 300px does).

@DavidCarlisle, you said it yourself, "the box models of tex and css differ fundamentally so tex does not make a good input syntax for client side parsing on the web platform". I take from the quote alone that mathjax operates differently from tex. I just wish something gets implemented into browsers that would allow raw tex code to be written inside web pages (like it's written inside TeXworks) and would produce output based on that code
And the browser would automatically render the output after processing the tex code (not mathjax).
(Because, aside from output generation, there are differences between mathjax syntax and tex syntax [differences in code itself too], no matter how they try to make mathjax similar to tex). I don't want to push my agenda here, but that's my (uneducated) view.
Sorry for taking up too much chat space. I'm out for now.
@bp2017 as I say you are asking for full tex rendering, and expect something to be happen I have actively been working to get anything frunctionally equivalent to \left\right to be implemented for something like 20 years (might actually happen soon, but it gives an indication of the mismatch between expectation and reality)
@bp2017 that's not usually a useful way to approach screen size differences though, you don't want to simply scale to width, you want line breaking to happen based on current window size, not that all your fonts shrink, re-running the entire tex line ad page breaking algorithms every time someone resizes their window isn't something that browsers are going to accept
4:48 PM
@DavidCarlisle just to be sure: I'm right that there is no way to "execute" the setting of the page resources in a whatsits at shipout? I have to go through the aux with a label (or use luatex+ \latelua)?
@UlrikeFischer I'm not sure I understand the question, why can't you .. oh you mean the values are not known until write time... you probably need to use write or if you know you are targetting dvips, you can (pehaps) push the logic in to postscript eg if you want the absolute page number in a special you don't know it but you can put a literal postscript that access it (that's basically how pstricks works)
@DavidCarlisle dvips, dvipdfmx and luatex are not the problem. They work out of the box. pdflatex doesn't work. E.g. in the following the resource should be added only to the second page but actually it is already on page one:


%\latelua{pdf.setpageresources("/Properties <</blub /zzz>>")
\pdfpageresources{/Properties<</blub /zzz>>}
@Dr.ManuelKuehner Let's hope he changes his mind
@UlrikeFischer if you knew @JosephWright someone with write access to the pdftex sources you could add a non-immediate \special that held its argument as tokens then expanded them at shipout.... Oh hang on can you not use \mark for that. Still I have to go, offline for a while...
@DavidCarlisle we have to go to the theater too. I will try out \mark later.
5:17 PM
@marmot Deleting has been cancelled ...
@JosephWright Glad to hear!
5:34 PM
@JosephWright Very good news!
@PauloCereda Woof Woof
@yo' ooh a dog :)
@yo' Feeling ruff?
5:49 PM
@JosephWright feeling like a wolf, but don't worry, my psychiatrist is on the way /sarcasm
6:21 PM
@marmot I hope so
7:10 PM
hello, someone here know how to work with arabtex ?
@PolineSandra Hi again. I don't think so. And in general I don't think people really use it any more, which is why the answer you got from @touhami used XeTeX and polyglossia. But he did give you an alternative with arabtex I think. (I assume you're asking about your previous question.)
it is not the same question
I use arabtex and to. change the numeration we use a package arqam.sty I need a professional to do modification in this file
@AlanMunn I would like to sent you it and when you have a time answer me
@PolineSandra I see. You could still try to ask a question on the site (not to request a professional, which is off topic) but to see whether someone could solve the problem for you. To do that you would need a minimal example document and a link to the arqam.sty if it's not part of TeX Live. And you can't assume people know Arabic, so your explanation of the problem should as much as possible not depend on knowing it.
@PolineSandra No, I'm sorry I can't do that. And I don't recommend contacting other users off site either.
Hello, could anybody help me how to write in Arabic including \section ?
Q: Typesetting a document using Arabic script

mariaI'm using TeXlive (2009-7) on Ubuntu 10.04. I've installed texlive-lang-arabic and I can't find out how should I compose the preamble to be able to use it. The babel's documentation I've found in the Internet http://www.tug.org/texlive/Contents/live/texmf-dist/doc/generic/babel/ is probably out-o...

@Student404Mus The accepted answer is still the best way to do things these days.
7:27 PM
@AlanMunn I appreciate that, I hope I find \section{some text in arabic}
@AlanMunn Becasue I already wrote in Arabic but in \section command it doesnt work
@AlanMunn In addition to the fact that Texstudio editor didn't recognize many commands s in that post
@Student404Mus I don't speak Arabic, but this works fine for me compiling with XeLaTeX:
% !TEX TS-program = XeLaTeX






\section{هذا هو القسم}
@AlanMunn I use Miktex, Texstudio and this command didn't work for me.
the errors:

Undefined control sequence. \ExplSyntaxOn
Missing \endcsname inserted. \csgappto{rmfamily~}
@Student404Mus How old is your MikTeX? Are you compiling using XeLaTeX?
Extra \endcsname. \csgappto{rmfamily~}
nope. I use Tex studio
@UlrikeFischer Hello, do you have a LaTeX-Firm?
7:41 PM
@Student404Mus No, TexStudio is an editor. You need to tell it to compile your document using XeLaTeX instead of pdfLaTeX.
@AlanMunn The editoris TeXstudio
@Student404Mus See this answer for what i mean: tex.stackexchange.com/a/367582/2693
@Student404Mus This might be a better answer: tex.stackexchange.com/q/235245/2693
@AlanMunn Oh, I see.
But i tried to complie using XeLaTeX and nothing works
@Student404Mus And change % !TEX TS-program = XeLaTeX in my example to % !TeX program = xelatex (what I wrote might work too, but I'm not sure.)
Ok. i'll check
I'm still strugling
@AlanMunn Is this code correct? \newfontfamily\arabicfont[Script=Arabic,Scale=1.1]{Scheherazade}
8:01 PM
@Student404Mus If you have the font, yes.
@Student404Mus If not replace it with the name of a font on your machine.
look at these errors
Undefined control sequence. \select@language {arabic}
Missing $ inserted. \end{document}
You have requested, on input line 8, version `2010/06/08' of package fontspec, but only version `' is available.
Overfull \hbox (50.44397pt too wide) in paragraph
@Student404Mus I think your version of MikTeX is too old.
@Student404Mus But I don't use MikTeX, so I can't help you much with that.
Ok the last chance is to update MikTeX
Thank you for your help anyway
Maybe i'll use online latex editor
8:47 PM
My second expl3 command. Goodbye \@ifstar... :)
@AlanMunn Nice :-) Not kicking and screaming anymore, I presume.
@PhelypeOleinik Exactly. :)
@PhelypeOleinik And at least for me, the first rule of learning any new language is don't try to learn it for its own sake, i.e., without having specific things you need to do.
9:06 PM
@AlanMunn Oh, me too! People I know usually watch youtube videos to learn (most commonly Matlab around here). That never works for me. I started learning both Matlab and Fortran by writing a tic-tac-toe game in them :P
@AlanMunn I started actually learning TeX when I started writing a document class about an year ago. Before that my knowledge ended with \newcommand\red[1]{\textcolor{red}{#1}} (yes, I used to do that back in the day :-)
@PhelypeOleinik I learned Fortran by writing a graphics output routine for a FFT (Fast Fourier Transform) library.
@AlanMunn Wow, graphic output with Fortran? That's really advanced!
@AlanMunn I only managed to do somthing like that with a .ppm format, which is rather unpractical.
@PhelypeOleinik It was a long time ago. We had a Perkin Elmer mini-computer with a fancy (at the time) frame buffer. The data was real time pressure data from a wind tunnel.
@AlanMunn What is a frame buffer?
@PhelypeOleinik It's a huge chunk of memory that maps into a raster output device. Minimally one bit/pixel for B/W but usually more in the case of colour.
@PhelypeOleinik Before I became a linguist I was a programmer in a civil engineering research centre.
9:21 PM
@AlanMunn Oh, it's similar (I think) to that .ppm format. Just a matrix of data which maps to a RGB or B/W value.
Someone with a mac here?
@UlrikeFischer Of course. :)
@AlanMunn Wow, that's a drastic change. It's awesome :D
@AlanMunn could you try tex.stackexchange.com/q/495824/2388? I get the error and think that I know why but don't understand why Herb don't get it.
@UlrikeFischer I get the error too. Not with TL2018 though.
9:26 PM
@UlrikeFischer I get the same error as the OP with my updated TL installation.
@UlrikeFischer I get the error.
So there is a clear statistical preference for the error.
@marmot :)
@AlanMunn This is how error propagation works, isn't it?
Can someone please explain why two number-commands placed one after another result in no output?

9:33 PM
@bp2017 You are making an assignment. This is the same as to say \count255=\count255.
@bp2017 You are saying to TeX to store in \count255 the current value in \count255. No output and no useful action either.
@PhelypeOleinik, @egreg, ha-ha, no useful action... True. Thank you.
@AlanMunn thanks, I can reproduce it, and it is clear that polyglossia needs to be adapted, the content of the nodes-table has changed.
@bp2017 If \count is found “alone”, that is, when TeX is not looking for a <number>, it starts an assignment. First it identifies a <number> to be the register number the assignment is made to, then looks for an optional = and then for another <number> in order to finish the assignment.
... another great contributor was removed ... sad year
9:40 PM
@marmot ?
@marmot Yes, I got -1222
Which is very strange: I was under the impression that in such cases votes were not removed.
@egreg A user, whose posts were mentioned excessively in a comment, was removed.
@egreg I got only -140.
@marmot Sorry, no pointer
@AlanMunn I got -2505.
@egreg I believe I am not supposed to explicitly say the name.
@marmot I guess they liked TikZ then. :)
9:49 PM
@AlanMunn Yes, that was as much of a hint as I can possibly give?
@AlanMunn My reputation loss is actually determined by the elevation of the Grossglockner pass. Luckily not Thorong La, which I made only once.
@marmot I guess you have many relatives around the Großglockner
@egreg Yes. Not so many around Thorong La.
10:22 PM
@DavidCarlisle Hello.
@DavidCarlisle Could you help me how to write in arabic in latex? I explored many posts in stackexchange and websites. but wihtout succuss
10:38 PM
@Student404Mus Please don't ping individual people in chat unless you've already engaged with them. I've already given you basic pointers on what to do. If you can't get the minimal example I gave you earlier to run, ask a question on the main site showing that example and the errors you get. Did you make sure your MikTeX is up to date?
10:48 PM
Yep. I did it
@AlanMunn The new error is Scheherazade fonts cannot be found
@AlanMunn In my paper, I want to add an abstract in arabic, however, the hole paper is english
@Student404Mus Do you have that font installed on your machine? If not, you need to choose another font name that matches an Arabic font that you do have.
How do I know that?
@Student404Mus Then you set the main language to english and the otherlanguage to arabic like the example document in the question I linked to earlier. My example document assumed that the main language was Arabic.
@Student404Mus If you open MSWord or OpenOffice or any other application on your machine that uses fonts, can you choose that font?
@Student404Mus XeTeX uses system fonts, so any Arabic font that you can use in another application on your machine should work.
I could write in Arabic in notepad for e.g.
@Student404Mus That's not the question. You need to know the name of a font.
11:02 PM
but I don't know what is the font name?
Maybe i could fint it in the setting of windows10
@Student404Mus Yes, look in wherever Windows 10 stores fonts. (Sorry but I don't use Windows so I can't give you more detail than that.) But if you have MSWord on your machine it will list the fonts you have too.
11:52 PM
Somehow the meta site does not seem to be good for us....

« first day (3148 days earlier)      last day (1862 days later) »