« first day (4978 days earlier)      last day (29 days later) » 

cis
cis
6:04 AM
What could be a good font for the 'letters' K, Q, J at playing cards?
Ahhh: and numbers 1,....,9
Ahh... one should use a 'slap serif font':
cfr
cfr
7:14 AM
Why does indentation disappear if I paste a script into an answer? It makes it look a complete mess.
cfr
cfr
1
A: How to display playing card symbols ♠ ♥ ♦ ♣ of all fonts

cfrUsing David's comment, $ albatross -t -b0 ♠ ♥ ♦ ♣ | sed 's/,.*$//' generates a list of all fonts on my system which include all four characters (but probably excluding some TeX fonts with non-standard encodings). Unfortunately, albatross doesn't seem to have an option for returning machine-parse...

@JosephWright The script at the bottom does not look like this in my editor ;).
What am I doing wrong?
7:48 AM
@cfr I just left a comment under the question
@cfr you mean to get the text without the fancy terminal formatting? try albatross -an -b0 -t ♠ | tail +6 | more here, -an ansi terminal -b0 no borders -t include tex fonts look for a spade tail +6 remove the annoying banner, more terminal pager. — David Carlisle 1 min ago
@PauloCereda ^^ can we have a --no-banner option to save having to use tail +6 ?
@cfr tabs? untabify first
cfr
cfr
8:06 AM
@DavidCarlisle The banner isn't the problem. I can get rid of that. It is the escape lines which are the real issue.
less /tmp/bart1
__ __           __
.---.-.|  |  |--.---.-.|  |_.----.-----.-----.-----.
|  _  ||  |  _  |  _  ||   _|   _|  _  |__ --|__ --|
|___._||__|_____|___._||____|__| |_____|_____|_____|

ESC[?25l  ⠋  Please wait while we map the TeX fonts.
^MESC[1A  ⠋  Please wait while we map the TeX fonts.
^MESC[1A  ⠋  Please wait while we map the TeX fonts.
^MESC[1A  ⠋  Please wait while we map the TeX fonts.
^MESC[1A  ⠙  Please wait while we map the TeX fonts.
^MESC[1A  ⠙  Please wait while we map the TeX fonts.
^^ albatross -an -b0 -t ♠ > /tmp/bart1
@PauloCereda Even a line break before the first font name would help ;).
@DavidCarlisle ??
@cfr the first time I use -t I get a wait while we map tex fonts message but then not again, is your cache directory not writable by the account you are using (not sure where albatross caches its lookup, but somewhere...)
cfr
cfr
@DavidCarlisle If the cache isn't written and I don't know where it is meant to be written, I'm not sure how to tell whether it is written.
@cfr but if you think having an escape character or two is bad, you should try it in cygwin rather than wsl, it basically acts as a room heater, it launches fc-list in the background then loses control of it and your cpu runs at 90% untill you kill teh process externally (just stopping albatross with ^C etc doesn't work you need to kill the fc-list (@PauloCereda loves my cygwin error reports)
@cfr well all I know is if I use albatross -t twice I get no messages the second time. but if we ping @PauloCereda enough times I guess he will show up
cfr
cfr
@DavidCarlisle ;)
@DavidCarlisle I think it must have written cache because it was much slower the first time. On the terminal, I get a single 'wait while we fetch the fonts', but the first time I think I got two and it definitely took longer. I only get 80+ lines of it if I redirect to file.
albatross -h
__ __           __
.---.-.|  |  |--.---.-.|  |_.----.-----.-----.-----.
|  _  ||  |  _  |  _  ||   _|   _|  _  |__ --|__ --|
|___._||__|_____|___._||____|__| |_____|_____|_____|

Usage: albatross [OPTIONS] glyphs...

A tool for finding fonts that contain a given (Unicode) glyph.

Options:
-s, --show-styles                Show available font styles
-d, --detailed                   Show a detailed font list
-a, --ansi-level [n|a16|a256|tc]
Set the default ANSI level
-b, --border-style [0|1|2|3|4|5|6]
albatross -c
__ __           __
.---.-.|  |  |--.---.-.|  |_.----.-----.-----.-----.
|  _  ||  |  _  |  _  ||   _|   _|  _  |__ --|__ --|
|___._||__|_____|___._||____|__| |_____|_____|_____|

Usage: albatross [OPTIONS] glyphs...

Error: Missing argument "glyphs"
??
@DavidCarlisle So if I add -c, I get an additional message on the terminal. So I don't think the lines I'm getting in redirected output are due to its not being about to write to cache.
I'm not going to try redirecting with -c because I suspect it will generate hundreds or thousands of lines rather than 80-90.
8:25 AM
@cfr I get 419 lines from albatross -an -b0 -t ♠ | tail +6 | grep -v '(family)' | sed -e 's/,.*//' > a.txt
cfr
cfr
@DavidCarlisle That's kind of what Max Chernoff's code did on my machine. Except it (and every other process running in an emulated terminal) get killed automatically).
AePagella-BoldItalic
AePagella-Italic
AntykwaTorunska-Bold
AntykwaTorunska-BoldItalic
AntykwaTorunska-Italic
AntykwaTorunska-Regular
AntykwaTorunskaCond-Bold
AntykwaTorunskaCond-BoldItalic
AntykwaTorunskaCond-Italic
AntykwaTorunskaCond-Regular
AntykwaTorunskaCondLight-Italic
AntykwaTorunskaCondLight-Regular
AntykwaTorunskaCondMed-Italic
AntykwaTorunskaCondMed-Regular
AntykwaTorunskaLight-Italic
AntykwaTorunskaLight-Regular
AntykwaTorunskaMed-Italic
AntykwaTorunskaMed-Regular
Arimo
Arimo Bold
Arimo Bold Italic
@cfr ^^
cfr
cfr
@DavidCarlisle To file? Or on stdout?
@cfr the exact line in my comment above ending with >a.txt then a.txt is what I pasted in above
cfr
cfr
@DavidCarlisle But why? I don't get it.
8:30 AM
@cfr why it doesn't work for you? no idea.
cfr
cfr
@DavidCarlisle No. What matters about that way of doing it? What's wrong with what I did?
@cfr as i say I have no idea why you are getting the messages, as I don't I can't confirm if they get mingled with font lines, I think you need somone who can trace the albatross code
cfr
cfr
@DavidCarlisle No, you don't understand. If I use your command, I get your output. Modulo the fonts on my system. If you don't pass it through grep, do you see the messages?
That is,
albatross -an -b0  -t ♠ | tail +6  | sed -e 's/,.*//' > a1.txt
gets the messages, but
  albatross -an -b0  -t ♠ | tail +6 | grep -v '(family)' | sed -e 's/,.*//' > a.txt
@cfr no messages, just the banner and in some cases visible glyphs adter a comma and (family) lines
cfr
cfr
@DavidCarlisle Oh. Sorry. I misunderstood.
8:37 AM
@cfr I have only ever seen the "waiting map tex fonts` message once, the first time I use -t so now I get no messages
@cfr blame @PauloCereda
cfr
cfr
@DavidCarlisle I only see that message if I clear the cache. The message I still get is different.
On the terminal it disappears once the fonts are displayed. If the output is redirected, it doesn't. Except albatross -an -b0 -t ♠ | tail +6 | grep -v '(family)' | sed -e 's/,.*//' > a.txt doesn't have the problem ...
[I'm guessing you have somewhat faster hardware and don't see the fetch message for that reason. But that doesn't explain why it doesn't show redirected.]
cfr
cfr
9:16 AM
@DavidCarlisle That's why. You need slower hardware or more fonts to see the problem. On your machine, you don't see the fetching message ever, so, of course, it doesn't show up in the redirected output. The same for Max Chernoff. On my machine, I do see it on the terminal and so it shows up repeatedly in the redirected output. @PauloCereda needs to not do that looping when the output isn't a terminal. (Whatever java does for readline, I guess.)
9:26 AM
@cfr When I run albatross -t x, I get the Albatross header followed by Please wait while we map the TeX fonts with the spining Braille thingy, then the message disappears and I get a list of fonts. But when I run either of echo | albatross -t x or albatross -t x | cat, I get the Albatross header followed by a pause, then the list of fonts, but I never get the Please wait… message.
9:47 AM
More concretely, when I run `printf '%q' "$(script -qefc 'albatross -t x')" | head -c 500`, I get

```
$' __ __ __\r\n.---.-.| | |--.---.-.| |_.----.-----.-----.-----.\r\n| _ || | _ | _ || _| _| _ |__ --|__ --|\r\n|___._||__|_____|___._||____|__| |_____|_____|_____|\r\n\r\n\E[?25l ⠋ Please wait while we map the TeX fonts.\r\n\r\E[1A ⠋ Please wait while we map the TeX fonts.\r\n\r\E[1A ⠋ Please wait while we map the TeX fonts.\r\n\r\E[1A ⠋ Please wait while we map the TeX fonts.\r\n\r\E[1A ⠋ Please wait while we map the TeX fonts.\r\n\r\E[1A �
 
1 hour later…
10:52 AM
user image
3
@PauloCereda ^^ ^Tonight on German television
11:47 AM
\showhyphens :(
\RequirePackage{latexbug}
\documentclass[12pt]{article}

\usepackage{fontspec}
\setmainfont{FreeSans}
\begin{document}



\showhyphens{ինչու ինչպես որտեղ հիվանդանոց հիվանդանոցում Երևան Երևանում Նամակ Երևանիս ԵՐԵՎԱՆ
ԵՐԵՎԱՆՈՒՄ ԵՐԵՎԱՆԻՍ շնորհակալություն անպայման այրվել անգին անձրևանոց ԱՆՁՐԵՎԱՆՈՑ հիվանդանոցու՞մ}


\end{document}
@JosephWright do you have an old texlive to hand did xelatex always give the warnings on the terminal or has tracing lost chars only ignored tracingonline since tracinglostchars=3 was added?
i can't check on overleaf as the messages would alwys have gone to the log
@DavidCarlisle I'll check
@DavidCarlisle Seems so
@JosephWright seems it changed or seems it didn't change?
@DavidCarlisle Ah, sorry - I get a warning at the terminal since tracinglostchars=3 was added
@JosephWright @PhelypeOleinik if I recall correctly?
@DavidCarlisle Yes
11:59 AM
@JosephWright email sent to texlive list
@DavidCarlisle we are using tracinglostchars=2, but yes the warning is there since 2021 and not before.
@UlrikeFischer Indeed :)
12:50 PM
@UlrikeFischer yes thought later that we changed the default but is it right that it sed to honour tracingonline and now doesn't?
Good day
I was just running a routine update on texlive but for some reason or the other it is giving me the message ERROR
any insights?
1:04 PM
@azetina just ERROR no message?
Yup just ERROR
weird i never use the GUI version just the command line what happens if you specify a repository explicitly rather than rely on the ctan mirror hub eg use ftp.fau.de/ctan/systems/texlive/tlnet
@DavidCarlisle I don't think that \tracingonline=0 actively suppress stuff on the terminal, it is more that \tracingonline=1 shows more. As far as I can see \tracinglostchars=2 always lead to messages on the terminal.
1:19 PM
@UlrikeFischer ah OK so we can let @PhelypeOleinik off then:-) and the comment in the latex source was wrong
@UlrikeFischer Glad to hear! :)
@UlrikeFischer The fun thing is that the question started out with such a nice short example which included the missing library tex.stackexchange.com/revisions/720768/1
@samcarter yes, it is so typical. They get some minimal example from somewhere else but never check if it is really reflects their problem.
1:37 PM
@UlrikeFischer Latex could add some new messages like "Congratulations, you loaded more than 100 packages, you unlocked a new level called 'check if they are all needed' " :)
6
Or "you used up all the packages, go feed the ducks to get more free packages"
2:27 PM
@PauloCereda rootloops.sh
2:52 PM
@DavidCarlisle Let me try it. But I already changed server and no change
@DavidCarlisle I get the same error even if I change the server. How do update using command line
@azetina just type tlmgr update --all
@DavidCarlisle What is the command line to install "not installed" packages
@azetina tlmgr install colortbl
So it seems @DavidCarlisle I had to run tlmgr update --self
@azetina yes that's needed occasionally if the tlmgr scripts themselves have changed
3:07 PM
@DavidCarlisle thanks, I learned some new commands to update if the gui fails
cfr
cfr
3:40 PM
@MaxChernoff Your hardware is also better than mine ;). You also don't ever see the second message, which I see each time on the terminal or repeated in the file.
 
3 hours later…
6:23 PM
@UlrikeFischer I guess we should do something about amsthm
 
1 hour later…
7:34 PM
@cfr @DavidCarlisle oopsie, sorry for the trouble. I am working on a rewrite and will work on this. Apologies. :)
@samcarter ooh
@PauloCereda you need to hurry, it'll soon be dinner time
@DavidCarlisle oh no
@PauloCereda perhaps albatross is tastier than duck
cfr
cfr
8:20 PM
@PauloCereda Why can't anybody reproduce it? Is my guess anywhere in the vicinity of correct?
Should I not use (either part of) this answer? (Actually, I assume I shouldn't use the second.)
7
A: How can I determine current font attributes and/or determine if the current font has been substituted by the kernel?

Max ChernoffWe can hook the internal LaTeX \wrong@fontshape macro to get a mapping between the requested font and the substituted font, then add a hook to selectfont to check to see if the current font was substituted or not: %% SPDX-License-Identifier: CC0-1.0 %% Initialization \documentclass[12pt]{article}...

cfr
cfr
8:48 PM
I've done something horrible, but I don't know what.
@cfr sounds like an introduction to a teeny horror movie.
@UlrikeFischer I ended up actually watching that...
cfr
cfr
@cfr Don't talk to me any more. — Ulrich Diez 30 mins ago
@cfr ooh, sorry if I made fun of the way you formulated things. I thought it was about your font problem. Well, I'm not nearly active enough on this page to have any idea what could've caused this. And I hope this is just a big misunderstanding.
@cfr That looks weird. And from your comment it looks like you have no idea of why. What is going on with people?
 
1 hour later…
cfr
cfr
10:10 PM
@mickep I honestly have no idea.
cfr
cfr
10:33 PM
@Skillmon It's OK. I'm just rather lost. I thought maybe somebody else would see something I'm not.
@DavidCarlisle What did you mean by this?
@cfr you said you were losing indentation, the main place I have seen that happen is files using tab for indent as the site changes tabs to spaces, but apart from makefiles you can usually change indentation to be done with space before posting
cfr
cfr
11:00 PM
@DavidCarlisle Hmm. Usually I do use spaces, but these are tabbed. So I need a way to replace them, I guess. Thanks. And thanks for commenting earlier.
@cfr M-x untabify in emacs:-)
@cfr or use the standard linux expand program

« first day (4978 days earlier)      last day (29 days later) »