« first day (4873 days earlier)      last day (45 days later) » 

12:25 AM
@DavidCarlisle I saw you removed your last comment from tex.stackexchange.com/questions/712051. Right now, I would finally be able to try it out. Might I ask you to tell us which line to add to a local copy of psfonts_t1.map for dvips -u local_copy_of_psfonts_t1.map? Is it usyr SymbolMT <usyr.pfb or something else? I know that these changes are less likely to be useful as TeX Live gets updated, but I'd like to try it out just for the purpose of an experiment.
 
12:40 AM
@DavidCarlisle This line alone is probably insufficient or wrong. Though the error message of dvips is gone after appending usyr SymbolMT <usyr.pfb to local_copy_of_psfonts_t1.map and running dvips -u local_copy_of_psfonts_t1.map, the viewer gv still displays boxes where glyphs for the logical and, or, and not should be present. Interestingly, the viewer evince run on the resulting PS file does display these glyphs.
 
@AlMa1r i deleted comment as I wasn't sure I had the syntax right and didn't want to test (and don't want to test at this time of night:-) you could ask a new question rather than ping here someone else may be awake:-)
 
1:38 AM
@DavidCarlisle I see. No problem, thank you anyway. I realized that two issues overlapped in that question: the warning by dvips/dvipdf and the glyphs not being shown by gv (but being shown by evince for the same PostScript and EPS files, though evince is an unusual viewer for (Encapsulated) PostScript anyway). Now I think that me redrawing the diagram in pstricks (which is used for other diagrams in the document anyway) would be easier.
 
 
6 hours later…
7:34 AM
@JasperHabicht same way as the normal loop, just nested... :P
 
8:05 AM
@JasperHabicht more seriously: will try to take a look this evening (or rather add it to my todo list)
 
8:20 AM
@Skillmon Nice! I made it a bit of a task for myself to better understand how things work ... I will try to make my way though it, but it is a real challenge =D
 
 
3 hours later…
11:10 AM
@UlrikeFischer writing some installation instructions. When adding map files to miktex do users still use initexmf --edit-config-file updmap and then add one line per map file?
 
 
1 hour later…
12:19 PM
Has anything changed in xelatex in the last year? Regarding the font stuff from last week. Xelatex works just fine on my local TL23. But in overleaf using TL23-xelatex the symbols does not show up in the pdf. They do under lualatex. There does not seem to be any errors or warnings in the log.
 
12:36 PM
@daleif According to sourceforge.net/p/xetex/code/ci/master/tree/source , didn't the last change to xetex happen in 2020?
 
1:27 PM
@AlMa1r It might be coming from some of the support stuff that has not been updated to the latest version on OL.
 
1:53 PM
I am searching for a TeXworks icon in SVG format (due to some internal code reasons). In the repository, I just found .png. Anyone knowing of some other icons?
 
@koppor Hasn't there been a package on CTAN?
I can't find it. But probably this icon was not part of it. The reflection looks difficult to reproduce using SVG
 
Anyone know of a way to control \url and \path separately when xurl is loaded? I'd like \path to be a bit more restrictive.
 
Oh, I meant this one: ctan.org/pkg/vectorlogos (but TeXworks in indeed not included)
 
2:19 PM
ahh, well nevermind
 
2:33 PM
@daleif add \XeTeXtracingfonts=1 and then show the log-file ...
@daleif you would have to redefine \path to change the break settings locally. So \DeclareUrlCommand\path{\urlstyle{tt}more setting here}
 
@UlrikeFischer I was trying that and for some reason it kept going into loops.
I'll not go further right now, need to finish this instead.
 
@daleif looks ok here:
\documentclass{article}
\usepackage{hyperref}
\makeatletter\let\OriBreaks\UrlBreaks
\usepackage{xurl}
\DeclareUrlCommand\path{\urlstyle{tt}\let\UrlBreaks\OriBreaks}
\textwidth1cm
\begin{document}

\url{www.abcdefghahahthht.de}

\path{www.abcdefghahahthht.de}
\end{document}
 
2:49 PM
@UlrikeFischer There is something easier: xurl comes with \useOriginalUrlSetting
I was trying to mess with that and failed.
 
@daleif ah right, that works too.
 
@UlrikeFischer You already have the font, here is the code (removed from the package) that I'm testing on overleaf
\documentclass{article}
\usepackage{fontspec}
\count0\tracinglostchars
\tracinglostchars=-1
\newfontfamily\AULogofont[Path = fonts/]{AULogoRegular.ttf}
\tracinglostchars=\count0
\begin{document}

huh

\AULogofont\XeTeXglyph\XeTeXglyphindex "uniF030"

\end{document}
And the raw log:
This is XeTeX, Version 3.141592653-2.6-0.999995 (TeX Live 2023) (preloaded format=xelatex 2023.8.28) 4 MAR 2024 14:57
entering extended mode
\write18 enabled.
%&-line parsing enabled.
**main.tex
(./main.tex
LaTeX2e <2023-06-01> patch level 1
L3 programming layer <2023-06-30>
(/usr/local/texlive/2023/texmf-dist/tex/latex/base/article.cls
Document Class: article 2023/05/17 v1.4n Standard LaTeX document class
(/usr/local/texlive/2023/texmf-dist/tex/latex/base/size10.clo
File: size10.clo 2023/05/17 v1.4n Standard LaTeX file (size option)
When looking at listfiles I only see differences in the expl3 stuff.
Downloading the PDF from OL we can see it refers to AULogo, but there is no "prefix" in pdffonts and it is not marked as embedded. It is when compiled locally.
 
@daleif and that doesn't work? Are you sure you are using the same font in both places? Add \XeTeXtracingfonts=1 to get some info about the path used.
 
Should be. Let me just disable this texmf tree locally
In overleaf I added that line after "huh" in the example. The only difference in the log is
< Requested font "[fonts/AULogoRegular.ttf]/OT:language=dflt;" at 10.0pt
< -> ./fonts/AULogoRegular.ttf
("<" from diff)
 
3:14 PM
@daleif hm, I don't know how to debug xdvipdfmx on overleaf ;-). Does it work if you put the font in the current folder?
 
@UlrikeFischer --output-directory strikes again? :-)
 
@UlrikeFischer hmm, good suggestion, 1min
@UlrikeFischer Does not seem to make a difference. Very strange.
 
it's supposed to work in s subdirectory: overleaf.com/learn/latex/…
 
Just added one of the other fonts, works just fine.
 
@daleif I didn't really believe that this is the reason. The only reason I can imagine that xdvipdfmx doesn't embed the font is a licensing flag. But then it would imho affect the local call too (assuming that you really have the same font and that you didn't change the xetex options).
 
3:23 PM
@UlrikeFischer as I never use xelatex I don't know how to change the settings ;-)
But then why should the other font work?
It is just this font that has issues and it is the only one using these private slots (and does not have a space char, which really should not do anything).
Is it better to send it to OL support? Perhaps they know exactly which settings are used?
 
@daleif Yes I think you should contact OL support. Locally I would do something like xelatex --output-driver="xdvipdfmx -vv" file to get some terminal info about what xdvipdfmx is doing, but I don't know if/how one can do that on overleaf.
 
@UlrikeFischer latexmkrc
That will have to be later in the week (will be attending a course the next few days).
Thank you for your time.
The code even works if I export it from overleaf and run it locally.
@UlrikeFischer just tried something: xelatex from TL23,22,21,20 works locally. So it seems to be overleaf specific
 
4:01 PM
@UlrikeFischer it might be a problem with latexmk, if I do this locally
xelatex --output-driver="xdvipdfmx" main.tex
This is XeTeX, Version 3.141592653-2.6-0.999995 (TeX Live 2023) (preloaded format=xelatex)
restricted \write18 enabled.
entering extended mode
(./main.tex
LaTeX2e <2023-11-01> patch level 1
L3 programming layer <2024-01-22>
(/opt/texlive/2023/texmf-dist/tex/latex/base/article.cls
Document Class: article 2023/05/17 v1.4n Standard LaTeX document class
(/opt/texlive/2023/texmf-dist/tex/latex/base/size10.clo))
(/opt/texlive/2023/texmf-dist/tex/latex/fontspec/fontspec.sty
then I get a PDF with a missing char.
Overleaf latexmk runs $xdvipdfmx = "xdvipdfmx -z 6 -i dvipdfmx-unsafe.cfg -o %D %O %S" in their systemwide latexmkrc
What is the normal driver when that options is not given?
 
@daleif xdvipdfmx is the normal driver, and the options looks ok. The main question is if you can access the debugging info from the option -vv somehow.
 
I also get the problem locally if I run xelatex -no-pdf main.tex and then xdvipdfmx main.xdv
Ahh, they are in stderr, 1min
 
@daleif well that is good news. Then one can perhaps debug it.
 
ChkTeX v1.7.6 - Copyright 1995-96 Jens T. Berger Thielemann.
Compiled with PCRE regex support.
One error printed; No warnings printed; 29 user suppressed warnings; No line suppressed warnings.
See the manual for how to suppress some or all of these warnings/errors.
output.xdv -> output.pdf
[1]
xdvipdfmx:warning: Creating ToUnicode CMap failed for "./AULogoRegular.ttf"
xdvipdfmx:warning: Failed to load ToUnicode CMap for font "./AULogoRegular.ttf"

2562 bytes written
Latexmk: ====List of undefined refs and citations:
The strange thing is, this
xelatex --output-driver="xdvipdfmx" main.tex
fails locally
But this
xelatex main.tex
works locally, where is the difference?
I understand now that this is a bit of a beast to debug.
Fails locally = generate a pdf that is missing a char.
I'm assuming here that things fail because this is a "private slots" only kinda font.
Off for a few days.
 
4:19 PM
@daleif const char outputdriver = "xdvipdfmx -q -E"; / default to portable xdvipdfmx driver */
@daleif so what happens if you specify -q -E do you get the same as not specifying a driver?
-E Always try to embed fonts, regardless of licensing flags.
@daleif ^^^ hmm
 
@DavidCarlisle -E helps
then it works.
so is the font set up such that one is not allowed to embed it?
That seems strange.
 
@DavidCarlisle ah, that explains why it works locally, chat.stackexchange.com/transcript/message/65288942#65288942
 
@UlrikeFischer but where is that flag then comming from? The font?
 
@daleif yes, xdvipdfmx gives a warning if you use the -vv option:
xdvipdfmx:warning: Embedding of font "./AULogoReg.ttf" disabled due to license restrictions`
 
@daleif probably "no subset" flag:
 
4:29 PM
@DavidCarlisle I just need to know where that setting is so I can complain about it. Which software can read that setting directly from the font?
 
@daleif the above is fontforge, which also complains about:
 
@DavidCarlisle I jsut realised that
 
You could try unchecking that and saving the font...
 
@DavidCarlisle which is also why I use the file name and not the font name.
@DavidCarlisle for now I'm not modifying the font at all. Only downloading it and repacking it.
 
@daleif yes but as a test you could see if that makes it work by default
 
4:32 PM
Then I'll complain about it. I'd like to see what Word does here
@DavidCarlisle sure. Will be on Thursday.
 
4:44 PM
The other fonts does not have that setting.
 
 
2 hours later…
6:28 PM
I've sent an email to the people responsible for the fonts. I wonder how word and power point handle this font
 
6:52 PM
@daleif well the flag only says not to subset not that it can't be embedded, since it only has a few characters anyway that's hardly a restriction but presumably xdvipdfmx doesn't have a code path not to subset fonts of this form so flags that as an error
 

« first day (4873 days earlier)      last day (45 days later) »