« first day (4605 days earlier)      last day (109 days later) » 

9:21 AM
@DavidCarlisle oh no
5 hours later…
2:14 PM
Does anyone know how to reduce the spacing between the title and the first heading
This is my preamble right now. It's a mess...
\pgfplotsset{compat = newest}
\usetikzlibrary{positioning, arrows.meta}
I'm trying to use the titlesec package
I'm working in overleaf btw
@Ajay Does it remain if you also fill the page with some content (text)?
@mickep Yes
OK, I don't know then, maybe the \maketitle expects also an author and if not set you get such a big space. Does it decrease if you also do \author{Ajay}?
No, it remains the same.
2:33 PM
@Ajay I think that you should try to prepare a minimal example and post it on the main site. But in my opinion that one is not a title... and you should consider another format/style for your document.
@Rmano Let me make a post.
@Ajay quite true. You should clean that up. Why e.g. are you changing arraystretch two times? And load enumitem twice? And you should not put a \section inside a \textcolor command.
@UlrikeFischer I really don't know. I was just dumping things inside with no organisation.
I actually read on this site to use \section inside of a \textcolor command.
2:55 PM
@Ajay please give a link --- that is probably very wrong. The very basic concept of LaTeX is separate semantics from low-level formatting... so if you want colored section titles, you use \section, and then specify that you want colored sections. If in the future you decide that your choice was bad for whatever reason, you change it in one place...
@Rmano Don't think I have it anymore. I accessed it back in February, i'll need to search for a bit...
3:22 PM
@Ajay unrelated to your question, but have a look at the \qty macro from siunitx. This would give you correct spacing between numbers and units
@samcarter Thanks, i'll have a look.
Q: How to reduce the space between the title and the first heading?

AjayHere is my MWE: \documentclass[12pt,usenames,dvipsnames,a4paper]{article} \linespread{1} \usepackage{times} \usepackage[siunitx]{circuitikz} \usetikzlibrary{arrows.meta, ext.paths.ortho} \usepackage{pgfplots} \pgfplotsset{compat = newest} \newcolumntype{T}[1]{S[table-format=#1]} \...

@Ajay Your code does not compile because of option clashes when you load the same packages multiple times. You should really clean up your preamble. The space is to show the author and the date -- both invisible in your example. Personally I would just add a negative vertical space before your first section.
... and wrapping the section in a colour command looks very wild. Maybe consider using a koma class? They make it very easy to change the colour of section titles.
@Ajay Compare these units to what you had:


\title{How does varying the capacitance between \qty{0.01}{\micro \farad}}



3:40 PM
Much better!
I'll remove the question for now and clean up the preamble.
@Ajay Instead of removing, you could rather edit it.
Yes, i'm in the process of doing that.
I also tried to implement your solution. It isn't working.
@Ajay Not working isn't a very useful problem description. If you take the short example from my question, does it work?
It works
@Ajay Great, then please show a reproducible example of the code which does not work.
3:53 PM
@samcarter I have edited my question. Hopefully the preamble is looking better.
Also, it somehow produces a new page when I run the code.
@Ajay Your code does not compile, the \usepackage[dvipsnames]{xcolor} prevents it from doing so. After an error, latex only recovers to syntax check the rest of the document. There is no point at worrying about empty pages and such. You must fix the errors first.
... and the `\vspace{-10

}` is wrong. You can neither use before the start of the document nor without unit

\pgfplotsset{compat = newest}
\usetikzlibrary{positioning, arrows.meta}
@samcarter Ok. I have made all the edits, please take a look at the question now.
@Ajay ^^^ You have to place the negative space before your first section. Not in the preamble and not before the title.
Oh dear, it works now
I'm such a noob at this lol
@samcarter Thanks :) It works now.
@Ajay Some other points: You shouldn't abuse \\ for line breaks and if you don't want your paragraphs to be indented, have a look at the parskip package
4:07 PM
I have made the changes :)
It suffices just to load the package right?
@Ajay Yes, just load it and remove \noindent
Ok :)
3 hours later…
7:01 PM
Are one allowed to suggest a package addition to the authors of 'fontspec.sty'?
7:18 PM
@cis make an issue at github

« first day (4605 days earlier)      last day (109 days later) »