« first day (3878 days earlier)      last day (53 days later) » 

yo'
12:17 AM
@barbarabeeton saw that news, it completely shocked me! What a story. They also said that it took a lot of experience and self-control from the diver to survive this, mostly importantly to survive the quick decompression from the humpback whale raising.
 
@yo' -- Ah, the version I saw didn't say anything about the depth. But humpback whales are typically surface (or near-surface) feeders (have seen them on whale-watching trips), so the depth was probably not dangerously great (likely not more than 10 meters, and probably less), but the diver's mouthpiece could have been knocked off. In any case, a very big surprise! (I wonder who will be the first to call him "Jonah"?)
 
yo'
@barbarabeeton hahah. I've heard something about 14 m of depth
 
12:37 AM
@yo' -- Possible. Humpbacks tend to take a vertical position below a school of their prey, then lunge upward with mouth open. Quite impressive. And figure that a full-grown humpback can easily be 10-15 meters in length. (It's awesome when one breaches!) Such a huge creature subsisting on such teeny-tiny prey. A mature sand lance is probably 20-25 cm long, and skinny.
 
 
3 hours later…
3:20 AM
Sheer laziness here, but if anyone has set up the gray and slant fonts for gftodvi on their system, I'd love to get dvipdf output of the gftodvi output for cmr10, cmti10 and mfman.
 
 
3 hours later…
6:31 AM
@yo' I was wondering if I could ask you a quick Overleaf-related question?
Do you happen to know who is in charge of the material on the documentation/learn pages like overleaf.com/learn/latex/Bibliography_management_with_biblatex?
 
yo'
@moewe yes
@moewe yes :)
Why are you asking?
 
@yo' Would you be interested in a few comments?
I have seen the example .bib entries from that page used in many MWEs on this site and I think they could be made slightly more biblatex-y.
 
7:12 AM
@DavidCarlisle I see. Thank you for the history lesson.
Just one more reason to use LuaTeX.
 
yo'
7:45 AM
@moewe sorry, had to get away
if they are specific things, probably best put through support@overleaf.com, I'll tag @PauloCereda there ;)
 
@FaheemMitha We did change things for the Unicode engines (to TU = Unicode) as the T1 approach is clearly wrong with those engines
 
@yo' No worries. Alright, I'll send a mail to the general support address. Thanks for the answer.
 
yo'
8:01 AM
@moewe it's not like the support email is some black hole in Overleaf ;-)
 
8:20 AM
@yo' I trust it isn't, but since the email would just be me whining about the .bib examples it didn't feel like a 'normal' support request.
 
yo'
@moewe yeah, it's not, but that's fine, more so that I know about it :-)
 
8:44 AM
@JosephWright and we are getting braver over the years so perhaps one day....
@DonHosek you mean like this?
@DonHosek I just did mf cmr10;gftodvi cmr10;dvipdfm cmr10; xpdf cmr10.pdf and the mktex-whatever scripts made anything that needed making.
 
9:12 AM
@JosephWright Why was it clearly wrong for those engines?
 
@FaheemMitha because the whole point of xetex is to use unicode fonts in standard Unicode encoding so using a font with only 127 characters in a wacky encoding only used by tex (and not recommended for use even with tex) was a little odd.
 
@DavidCarlisle And LuaTeX?
 
@FaheemMitha ditto, except in luatex it's not "the whole point" as luatex has the additional aim of adding Lua
 
@DavidCarlisle OK
 
9:51 AM
If I have the following file:
\RequirePackage{iftex}
\RequireLuaTeX
\documentclass[12pt]{scrartcl}
\usepackage{amssymb}
\RequirePackage{unicode-math}
\begin{document}
$\square$
\end{document}
this works. If I put the amssymb line after the unicode-math line, I get an error.
! LaTeX Error: Command `\eth' already defined.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...

l.240 ...mbol{\eth}            {\mathord}{AMSb}{"67}

?
This isn't very helpful.
Can someone tell me what's going on here, exactly?
> Load amsmath (or mathtools) before fontspec (and unicode-math).
but no reason is given.
 
@Plergux /poke
@yo' <3
 
@FaheemMitha don't load amssymb
 
@samcarter_looks_forward_TUG'21 ooh we should have a tikzwhale
@DavidCarlisle quack
 
@PauloCereda brunch
 
@DavidCarlisle oh no
 
10:04 AM
@DavidCarlisle Does unicode-math obsolete it, then? I've used amssymb for what feels like forever.
 
@FaheemMitha why use RequiRePackage for unicode-math rather than \usepackage (it is exactoy the smae thing, just looks odd in a document)
 
@DavidCarlisle Cut and paste from a style file. Forgot to convert. Sorry.
 
@FaheemMitha amssymb means use the symbols from 7bit legacy fonts supplied by the AMS in the 1980s, unicode-math means use symbols from the modern unicode math font format as specified by Microsoft in the 2000s . These are somewhat incompatible aims.
 
@DavidCarlisle The "Getting Started" says:
> Once the package is loaded, traditional TFM-based maths fonts are no longer
supported; you can only switch to a different OpenType maths font using the
\setmathfont command. If you do not load an OpenType maths font before
\begin{document} , Latin Modern Math will be loaded automatically.
Note that amsmath should be loaded before unicode-math to avoid conflicts,
and it will be loaded automatically if not requested earlier in the preamble.
 
@FaheemMitha why isn't it helpful, it seems a fairly accurate error message, You explicitly loaded two packages that define math symbols and you get an erro rmessage that says you have loaded math symbos twice.
 
10:10 AM
So if you want amsmath, you load it before?
 
@FaheemMitha yes (but actually it's loaded anyway in recent releases so it doesn't make any difference) but that is amsmath not amssymb.
 
@DavidCarlisle A more helpful message would tell you not to load amssymb after unicode-math.
@DavidCarlisle I thought they were part of the same thing.
So essentially uncode-math makes amsmath and amssymb redundant (or obsolete)? If so, it might help to say so.
 
@FaheemMitha no that's not reasonable. You can not expect a package to check by name every package written by anyone else on the planet. The error is not from unicode-math it is from the command that actually defines math symbols telling you that the symbol is being defined twice.
 
@DavidCarlisle Yes, I understand what the error message is saying.
 
@PauloCereda sqeeeeep! uh, I mean, Baa!
 
10:13 AM
@Plergux ooh
@Plergux /hug
 
@PauloCereda /hug
 
I wasn't suggesting all packages should check for all other packages. Just packages that are a replacement for another package.
 
@FaheemMitha unicode-math is about defining symbols from unicode math fonts so it makes amssymb obsolete as you presumably don't want to use the non-unicode ams fonts. It doesn't make amsmath obsolete as that is about layout, but it (now) includes amsmath to save you including it.
@FaheemMitha there are literally hundreds of math font packages almost every one is incompatible with every other one. as they all try to set up the default math font. If you load any two then you will get errors of some sort.
 
@DavidCarlisle the amsart/ebgaramond question is basically doing this:
\documentclass[]{article}
%from amsart
\AddToHook{begindocument}[A]{\settoheight{\footnotesep}{\footnotesize M$^1$}}
%from fontspec
\AddToHook{begindocument}[B]
 {
   \DeclareSymbolFont{legacymaths}{OT1}{cmr}{m}{n}
   \SetSymbolFont{legacymaths}{bold}{OT1}{cmr}{bx}{n}
   \DeclareMathDelimiter{(}{\mathopen} {legacymaths}{40}{largesymbols}{0}
   \DeclareMathDelimiter{)}{\mathclose}{legacymaths}{41}{largesymbols}{1}
 }
%\DeclareHookRule{begindocument}{B}{before}{A}
\begin{document}
\footnotesize
$(a=b)$
 
@DavidCarlisle ooh combinatorics
 
10:20 AM
@DavidCarlisle one shouldn't do typesetting in begin document ;-)
 
@UlrikeFischer ooh maybe it's a secret
 
@DavidCarlisle Oh. I didn't know there were hundreds. I think I've mostly just used the AMS ones.
I always thought they were kinda official. And they certainly seem to be widely used. Did the AMS originally sponsor TeX, or something like that?
Back in the 1970s, I think it was.
 
10:39 AM
@UlrikeFischer quite so which is why my brilliant answer solves the problem by doing even more typesetting at begin document
 
@DavidCarlisle ooh
 
@UlrikeFischer Petra didn't like ltxtable :(
 
@DavidCarlisle oh no
 
@PauloCereda ... and call it "Mobby TikZ"?
 
@samcarter_looks_forward_TUG'21 OH MY YES
 
10:48 AM
@PauloCereda :) @barbarabeeton's whale story totally reminded me of this book :)
 
@samcarter_looks_forward_TUG'21 you got mail. :)
 
11:02 AM
\documentclass{article}
\begin{document}
\begin{picture}(200,100)
\put(150,50){\oval(100,30){}}
\put(100,55){\line(-1,1){15}}
\put(100,45){\line(-1,-1){15}}
\put(80,50){\oval(10,50)[r]{}}
\put(190,55){\circle*{3}}
\put(200,45){\line(-6,1){20}}
\put(170,65){\line(0,1){15}}
\put(170,82){\circle{1}}
\put(172,84){\circle{1}}
\put(168,84){\circle{1}}
\put(174,82){\circle{1}}
\put(166,82){\circle{1}}
\put(174,80){\circle{1}}
\put(166,80){\circle{1}}
\end{picture}
\end{document}
2
 
@DavidCarlisle What an amazing naturalism!
 
12:06 PM
user image
3
^^^ Chemistry duck is doing some experiments. Will it make boom?
 
@DavidCarlisle what did she object to? No date jumps over more that 20 years?
@DavidCarlisle Mody Pics
 
12:51 PM
@UlrikeFischer I consistently put the date as 2001 not 2021 everywhere :-)
@samcarter_looks_forward_TUG'21 is that a photo of @JosephWright?
 
 
1 hour later…
2:06 PM
@FaheemMitha -- Everything that's in amssymb should be in unicode-math, although it's possible that a couple character names may be a little different. (Some shapes may also vary slightly.)
 
2:17 PM
I just installed new Ubuntu and new TL 2021 all under windows 10 Linux subsystem. I do not know what happend, I changed changed my $TEXMFHOME and do not think I changed anything else, now I get this error. I am sure it is just something silly I did but have no idea what.

>which lualatex
/usr/local/texlive/2021/bin/x86_64-linux/lualatex
>cat foo4.tex
\documentclass[12pt]{article}
\begin{document}

test

\end{document}
>lualatex foo4.tex
This is LuaHBTeX, Version 1.13.2 (TeX Live 2021)
restricted system commands enabled.
 
@FaheemMitha -- AMS was the first "institutional" adopter of TeX, and had to do a lot of work to set up a production system for publishing their journals and books. Doesn't necessarily make it "official", but does explain why some things are the way they are. (AMS also requires stability and backward compatibility, which some equate with backwardness. But those are not the same.)
 
@Nasser are you sure you did install everything? you seem to miss luaotfload.
 
@UlrikeFischer I installed everything. I am sure. Installation finished with no errors. it was working OK last night. something silly I must did when I changed some path to make texmf point to different folder. But this should not affect lualatex. I have no idea why it now fails. I will reboot windows 10 and try again to see. very strange.
I am using the new windows 10 Linux subsystems WSL 2.0, which is supposed to be faster. But again, this should not have anything to do with why this error suddenly shows up. Will update once I reboot windows to see if has anything to do with it.
Ok, rebooted windows. Started new Ubuntu terminal. Still the error is here. Very strange. I swear it was working OK last night after I installed TL 2021. This is brand new Ubuntu also, from windows store.

>lualatex --version
This is LuaHBTeX, Version 1.13.2 (TeX Live 2021)

Execute 'luahbtex --credits' for credits and version details.

There is NO warranty. Redistribution of this software is covered by
the terms of the GNU General Public License, version 2 or (at your option)
any later version. For more information about these matters, see the file
 
2:43 PM
@Nasser did you added the texinputs setting in between?
 
@UlrikeFischer Yes. I think I messed it up by changing TEXINPUT. Because of this

>which pdflatex
/usr/local/texlive/2021/bin/x86_64-linux/pdflatex
>
>
>pdflatex foo4.tex
This is pdfTeX, Version 3.141592653-2.6-1.40.22 (TeX Live 2021) (preloaded format=pdflatex)
restricted \write18 enabled.
entering extended mode
(./foo4.tex
LaTeX2e <2021-06-01>
L3 programming layer <2021-06-01>

! LaTeX Error: File `article.cls' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: cls)
 
@Nasser try with a colon at the end
 
@UlrikeFischer yes, I just changed it. I removed the : at the end of TEXINPUT, I did not think it was needed. OMG. All of this because of one simple :
Now it is all working again. I knew I did something silly because it was working OK. Does one need : at end of PATH also? I removed that also, and then I noticed the : at end of TEXINPUT so removed it there at same time.
 
3:01 PM
@Nasser removing the : means remove the standard search path.
@n
you have . at the front (almost) of your path? That's not recommended for security and other reasons.
 
@DavidCarlisle I'm just pondering over lscape. It contains \pdfpageattr{/Rotate 90} which should be handle if the pdfmanagement is used. But basically lscape uses this only if \usepackage[pdftex]{lscape} is used, only with pdftex and only on the last landscape page. So imho this is rather senseless, pdflscape does it better. Should remove this completly?
 
    Experts: I am really confused on $TEXMFHOME.

I created new folder for texmf, and exported TEXMFHOME to point to it. From my .bashrc

export TEXMFHOME=/mnt/g/public_html/styles/texmf:

But when I compile latex file, it still says it can't find the style file.

I also did texhash.   I do not know what else to try. I can post this as question, but I am sure I am doing something silly. Here it is

    kpsewhich -var-value TEXMFHOME
    /mnt/g/public_html/styles/texmf

    >texhash

    texhash: /usr/local/texlive/2021/texmf-config: directory not writable. Skipping...
Oh, I think I see the problem. I need latex below tex !! Will fix that now and try again.
 
is TEXMFHOME set in the shell from which you start latex (eg if you run latex from an editor you start from the desktop, it probably isnt)
@UlrikeFischer I had a request to add the pdfpage attrbute and some user sent a diff which worked when I tried it so I applied it, it was only later I noticed it was activated by explicit pdftex option rather than being integrated in the pdftex back end however chosen. (I think there is a gnats issue somewhere) but then instead of fixing that Heiko put out pdflscape with versions for all kinds of back ends. We shoud really make pdflscape an alias for lscape and then make lscape do something sensible
@UlrikeFischer note I was careful to blame someone else \changes{v3.01}1999/06/22} when adding that code, so it's not my fault.
 
3:29 PM
@DavidCarlisle my error was in putting latex/ at same level as tex/ below texmf, that is why it failed. Fixed it so it is tex/latex/ and now it worked. About the "." in the path, I think you are right, I should remove it and just use ./command if I want to run something in current folder. Thanks.
 
4:12 PM
@DavidCarlisle pdflscape an alias for lscape or lscape an alias for pdflscape?
 
@UlrikeFischer lscape ought to be the main name
 
@DavidCarlisle so we move most the code of pdflscape into lscape and pdflscape then simply loads it. ok with me.
 
4:28 PM
@UlrikeFischer yes
 
@barbarabeeton Does the AMS now use unicode-math, then?
 
@FaheemMitha I think they are still mostly pdftex for production, so no.
 
4:43 PM
@FaheemMitha -- I don't actually know. When last I checked, there were plans to switch from Computer Modern to the STIX fonts, but I don't know whether that has happened yet. I have a feeling, though, that it would first be necessary to move the production stream into a more recent version of TeX Live. (The switchover usually takes at least two years; part of this is just backlog delay, but testing of the newer version is always nontrivial, more so with recent upgrades to LaTeX.)
 
@DavidCarlisle OK.
@barbarabeeton Two years seems like a long time. Do they check that all their text still looks the same, or what?
 
4:56 PM
@FaheemMitha -- When completely switching the fonts, line and page breaks may change, so that requires at least a full editorial review, if not a second proofreading. Such a major change must be made at a full issue break, and preferably at a volume break, so papers are optimally scheduled so that as few as possible must be reprocessed. The most recent backlog report I can find shows a backlog of 6-20 months from delivery for processing to publication in an issue,
 
@barbarabeeton I see. Thank you for the explanation.
 
cis
5:10 PM
I have a question. I have 7 distinctions of the following kind (in the example only 3 of them). Is that correct to do it that way?
\ifnum\Z>10%
\edef\List{\NeList}%
\def\NbGAbbr{[Ne]}%
\else
  \ifnum\Z>2%
  \edef\List{\HeList}%
  \def\NbGAbbr{[He]}%
  \else
    \edef\List{\OrbList}%
    \def\NbGAbbr{}%
\fi\fi%
BTW: I think it will be 2 * 7 = 14 distinctions. Mmmh....
 
cis
5:27 PM
Ui, that can be done with \ifcase, I think, but I've never done that much before.
 
@cis ifcase is good if it's testing 1,2... but nested if is fine if there are ranges, ut beware putting % after integer literals, your code does the right thing there as you have \edef after the numbers but it would be safer and quiicker if you removed the % after 10 and 2
 
cis
@DavidCarlisle Ok. Maybe I can create a runnable MWE. I'm always very interested in shortcuts / summaries.
@DavidCarlisle Ah yes, I think I understand. I didn't know how to use the '>' condition in connection with ifcase.
 
6:18 PM
Let's be positive! github.com/circuitikz/circuitikz/pull/554 positive effect of new Travis policy: reducing the carbon footprint of circuitikz development (around 25% less!)
2
 
7:13 PM
@Rmano Did you offset the environmental impact of the coffee you consumed while battling with the Travis quirks?
 
 
1 hour later…
8:25 PM
@samcarter_looks_forward_TUG'21 hmmm... Good point. ;-)
 
9:20 PM
@egreg Hi, can you see my answer when have you a bit of the time? tex.stackexchange.com/questions/601125/… I not know with xy package where put the symbol | to get the circle label into an arrow. Hi.
 
 
1 hour later…
10:48 PM
@Rmano Avoid the climate impact of consuming coffee, just skip it and use the coffeestains package.
 

« first day (3878 days earlier)      last day (53 days later) »