« first day (3814 days earlier)      last day (32 days later) » 

5:59 AM
@FRQ Hi!
 
 
4 hours later…
9:31 AM
quack
 
10:06 AM
@PauloCereda <b>Breakfast</b>
 
@DavidCarlisle oh no
 
@DavidCarlisle I mean oh no
 
@JosephWright @UlrikeFischer ^^ and then there were three
 
@DavidCarlisle Oooh
 
10:07 AM
@JosephWright ooh
 
@JosephWright not well set up and not on the settings page but the tex lwarp comment does something
 
@DavidCarlisle when will you be able to make breakfeast there?
 
@DavidCarlisle Ah
 
@UlrikeFischer OH NO
 
@UlrikeFischer https://texlive.net/run?%5Ctextbf%7BBreakfast%7D
 
10:11 AM
Hi everybody!
 
@DavidCarlisle ;-)
 
@LukeTheWolf 'ello
 
@PauloCereda can I piss you off for a second? :P
 
hmm I think I had better institute a black list at that server
 
@LukeTheWolf no? :)
 
10:12 AM
@PauloCereda F
 
@DavidCarlisle you are mean
@LukeTheWolf fire at will :)
 
@LukeTheWolf Hi
 
@PauloCereda yes
 
@DavidCarlisle oh
 
@PauloCereda It's about this code
It's a triviality tbh
 
10:14 AM
@DavidCarlisle ^^ oh no
@LukeTheWolf ooh invisible code :)
oopsie forgot to follow the link :)
 
Oh no hahaha
 
@LukeTheWolf What can I help? :)
 
\documentclass{article}

\usepackage[T1]{fontenc}

\usepackage{tikz}
\usetikzlibrary{automata}
\usetikzlibrary{positioning}
\usetikzlibrary{fit}

\begin{document}

\tikzset{basic/.style={draw,fill=blue!20,text width=1em}}
\tikzset{functions/.style={basic,circle,fill=blue!10}}

\begin{tikzpicture}[
shorten >=1pt,
node distance=2.5cm,
on grid,
auto
]

\node[state, initial] (q0) {};
\node[state] (q1) [right=of q0] {};
\node[state] (q2) [right=4 of q1] {};
\node[state, accepting] (q3) [right=of q2] {};
 
@JosephWright added to settings menu (I won't document the config yet as it will probably change)
 
10:19 AM
Is LaTeX in some way interfereing profoundly with \directlua or \latelua? I have some very low-level code (creating annotation whatsits) which is creating different annotation with plain TeX and LaTeX. Does this make any sense?
Plain TeX delivers `/Type/Annot 222` (expected result), and LaTeX `/Type/Annot 111` (not expected).

```
\pdfvariable compresslevel = 0
\directlua{
annot = node.new('whatsit', 'pdf_annot')
annot.data = '111'
node.write(annot)
}
\latelua{
annot.data = '222'
}
```
 
@AndreasMatthias it is the same primive as in plain tex but of course the tex and lua contexts are completely different so whether a fragment works the same way depends on things...
 
@LukeTheWolf In the original code, the "right of" thingy would put the L node in the correct place because I added some convenient distances. :) Since your code modifies these, the trick fails. :)
@LukeTheWolf The solution is to do things the proper way. :) First add \usetikzlibrary{calc} and then let's calculate the "center" coordinate between these two nodes:
\node at ($(q1)!0.5!(q2)$) {{\sffamily\bfseries\large L}};
And there you go. :)
 
@PauloCereda Oh... I've unconsciously made a mess on you code, sorry for that!
Muito obrigado!
 
@LukeTheWolf not at all, it's my "fault" for using a lazy approach. :)
I just wanted to save a calculation. :)
@LukeTheWolf Prego? :)
 
Tricky question btw hahah
It has many interpretations in Italian that questions ;P
 
10:28 AM
@DavidCarlisle ^^ I put "fault" in quotes so it's not my fault. :)
@LukeTheWolf :)
 
@AndreasMatthias in'm surprised you get 222 in plain actually but it seems fragile to change the data in the node in the output routine, the difference is probably latex flioatpage/clearpage handling which can discard zero sized boxes in the output routine
 
@DavidCarlisle I'm surprised too, if both the node.write and the latelua are delayed to shipout, I would expect if at all the node.write to be first.
 
@DavidCarlisle Markup annotations have /QuadPoints which coordinates can only be calculated correctly during shipout. But then it's too late too create new nodes. That's why I'm creating the node first, and update the data later...
 
@AndreasMatthias you will probably have to wander through the shipout box like the tagging code or luacolor or lua-ul does it and then create and insert the nodes.
 
@UlrikeFischer Is it possible to insert new nodes in \latelua?
 
10:37 AM
@AndreasMatthias the alternative is to calculate the coordinates, store them in the aux and use them in the next run.
 
@UlrikeFischer That's exactly what I do not want to do ... ;)
 
@AndreasMatthias I don't know, I mean that is not what tagpdf does, I process the whole shipout box and insert new nodes there.
 
@AndreasMatthias Er, don't they only work in Acrobat?
 
@AndreasMatthias what is wrong in fixing things up on a second run? (I'm not saying it is needed but sonce you need multiple runs for any non trivial document it isn't much of an issue normally)
 
@JosephWright E.g. Highlight annotation are displayed in evince, too.
 
10:43 AM
@AndreasMatthias Hmm, must be new-ish - when I was looking at these for breakable links, they didn't seem to work
@UlrikeFischer ^^ ??
 
@JosephWright I don't know, I haven't tried something here. @AndreasMatthias Do you have small example with QuadPoints so that one can check the viewer support?
 
@UlrikeFischer I sent it by mail.
 
@AndreasMatthias that looks like a rectangle? Do you have something with irregular borders?
@AndreasMatthias but I have to go now, I will be back in the afternoon.
 
@UlrikeFischer Would make the breaking-links-in-dvips trivial
 
@JosephWright also over page breaks?
 
10:53 AM
@UlrikeFischer That I'd have to check - I didn't look at all of the code as I'd concluded the QuadPoint approach didn't work for other viewers
 
@UlrikeFischer Just edit the /QuadPoints in the PDF.
@DavidCarlisle Of course I'll take the aux way if it's necessary. But I'm feeling queasy that plain tex and latex give different results with such low-level code.
 
@AndreasMatthias the output routines and handling of the shipout box are entirely different so it is not surprising that you get different behaviour here
 
11:09 AM
@DavidCarlisle I wonder if we might add one line to learnlatex.org/en/lesson-03 to say 'If you want to produce HTML output, take a look at the help'?
 
@DavidCarlisle It seems like I'm too late with \latelua in LaTeX. It's like the data of the whatsit is already fixed and cannot be changed any more.
 
@JosephWright looks like the html output option will be a permanent fixture so yes, why not
 
@DavidCarlisle :)
 
@JosephWright I just flicked through the site with lwarp, just usual failures, images found via path search not getting copied, and bibliographics not getting processed, both probably fixable in lwarp. but tables math, fonts etc all seem to work fine
 
@DavidCarlisle All good
 
11:19 AM
@JosephWright current lwarp setup is rather basic github.com/davidcarlisle/latexcgi/blob/main/lwarp/latexcgilwarp
@JosephWright looks fine should I merge?
 
@DavidCarlisle Cool
 
11:36 AM
@DavidCarlisle this is a bit hacky, but you can pass the "mathml" option just to test-directlua.tex using:
\edef\testdirectlua{test-directlua}
\ifx\jobname\testdirectlua
\Preamble{mathml,mathjax}
\else
\Preamble{xhtml}
\fi
\ifdefined\xeuniuseblock
\xeuniuseblock{Greek}
\xeuniuseblock{CJK}
\fi
\begin{document}
\EndPreamble
it seems to work :)
 
@michal.h21 ah I guesed it would, it would also be a more generic fix for the example with a local definition of \diff as d for dx. I could of course do that always, what is your recommendation for the best "general" option for math, tex sysntax mathjax or mathml mathjax or svg or ... ?
 
@UlrikeFischer I think "mathml,mathjax" is best in most cases, as it supports expansion of LaTeX commands. You may run into bugs with MathML support in TeX4ht, but I think the basics works good enough nowadays.
 
@michal.h21 thanks I may switch to that, If I don't support MathML, who will?:-)
 
@DavidCarlisle and who can better spot errors in the MathML output :) so maybe we will fix something :)
 
@JosephWright @michal.h21 ^^^ another failing test passing :-)
 
yo'
11:55 AM
hi all
 
12:18 PM
@yo' Dinner
 
yo'
@DavidCarlisle you eat red squares?
 
@yo' Looks like a waffle to me :p
 
yo'
@Plergux haha. Btw, how do you like your haggis? I love the soup!
 
@yo' I'm a garbage disposal. I'll eat anything. Well, almost. Not a soup fan generally (unless it's fifty percent cream) and I hate celery :p
 
yo'
@Plergux haha
my soups are the other way around: nothing can beat a good strong broth, like the haggis soup ;)
50% cream would be a sauce here really...
 
12:32 PM
@yo' Well, considering that I have my sauce in a cup with my meal... :p
@yo' Good Christmas Turkey gravy, who needs turkey :p
 
@Plergux celery soup for you then.
 
@DavidCarlisle LOL. Can I have octopus arsehole soup instead? :p
 
@yo' quack <3
@Plergux ooh an ostrich sheep
 
@PauloCereda see my reply
 
@DavidCarlisle oh no
 
12:45 PM
@PauloCereda hmmm... would that be a sheep with an ostriches head and four ostrich legs or a wooly ostrich with a sheeps head? :p
 
@Plergux DRAW A POKÉMON PLEASE <3
 
1:04 PM
user image
4
 
@Plergux OMG
 
1:50 PM
@JosephWright or @StefanKottwitz Would you please turn the comments section of this topic: tex.stackexchange.com/q/591502 into chat? Thanks!
 
2:02 PM
@AlexG should I try something on windows?
 
yo'
2:34 PM
Overheard on the internet: Forget nuclear. Let's harvest energy from children at bedtime.
3
 
@UlrikeFischer Thank you, Ulrike. If you have some spare time, would you please try the example with MiKTeX? I did a fresh tl21 install on an old Win-7 laptop and ran mpost on the example file. It worked flawlessly.
 
@AlexG which one of the many edits? And with which calls? (I got a bit lost in the discussion)
 
@UlrikeFischer mpost --tex=latex exp.mp. This is the example file from animate.
 
2:50 PM
@yo' lol
 
@AlexG Hm, I download the whole animate folder from ctan as zip, unzipped it and switch to the files folder and run the command and it works fine, both with miktex and texlive. The mpx is found without problems.
 
@UlrikeFischer This is what happened on my end too. There must be something mis-configured in OP's environment.
 
@AlexG Imho the OP simply downloaded only the mp and not the rest of the files.
 
@UlrikeFischer Should work out of the box with only the mp file. There are no dependencies, except from a working TeX environment.
This is just generates the PS files of the animation sequence.
 
3:07 PM
@AlexG oh the mpx is an output file, I had forgotten that I compiled already once. Then it is perhaps virus protection or so. That could prevent the creation of the mpx.
 
@UlrikeFischer Good point. I will tell him.
 
@AlexG I already added a comment.
 
@UlrikeFischer Oh, thanks!
@UlrikeFischer By the way, Windows is a nuisance. I changed some 20 years ago.
 
@AlexG no not really. I see less OS specific problems then with linux, where people often fight with the difference between distrib and vanilla texlive, or wonder why xelatex doesn't find fonts.
 
@UlrikeFischer Maybe they were starting with TeX and Linux at the same time?
 
3:40 PM
@AlexG do you understand the coordinates of QuadPoints? I don't get rectangles ;-(
 
@UlrikeFischer (x,y) of 4 points in "default user space". You need all 8 values because the quad-rectangle might be rotated, whereas for /Rect 4 values suffice because a /Rect cannot be rotated.
 
@AlexG I moved the comment thread to a chat room
 
3:55 PM
@AndreasMatthias yes I know that. I'm using 8 values. But the order is odd, and I don't get a rectangle. E.g. if do this:
\RequirePackage{pdfmanagement-testphase}
\DeclareDocumentMetadata{pdfversion=1.7,uncompress}

\documentclass{article}
\usepackage{tikz}
%
\AddToHook{shipout/background}{\put(0cm,-\paperheight)
 {\tikz[overlay]
    \filldraw[red](238.68544bp,603.7864bp)--
                     (260.67048bp, 603.7864bp)--
                     (260.67048bp, 679.4078bp)--
                     (238.68544bp, 679.4078bp)--
                     cycle;}}
  %
\begin{document}

\ExplSyntaxOn
\pdfannot_box:nnnn{5cm}{1cm}{4cm}{
Oh is perhaps a sumatra bug. Adobe reader shows a different output..
This is sumatra:
@AndreasMatthias but adobe reader is curious too, there I get e.g. (if use the same order as in the tikz code):
 
@UlrikeFischer Yes, I see. Somethings weird. Maybe the /Rect? All /QuadPoints should lie inside the /Rect...
 
@AndreasMatthias the rectangle is [133.768 553.812 275.501 695.544] so I think I'm inside.
 
4:13 PM
@UlrikeFischer I created the annotation with okular. But I have no idea why the points are give diagonally instead of clockwise or counter-clockwise.
This is from the PDF specification...
 
@AndreasMatthias yes, I checked that. That is why I'm so bewildered. I get some rounded rectangle by using topleft, topright, bottom left, bottom right, but this is clearly against the spec.
 
@yo' more or less "Monsters s.a." ;-P
 
@UlrikeFischer Both evince and okular display a normal rectangle when the points are given diagonally. But display a distorted rectangle when point are given counter-clockwise. That's weird...
Same result with gv.
 
@AndreasMatthias, @UlrikeFischer I got round to re-testing QuadPoints for links
\documentclass{article}
\usepackage{hyperref}
\ifnum\pdfoutput=0 %
  \usepackage{hypdvips}
\fi
\begin{document}

Hello world which we deliberately force
to the edge of the \href{some-text}{a-link-broken-over-lines}

\end{document}
still doesn't really do the right thing with Preview or TeXworks PDF viewer
 
4:29 PM
9
Q: PDF Spec vs Acrobat creation (QuadPoints)

tillerstarrI've created some annotations (Underline, Highlight, Strikeout, Squiggly) in Acrobat and am digging out the QuadPoints array to render with. The pdf spec PDF 32000-1:2008 says they are in counter clockwise order, and x1,y1 -> x2,y2 specifies the base of the quadrilateral. This should look like:...

 
yo'
@Rmano lol
 
Do the following diagrams have name in mathematics?
:57609929 So what should I say to refer to this diagram? :-)
 
yo'
@MoneySetsYouFree really depends on what you need to say. Types of relations?
 
@JosephWright but there at least the quadpoints coordinates follow the spec. So it looks as if for link annotations adobe does it right, but it fail for Highlight and other markup annotations. @AndreasMatthias
 
If there are a cartesian product {(a,1),(b,2),(c,1)} and I want my students to draw this relation with the above diagram rather than plotting the dots on the Cartesian coordinate system, what should I say in the question sheet?
@yo' ^^
 
yo'
4:40 PM
@MoneySetsYouFree "Draw the domain and image sets and connect the elements paired by R = {(a,1),(b,2),(c,1)}"
no need to give it a name.
 
@yo': OK thank you. :-)
 
yo'
@MoneySetsYouFree no worries
you know, I hate overnotionizing maths, and school math in particular :)
 
@yo' I love using internationally standardized terminologies and notations. I have to quit. Thank you for your time. :-)
 
yo'
@MoneySetsYouFree yeah, and in order to have standardized notions, you should have as few terms as possible ;)
bye!
 
5:01 PM
@UlrikeFischer PDF 1.7 Spec is quite old. Do you know someone who has access to the new ISO version of the spec?
 
@AndreasMatthias it is the same in pdf 2.0. And I'm just writing an issue at the pdfa. This behaviour makes quadpoints useless, but as this they are a required value this must be resolved somehow.
 
yo'
5:18 PM
user image
2
 
@yo' XD
 
Hello. Does someone know how to change \usepackage[margin=1.7cm]{geometry} to 2.5cm of margin on the right, bottom and top? and on the left 4cm?
 
@Verónica you simply specify each one: left=4cm, etc.
 
yo'
@Plergux yeah, or [hmargin={4cm,2.5cm}, vmargin=2.5cm]
@Verónica btw, the documentation to geometry is nicely written, so you can read more details there: ctan.org/pkg/geometry
 
@Verónica as the others have said but you should probably also use heightrounded so that the page height is consistent with baselineskip
 
5:42 PM
Thank you thank you. I got it.
@DavidCarlisle ??
 
@Verónica if you set the top and bottom margin to exactly 2.5cm then the remaining \textheight will not be a multiple of \baselineskip so if you have a page just with text with no stretchy space eg from a section heading it will be impossible to meet the specified size. If you add heightrounded at the end of the option list geometry will adjust \textheight (effectiively adjust the bottom margin) so that the text height does match a page that just consists of lines of text
 
@yo': I think the diagram in question is called as arrow diagram.
 
yo'
@MoneySetsYouFree never heard that. As I said before, IMHO if you don't need that notion, you shan't use it.
 
@yo' OK. Thanks!
 
yo'
but that's only my opinion, you know :)
 
6:01 PM
@DavidCarlisle thanks, I included it too.
I have another question: Is there a way to change all the \vspace{Num.cm} on the document to a unique and fixed \vspace{.6cm}?
 
6:23 PM
user image
4
Wrong comma, but on my way to 210,012 ;-)
@Verónica The best way is probably to do a search and replace in the editor --- best not to change internal LaTeX commands. Any decent editor should be able to do that...
 
6:45 PM
@Rmano huh? I'm working in Overleaf. I know this changes are possible on programming code, but I don't know how can this be done here. Worst case scenario, manually..
 
6:57 PM
@Verónica you can do search/replace in overleaf's editor (of course there should not really be any vs[ace at all in the document)
@Verónica ctrl-f pops a find and replace box . If you open the sidebar menu and click on "show hotkeys" near the bottom you see all such keys
 
7:34 PM
@Verónica Ctrl-h, write old string, new string and then click "All"
 
7:58 PM
@StefanKottwitz Danke ;)
 
Maybe interesting, LaTeX-2-Unicode converter: unicodeit.net
 
@Dr.ManuelKuehner @JosephWright ^
 
8:15 PM
@AndreasMatthias As far as I can tell, only Acrobat supports quadpoints, @UlrikeFischer
@AndreasMatthias , @UlrikeFischer I didn't follow your discussion; did you see this example: tex.stackexchange.com/a/415756 ?
 
@AlexG yes, but the discussion wasn't primarly about quadpoints in links, but in text markup annotations. Adobe creates there the coordinates in the wrong order
 
@UlrikeFischer Ah, sorry.
 
@AlexG no need to be sorry your links are useful too (I guess with the new code less patching is needed here ...), and Joseph is also interested in the support for links as it would help in breakable links for dvips.
 
@Rmano Just FYI, this link on your personal website seems to be down: gallery.rgtti.com (HTTP ERROR 500)
 
@AlexG btw: it would probably be good to mention to the gs-devel list that setting the version before the comment is not standard conforment.
 
8:28 PM
@UlrikeFischer @JosephWright ^^ command completion... (still haven't figured out how @yo' manages to feed it a pre-existing list of latex commands:-)
 
@DavidCarlisle You are enjoying this ;-) Does it know \duck (and then print \breakfast)?
 
@UlrikeFischer Ah, yes. Thank you for the reminder. And what about Distiller? Does it allow for setting the PDF version after the DSC header?
 
@UlrikeFischer currently it only knows things that are already in that editor, theer is an API for adding language specific completion function but the documentation reminds me why it's a bad idea to read documentation
 
@AlexG it doesn't seem to allow the version at all. It quite insists to use its own settings (which doesn't include pdf 2.0 in my version).
 
8:50 PM
Good evening to all user that in this moment are in chat.
@Dr.ManuelKuehner Dearest I liked your message to a female user who just signed up today. But was it really referring to MWE the compliment or to her? ahahahahah
 
@Sebastiano Haha, it was about the MWE :).
 
@UlrikeFischer And if you s/setpagedevice/setdistillerparams/ ?
 
9:06 PM
@AlexG no. it doesn't work either. But I'm not sure if it is in the right place. (But I checked: the option to allow the postscript to overwrite settings is set).
 
@UlrikeFischer Ok, that's the way it is...
 
@Dr.ManuelKuehner ups, yes. Never looked at the gallery... thanks for the heads-up!
 
@DavidCarlisle Thanks. With this option, I can see that I can change, for example, all \vspace{1cm} to \vspace{.6cm}. Can the 1cm be set to, say, "x" cm so that all the different numbers {1,2, etc} are changed to .6cm at once?
 
@Dr.ManuelKuehner I absolutely do not believe this ahahahahah. I'm sorry ahahahha.
 
9:19 PM
@CarLaTeX Thanks too. I did notice that ctrl-f and ctrl-h does the same
 
@Verónica replace vspace.[0-9.]*cm by vspace{4cm after clicking the left most icon below the replace text "regex search"
2
 
@DavidCarlisle it is already online or are you the only one who can play with it?
 
@UlrikeFischer just me and it only knows that input and inputiffileexists both start with inp. the rest is a "exercise for the reader"
 
@UlrikeFischer Done.
 
Yes you can use regular expressions search and replace --- you can replace `\\vspace{.*}` with `\vspace{0.6cm}`.
But really, this is probably an XY problem: you should almost *never* need a `\vspace` in a LaTeX document
 
9:27 PM
@Rmano [0-9.]*cm safer than .* or \vspace{5cm} \mbox{aa} will get changed to \vspace{0.6cm}
 
@AlexG As Ulrike already said, we were talking about highlight annotations. Okular can create highlight annotations, and evince displays them correctly. Even gv displays the hightlighted lines, but no interaction of course.
 
@DavidCarlisle yes, you're right, I always forget that regexp are greedy by default (I think that was an error --- the other way around seems much more natural to me)
@Verónica regular expressions are really a kind of swiss-knife thing: en.wikipedia.org/wiki/Regular_expression
but also: xkcd.com/1171 ;-)
 
@MoneySetsYouFree Maps? (Maybe the mathematicians here know better.)
 
@DavidCarlisle Did you mean this \vspace{[0-9.]*cm}? and below \vspace{.6cm},
didn't work
 
@Verónica use . not { for the {} in the search text as I had above and omit the \ at the start
 
9:41 PM
aah
 
@Verónica \ { } (and .) are special characters in regex it is possible to quote them but the exact syntax differs in different editors and actually I have never used regex search at overleaf until just now, so simpler to avoid needing to quote
 
@Verónica in regexps you need to double the `\`
 
@Rmano describing quoting in regex while using crazy almost but not quite markdown chat syntax is fun isn't it?
 
@DavidCarlisle yeah....
 
@Rmano simpler just not to have \ at all unless you think vspace may occur in plain text
 
9:46 PM
@DavidCarlisle yes, I see... Too slow ;-)
 
@DavidCarlisle got it, it worked:) ..At first I thought you had missed the } on the vspace{4cm
 
@Verónica regex are quite powerful to do complicated search and replace, but typically it is only worth the time to fight with the syntax if you have a lot to replace which really needs regex. If you have only 5-6 different vspace values, you are faster if you do them with simple search and replace.
 
@Verónica I had actually tested it at overleaf before posting:-) But as said before if you have more than a couple of vspace in a document then you are doing something wrong!
@UlrikeFischer spoil sport: where's the fun in that.
 
Sometimes I think that I have friends that hate me to have shown them regexp...
 
@Rmano no, they would have hated you anyway, does that make you feel better?
 
9:54 PM
@DavidCarlisle yeah, that's a comforting thought
I once scared away a girlfriend by showing her the movie "On the beach" - regexps are similarly scaring I think
 
@yo' do you know if the command completion at overleaf is sensitive to the packages used or does it always offer the same list?
 
10:11 PM
anyone an idea how you call a driver file in french?
 
10:24 PM
@UlrikeFischer Pilote informatique??? I searched for 'device driver' in the english wikipedia and then switch the langugage to french.
 
@UlrikeFischer Our friends at TeXnique.fr could tell us.
 
@AlexG Map or Mapping or Function is a special kind of relation. So using Map to represent this kind of arrow diagram will make a severe confusion. :-)
 
@AndreasMatthias I found "pilote" to, but I'm not sure if it is the word used by latex users.
@StefanKottwitz yes, I can also ask tomorrow Denis, but I thought I try at first the fast way here.
 
@MoneySetsYouFree Alright, I knew any maths guy would be more competent at this ;-)
@UlrikeFischer Yes, pilote is definitely the right french technical term for (device) driver.
And also for wrappers around other pieces of software.
 
10:44 PM
@Canageek Yes, you can roll your own here: dev.to/rly
 
11:37 PM
@DavidCarlisle yes, sorry for my comment. I'm the one that does lots of mistakes here and there on Overleaf. What do you mean with "if you have more than a couple of vspace in a document then you are doing something wrong!" I actually have a lot.
but they don't cause problems, save for this one.
@DavidCarlisle indeed. That profile picture that you have, Rmano, would have been enough. jk. It's very hilarious, the prominent eyes.
 

« first day (3814 days earlier)      last day (32 days later) »