« first day (3732 days earlier)      last day (42 days later) » 

12:06 AM
Do you have any idea how to make this line work in windows?
\immediate\write18{wolframscript & echo %ERRORLEVEL% > latexalpha2_check.tmp}
I tried escaping \% and \& but it still doesn't
 
@Diaa \begingroup\catcode\%=12\catcode\&=12\catcode_=12 \@firstofone{\endgroup\immediate\write18{wolframscript & echo %ERRORLEVEL% > latexalpha2_check.tmp}`
@Diaa change the category codes locally (like done above) or use the \lowercase trick (but that one would be annoying since you actually need uppercase characters).
 
@Skillmon I forgot to say that this line should be written inside a package definition.
@Skillmon Would it work inside a *.sty file?
 
\begingroup
  \catcode`\%=12
  \catcode`\&=12
  \catcode`\_=12
  \expandafter
\endgroup
\@firstofone{\newcommand*\mywolframcall{\immediate\write18{wolframscript & echo %ERRORLEVEL% > latexalpha2_check.tmp}}}
@Diaa use the above, and then use \wolframcall instead wherever you'd want to put your \immediate\write18.
 
@Skillmon you mean \mywolframcall?
 
@Diaa It doesn't really matter whether you use \@firstofone{\endgroup\newcommand...} or \expandafter\endgroup\@firstofone{\newcommand...} (but the former is a bit faster)
@Diaa of course :P
 
12:16 AM
i just thought asking wouldn't be bad
instead of bouncing around
nevermind
 
@Minsky yeah, but you didn't ask.
 
yeah i didn't sleep much
 
@Minsky instead you posted a few words without context and a question mark, that's not a question.
 
i know i know
sorry
 
@Minsky so, what did you mean? Do you want to implement a neural network in LaTeX? If so, bad idea, don't.
@Minsky do you want to draw network topologies? If so there are more than enough examples on the site already.
 
12:18 AM
wanna do wan to chase monsters
 
@Minsky afaik, there is no dedicated package to draw or create NNs, but drawing can be done with TikZ rather easily.
 
I see. Yes, this kindof diagram:
with less lines though
i'll check tikz
 
@Minsky should be easily done in LaTeX with TikZ and \foreach. Code on the main site.
 
great, thanks @Skillmon
 
@Minsky there are newer questions with coloured networks and maybe more fancy code.
 
12:21 AM
It didn't work with me. For the following snippet

\AtBeginDocument{%
%^^A heck if shell-escape is available
\ifcase\pdf@shellescape
\PackageError{latexalpha2}{Shell escape is not enabled, which is required to use latexalpha2}{}\or
\PackageInfo{latexalpha2}{Shell escape is successfully enabled}{}\or
\PackageError{latexalpha2}{Shell escape is not enabled, which is required to use latexalpha2}{}\fi

%^^A check if wolframscript is available
\begingroup
\catcode`\%=12
\catcode`\&=12
\catcode`\_=12
\expandafter
 
@Minsky interesting link: github.com/battlesnake/neural
@Diaa you're missing a } after the last \PackageError line for \AtBeginDocument.
 
that looks good
 
@Skillmon I think I don't since I had no error before inserting this chunk of code.
 
@Diaa but you do, at least I don't see the matching closing brace. Also, please note that my code must not be nested as the argument of another macro, so you can't use it inside \AtBeginDocument but must define \mywolframcall at the top level.
 
I go in endless compilation when having this

\begingroup
\catcode`\%=12
\catcode`\&=12
\catcode`\_=12
\expandafter
\endgroup
\@firstofone{\newcommand*\mywolframcall{\immediate\write18{wolframscript & echo %ERRORLEVEL% > latexalpha2_check.tmp}}}

\AtBeginDocument{%
%^^A heck if shell-escape is available
\ifcase\pdf@shellescape
\PackageError{latexalpha2}{Shell escape is not enabled, which is required to use latexalpha2}{}\or
\PackageInfo{latexalpha2}{Shell escape is successfully enabled}{}\or
\PackageError{latexalpha2}{Shell escape is not enabled, which is required to use latexalpha2}{}\fi
 
1:01 AM
@Diaa you can use \@percentchar
@Diaa why not simply run the script before latex, why use write18 at all? (also it seems to be using commands you have not defined (or shown them being defined such as \pdf@shellescape
 
@DavidCarlisle Please, have a look at this package file
%% This is file `latexalpha2wlua.sty',
%% generated with the docstrip utility.
%%
%% The original source files were:
%%
%% latexalpha2.dtx (with options: `package')
%%
%% This is a generated file.
%%
%% Copyright (C) 2019 by Yi Liu <me@yliu.io>
%%
%% This file may be distributed and/or modified under the conditions of
%% the LaTeX Project Public License, either version 1.3c of this license
%% or (at your option) any later version. The latest version of this
%% license is in:
%%
%% http://www.latex-project.org/lppl.txt
The problematic line is no. 186
\immediate\write18{wolframscript \@ampchar echo \@percentchar ERRORLEVEL\@percentchar > latexalpha2_check.tmp}
 
@Diaa well that runs wolframscript whatever that does
 
This Windows command
wolframscript & echo %ERRORLEVEL% > latexalpha2_check.tmp
needs to be interpreted inside the package definition.
 
@Diaa do you have the command wolframscript installed?
 
@DavidCarlisle Yes. I can run the command externally in the command prompt without any problems
 
1:10 AM
@Diaa well as a start just use \immediate\write18{wolframscript} and skip the checks
 
@DavidCarlisle Actually all the AtBeginDocument part can be skipped/deleted since I am sure that I have wolfram installed and shellescape enabled.
I am just curious how to make this command work for my own knowledge.
 
@Diaa delaying the shell escape checks to begin document makes no sense anyway as it can not change
@Diaa sure but remove all the tests simplify it to get it working then put them back bit by bit until it breaks
you say it loops?
 
I just copied what the original author wrote :)
If you have further recommendations I would be grateful to give them as comments on this answer to my question https://tex.stackexchange.com/a/579254/2288
@DavidCarlisle This version pastebin.com/CuScXXVm doesn't stop compiling.
 
@Diaa stick \tracingall somewhere and see what it is doing, but it's 1 in the morning and I don't have a windows tex or a wolfram alpha script so I'm out:-)
 
@DavidCarlisle good night :)
 
1:31 AM
@DavidCarlisle @Skillmon I knew what made it loop. Wolframscript in Windows is waiting for my input, so I had to make it like this

\immediate\write18{WHERE wolframscripts >nul 2>nul \@ampchar echo \@percentchar ERRORLEVEL\@percentchar > latexalpha2_check.tmp}
to work

Thanks for your consideration and help
 
1:53 AM
@Diaa Are you trying to make that package compatible for windows?
 
Yes. This is my original question https://tex.stackexchange.com/q/578144/2288
I think I managed to make it work after the answer I got and the help here.
 
 
7 hours later…
8:31 AM
@DavidCarlisle sometimes I should think before providing a great solution :)
@Diaa there is the possibility to check whether you're currently running on a Unix or on Windows from within TeX, you can use the ifplatform package for that. With it you could make latexalpha2 OS independent.
 
@Skillmon Or in expl3 \sys_if_platform_unix:TF
 
8:51 AM
@Skillmon thinking is definitely optional at that time of night
 
@PauloCereda breakfast
 
@DavidCarlisle oh no
 
@Skillmon To be fair, Will does more work in ifplatform, but really I think if you are in one of the pathological situations, you are on your own
@PauloCereda Morning
 
@JosephWright quack <3
 
8:53 AM
@PauloCereda I see some parts of Brazil have slightly more sane leadership than your president
 
@JosephWright SP has started vaccination yesterday, yes.
 
@PauloCereda :)
@PauloCereda Good stuff
 
@JosephWright although I wouldn't use the term "sane" to describe any of our politicians. But as long as people get vaccinated ASAP, that's what really matters.
 
9:09 AM
@PauloCereda Are politicians ever sane? My husband once said that anyone caught showing the slightest interest in becoming a politician should immediately be banned from becoming one forever. :p
 
@PauloCereda foreign languages don't help with notable linguists ;-)
 
@UlrikeFischer ooh hallo <3
@Plergux ooh
 
@DavidCarlisle agreed, it was past 1am for me :)
 
@Skillmon ooh a night rabbit
 
@Plergux I worked for many years for an MP and found him very nice and very sane. He (and a number of his and our friends) got into politics because they cared about their city and the people who lived there.
 
9:18 AM
@UlrikeFischer ooh I wanna be German
 
@Plergux I think this is taken from some movie (or philosopher?)...
@PauloCereda @DavidCarlisle incoming citing you saying you want to be British.
 
@Skillmon oh no
 
@UlrikeFischer My dad did local politics, so I can believe that: even the 'opposition' could be pretty reasonable on a lot of local issues
 
Dec 4 '19 at 20:17, by Paulo Cereda
I wanna be Swede
 
@DavidCarlisle ooh
 
9:22 AM
@Plergux Problem is of course somebody has to do it: we do need government, and lots of (mainly boring) service provision
 
@mikep ^^
@JosephWright During the Brexit discussions in Parliament, it was great to watch the house of commons talk. There's so much titles involved, the Right Honourable Gentleman for <district>.
 
@PauloCereda :)
 
@Plergux although the politicians today don't get much of the things right, I must admit that I align myself with Paul VI's thoughts when he said politics is one of the highest forms of charity. :)
ooh so a Pope used vi?
@DavidCarlisle @Skillmon ^^
 
@PauloCereda Henry the eighth saved us
 
@DavidCarlisle so you exchanged a pope for a queen as head of the church. :)
 
9:32 AM
@PauloCereda and she uses emacs
 
@DavidCarlisle ooh queenmacs
 
10:22 AM
@UlrikeFischer There is always an exception (the linguists maxim :p) But my experience with Icelanders who go into politics due to principle tend to lose them fairly quickly once they get their ass into a comfy chair.
@Skillmon Probably. He reads a lot of philosophy. :p
@JosephWright So did mine. He's mad as a hatter :p
@JosephWright My brother in law is very much into the idea of treating government like jury duty.
@PauloCereda In the sense that it's giving jobs to people who nobody else wants to employ?
 
@Plergux :D
 
@Plergux Sounds like being head of department: where I did my degree, it wasn't optional for the senior staff :)
 
@JosephWright I think it's the same here. At least in the humanities.
 
@Plergux My current place doesn't work like that; some of my more senior colleagues don't want to do it as it will suck up their research time. I think 'tough, you took the Professorial promotion'
 
10:42 AM
@JosephWright Yeah, it's like all of the perks with none of the responsibility of making the whole work.
@JosephWright (but I bet they're not shy to complain how others do it)
 
10:54 AM
@DavidCarlisle I didn't see that coming... :)
@PauloCereda I think this really depends on the politician. For some this might be true, for others it's just about personal benefit.
 
@Skillmon quite
 
11:07 AM
@PauloCereda sure, show the code.
 
@UlrikeFischer ooh
 
@PauloCereda lualatex?
 
@UlrikeFischer pdflatex
 
11:46 AM
@UlrikeFischer what exactly is trimspaces.ins doing? :-) anorien.csc.warwick.ac.uk/mirrors/CTAN/macros/latex/contrib/…
 
@DavidCarlisle ooh I use this mirror too
 
@PauloCereda you don't live within walking distance of Warwick (longish walk:-)
 
@DavidCarlisle oh but I wanna be English
 
@DavidCarlisle hm. What on earth is this?
 
@UlrikeFischer it's the .ins file for trimspaces....
 
11:50 AM
@DavidCarlisle yes, but what it is supposed to do?? This must be some error?
 
Mar 5 '15 at 17:32, by Paulo Cereda
I wanna be Italian. Oh wait, I sort of am. :)
 
@DavidCarlisle ooh
 
@UlrikeFischer one almost suspects that Will may have randomly copied files from one of his other packages. I would never make such an error.
 
@DavidCarlisle but it is quite explicitly in the .tex (but the tex no longer compiles).
 
@UlrikeFischer I mailed Will
 
12:02 PM
@DavidCarlisle good.
@PauloCereda it is actually documentated (page 245 ...)
 
@UlrikeFischer oh
 
@PauloCereda don't take any note of cheaty "read the documentation" answers. Bound to be fake news.
 
@DavidCarlisle I was actually using your code snippet and it didn't work. :)
@UlrikeFischer ^^ :)
 
@PauloCereda I have no idea what that thread was about, I just added the comment on general principles.
 
@DavidCarlisle ooh <3
@DavidCarlisle I was using another class, so no harm done. It was my fault. :)
 
12:21 PM
@DavidCarlisle I actually looked in the documentation only to check if I should complain to @daleif that the command I found in the code is not documentated ;-) (if you really want to emulate mparhack with memoir you need \strictpagecheck):
 
@UlrikeFischer <3
 
@UlrikeFischer I have no idea what package this is about?
 
@DavidCarlisle it fixes marginpar being issued in the "wrong" side of the margin when a new page is being shipped.
 
@PauloCereda what is "it"
 
@DavidCarlisle mparhack
 
12:28 PM
@DavidCarlisle the mparhack thingy
 
@PauloCereda that's not my code is it? I think I will drop out of this conversation it's too confusing
 
@DavidCarlisle not it's not, you offered an ad hoc patch for the issue, so no worries. :)
 
@PauloCereda if it didn't work blame Ulrike.
 
@DavidCarlisle she actually saved me. :)
 
@PauloCereda she may need to save you again, it's nearly lunch time
 
12:33 PM
@DavidCarlisle oh no
 
@PauloCereda oh, an Albatross update.
 
@Skillmon ooh
 
Yesterday I broke my sleigh :(
 
@Skillmon oh no
 
1:15 PM
@UlrikeFischer I don't think mparhack is needed for that in memoir, but \strictpagecheck is
 
@daleif yes, I found that out. But it is a bit confusing, that memoir writes "emulating mparhak" but then doesn't actually do it unless you activate the strick check. Btw: memoir doesn't work like mparhack in two column mode. This here still fails (the example is from the latex bug tracker):
\documentclass[twocolumn]{memoir}
\strictpagecheck
%\documentclass[twocolumn]{article}
%\usepackage{mparhack}
\setlength{\marginparwidth}{2mm}
\begin{document}
\vspace*{15cm}
right margin\marginpar{\tiny A}\vspace{1.5ex plus1ex minus1ex}\par
right margin\marginpar{\tiny A}\vspace{1.5ex plus1ex minus1ex}\par
right margin\marginpar{\tiny A}\vspace{1.5ex plus1ex minus1ex}\par
right margin\marginpar{\tiny A}\vspace{1.5ex plus1ex minus1ex}\par
right margin\marginpar{\tiny A}\vspace{1.5ex plus1ex minus1ex}\par
 
Maybe someone here is interested in this: ai.stackexchange.com/questions/7431/…
 
2:17 PM
Why isn't \textasciiunderscore and alias for \_?
 
@PauloCereda $ man arara
Ninguna entrada del manual para arara
 
@PabloGonzálezL we have one for version 6.0 :)
@PabloGonzálezL also, man should not work, you should go with
$ bird arara
2
/ba dum tss
:D
 
@PauloCereda Jejej, 'arara' will speak Spanish?
 
@PabloGonzálezL good question...
@PabloGonzálezL no Spanish this time, I am afraid. :(
 
@PauloCereda I think @Rmano speaks Spanish?...dejo la pelota dando bote :)
 
2:26 PM
@PabloGonzálezL ooh los ardillas son muy buenos com español
 
@PauloCereda I looked for something like "translations" in the repository (in git they were somewhere), but in GiT Lab I can't find it :(
 
@PabloGonzálezL The format has changed now, hold on...
 
@PauloCereda Great, maybe (just maybe) they should put a collaborative section for translations...arara is multiplatform, it would be great if it was multi-language too :)
 
@PabloGonzálezL Thanks. :) Version 7.0 will have a very different approach than the next one, so we can discuss a better localisation framework. :)
 
@PauloCereda Yep, but as my second language (first is Italian, third English)
 
2:32 PM
@PauloCereda Great, the world will know the power of the arara 7 side :D
 
@Rmano ooh scoiattoli are very smart :)
Jul 23 '14 at 19:15, by percusse
@PauloCereda arara is on its way of becoming the emacs of TeX
 
@PauloCereda a strange thing it happens to me is that no one is able to locate my accent (not even italians now)
 
@Rmano ooh which region are you from?
 
@PauloCereda Telling the region is not useful --- I am from a village near to La Spezia, which is on the en.wikipedia.org/wiki/La_Spezia%E2%80%93Rimini_Line linguistic line --- I used to notice changes of accents in my zone for places just 20km apart, now I lost it together with my special Sarzana's accent.
 
@Rmano oh no
 
2:38 PM
@PauloCereda well, worse things can happen
 
@Rmano mum is from Emilia-Romagna
 
@PauloCereda She's on the same side of the line ;-) so
 
@Rmano ooh
 
@Rmano No tener acento es como hablar en modo incógnito ...tiene sus ventajas :)
@PauloCereda You collaborate with (learnlatex.org)
 
@PabloGonzálezL Here in Spain they used to think I were Argentinian but controlling a lot my accent. Now in Italy (at least the first couple of days before I get up to speed) they thinks the same :-)
 
2:42 PM
@PabloGonzálezL I annoy the English blokes :)
@Rmano Pelé es mejor que Maradona
Let's test. :)
 
@Rmano Argentinean NOT :) [I am Chilean]
 
@PabloGonzálezL ooh Valdívia played for my football team
 
@PauloCereda +1
 
@PauloCereda vivamente y sin dudar
 
@Rmano ooh not Argentine :)
 
2:46 PM
@PauloCereda I have a question, actually it's just out of curiosity, it's very difficult to implement a "copy to clipboard" button (at www.learnlatex.org)
 
@PabloGonzálezL Probably not too difficult, I will poke them. :)
 
@PauloCereda It is something quite useful, actually I would like it to be here too, but, it is not part of the design of this site :(
 
3:01 PM
@PabloGonzálezL There are browser addons to add such a button to stackoverflow, github etc.
 
@DavidCarlisle @JosephWright @PabloGonzálezL I see code for copying, perhaps it's just a matter of enabling copy in ACE?
 
@samcarter_says_quack Thank you very much :) it's just what I need
@PauloCereda It would be great, although the option of using an 'addons' is comfortable, it is better to have it natively :)
 
3:50 PM
@PabloGonzálezL there was one but I removed it (@PauloCereda)
 
@DavidCarlisle Any reason?
 
@PabloGonzálezL unlike the code blocks here you can simply do ctrl-a cntrl-c to copy so it doesn't really add anything useful
@PabloGonzálezL you can copy text from ace editor easily enough already can't you?
 
@DavidCarlisle sorry
@DavidCarlisle oh Jonas
 
@DavidCarlisle Yes, now I understand the reasoning, for small texts it is not a problem, it is just that the button is more comfortable, using the key combination is ultra easy if you have a keyboard, but, nothing practical if you are in a tablet :(
 
4:00 PM
@PabloGonzálezL hmm there may be a select all gesture on a tablet not sure, but again on a tablet it's not so clear where to put the button either (coding it is just half a dozen lines of code so that is easy enough)
 
@samcarter_says_quack ooh
 
@DavidCarlisle The 'addons' that @samcarter_says_quack gave me put the copy button in a quite useful position, actually, nowadays it's much more common to see a student using a tablet than a pc :(
 
@PabloGonzálezL without any add on if you hold down in android at least you get a select all then copy menu and I copied a whole document easily enough
 
@samcarter_says_quack where's the chicken? twitter.com/hyxpk/status/1351197672728899584
@samcarter_says_quack I love this artist and this comic strip about little nuns and ducks. :)
 
4:16 PM
@DavidCarlisle Yes :) it's easy, but in the world of clicks a button is more comfortable. The selection in android is horrible (in version 9 not so much), but it's a mess and copies more than the account.
 
@PauloCereda actually I removed it not Jonas, when I switched to the ace editor rather than a simple content editable div
 
@DavidCarlisle since the designer is working on it (I suppose), perhaps give the buttons a better design...
@DavidCarlisle ah so it's one less commit from him, understandable. :)
 
@PauloCereda oi
 
2 hours ago, by Paulo Cereda
@PabloGonzálezL I annoy the English blokes :)
 
Oct 5 '19 at 10:51, by David Carlisle
@PauloCereda don't worry it'll soon be dinner time
 
4:19 PM
@DavidCarlisle oh no
 
@PauloCereda Found it :) These comics are so cute!
 
@samcarter_says_quack They are! And there is always a hidden chicken! :)
@samcarter_says_quack I thought of buying the artist's comic book, but given the pandemic restrictions on delivery, I decided not to. Now the Kickstarter is closed...
 
4:37 PM
@PauloCereda Maybe it will become available as regular book if successfully :)
@PauloCereda Pandemic seems to really impact book deliveries. I'm already waiting 3 weeks for a book from Springer - normally it takes 2 or 3 days :(
 
@samcarter_says_quack oh my
 
5:02 PM
@samcarter_says_quack Exciting books?
 
@PauloCereda /QUACKKKKK
 
5:30 PM
@JosephWright ooh a duck
 
@PauloCereda Unfortunately, chemistry doesn't feature many ducks ...
 
Jan 8 '13 at 13:35, by egreg
@PauloCereda Here's a book for you! http://www.amazon.com/Discrete-Mathematics-Ducks-sarah-marie-belcastro/dp/1466504994/ref=sr_1_1?ie=UTF8&qid=1357652050&sr=8-1&keywords=discrete+mathematics+with+ducks
 
@JosephWright oh
@DavidCarlisle ooh
 
6:06 PM
@JosephWright very exciting :)
Death Dead stars
 
6:24 PM
user image
3
Today is World day of Snowman!
 
@UlrikeFischer There are snow squirrels: theladytravels.com/creative-snowmen-london
2
 
@samcarter_says_quack the network engineers seem to build a network of closed questions...
 
@Skillmon :) they probably like them all connected
 
6:47 PM
I now write LaTeX enough that when I was writing about latex gloves, I had to autocorrect it back as my phone now defaults to the typesetting language.
(Which is also why I use the capitalization, to tell the two apart)
Question of the day: For some reason, this GNUPlot to LaTeX package is causing latexmk to compile over and over again until it hits max tries. Is it worth it making a MWE and seeing if anyone can fix it or should I focus on writing?
I think it is as its costing me a lot of time compiling
 
 
1 hour later…
7:57 PM
Oh yeah, that didn't take long to make a MWE, and there appears to be a related question, though I'm not sure how to use it exactly as they don't have a fully worked example
 
@Canageek what is the content of loop-gnuplottex-fig1.tex?
 
8:14 PM
EFFING HECK
I see the problem now
"%% 2021-01-18 11:32:42 AM"
It includes a to the second timestamp
 
8:34 PM
@Canageek I suspected something like this ;-)
 
@UlrikeFischer I found where that is set, and the ConTeXt option has an output to disable it, but not the LaTeX driver. I can edit the lua file manually though
KINDA an ugly solution though
 
@Plergux -- I've actually known of several people in Rhode Island who were politically inclined, and acted sane. Two were senators (Claiborne Pell, Democrat known for "Pell grants" and support for the arts and humanities, and John Chafee, Republican, who was defeated for reelection as Governor when he said, truthfully, that he'd have to raise taxes), and two more at the state level, again one of each party. Maybe they had idiosyncracies, but they held the public interest above their own.
 
@barbarabeeton It's good to know that they exist :)
 
8:51 PM
@UlrikeFischer Made it work by manually editing the lua file, going to contact the person as per the README and see if there is a better way of doing that, or that option can be turned off by default or made accessible
 
9:38 PM
Does anyone have recommendations for quote chars for the csquotes package? I was thinking maybe:
```latex
\MakeOuterQuote{"}
\MakeInnerQuote{'} % this is invalid, as is ' for the outer quote, for some reason
\MakeAutoQuote{«}{»}
\MakeBlockQuote{<}{|}{>}
```
 
 
2 hours later…
yo'
11:09 PM
@JosephWright @DavidCarlisle Btw, I bought the new car :)
Whoch also means that when @PauloCereda gets to Europe, we might make a road trip to @UlrikeFischer and @egreg very nicely :)
 
11:39 PM
The following code is supposedly checking for a '0' inside the *.tmp file

\newread\wsreturncodefile%
\immediate\openin\wsreturncodefile=latexalpha2_check.tmp%
\readline\wsreturncodefile to \wsreturncode%
\immediate\closein\wsreturncodefile%
\def\instring#1#2{TT\fi\begingroup\edef\x{\endgroup\noexpand\in@{#1}{#2}}\x\ifin@}%
\if\instring{0}{\wsreturncode}
How to make it check for "wolframscript.exe"? knowing that \if\instring{"wolframscript.exe"}{\wsreturncode} didn't work for me
The file has this text
C:\Program Files\Wolfram Research\WolframScript\wolframscript.exe
 

« first day (3732 days earlier)      last day (42 days later) »