« first day (3493 days earlier)      last day (41 days later) » 

12:08 AM
@PhelypeOleinik Hola :) ...¿Cómo estas?
 
@PabloGonzálezL ¡Hola! Estoy bien (and that's as far as my Spanish goes :-)
@PabloGonzálezL Power just came back here :P
@PabloGonzálezL How about you?
 
@PhelypeOleinik Dividir minha cabeça com um script em Perl ...me mantém ocupado :)
And that was my Portuguese
 
@PabloGonzálezL Good enough :-) “dividir minha cabeça” sounds a bit odd, but it's understandable
 
@PhelypeOleinik jejej
@PhelypeOleinik Can you run:
lualatex sample2e
pdfcrop --luatex sample2e.pdf
 
@PabloGonzálezL !!! Error: LuaTeX run failed with value 1!
 
12:20 AM
@PhelypeOleinik Yes :( ....
@PhelypeOleinik I think 'pdfcrop' needs to be updated... it doesn't follow the changes in LuaTeX
 
@PabloGonzálezL Running pdfcrop --luatex --verbose sample2e.pdf seems like it is trying to use some pdfTeX primitives, like \pdfoutput and \pdfcompresslevel...
 
@PhelypeOleinik Yeah, apparently that code's been there since before some things were implemented in LuaTeX
 
@PabloGonzálezL Perhaps loading luatex85 would work...
 
Last update was 2012/11/02
@PhelypeOleinik Yes, in fact I can use -pdftex and it will work, but it will modify Producer in the pdf file
@PhelypeOleinik Not an option :( ... only causes more problems
 
@PabloGonzálezL Try this (around line 816 of pdfcrop.pl):
if ($::opt_tex eq 'luatex') {
    print TMP <<'END_TMP';
\begingroup\expandafter\expandafter\expandafter\endgroup
\expandafter\ifx\csname directlua\endcsname\relax
  \errmessage{LuaTeX not found!}%
\else
  \begingroup
    \newlinechar=10 %
    \endlinechar=\newlinechar %
    \ifnum0%
        \directlua{%
          if tex.enableprimitives then
            tex.enableprimitives('TEST', {
              'luatexversion',
              'outputmode',
              'pdfvariable',
              'pagewidth',
 
12:37 AM
@PhelypeOleinik Great, it works perfectly :)
Unfortunately Heiko is a bit far away from the TeX world :(
 
@PabloGonzálezL Is he still the maintainer? Isn't that under ho-tex?
 
@PhelypeOleinik Unfortunately it's not in ho-tex, maybe @DavidCarlisle can adopt it :)
 
12:57 AM
@PabloGonzálezL I would but it's time for bed
 
@DavidCarlisle Great, tomorrow will be another good day for ho-tex :) Have a good rest.
 
 
1 hour later…
2:21 AM
@PauloCereda In file:
% arara: lualatex
% arara: halt
In terminal
$ arara -H file.tex

ERROR

It looks like no directives were found in the provided file. Make
sure to include at least one directive and try again.
The rules in the file collide with the -H option ... or is this by design?
 
 
2 hours later…
4:07 AM
Hi guys
I am finding it a bit hard to manage four figures to be inside a certain margin and not to cross each other using tabular
2 by 2
 
 
3 hours later…
7:03 AM
@BAYMAX That should be straightforward, what did you do? (My guess would be that you're using p columns, and have set the image width to be wider than the column width, but without an example that's just a wild guess.)
 
 
1 hour later…
8:31 AM
Thanks@TorbjørnT., it seems like I have crossed the width as you mentioned. I will try to play with it a bit more. I have four images, which i try to subplot in 2 rows and 2 columns
 
9:13 AM
@UlrikeFischer $ git commit -a -m "no need to force utf-8 now updated to tl2020"
 
@PhelypeOleinik @PabloGonzálezL It isn't under ho-tex but probably we could change it (see e.g. github.com/ho-tex/oberdiek/issues/63). And probably we should, apart from the luatex problem is also fails for pdf 2.0. @DavidCarlisle
@DavidCarlisle ;-)
 
@BAYMAX you could just use \includegraphics[width=.5\textwidth]{a}\includegraphics[width=.5\textwidth]{a}\\\includegraphics[width=.5\textwidth]{a}\includegraphics[width=.5\textwidth]{a} what else do you need?
@UlrikeFischer do you want to write to Heiko and ask?
@UlrikeFischer oh or does Karl's comment mean we already have the nod to add pdfcrop?
 
@DavidCarlisle I guess yes, would could ask ctan for confirmation. But perhaps we should ask/notify Heiko anyway.
 
@UlrikeFischer it's probably simplest to add it, fix it then mail ctan and Heiko to say what we have done. Easier than describing what changes are planned in advance.
@UlrikeFischer I don't think Ive ever used pdfcrop but I could set up the repo if you want (or you could:-)
@UlrikeFischer oh just looked on ctan its just a perl file and readme no proper doc at all?
 
@DavidCarlisle yes, there is not more. It looks not so difficult to adapt the perl even with my rather restricted skills (I haven't used perl for years), but probably we should then create also some docu and some test files (can one test pdfcrop with l3build?? @JosephWright)
 
9:28 AM
@UlrikeFischer I can probably help with the perl but apart from guessing from the name I don't really know what it's supposed to do or what's broken:-) Do you want to have first pass at setting up the repository?
 
@DavidCarlisle pdfcrop calls ghostscript to get the bounding boxes of the pages of a pdf, then creates a small tex-document and includes the cropped pages. You can simply compile a small document with pdfcrop --debug file.pdf and then look at the created tmp-file, then it is quite obvious what is broken for luatex. For pdfversion the problem is that it uses a regex ~ /^(|none|auto|1\.([2-7]))$/ which naturally don't fit 2.0. You can setup the repo - you are used to it ;-)
 
@UlrikeFischer OK I'll set up the repo, you can sharpen your pdf2 sword.
 
@DavidCarlisle I found the second relevant place for the version. How do one write this to include 2.0 (or should we allow 2.0 - 2.9?) ($buf =~ /%PDF-1.([0-7])\s/)
 
9:48 AM
@UlrikeFischer l3build ctan does something:-)
@UlrikeFischer could just allow 2.0 but then it'll fail in another decade I'd allow [0-9]\.[0-9]
@UlrikeFischer if you use ([0.9])\.([0-9]) then $1 is major and $2 (not $1) is minor in the following lines.
 
@DavidCarlisle yes I just realized that the code stores only the minor version ;-(
 
@UlrikeFischer or \d instead of [0-9] as he uses here $header =~ /^%PDF-1\.(\d)\s$/ or die "!!! Error: Cannot find header of $tmp.pdf'!\n";`
 
@DavidCarlisle that was the error I got in my test.
 
@UlrikeFischer so change 1 to \d or [1-2] but I'd use \d
@UlrikeFischer I think latex should have a die command, it's so much more assertive than PackageError, tells the users the consequences of their errors.
 
@PabloGonzálezL The rule seems to have .dvi as fixed extension. Either I need to update the rule to add the option to change it or you can extend the rule. :)
@PabloGonzálezL Really?! I cannot reproduce it here...
@PabloGonzálezL is that test.tex? Because for me it works...
We need to investigate...
 
10:02 AM
@DavidCarlisle ;-). The code uses the version for comparision so probably one must add something to store the major version too. Do the colons have any meaning in the variable names? $::opt_pdfversion?
 
@PauloCereda perl -e "die 'breakfast'"
 
@DavidCarlisle echo 'ZWNobyAnb2ggbm8n' | base64 --decode | bash
 
@UlrikeFischer :: is a bit modern for me it's the package/module prefix perldoc.perl.org/perlmod.html (perl 5 came out in 1994 so after I last read a perl manual:-)
 
11:06 AM
@DavidCarlisle Thank you! will try that and will let you know! thanks!
 
11:18 AM
@DavidCarlisle Excellent work on the translations: we are well 'ahead'
@barbarabeeton Looking forward to third-party reviews of learnlatex.org
@barbarabeeton (@DavidCarlisle, @egreg) Perhaps we should add a bit more math mode: I'd welcome 'balanced' suggestions (I'm not a mathematician, so y = mx + c is abotu it for me)
 
11:30 AM
@JosephWright I'm sure @barbarabeeton and I can come up with something...
@JosephWright if we get platex at latexonline I may ask the usual suspects to add some examples in jp/language-*.md
 
 
1 hour later…
12:58 PM
@PauloCereda echo 'LaHtoUWzPt==' | tr '[A-Za-z]' '[N-ZA-Mn-za-m]' | base64 -d | tr '[A-Za-z]' '[N-ZA-Mn-za-m]'
 
1:14 PM
@Skillmonlikestopanswers.xyz ooh
 
@JosephWright -- I just found a glaring gap in the math lesson. It may be somewhere else, but it's essential in math: blank lines (= par) are not allowed in any math. (DEK's mechanism for filtering out forgotten $ signs.) Please add.
 
@barbarabeeton yes but also I think we need to say more about alignment in general, I may pass a version past you later....
 
@DavidCarlisle and @UlrikeFischer -- Please don't break `pdfcrop. I use it all the time to trim examples fir insertion into answers here. I can probably provide some test files, although I'm using only pdflatex.
 
@barbarabeeton the intention wouldn't be to break it, rather fix it in the case it's currently broken:-)
 
@DavidCarlisle -- Didn't I already ask for more about alignment? In my very first critique?
 
1:23 PM
@barbarabeeton yes but now more of the lessons done, can get back to that with a sense of the level of coverage in other places:-)
 
@DavidCarlisle -- Oh, I realize that, but fixing one thing sometimes has unexpected consequences. (Long personal experience.)
@DavidCarlisle -- Probably not as much as for tables though. I'll send some suggestions in mail.
 
@barbarabeeton yes that's why I'm letting @UlrikeFischer make all the changes, so she can be blamed if necessary.
@barbarabeeton thanks
@barbarabeeton surprised you need pdfcrop for examples here, I just paste in a selection from the screen.
 
@DavidCarlisle -- That's a possibility, but the trackpad on my laptop is often recalcitrant, and the auxiliary mouse often is also. A reliable command-line procedure usually gets quicker and ore predictable results. (Of course, pdfcrop also requires convert, but the procedure is easily scripted.)
 
@barbarabeeton oh, it would be nice if you can run some tests then. I will notify you when I think I have done all the changes.
@DavidCarlisle I made the version changes and will do the luatex stuff now. But I need to check against older texlive without pdfmajorversion ...
 
@PauloCereda more fun is the symmetric "encryption" echo $* | base64 | tr '[A-Za-z]' '[N-ZA-Mn-za-m]' | base64 -d, but the result can't always be copied because it might contain unprintable characters.
 
2:16 PM
@JosephWright to build the doc of beamer does one need anything else than l3build doc ?
 
2:27 PM
@Skillmonlikestopanswers.xyz <3
@Skillmonlikestopanswers.xyz rabbits are very advanced
 
 
1 hour later…
3:43 PM
@PauloCereda Try
%test.tex (no space before test.tex)
% arara: lualatex
% arara: halt
\documentclass{article}
\begin{document}
Hola don pato
\end{document}

$ arara test.tex
__ _ _ __ __ _ _ __ __ _
/ _` | '__/ _` | '__/ _` |
| (_| | | | (_| | | | (_| |
\__,_|_| \__,_|_| \__,_|

Processing 'test.tex' (size: 2.0 kB, last modified: 05/24/2020
11:40:06), please wait.

(LuaLaTeX) LuaLaTeX engine .............................. SUCCESS
(Halt) The halt trigger ................................. SUCCESS

Total: 1.47 seconds
 
@PabloGonzálezL ah it's by design
-H stops the directive lookup after any non-empty line which is not a directive.
Line 1 has %test.tex, so arara stops right there.
 
@PauloCereda OK, actually the first line is a %<*dtxtag>. I think I'm confused with the behavior of H :(
@PauloCereda In short, I either use halt or use -H, but can't use both
 
@PabloGonzálezL I will make a note to include a potential extension for -H...
 
@PauloCereda Thank you, regarding dvisvgm ... I think the rule needs updating ... it was created when dvisvgm only supported .dvi, but, it's been supporting .xdv for years.
 
@PabloGonzálezL I will update the rule accordingly.
 
3:56 PM
@PauloCereda :)
@UlrikeFischer A small update would be great, it's a great utility for those of us who use pstricks and to trim any pdfs in general.
 
@PabloGonzálezL I'm working on it. But why do you need the --luatex switch? And do you know about other problems?
 
@UlrikeFischer I need to pass --luatex otherwise it will take -pdftex by default and change the -Producer: line in the generated file
@UlrikeFischer The rest is fine, it's written in "Old Perl" but it works OK.
 
@PabloGonzálezL ah yes, the metadata would change this is right.
 
@UlrikeFischer I think you already noticed this, but --pdfversion only works up to 1.7
 
@PabloGonzálezL see the commit ...
 
4:08 PM
@PabloGonzálezL oi I explained to @UlrikeFischer that the :: syntax was modern perl.
 
@DavidCarlisle Heh heh, but, the use of global variables is not very well seen nowadays.
 
4:32 PM
@PabloGonzálezL no I suppose everyone uses Fortran COMMON blocks instead.
 
@DavidCarlisle A matter of taste, it is like the use of open($FH > $file); or open $FH, '>', $file;
@PauloCereda
% arara: xelatex: { options: [-no-pdf] }
% arara: xdvipdfmx
\documentclass{article}
\begin{document}
Hola don pato
\end{document}
 
org.zeroturnaround.exec.ProcessInitException: Could not execute
[xelatex, -no-pdf, cc901.tex] in C:\tmp. Error=2, The system
cannot find the file specified
@PabloGonzálezL is that expected?
 
The rule assumes that `infile = getBasename(reference.getName()).concat('.dvi');`
but, `-no-pdf` generate `.xdv`
 
@PabloGonzálezL add a rule to copy in between the two?
 
I want to use dvisvgm over .xdv
% arara: xelatex: { options: [-no-pdf] }
% arara: dvisvgm
% arara: xdvipdfmx
But dvisvgm and xdvipdfmx assume the extension is .dvi :(
 
4:51 PM
@PabloGonzálezL if you only wanted to run one of the drivers you could presumably specify that as -output-driver instead of using -no-pdf
@PabloGonzálezL but I get same error for % arara: xelatex: { options: [--output-driver=dvisvgm] } :(
O (@PabloGonzálezL ) I get same error for % arara: xelatex
 
@DavidCarlisle Strange... it works for me
 
@PabloGonzálezL I expect it's the usual issue of cygwin paths
 
@DavidCarlisle cgwin is such a headache :(
@DavidCarlisle It is better to use WSL, the versions of perl and others that cygwin has cause false positives when testing
 
@PabloGonzálezL no @PabloGonzálezL loves me giving him cywin path issues. The trouble is it doesn't ship with a java implementation so you end up with the windows java reporting paths like c:\tmp which don't work with xetex.
 
luatex85 is such a nice package ;-)
 
5:00 PM
@PabloGonzálezL probably will go that way but we have decades of cygwin use and use it for everything, notably X which isn't in wsl by default either
@UlrikeFischer but if you need it there is something wrong elsewhere:-)
 
@DavidCarlisle I need it for the translations ;-)
 
@DavidCarlisle But it will be on WSL2 :)
 
@PabloGonzálezL is it oh haven't checked. about time windows shipped with a decent window system
@UlrikeFischer ?
 
@DavidCarlisle it is a nice list to look up what \pdfximage should be. Very useful.
 
@UlrikeFischer oh you mean just looking up the new names, yes there is that:-)
@UlrikeFischer "translations" put me back in learnlatex mode for a minute so i was confused.
 
5:03 PM
@DavidCarlisle For some time now, Windows has been getting closer and closer to supporting linux :)
 
@PabloGonzálezL yes I feel a os X moment when they manage to switch in a linux based posix OS underneath but keep the top level GUI near enough the same to keep users happy
 
@DavidCarlisle If that's a big point. Now that you've named cygwin I remember that the console that provides GitHub on windows is based on cygwin ...it's a headache to adjust the paths for the scripts, which is why I switched directly to WSL and haven't used cygwin anymore :)
 
@DavidCarlisle -- a comment on this question confuses me: "Interestingly, subscripts don't use \scriptsize." Huh? What does a sub/superscript use, and why not \scriptsize?
 
@PabloGonzálezL pure cygwin is fine. mixing windows and cygwin means juggling paths a bit but you get used to it (cygpath helos:-)
@barbarabeeton \scriptsize is a text font size command unrelated to math, \scriptstyle is the tex primitive
@PabloGonzálezL in fact it only really comes up for me with java as everything else I use cygwin, I don't have a windows git or ssh or tex or ..
 
@DavidCarlisle -- Okay. Right. But that's just a diversion then, and doesn't come anywhere near answering the question.
 
5:16 PM
@barbarabeeton no it was just a comment it seems (although there are some real questions on site asking about cases when \scriptsize and \scriptstyle give different font sizes.
@barbarabeeton since the question is "I did something and something didn't happen, can you fix it" it's hard to give an actual answer.
 
And this:
perl pdfcorp file.pdf
is executed correctly in `cygwin`?
 
@PabloGonzálezL ? Can't open perl script "pdfcorp": No such file or directory
 
@DavidCarlisle As a note, now that pdfcrop is in ho-tex you might want to update Copyright
 
@PabloGonzálezL give @UlrikeFischer a chance.
 
@DavidCarlisle Ups... pdfcrop
 
5:21 PM
@PabloGonzálezL no, but it does without the perl in front
 
Look what I get (also without pdfcrop): warning (file version-test.pdf) (pdf inclusion): PDF inclusion: found PDF version '2.0', but at most version '2.0' allowed
 
@PabloGonzálezL which is what I expect as pdfcrop isn't in perl's default search path is it?
@UlrikeFischer well that's true at least
 
@DavidCarlisle Yes and no, in order to run a specific test of the script (perl -cw script) you don't need to call the version installed in TeXLive and of course, it gets confused with the paths when searching `gs
 
@PabloGonzálezL why should it get confused about paths if perl and gs are both cygwin applications?
@UlrikeFischer any thoughts on more: titles?
 
@DavidCarlisle I don't remember well the 'why' but I know I had that problem when I was using winxp, I don't know if today it will be different, I have left cygwin completely
 
5:28 PM
@DavidCarlisle I think one will to this call this "Extra Lektion zu ..." or "Extra Lektion: ...." But first I need to figure out if one need this enable primitives command in pdfcrop ...
 
5:38 PM
@UlrikeFischer :)
 
6:05 PM
@UlrikeFischer @DavidCarlisle Another note for pdfcrop, the executable attribute must be removed from pdfcrop.pl . CTAN maintainers complain when an executable script is uploaded.
 
6:15 PM
@PabloGonzálezL you mean the #!/usr/bin/env perl?
 
@UlrikeFischer No... chmod -x
 
@PabloGonzálezL well I'm on windows ;-)
 
@UlrikeFischer Ups ...
It's a file permissions issue, if you run pkgcheck it will give an error :(
 
@PabloGonzálezL I updated the luatex code and pushed the version. So could you test? @DavidCarlisle what should we do with the copyright?
 
@UlrikeFischer I'd leave it with Heiko, and just assume its his code but he's allowed us to update.
@PabloGonzálezL really that's odd. so then texlive have to make it executable after they get it from ctan?
 
6:28 PM
@DavidCarlisle Sí
 
@DavidCarlisle ok, so I only update the copyright. could you try with perl pdfcrop.pl --debug somefile and check if it finds a sensible ghostscript? (And does it find the same as pdfcrop --debug in texlive?
@DavidCarlisle I assumed they create some wrapper anyway. On windows I get an exe which uses runperl or whatever.
 
Everything OK in my tests, I would just adjust:

--uncompress creates an uncompressed pdf, useful for
debugging ($bool[$::opt_uncompress])

To keep the length of the lines at 80
 
@UlrikeFischer that's just because windows has no sensible execute permission mechanism
@UlrikeFischer seems to do the same thing an diif of the tmp-pdfcrop...log files shows nothing
 
@DavidCarlisle It's because of the filters that CTAN has without bad memory, I once uploaded a file from windows and this had a permission to run (which is not directly visible) and I get an email from the maintainers of CTAN, from there I use pkgcheck to check permissions and so on.
 
@PabloGonzálezL yes I know they check executable permissions on images and tex files etc but checking it on executable scripts seems ... strange
 
6:38 PM
@PabloGonzálezL the line length is below 80, at least for me. But I aligned the default value better. But you can test now a bit, and @barbarabeeton can do it too. If nothing comes up we can upload in a few days. But should to be clear: I did not try to support all the luatex versions from the last decade. And if you try to use pdf version 2.0 you should have a new pdftex.
 
@UlrikeFischer Now it's OK.
@DavidCarlisle Tienes razón :) ctan.dcc.uchile.cl/help/ctan/…
@DavidCarlisle My memory played a trick on me, anyway, the TeXLive team checks and modifies the permissions of the scripts before incorporating them :)
 
@PabloGonzálezL so perl should be executable: Only files that are truly executable (like Shell, Perl, Python, Ruby, and other scripts) should be marked as such
 
@DavidCarlisle Yes (I wrote in Spanish above, sorry)
 
@PabloGonzálezL that's OK, I speak all languages
 
@DavidCarlisle Mmm... reading them maybe, but speaking them all... it's not worth the trick of putting a "ñ" and saying it's Portuguese :)
 
6:57 PM
@PabloGonzálezL let's just say I speak all non english languages with equal fluency
 
@DavidCarlisle If not for google I would only understand Spanish :(
 

« first day (3493 days earlier)      last day (41 days later) »