« first day (3123 days earlier)      last day (124 days later) » 

KJO
12:02 AM
@carlatex My bad :-( its exCarter that would be affected Woops
 
12:35 AM
@marmot are you there?
 
12:55 AM
@manooooh Where is there?
 
@marmot here :)
Listen
I am trying to graph the norm of a vector in 2D trying not to use unit vector ratio=1 1 1 or axis equal image or axis equal etc., but I am not able to achieve the angle of this unscaled graph
\documentclass{article}
\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[a4paper,margin=1in,footskip=0.25in]{geometry}
\usepackage{amsmath}
\usepackage{pgfplots}
\pgfplotsset{compat=1.15}

\usetikzlibrary{shapes.misc}

\pgfplotsset{soldot/.style={color=black,only marks,mark=*}}
\pgfplotsset{holdot/.style={color=red,fill=white,very thick,only marks,mark=*}}

\begin{document}

\begin{center}
\begin{tikzpicture}
\begin{axis} [
axis on top,
axis lines = center,
 
What do you mean by "achieve angle"? And why don't you use node[above,midway,sloped] (i.e. sloped instead of rotate)?
 
@marmot OH the command was sloped (I did not know the command), THANKS MARMOT
<3
 
@manooooh You're welcome!
 
@marmot hm, do you want one more? I think the solution is easy but I am not able to find my error there
 
1:07 AM
@manooooh What's the problem?
 
@marmot the problem is that I am trying to plot 5sin(2x)e^(x) from 0 to 10 using this MWE:
\documentclass{article}
\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[a4paper,margin=1in,footskip=0.25in]{geometry}
\usepackage{amsmath}
\usepackage{pgfplots}
\pgfplotsset{compat=1.15}

\begin{document}


\begin{center}
\begin{tikzpicture}
\begin{axis} [
axis on top,
axis lines = center,
xticklabel style = {font=\tiny},
yticklabel style = {font=\tiny},
xlabel = $t$,
ylabel = $f(t)$,
legend pos=outer north east,
legend style={cells={align=left}},
legend cell align={left},
And WA plots it as:
I do not know why the plot has range [-.2,1] instead of things like [-60,100]
Well, now I discovered restrict y to domain works (more or less):
\addplot[very thick,red,variable=t,domain=0:15,restrict y to domain=-10000:10000,smooth,samples=201] {5*sin((2*t) r)*e^(t)};
 
@manooooh
\documentclass[tikz,border=3.14mm]{standalone}
\usepackage{pgfplots}
\pgfplotsset{compat=1.15}
\begin{document}
\begin{tikzpicture}
\begin{axis} [
axis on top,
axis lines = center,
xticklabel style = {font=\tiny},
yticklabel style = {font=\tiny},
xlabel = $t$,
ylabel = $f(t)$,
legend pos=outer north east,
legend style={cells={align=left}},
legend cell align={left},
y tick label style={/pgf/number format/fixed},
ymin=-7500,ymax=7500,xmax=10.5
%clip=false
]
\addplot[very thick,red,variable=t,domain=0:10,smooth,samples=201] {5*sin((2*t) r)*e^(t)};
@manooooh ^^^ I think it is mainly a matter of adjusting ymin, ymax and xmax.
 
@marmot that worked, thanks again!!
 
1:32 AM
@marmot in y-axis I am having the values: 1, 8 and 512. If I plot the graph then I can't see the small values, so how can we "cut" values from 9 to 511?
I am seeing: tex.stackexchange.com/q/46422/152550 but the solution is a bit tedious to implement :/
 
1:53 AM
@manooooh I do not know anything better than the link or using a logarithmic plot.
 
2:40 AM
Ok
 
 
2 hours later…
4:24 AM
@KJO Sorry, your messages are too slangy for me to understand :)
 
 
3 hours later…
7:46 AM
Does anyone have any thoughts on this? github.com/pgf-tikz/pgf/issues/678
 
@HenriMenke I had already noticed that behaviour when using the FPU, but I thought that it was due to the internal representation of the number, thus I always used /pgf/fpu/output format=fixed> I confess I never did a thorough reading of the manual to check if that was by design or not.
@HenriMenke Hypothetically speaking, how large would be the damage of replacing pgf's fpu by expl3's?
 
8:38 AM
@HenriMenke Long standing issue
@HenriMenke I think you are basically right: the FPU is simply not compatible with drawing, but it was never designed to be
@PhelypeOleinik pgf's FPU is not expandable so can have box measuring inside expressions ...
 
@JosephWright Oh :/
@JosephWright What was it designed for, then?
 
@PhelypeOleinik Supporting maths work in other places: pgf has a lot of tools beyond those strictly needed for typesetting
 
@JosephWright I think it is a bug in fpu itself if output format=fixed is used.
 
@UlrikeFischer Could be
 
@JosephWright this breaks:
\documentclass{article}
\usepackage{tikz}
\usetikzlibrary{fpu}
\begin{document}
\pgfkeys{/pgf/fpu,/pgf/fpu/output format=fixed}
\pgfmathcos{1}
xxx
\end{document}
 
8:46 AM
@JosephWright Hm. I might need to take a look at what it does besides drawings :-)
 
 
1 hour later…
10:15 AM
@PhelypeOleinik You simply can't replace PGF's FPU with l3fp. The parser is different, e.g. l3fp has the ternary operator ?: while PGF has ifthenelse. Also l3fp has accuracy problems when dealing with dimens, e.g. 2.1pt * 3.14cm.
@UlrikeFischer Thanks for the \pgfmathparse{atan2(...)} workaround. Unfortunately, this can't go into the core because it's way too slow.
 
@HenriMenke Yes, I imagine that a lot of code would need to change for such replacement (if that's what you meant with the ifthenelse). It was more of a curiosity if it would be doable, given an enough amount of effort and patience, but apparently it's not, judging from Joseph's comment. I didn't know of that inaccuracy you mentioned. Is it documented somewhere?
 
@PhelypeOleinik Not that I know of. I only have a testcase.
\documentclass{article}
\usepackage{tikz}
\usepackage{xfp}
\usetikzlibrary{fpu}
\begin{document}
\dimen0=2.1pt \dimen1=3.14cm
Lua: \directlua{tex.sprint((tex.dimen[0] / 2^16) * (tex.dimen[1] / 2^16))}

\pgfmathparse{2.1pt * 3.14cm}
PGF: \pgfmathresult

l3fp: \fpeval{2.1pt * 3.14cm}
\end{document}
 
@HenriMenke Interesting... I just did a test myself before, and apparently TeX misses the result by about the same amount:
\input expl3-generic
\ExplSyntaxOn
\fp_eval:n {2.1pt * 3.14cm}
\par
\the\dimexpr 3.14cm*2 + 3.14cm/10

\bye
@HenriMenke Or I could've just \dimen0=3.14cm~\the\dimexpr2.1\dimen0, in which case the result is the correct one.
 
10:48 AM
@HenriMenke it looks wrong to use dimensions like this in \fpeval. Beside this: if you copy the lua calculation method you also get the same result: \fpeval{\dim_to_decimal_in_sp:n{\dimen0}/2^16 * \dim_to_decimal_in_sp:n{\dimen1}/2^16}
 
10:59 AM
@UlrikeFischer Yeah, I think this is to do with the limitation on conversions
@HenriMenke I think the issue arises due to the way Bruno decided to treat pt, cm, etc. in floating point expressions: units are treated as constants multiplied by the number, rather than converting first
 
12:03 PM
@HenriMenke BTW, where does this come up 'in the wild': it's working out an area, no?
 
@JosephWright does this loop for you too?
\documentclass{article}
\usepackage{l3benchmark,xfp}
\ExplSyntaxOn
\cs_set_eq:NN\benchmark \benchmark:n
\ExplSyntaxOff

\begin{document}
\fpeval{atand(1,2)}
\benchmark{\fpeval{atand(1,2)}}

\end{document}
 
@UlrikeFischer It loops for me.
@UlrikeFischer And \benchmark{\fpeval{atand(1)}} issues ! Number too big
@JosephWright It's well known, though, that computations with TeX dimensions can't be accurate.
 
@egreg one for Bruno ?
 
@egreg Well, it depends on how you set things up: the point is that pgf or 'raw'` Lua use the sp values, whereas we don't (I think)
 
12:19 PM
@JosephWright Let's see:
bc -l
bc 1.06
Copyright 1991-1994, 1997, 1998, 2000 Free Software Foundation, Inc.
This is free software with ABSOLUTELY NO WARRANTY.
For details type `warranty'.
473628672/2^16
7227.00000000000000000000
 
@JosephWright if one doesn't the curious dimension multiplication but e.g. 2.1 * 3.14cm then l3 is actually nearer to the luatex values than pgf.
 
@JosephWright With LuaLaTeX, doing
\dimen0=1in \directlua{tex.sprint(tex.dimen[0]/2^16)}
prints 72.269989013672
@JosephWright So it's LuaTeX at fault.
 
@UlrikeFischer That I do not doubt
@egreg Ah, right ....
 
Note that there's a difference between the factors: in TeX it is 473628672/100 rather than 4736286. But then also TeX uses the latter value for converting back to pt.
 
@egreg Yeah, I think that's where the issue comes
 
12:30 PM
Dear @UlrikeFischer ;), could you please do me a favour? I am currently working on extending ocgx2 by OCMDs (opt. content membership dictionaries). Would you please look into the new Spec and see whether there are notable changes regarding OCMDs as compared to PDF-1.7? The sub-section "Optional Content Membership Dictionaries" is about 2.5 pages long. Thank you!
 
@JosephWright Which is what I meant when saying that working with TeX dimensions is inaccurate to begin with, so differences of 0.000x% should be expected.
 
@AlexG looks quite the same, I see nothing marked as "pdf 2.0".
 
@UlrikeFischer Perfect! Thanks a lot!!!
 
@UlrikeFischer I've tracked this down: we have a \relax missing somewhere, and the FP expression is 'leaking' into an \in_gset:Nn ...
 
12:46 PM
@JosephWright you are much too fast ... I just added an issue so that it doesn't get forgotten ;-(.
 
@UlrikeFischer It was really strange, so I wanted to know why
 
@JouleV @marmot regarding to the circle and patterns's question, my idea for you was to use the MWE that I have provided to be completed by you. That didn't happen, and I understand. My first action was to accept JouleV's answer, but then I said this to you and marmot was the first to complete the task I wanted. So, what do you prefer wrt the accepted answer? I know that JouleV will do the same in a while, but marmot completes the task I wanted first
marmot would you mind if we wait until JouleV's update?
 
@egreg I see that, but I guess for @HenriMenke it's more that pgf and the L3 approach are different that's important: both outcomes are arguably valid
 
@manooooh I didn't write the answer to "steal" the tick from @JouleV, but really only for completeness.
 
@JosephWright You should need to \relax (or to \scan_stop:, if you prefer). ;-)
 
12:53 PM
@marmot but I have made a mistake: not clarifying that I wanted the same structure of my MWE. You have done the task first, so I don't know what to do with your update, since you didn't want to do it in that way :/
 
@manooooh I really want just to add the even odd rule thingy because there are situations in which filling does no good. So you should leave the tick at @JouleV's answer. (Frankly, I feel that here the tick should go to mine, but probably it won't happen. ;-)
 
@marmot hahaha I love your sense of humor <3. Anyway, sorry for asking about an update that didn't have nothing to do with your answer, I will try to avoid these situations
 
@manooooh That's fine, you can always ask. I can say no if I don't want to. And really, this additional question wasn't hard.
 
@manooooh I have absolutely no idea. That is your opinion, your choice and your right to choice. All of us are not following ticks, reps and badges, so accepting and unaccepting is never a problem. We just want to help you in the a friendly way :)
If I were in a similar case, I would do like this: not accepting anyone...
 
1:11 PM
@JouleV yes of course. My problem is that I am impatient, I want you to have your "prize" asap, and that leads me to make early decisions
 
Let's ask for moderator's advice here. @JosephWright What would you do if you were in @manooooh's situation?
 
@JouleV do you know if it possible to make the tick labels visible? Because in your last solution we don't see xtick/ytick={1,2}
 
@manooooh What do you mean? My output is (literally) identical to marmot's, and both codes have xtick={1,2}, ytick={1,2}
Do not trust the image rendered :) My PDF viewer and my latexmk is having some problems these days with patterns
 
@JouleV you are right, my mistake
@JouleV what about \addlegendentry? When I add it to axis environment I don't get a pattern image but a dotted line
 
@manooooh Maybe you should edit the question so that I can have a look. Chat is, of course, for chat :D
 
1:25 PM
@JouleV well, you have to look at my first picture posted...
 
@manooooh Of course I know, but as I said, I am not so familiar with pgfplots, I just use it with my TikZ (not pgfplots!) knowings, so you may need a code otherwise I can do nothing ...
 
Ok
 
 
1 hour later…
2:31 PM
@AlexG I think I have the page resources working. I reproduced your ocg example by mapping through your seq's:
\RequirePackage[enable-debug]{expl3}
\RequirePackage[patches]{pdfresources}
\documentclass{article}
\ExplSyntaxOn
\driver_pdf_compresslevel:n {0}
\driver_pdf_compress_objects:n {0}
\ExplSyntaxOff
\usepackage[a6paper]{geometry}
\usepackage{ocgx2}
\usepackage{color}
\ExplSyntaxOn
\pdf_pageresources_gput:nnn {Properties}{test}{<</test (value)>>}
\ExplSyntaxOff
\begin{document}
\ExplSyntaxOn\makeatletter
\tl_if_exist:NT \pbs@last@page
{
 \int_step_inline:nn{\pbs@last@page}
 {
  \seq_map_inline:cn { pbs@props@#1 }
 
3:12 PM
@UlrikeFischer Sounds fantastic. What do I need for testing, just github.com/latex3/pdfresources/blob/testlinkstuff/… ?
 
@AlexG and perhaps also the newest l3kernel (I'm not sure, Joseph's uploads frequently so probably the ctan version has all driver commands). The open question is the "end document" stuff (I lost the layer in the float in my first test). You will get warnings in the log as I'm overwriting your resource stuff. I'm now thinking about the catalog ... ;-)
@AlexG and you will need the tmpl3shipout.sty.
 
3:46 PM
@UlrikeFischer Where do I get this one?
@UlrikeFischer Ok, found it.
 
 
1 hour later…
4:50 PM
@UlrikeFischer I guess I'll update CTAN with that benchmark fix
 
@JosephWright next time I see Petra and Manfred I will invite them to a glass wine ;-)
 
@UlrikeFischer Oh, they must be used to it and probably warned by older CTAN people: I've been I think the single biggest 'user' for at least the past 10 years
@UlrikeFischer I used to keep Robin very busy
 
@JosephWright ;-). You should get a ctan-upload gold badge ;-)
2
 
@UlrikeFischer ooh
 
 
3 hours later…
7:39 PM
@UlrikeFischer ooh
 
@JosephWright , hello all, is there some predefined L3 equivalent for \@gobble, a command that swallows its first and only argument?
 
@AlexG \use_none:n
@AlexG Lots of stuff in l3basics
 
@JosephWright Thank you. Will be taking a look into l3basics.
 
 
1 hour later…
8:55 PM
Hi, where can I find the options for the enumerate environment in beamer? I took out the enumitem package because my bullets weren't appearing, but I'd still like to set the leftmargin for one of the environments.
 
@ahorn it loads enumerate package but that doesn't offer an interface to setting margins so just basic latex syntax \setlength\leftmargini{2cm}
 
9:21 PM
Thanks! I had to do it outside the `enumerate` environment, even though `\setlength\labelsep` works fine inside the environment. It looks like the parameter isn't carrying over to other slides.

@DavidCarlisle I just saw your name mentioned in Kopka and Daly's book for fixing the `seminar` class file for LaTeX2e, then remembered I've seen your name on this site and checked out your profile. So, you're a celebrity!

I'm very comfortable with the `article` document class, but I'm making my first presentation today. I thought I'd use Kopka and Daly's book to get some guidance, but I think it's
 
@ahorn all latex packages come with a manual, which is often more authoritative than random wikis you may find on the net, texdoc beamer in this case.
@ahorn the setting is local to the current environment as normal, so if you want to apply to the whole document set it in the preamble
 
@JosephWright I don't know if it comes up at all. This was just an example of where l3fp differs from the pgfmath in a way that is not easily fixable.
@PhelypeOleinik By the way /pgf/fpu/output format=fixed was simply working by chance previously, because the result, e.g. -28.45274000000000 sort of looks like a dimension but it would break with any other output format.
 
@DavidCarlisle there are manuals?
 
Did you mean to say that all classes come with a manual, since I'm talking about the `beamer` document class? Which I would assume to be http://tug.ctan.org/macros/latex/contrib/beamer/doc/beameruserguide.pdf
What do you mean exactly by "`textdoc beamer`"?

I'm aware of the documentation on CTAN --- yes, I should probably read more of it.
 
@UlrikeFischer some German lady on an unreliable wiki told me they existed.
@ahorn in texlive tex (and also miktex I think) you can type texdoc beamer on the commandline and a manual for beamer will be opened.
@ahorn you almost certainly have all that documentation installed on your machine, no need to go to ctan for it.
 
9:33 PM
@DavidCarlisle you shouldn't hang around in such places.
 
@ahorn The problem with computer books is that they date. Often quite quickly.
In an alarmingly short time, what you are left with is a paperweight made of dead trees.
Or possibly, kindling.
 
@HenriMenke Certainly there are differences: on this particular one, the issue is that TeX itself provides a somewhat 'moving' target, depending on how one chooses to handle dimens ('natively' pt or sp)
 
9:48 PM
Onboarding new users needs to be done really well, so laying out everything is important, something to the effect of a codecademy. Helping new users know the best place to learn is important (as we know that "googling" isn't a long-term strategy). I think @DavidCarlisle 's `texdoc` tip is a good one to that effect.
I found Kopka and Daly's book quite insightful with tips and good methodologies.
 
10:48 PM
@DavidCarlisle Sorry, thought that had fixed it but you where right, it had not. Also spent a bunch of time trying to get a MWE in order, then thought to compile the RSC's example and it appears not to work anymore
 
11:02 PM
Crud
Found why my paper was compiling wrong: There is something wrong with the RSC's template.
 

« first day (3123 days earlier)      last day (124 days later) »