« first day (1767 days earlier)      last day (3246 days later) » 

7:21 AM
Has anyone ever written a doc showing how the various macros in etoolbox (at least those that apply) are done in expl3?
@daleif Not that I know of
@daleif I could write something: they don't all map as for example 'patching' is something we'd rather avoid in expl3
Bummer. Things like \ifcsvoid is very handy but I don't know the equivalent in expl3.
@JosephWright Isn't patching very widely used in say biblatex? So why wouldn't that be a part of expl3?
@daleif The only patching I know of in biblatex is for interfacing with other packages
@daleif What we want is to have code with well-defined interfaces such that you don't have 'Now we alter the internals of package X as ...'
@JosephWright Ok I thought patching was being used when you want to alter an exising formatting style.
@daleif People do that but the official position is you are meant to define your style yourself. There's of course a question of how much flexibility one can build into an interface and how you deal with small changes in big pieces of code
7:30 AM
@JosephWright But can you have enough callback points (or what ever) to meet all user requirements of inserting this and that in strange places due to weird requirements
@daleif Exactly
@daleif You don't find patching in ConTeXt, for example
@daleif That would be a two-part in expl3 as there are different concepts at work
one less \outer in the world.
@DavidCarlisle CTAN update of etex.sty?
@JosephWright bingo
8:17 AM
@UlrikeFischer, do you mind vvvv
Q: Error in Updating FNDB after last update

gcassAfter updating packages this morning nothing works anymore (I am working under Windows 8). Particularly, compiling files with TeXWorks returns the message: running 'initexmf --quiet --update-fndb' to refresh the file name database The operation failed for some reason. This is of little help, un...

I haven't used MikTeX for years.
8:45 AM
@daleif I added a comment. Imho it is due to the missing "autoinstall new things" feature in miktex and so you can run into troubles if you update binaries and then check for new package first. There is a new miktex-log4XX-package and there has been a report that things breaks if you don't install them first. I'm away now and will be back in around two hours ...
@UlrikeFischer Thanks for your time, I was completely at a loss there.
(or however that is phrased)
9:05 AM
@JosephWright what exactly are the convention of using : in data macros. If I use \cs_set_nopar:cn {test-test}{data} it keeps bugging me that there should be a : in the name. (Perhaps I'm using the wrong macro?) But in other contexts, such a format is not imposed: \seq_get_right:NN \l_yo_a_seq \l_prefix
@daleif Variable names do not contain :, which is used for the argument spec. of a function (macro). There is of course the question of whether an argument-free macro is a function (\my_foo:) or a variable (\l_my_foo_tl). I tend to think the latter is best used for something containing mainly 'text' whereas the former is more for 'actions'.
@JosephWright Then which macro should I use to store a data in a macro?
@daleif Don't follow
Say I want to make the following (etoolbox syntax) \newcommand\setData[2]{\csdef{data-#1}{#2}} in expl3, I was trying \cs_set_nopar:cn{data-#1}{#2} internally, but get the missing : error.
@daleif Ah
9:11 AM
I'm guessing I'm doing it wrong
@daleif We have two versions of \cs_set - \cs_set:Npn and \cs_set:Nn. The latter 'auto-detects' the number of arguments but requires a : in the name
@JosephWright so I can use the Npn version without macro specification?
@daleif To me this looks like a token list, so I'd do \tl_set:cn { data- #1 } {#2}, but if #2 is more about 'actions' then \cs_set:cpn { data- #1 } {#2}
@daleif Yes
@daleif @FrankMittelbach and I strongly favour the :Npn version, but others on the team like the convenience of the :Nn version so it is a permanent feature of expl3
@JosephWright Might be an idea to mention the : requirement somewhere in the manual.
@daleif Within the code, the number of parameters is detected automatically from the function signature.
9:15 AM
@JosephWright Not sure what is most relevant. I'm more or less just makeing the equivalent of a hash list (look up data structure).
@daleif That's a token list structure
@daleif Functions with no arguments are more for 'programming' contexts, e.g. \cs_new:Npn \my_foo: { \my_foo_auxi: \tl_if_empty:NTF \l_my_tl { \my_foo_auxii: } { \my_foo_auxiii: } }
@JosephWright ok. Back to editing, a preprint with lots of suboptimal structures (that Emacs macro I made yesterday, saves quite a bit of time ;-)
9:33 AM
@barbarabeeton @egreg following this post on meta: meta.tex.stackexchange.com/questions/6267/… , I'm thinking to write something about how to create a class template step by step for TUGboat. I never create any class before, so it will be from a total beginner point of view. Interesting topic or not?
@daleif probably \tex_ifcsvoid:D, with the sarcastic smiley in the end indicating you can't use it :D
@JosephWright shouldn't it be \cs_set:cpn { mymodule_data-#1: } { #2 } or the colon : is not requeired here?
@DavidCarlisle Me likes ciders :) (and cidres, too)
@yo' The question was about 'data store' like cases, so they are not really functions. Moreover, my reading of the question was that the data storage names are perhaps meant to work outside of expl3 (perhaps as a user argument)
@JosephWright yeah, well, I more meant, if you dynamically create cs's, you still should follow the L3 naming scheme I suppose. And then provide a public "caller", if need be ... ?
@yo' Broadly yes
like \NewDocumentCommand \usedata { m } { \use:c { mymodule_data_#1: } }
@JosephWright ok, thanks
9:41 AM
@JosephWright at least with a user interface. For example my playing around with fancyref, I need to store what say the prefix thm corresponds to (perhaps even language dependent, but that is another matter). And was looking at what the proper method for storing information like this would be in expl3. I guess I'd better start looking at the siunitxsrc
Module luatexbase Error: Attempt to use callback.register() directly. on input l
ine 146

! LuaTeX error /home/davidc/texmf/tex/latex/base/ltluatex.lua:112: See luatexbas
e Error
stack traceback:
        [C]: in function 'error'
        /home/davidc/texmf/tex/latex/base/ltluatex.lua:112: in function 'module_error'
        /home/davidc/texmf/tex/latex/base/ltluatex.lua:119: in function 'luatexbase_err
        /home/davidc/texmf/tex/latex/base/ltluatex.lua:295: in function 'register'
        ./xinputenc.lua:50: in function 'register_callbacks'
@DavidCarlisle looks like a "feature" to me :-)
@JosephWright ^^ shouldn't we put the message in the error() so it comes on the ! line not before (also we ought to have a line break not . as followed by on input line
@AdamLiter In that case, you'd need another directive to achieve what you want. :)
10:15 AM
@daleif If you look at siunitx, go for the v3 sources (in development) as the v2 (release) code has been co-developed with the 'rules' and doesn't always follow them! github.com/josephwright/siunitx/tree/master
@DavidCarlisle Go for it :-)
10:26 AM
@JosephWright I've fixed up the messages not to end with . need to check implications of just using error() partly as I'm not sure I understand this, what's the difference between these, why do we need to write each line separately?
  for _,i in ipairs(msg_format(mod, "Info", text):explode("\n")) do
    texio_write_nl("log", i)

  texio_write_nl("log",msg_format(mod, "Info", text))
@RomainPicot It is, in my opinion
@DavidCarlisle It's taken from luatexbase: from memory there's otherwise a lack of control over what goes to a new line
@DavidCarlisle Idea is it's more-or-less the same as \MessageBreak
@JosephWright yes but I think you may have made it no longer needed as you've already inserted the (package) line prefix on every line in msg_format
@DavidCarlisle Could be :-)
@JosephWright it matters in the error case as you want the whole message before (or at least not after) the error which is why it's currently making the message before the error line. But if we can do the whole message in one go then can easily use error not texio_write_nl . Will experiment a bit later....
10:53 AM
@JosephWright noted for later
@JosephWright New talk for this year's meeting? :)
@yo' 'How to make your lists invisible within the body of your text'
@PauloCereda Perhaps
@JosephWright Either that or David's adventures in Lualand. :)
@PauloCereda I suspect either @DavidCarlisle or I will talk about the LuaTeX stuff
11:01 AM
@JosephWright Cool. :)
@JosephWright we should send @PauloCereda to do the talk, he's already conveniently on the right side of the Atlantic
@JosephWright 'how to destroy the page margins', especially in twocolumn :)
@yo' Bullets in the margin (which has nothing to do with hanging punctuation) are used by Bringhurst. The example with bullets inside the type block cannot be deemed “incorrect” (but I'd prefer a small indentation of the bullets): it's just stylistical preference. The example with the “pull quotes” is hilarious: the closing quote in the right margin is simply stupid.
@egreg I'd agree that one can use the bullet style, but it very much depends on the overall appearance
@egreg yeah. Well, I use pull quotes ... inside the quote environment, so they still don't make it into the margin :)
btw, how can I get the value of the interword space? Something like \fontdimen2\font?
11:05 AM
@yo' Typographers avoid pull quotes by simply setting a quote in smaller type (with or without narrower line width).
@egreg maybe I use the notion the wrong way, I mean this:
@yo' Yes, \fontdimen2\font is the (natural width of the) interword space for the current font.
@DavidCarlisle I can fly to Rio and try to ask Roberto to talk about Lua. He might know a thing or two. :)
@PauloCereda you mean, given UK-TUG reimburses the ticket? :)
@egreg thanks. The question is, how enumitem handles the information... whether it's "by value" or "by name"
11:08 AM
@yo' ooh I like the way you think. :)
@yo' ?
Sitting on the Copacabana beach under a parasol with a laptop writing TeX code while drinking a piña colada. :)
That is, three minutes before being robbed. :)
@egreg \setlist{ ... , labelsep = \fontdimen2\font } is what I wanna do
@PauloCereda you never can trust those users always trying to rob your tex code
@PauloCereda shut up enjoy!
11:11 AM
@DavidCarlisle They might be ConTeXt afficionados.
@yo' <3
@yo' There's a timing problem: the value of \labelsep will be set to the normal interword space relative to the font that's current when the setting is performed.
@egreg yep, that's what I meant. But I of course set up fonts first, so it should be fine in most cases (hopefully the space is not much different in the italic font, well, I can test this.)
anyway, it looks too tight to me, I should probably aim at the inter-sentence space
11:55 AM
Hello again, dear texians!
@Gigili Aloha!
I use the exact same code of this answer (the one by Niel) but unfortunatelly the arrows are not shown as expected
@Gigili You know the procedure. :) We might need a MWE. :)
! LuaTeX error ./ltluatex.lua:106:
Module luatexbase Error: Attempt to use callback.register() directly
(luatexbase)             on input line 146

stack traceback:
        [C]: in function 'error'
        ./ltluatex.lua:106: in function 'module_error'
        ./ltluatex.lua:115: in function 'luatexbase_error'
        ./ltluatex.lua:291: in function 'register'
        ./xinputenc.lua:50: in function 'register_callbacks'
        [\directlua]:1: in main chunk.
l.146 \directlua{xinputenc.register_callbacks()}
@JosephWright ^^ seems to work
@PauloCereda Yes yes, trying to provide one




% font definitions, try \usepackage{ae} instead of the following
% three lines if you don't like this look


% Define how TiKZ will draw the nodes
12:01 PM
@Gigili Did you compile twice, it works fine here.
@TorbjørnT. I did, and now it looks better
wonders why
@Gigili Because the information about the position of the equation elements are written to an auxiliary file on the first run, and used on the second run.
Ah that makes sense
@PauloCereda this has been closed as off topic, but do you (or could you) offer a Java API for running tex from java?
How to remove the number?
12:18 PM
@Gigili Which number?
12:30 PM
@DavidCarlisle Sure! A comment might suffice?
@PauloCereda he just asked same question on luatex list, if you are on that
@DavidCarlisle Sadly, no. I'd point the OP to this bit of the Java documentation: docs.oracle.com/javase/7/docs/api/java/lang/ProcessBuilder.html
@PauloCereda ah that's the general system call thing, I meant did you have a java API for arara?
12:47 PM
@TorbjørnT. The equation is numbered
@Gigili as always gather numbers, star forms do not number
@Gigili As David said, use gather*.
Or, as that is a single equation, equation*.
1:03 PM
@PauloCereda Would there be a straightforward way of pairing an output directory with a jobname? So could I do something like %arara: pdflatex: { jobname: [foo, bar], output-directory: [dir1, dir2] } and have dir1 be the output directory for foo and dir2be the output-directory for bar?
@PauloCereda Again, no need to worry about this all that much, if it proves to be a pain. I have a working solution at the moment. :)
@FrankMittelbach I'm trying some stuff now on your l3build query :-)
@AdamLiter I couldn't include this in the default engine rule because I don't feel it is something the majority of users would need. But it is surely possible, I can even write this rule for you. :)
Is there a way for me to fetch some mail from the LuaTeX list? I registered myself now, but I would like to reply the previous messages.
@RomainPicot -- i do find that an interesting topic, but there's a more urgent question to be answered first: exactly what is a template? to my understanding, a document class is not a template, and vice versa. a template (to me) is a basic outline, providing basic required commands (like \documentclass) and recommendations (usually as comments) for desirable or often-used (but not universal) features. however, that "definition" isn't universally agreed. (cont'd)
@AdamLiter It's easy to write such rule. arara 4.0 supports rules providing a list of tasks to execute. :)
(cont'd) and i would like to have an agreed definition of what a template is before adding more confusion in tugboat.
1:09 PM
@barbarabeeton Interesting. What I consider a template can contain a specific document class. For instance, what I presented at TUG15 (including the minimal document code) is a template for me.
@PauloCereda Fair enough, that makes sense. :) I haven't installed 4.0 yet and don't know how rules are written, so if you're not opposed to doing that for me, that'd be nice, but I can always figure it out on my own at some point, too. :)
@AdamLiter Sure, I'll provide all batteries soon. :) Just a quick question, which OS are you using?
@PauloCereda Usually Mac OSX. Very occasionally, Linux (Ubuntu).
1:34 PM
@AdamLiter Cool. Leave it to me.
user image
@PauloCereda ^^^ Thanks, Paulo! :)
@AdamLiter awwww
1:59 PM
@DavidCarlisle: replied. :)
2:11 PM
@PauloCereda shame it's not a call to arara.doWhateverTheFunkyCommentsSayToDo("myfile")
@DavidCarlisle I could open some API call. :)
@DavidCarlisle Martin's BTDT reply is amazing. :)
@PauloCereda That's my day job hiding API calls to fortran in more exotic languages
@DavidCarlisle oooh
2:37 PM
can anyone answer this question:tex.stackexchange.com/questions/264377/…
@ninja Hello! Do you have a complete yet minimal document to show us, so we can understand what's going on? :)
can i post the read only link of overleaf here
@PauloCereda or do u need the edit link also
@ninja Sure, go on. :)
i am pasting a read and edit link u can edit there only
@PauloCereda what is the issue i tried adding /hfill after every subsection but then it genrated a warning but solved the issue
in the template that i was using they already had a local hfill
2:57 PM
I'm curious if anyone would like to help me figure out a problem I have with a document I'm compiling.
I haven't been able to figure out what's causing the problem, as running the code with lipsum text didn't reproduce the issue.
My files are located here:
If you look at e.g. page 20 and 23 in the .pdf, you'll see big vertical spaces between paragraphs.
I have no idea what's causing it.
@Sverre Sounds like \flushbottom is active to get a a coonsistent bottom, try \raggedbottom
@Johannes_B Any idea what might have triggered \flushbottom to begin with (I'm not using memoir or twocolumn)?
@Sverre Your code is just compiling, let me look at it. (i see many box-warnings)
@Johannes_B Maybe the geometry option nofoot causes this (the box warnings are there before running biber).
@Sverre It is `twoside. If you have the book (or article) laying open in front of you, and some times the left page is a bit shorter, sometimes a bit longer it looks horrible.
3:10 PM
Ok, nofoot was not the culprit
twoside activates \flushbottom?
@Sverre yes, in most classes
I'm using article. Where should I add \raggedbottom? Anywhere? As a geometry option?
@Sverre Doesn't really matter where to put it. I put it in the preamble.
@Johannes_B I meant where in the preamble :)
Ok, I'll try
@ninja please read the advice the site gives on how to construct a question, the one posted there isn't really answerable. You should be able to construct an example without requiring external link
3:15 PM
It was sufficient to just remove twoside as an article option, and keep twoside as a geometry option.
@Sverre it's because \subsection{Sjølvstendet til folkemålet} is moved to the next page, plus \flushbottom because of twoside. Had you been using memoir, you could have issued \raggedbottomsection to stop this stretching when a \section is moved to the next page.
@JosephWright ok ... I'm sitting in the garden talking to Chris instead
@Sverre Please don't use \makeatletter and \makeatother inside packages.
This also explain why the top bibliography entry on my last page remained dashed - it's because it's on an odd page, so the reader will see the author's name on the even page ... this is the first time I've compiled a two-side document :)
@FrankMittelbach Ooh
3:17 PM
@JosephWright he just arrived
@FrankMittelbach Cool
@Johannes_B Right! I actually just added them because I suspected my redefinitions of the line spacing had something to do with it. I'll remove them again. Thanks :)
@Sverre are those free fonts? because otherwise, you might need to remove that ZIP.
@daleif Yup, I was just about to remove the zip for that very reason!
@Sverre good
3:19 PM
@daleif Deleted ... the problem was that the document had to be compiled exactly the way it looks now for the issue to appear, so I had to keep the fonts in the zip :-/
@Sverre it is not that hard to reproduce with standard fonts. But hard if you do not know what is causing it.
@daleif Well I've compiled the document dozens of times over the last few days, but the issue only appeared right now.
@Sverre or you just never noticed it before. The conditions need to be just right for it to appear.
@daleif Yes, that's what I meant. And putting a different font in would probably change those conditions.
But anyway, it's solved now. Thanks guys! (@Johannes_B)



@Sverre try changing that mwe to memoir and add \raggedbottomsection to the preamble.
3:29 PM
@daleif Yup - that's my issue wrapped up nicey in a mwe :)
@barbarabeeton I see two different things that could be named template now. 1 - The way to organized a preamble and 2 - the document layout produced by (La)TeX compilation. What I was thinking is the 2nd one.
So: "How to create your own class" if I rewrite what I mean
@Johannes_B emacs ewwwww
3:50 PM
@PauloCereda :-D <3
4:03 PM
@GonzaloMedina hmm seems like you are chasing after @egreg now:-)
@DavidCarlisle I wonder what @FrankMittelbach and Chris are up to :-)
@JosephWright Chris probably explaining to Frank what's expected of a gentleman in retirement.
@DavidCarlisle :-)
@DavidCarlisle Move to the other side of the world?
@JosephWright something like that
@JosephWright ooh South America!
4:16 PM
@DavidCarlisle Illusions.
@PauloCereda Perhaps Frank will consider that (he seems to like it)
@JosephWright ooh I will have a neighbour, yay!
@egreg well he's passed me:-)
@JosephWright just updated dpc-inputenc-tests on github to assume ltluatex:-)
@DavidCarlisle That obeys the laws of the universe.
@DavidCarlisle @egreg Looking at the month, @touhami is first
4:22 PM
@Johannes_B Let's see in three or four days. ;-)
@Johannes_B Statistical fluctuation.
@DavidCarlisle I'll take a look
@egreg :-)
@JosephWright not done anything really other than replace callback.register, so now I'll be able to have tests without luatexbase (via fontspec) complaining I'd been bad....
@DavidCarlisle I see: quite small
@JosephWright I can hardly remember what some of it did but it might bump up priorities again once luatex support is in.
4:48 PM
@egreg @UlrikeFischer ctan.org/pkg/lettrine
5:02 PM
@Johannes_B Yes, I saw it.
5:15 PM
@Johannes_B hmm, might be better for the auctex mailing list. Actually getting \citeto work properly in my Emacs (regexp searching the bib file), does not always work for me either. Might be a version issue.
1 hour later…
6:28 PM
Could anyone fill me in on why ltxgrid is inadequate to warrant this question: tex.stackexchange.com/questions/262879/document-layout-styles?
@Johannes_B: I accessed my Fedora account today and found out I won a badge for being a penguim...
@PauloCereda What is a curious penguin?
@Johannes_B Apparently, it's a badge you earn when you ask your first question in the Fedora forum.
@Johannes_B: and I have another penguin badge: badges.fedoraproject.org/user/cereda
@PauloCereda Just considering Fedora as my next OS. ;-)
@Johannes_B Really? That's awesome. If you opt for Fedora, poke me about post-install goodies. :)
6:39 PM
@PauloCereda I'll do.
@PauloCereda We should ask SE to create a “duck” badge.
@egreg ooooooooooh
I like this idea very much. :)
@JosephWright: As moderator, do you see any badge creation option?
@AndrewCashner: Aloha!
@PauloCereda Hi!
@Johannes_B If you use master .bib in your texmf tree you can do this, not sure if that's what is needed: `(setq reftex-plug-into-AUCTeX t) (setq reftex-default-bibliography '("~/texmf/bibtex/bib/master.bib"))
(setq reftex-bibliography-commands '("addbibresource"))`
@PauloCereda I'm sorry to tell you I've been learning emacs... but you might be heartened that I'm also learning scheme and XML
@AndrewCashner Oh my! :) How nice!
@PauloCereda What would be the specs to get a duck badge?
6:54 PM
@PauloCereda I am moving from dissertation to book and I thought TEI-XML would give me more flexibility when dealing with publishers who want Word documents and can't deal with TeX. But it's still a new experiment for me.
@Johannes_B How about a nice ratio of upvotes/downvotes? That way, everybody in the TeX.sx community will earn it. :)
@AndrewCashner That sounds like a great move. :) As long as it is not Word directly, everything is fine. :)
@PauloCereda checked profile: downvotes: 3; upvote: 1266
@Johannes_B You qualify. :)
@PauloCereda Yay
@PauloCereda Duckling badge: First upvoted answer.
@PauloCereda closure: 360, reopen: 10
@PauloCereda I second that :)
7:22 PM
Somebody posted a link in here to a new monospace-font. I think it was @werner, but i am not sure. Can anybody remember it?
7:34 PM
@PauloCereda Thanks. Of course I will still be using LaTeX heavily for everything I print myself!
7:57 PM
Is TeX's "pt" a printer point or a computer point?
@1010011010 It's a TeX point ;-)
A: Why does a TeX point differ from a Desktop Publishing point?

AradnixThe history about the pica pint is quite interesting (at least for me). And it has to do with the way we measure types. In the beginning From the early days of the emergence of the printing press, and the mythical Gutenberg and for a long time, each printer, each workshop had its own way of mea...

@1010011010 -- tex's "pt" is the traditional printer's point. there are 72.27 of them to an inch. this measurement predates computers by at least a century, and computer printers by even more. (adobe really wasn't doing anyone a favor when it redefined the point to be exactly 72 per inch; that "point" is called a "bp" = "big point" in tex.)
@Johannes_B Hmmm... I don't recall.
@Johannes_B: You might be referring to this:
Jul 24 at 13:44, by Paulo Cereda
Just read about this new monospace font: https://github.com/larsenwork/monoid
so 72bp is 72.27 pt
@Werner Looks interesting, thanks. But it wasn't the one i meant.
8:10 PM
Ooh a new terminal font!
What has the TikZ ever done for us? :)
@yo' The shoe bin is a good idea
(desining new furniture in the entrance hall)
@AndrewCashner it will be sturdy enough so that people can sit on it :)
(I actually don't think I'll store many shoes in it, since I can leave them in the outer corridor, people don't steal things here)
8:37 PM
@JosephWright @DavidCarlisle watching Endeavour
@FrankMittelbach Endeavour?
@FrankMittelbach Inspector Morse?
@JosephWright yep the early days
and I'm now sitting down and rereading the books
or one of them at a time
Now I think, it's bedtime. See you tomorrow!
@JosephWright so why is r5906 breaking the testsuite?
Morse didn't have a clue
@FrankMittelbach It's not: there's an earlier commit where I missed the need to change a test file
8:44 PM
ah :-)
@FrankMittelbach r5900
but the change looks suspicious ... why should such a result change?
was it wrong before?
no I don't really want to know :-)
@yo' sleep well
@FrankMittelbach I've altered how \char_set_active_eq:NN works, and that confused a test (which was testing something else, hence me missing it)
@yo' Night
@JosephWright good ... had me puzzled ... I should have tested before makin the change but I thought the suite is up to date
8:50 PM
@FrankMittelbach Took me a little while to find the issue, but I did have an idea it was probably related to the checkins to do with active chars
ah well ... Morse calling then bed caling
@FrankMittelbach Night
9:58 PM
@PauloCereda Mildly related: youtube.com/watch?v=TllPrdbZ-VI
The Gordon Ramsey spoof is .... interesting too
10:11 PM
@PauloCereda Oh no, this is not what coooking is supposed to be.

« first day (1767 days earlier)      last day (3246 days later) »