« first day (4643 days earlier)      last day (99 days later) » 

4:20 PM
@Pᴀᴜʟsᴛᴇʀ2 I've actually got a mechanical car-related issue you may be able to help with. I'm almost certainly going to post it as a question, but the core of it is: I got my daughter a 2012 BMW 5 series M-sport diesel. It's done 200000 miles so has general age issues, which is fine, but just recently has occasionally just not gone into drive
It will be parked, and selecting D doesn't engage the transmission, and after 8-10 seconds it pops back into P
Error messages have been either "Transmission Fault, drive moderately" or "Drivetrain fault, call BMW Mobile care"
BMW garage have looked at it and haven't managed to identify the fault - it being intermittent doesn't help. As a BMW enthusiast, do you have any thoughts on things to check? Areas that are likely to be the culprit?
 
4:52 PM
@RoryAlsop - Well, I'm not really an enthusiast, but I'd wonder if the transmission filter is clogged (or getting clogged)? Also, the solenoids may not be moving correctly to engage the bands/clutches as it is supposed to. If one was sticking, it might provide an intermittant issue like you're describing.
It could just be tired and need a rebuild.
If you have to take the innards out for any reason, I'd suggest you have a rebuild done on it.
 
5:14 PM
@Pᴀᴜʟsᴛᴇʀ2 thanks - I'll try some more home diagnosis. Definitely seems to improve when warmed up - so some other posts on here seem similar. Rebuild may be the best option - will find out
 

« first day (4643 days earlier)      last day (99 days later) »