« first day (1857 days earlier)      last day (3151 days later) » 
00:00 - 21:0021:00 - 23:00

12:09 AM
@terdon , hope I will learn slowly :)
We all do :)
Learn, I mean.
12:38 AM
@faheem - is there a legacy version of that vdpau package? in sid there's nvidia-legacy-340xx-vdpau-driver but that's a later version than your 304xx. do the 340xx drivers support your GPU? if so, it's probably safe to upgrade. if not, then unsafe.
2 hours later…
2:42 AM
> The Linux 340.* legacy driver series is the last to support the G8x, G9x, and GT2xx GPUs, and motherboard chipsets based on them. Support for new Linux kernels and X servers, as well as fixes for critical bugs, will be included in 340.* legacy releases through the end of 2019.

The Linux 304.* legacy driver series is the last to support the NV4x and G7x GPUs and motherboard chipsets based on them. Support for new Linux kernels and X servers, as well as fixes for critical bugs, will be included in 304.* legacy releases through the end of 2017.
The only reason not to be running the latest nvidia drivers (imho) is if support for your card has been dropped, and in that case I'd run the last driver to support it.
2:54 AM
@FaheemMitha which nvidia card do you have?
1 hour later…
4:11 AM
@casey lspci gives me:
06:00.0 VGA compatible controller: NVIDIA Corporation G72 [GeForce 7300 GS] (rev a1)
@cas I'll check on that and get back to you.
@FaheemMitha is that in a laptop?
if not, i very strongly recommend getting a new GPU. the 7300 GSs were notoriously buggy (i had one years ago). even a GT210 (approx. $39 AUD) will beat the pants off a 7300GS and use less power in doing so.
2 hours later…
5:52 AM
@cas No, it's a desktop/workstation.
@cas Ok. And yes, X has been crashing regularly this past year. It's quite annoying. I thought initially it was hardware, but am wondering if it is the Nvidia drivers.
i'd be inclined to suspect the 7300gs.
Do you have any specific recommendations on a good card? I could always reuse it in the next configuration of my workstation. Graphics cards can last quite a long time.
how much do you want to spend?
@cas The software or the hardware?
hardware. who spends money on software :-) ?
5:55 AM
@cas Hmm, not sure. Midrange, maybe? Bear in mind that hardware prices here tend to be inflated.
where's here for you?
prices in .au are inflated too, due to exchange rate. currently around $0.70 USD for $1 AUD.
@cas No, I was replying to "i'd be inclined to suspect the 7300gs.". In other words, where is the problem more likely to lie, with the Nvidia graphics card itself or the Nvidia drivers?
@cas India.
@cas Maybe give me a couple of reasonable suggestions with some variations in price?
oh, in the hardware, probably. but mostly because my experience with 7300gs is that they suck.
If there were any halfway reasonable graphics card with free drivers, I'd use them in a heartbeat.
well, like i said the GT210 will beat the pants off a 7300GS for around $39 AUD. about twice as fast, if not more.
a GT610 for about $55 AUD will be twice as fast again.
5:57 AM
@cas And more reliable / less buggy?
both will be much more reliable. the 7300gs was buggy hardware.
I'm not too concerned about speed, I just don't like X crashing. It's freaking annoying.
@cas Excellent. That's very helpful feedback. Thank you. I'll consider getting a new card.
A GT750 for around $150 AUD would be about 6-7x as fast as the GT210 (so about 14x as fast as your 7300gs)
@cas How is a faster video card useful? For playing video games? I play videos, write stuff (email etc.) and use a browser. Basic stuff.
most of those cards will work either nouveau (free software drivers). they'll all work with nvidia proprietary drivers.
largely for playing games. also for playing video files (although a GT210 or 610 is likely to be fast enough). and for accelerating stupid animation effects in your desktop (i turn all that crap off on my machines).
6:01 AM
@cas Oh. I had problems getting this one to work with the nouveau driver and KDE. I think I tried switching to nouveau when I upgraded to jessie a few months ago (I think that is when it was).
Does the world have a decent graphics card with properly supported free drivers?
@cas OK. It sounds like the GTK210 would likely be enough for me. And much more reliable, you say.
7300gs is so ancient probably nobody in the free software world is going to bother testing drivers against it...especially when you can get a brand new GT210 for about $25USD.
much more reliable.
@cas Ok. I think I'll get one then. It probably doesn't cost much here either.
the 7300gs really was a crap card. most other nvidia cards have been good or great, but that model was buggy as hell.
@cas Oh. Nobody told me. :-)
nobody told me either. i discovered it myself :( and then confirmed it by googling
6:04 AM
@cas :-)
I have GTX-750s in my myth front-end boxes. serious overkill but future-proof for at least half-a-decade worth of driver upgrades. GTX-560Ti or GTX-560 in my main desktop machines. The 560s were great cards at a great price, I've had them for several years now and have been waiting for nvidia to produce something worth upgrading to for around $200-$300 AUD....the GTX-970 for around $500 AUD is too expensive for my liking.
@cas Wow, those are some expensive cards.
I'm surprised anyone thinks they are worth buying.
You can get a full machine upgrade for not a lot more than $500. At least in the US, I think.
New MB and stuff.
some people spend far more than $500 on a GPU. silly, i think.
@cas Agreed.
the top end cards are well over $1000
6:11 AM
@cas Yikes.
I wish some company would make good, reasonably priced video cards, and support the making of free drivers. I had a Matrox card once. It was nice. Matrox Millenium, I think it was.
With my win7 steam box, i'm pushing the GTX-560 about as far as it can go since I recently upgraded my monitor to 2560x1440. I'll probably have to get a GTX-970 for it eventually but I'm delaying that for as long as i can.
@cas Is that a single monitor? If so, what size is it?
a 7300gs would beat an original matrox card, and a $39AUD GT210 would beat that again. modern cards are much faster and cheaper than matrox were....they were top-end equipment in their day. and priced accordingly.
single monitor. 27" IIRC.
Benq GW2765
@cas Oh. I have a 24 in and a 19 in. The card I have runs both of them.
a reasonably cheap 1440p monitor
6:14 AM
@cas Good monitor?
not bad. a bit slow switching between inputs (i have it connected to my main desktop and my win7 steam games machine) but otherwise excellent.
The 19 inch is ancient. I bought it in 2004. Still works, and not a single dead pixel. I think I got the 24 inch in 2008.
are your monitors DVI or VGA?
@cas Both, I think. Is that possible?
if VGA you may need to be careful about which brand of GT210 you get...different brands have different kind and number of connectors. e.g. some will have 2 or 3 x DVI and one HDMI or display port. Some of the DVI ports may support analog VGA via an adaptor.
6:16 AM
I think the card I have has one DVI and one VGA output.
@cas Hmm, Ok, I'll check on that.
yes, it's possible. use DVI in preference to VGA. DVI is digital and crisper/clearer than analog VGA signals, esp. over long cable distances or in electrically noisy environments or unshielded cables.
@cas Is this the GT210 you meant?
btw, video cards often come with a DVI->VGA adaptor if they support it.
yep, that's a GT210. One of many brands (e.g. Asus, Gigabyte, Zotac, and many others) based on the reference design and chipset produced by nvidia.
6:19 AM
@cas Ok. And these cards can vary in the connectors they supply?
Curious. One would expect them to be standardized.
$76 seems expensive, even considering that it's a fanless model.
capitalism. choice. pointless product differentiation. and then, paralysis of choice.
Do you use ATI cards at all? I heard they have some kind of free driver.
@cas Crap, I thought that was Amazon India. One sec.
nope. i've tried radeon cards but gone back to nvidia. i want to use free drivers, but they just don't compare to the propriatary nvidia drivers. yet. i hope.
same price. it must be redirecting me to a .au or .us site.
anyway, try a local dealer if there's one nearby. probably get better prices than amazon.
6:23 AM
@cas The site is putting in an amazon.com link, when I put in an amazon.in link. I'll try inline. One sec. -> amazon.in/ZOTAC-GeForce-DDR3-Graphic-Card/dp/B005IHM274
Do you see the India link? Rs. 2000 is about USD 30.
How much is Rs 1945 in AUD or USD?
$30 is OK.
@cas Does that card look reasonable, then?
"Its very awesome product came with HDMI, DVI & VGA. By using this card i am easily able to setup dual monitor and play games very smoothly." From a review.
you could probably find a slightly cheaper model if you didn't mind having a fan. zotac specialise in quiet and/or fanless stuff.
@cas I'd prefer not to have a fan. And $30 is not a significant amount of money.
I mean, fans tend to go bad and make noise. And there is tons of dust over here. India specialises in dust. AU possibly too.
Assuming of course, that the card will work fine with no fan.
it's designed to work without a fan. clean it out with a brush and/or mini-vaccum every year or so.
6:28 AM
Is unix.stackexchange.com/q/241766/4671 really on topic here I wonder. Seems more of a web programming question.
@cas Ok. Let me pull up the question I asked about X crashing. One sec.
Dated Jan 5th. This has been going on all year.
Less recently. Though the logs show crashes, X does not seem to actually crash for some reason. Anyway, I think a new card is worth trying. Do you have any specific information links about the bugginess of my card? It would be interesting to take a look.
try a new card, like that GT210, along with matching new drivers. the problem will probably just go away.
nope, i haven't had a 7300gs for over 10 years. i just remember it because it caused me a lot of hassle.
try googling for 7300gs crash or similar.
@cas Ok, I'll do that. Thanks.
@cas Well, one can hope... :-)
@cas Wow, apparently they are really old. I hadn't realised.
6:43 AM
@cas Yes, I see.
Thanks for the advice. It's very helpful.
4 hours later…
11:01 AM
Hey hey hey,
hello everyone,
If anyone here is very good at postfix configuration I could really use his advice with a *ù*^$$ù*$^$ Zimbra server that almost work corretly
11:48 AM
@Kiwy what's going wrong with it? i know a few things about postfix. i know nothing about zimbra, though.
@Kiwy You could check if there is a postfix IRC channel.
12:12 PM
@FaheemMitha good idea I will
@Kiwy Yes, there's a #postfix channel on freenode. I just checked. But you have to be registered to talk there.
@cas, I just can't manage to make my serveur to accet mail from server with wrong HELO
There are a lot of people in the channel. Probably mostly idling though.
@FaheemMitha I'm not use to freenode or stuff like that but I'll take a look
I don't know if my problem is Zimbra specific
@Kiwy You could give irccloud a try. It's a web interface, and fairly painless to use.
12:25 PM
@FaheemMitha I try the freenode #zimbra thanks for the advice
12:35 PM
> PHP can also be seen as the Justin Bieber of programming tools. Both prove conclusively that you don't have to be good to be popular.
12:54 PM
@Kiwy Oh, there's a #zimbra?
@Kiwy remove the helo restrictions from main.cf. they'll be either in smtpd_helo_restrictions or in smtpd_recipient_restrictions. look for
from main.conf

smtpd_helo_restrictions = "";
these are kind of useful for blocking spam (because spambots make up non-existent hostnames for the SMTP HELO/EHLO negotiation). but if you need to accept mail from a misconfigured server (usually a windows box), then disable them
^ note: you don't
they might be in smtpd_recipient_restrictions. which is kind of a catch-all for all restrictions, not just recipient.
because it's easier to have them all in one place under smtpd_recipient_restrictions than scattered over recip/sender/helo/etc restrictions.
12:57 PM
@cas Isn't accepting mail from a misconfigured server a bad idea?
@cas that's what makes me completly crazy...

smtpd_recipient_restrictions = reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unlisted_recipient, permit
yep. if your boss (or customer) wants to receive that mail, though, it may be a CLM.
@FaheemMitha depends, when it's order from custommer very important, it's a bit risky to argu that you don't receive it's order because they have a badly configure server :D
what does the postfix log say when rejecting those msgs?
@cas excuse number one: if we want to receive mail from them, they either fix their stuff, or we wouldn't be able to send and receive emails from anyone
1:00 PM
(BTW i have those helo restrictions on my home mailserver. because i don't care if i lose one or two legit emails per year vs the thousands of spams auto-rejected)
@Braiam "but my marketing friend at gmail.com can receive them just fine. fix it or be fired".
@cas the return message to the client is :
554 5.7.1 This message has been blocked because the HELO/EHLO domain is invalid
@Kiwy what does YOUR log say?
grep the queue-id from /var/log/mail.log (or whatever it is on zimbra)
@Kiwy Fair enough.
@cas CLM?
@FaheemMitha - career limiting move.
@cas because google knows his stuff doesn't mean that he knows it
1:02 PM
@cas Oh.
Is it a bad idea to tell the customer to fix his server, then?
@Braiam boss don't care. boss wants his mail.
@FaheemMitha, not necessarily. but don't expect a customer to have a clue or even care about not having a clue.
`Nov 9 08:31:12 zimbra postfix/smtpd[23171]: connect from zimbra.company.fr[]`
`Nov 9 08:31:12 zimbra postfix/smtpd[23171]: lost connection after EHLO from bad.ehlo.server.com[]`
`Nov 9 08:31:12 zimbra postfix/smtpd[23171]: disconnect from zimbra.company.fr[]`
sometimes it's just far less hassle to give bosses/customers what they want even when you know it's just plain wrong.
@cas amen !
what version of postfix is that? that's quite minimal logging. on my home mail server it looks more like
Nov 10 00:01:37 ganesh postfix/smtpd[2332]: NOQUEUE: reject: RCPT from unknown[]: 504 5.5.2 <>: Helo command rejected: need fully-qualified hostname; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<>
1:05 PM
@cas oh, he will lost his mail, trying to sweep through all the crap
@cas, that's F***** zimbra log
note how the spammer tried to forge my IP address in the HELO. which a) no way b) IP addresses aren't valid in helo/ehlo.
maybe whitelist the sender's IP?
Anyway, it would work to check any details of the RFC if everybody respected, but it's not the case, so why bother... :-(
e.g. bad.ehlo.server.com permit_auth_destination in your junk map
@Kiwy yeah, why bother, your dwarfs are waiting :D
1:08 PM
(don't use OK for whitelists. use permit_auth_destination or else you are open relay for anything claiming to be that host)
@kiwy, try postconf | grep helo...maybe you'll see something relevant.
`milter_helo_macros = {tls_version} {cipher} {cipher_bits} {cert_subject} {cert_issuer}`
`postscreen_helo_required = $smtpd_helo_required`
`smtp_helo_name = $myhostname`
`smtp_helo_timeout = 300s`
`smtpd_helo_required = yes`
`smtpd_helo_restrictions =`
`unknown_helo_hostname_tempfail_action = $reject_tempfail_action`
I have no idea if it looks OK
to me it looks OK
try commenting out the smtpd_helo_required = yes.
or the whitelist i mentioned earlier.
@cas It sounds like you speak with the voice of experience. :-)
if you don't have a general purpose junk map you could make a map for just helo whitelists with: check_helo_access hash:/etc/postfix/helo in smtp_recipient_restrictions. and then add ` bad.ehlo.server.com permit_auth_destination` to it and run postmap helo and postfix reload
1:23 PM
@FaheemMitha i used to do a LOT with mail servers, working at ISPs etc. but i've done very little with them for the last 5 or so years. don't even bother updating my home spam filters much (very little spam gets through anyway...maybe a handful per month).
anyway, it's after midnight here. gotta go before i turn into a pumpkin or something.
1:38 PM
@cas goog evening then
thanks for the advise, I will try to do so in Zimbra
1:57 PM
@cas Ok. Have a good night.
2 hours later…
4:22 PM
Interesting post:
A: Disks constantly spinning no matter what I do (jbd2). I'm on the brink of insanity

SteveBased on their model numbers (WDC WD20EARX-00PASB0), both of your RAID disks are "Green" drives these are notorious for constantly parking and unparking the drive heads and are not recommended for use for RAID applications. Take a look at the output of smartctl or via the graphical "Disk Utility...

Has anyone else seen this kind of thing?
I'm also seeing this jbd2 thing a lot.
5:10 PM
Does anyone know of free software that has similar functionali8ty to HD Tune?
5:58 PM
So, what does this mean?
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
1 Raw_Read_Error_Rate 0x002f 200 200 051 Pre-fail Always - 0
3 Spin_Up_Time 0x0027 175 174 021 Pre-fail Always - 4233
4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 148
5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0
6:49 PM
1 hour later…
8:11 PM
Hi people
any strace wizards?
I come for kernel knowledge and can offer hardware knowledge in exchange
@crasic You could post a question on the site. That's how it's supposed to work.
8:42 PM
Hello guys
I'm having some trouble understanding apt-get. Could someone please help me?
@TheQuantumPhysicist What's your question?
I have Debian Wheezy, and to install php 5.6, I added the repository of dotdeb. Now I'm trying to install php5-curl, but it claims there's a dependencies problem
Now I'm looking at the return of command apt-cache policy php5-curl
and I see higher versions, and I'm wondering, why isn't debian installing the newer versions by itself?
I mean version 5.6.15-1~dotdeb+7.1 looks good with all dependencies available from dotdeb repos... how can I go there?
If I try: `apt-get -f install php5=5.6.15-1~dotdeb+7.1`, it says:

 php5 : Depends: libapache2-mod-php5 (>= 5.6.15-1~dotdeb+7.1~) but 5.6.6-1~dotdeb.1 is to be installed or
                 libapache2-mod-php5filter (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 php5-cgi (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed or
                 php5-fpm (>= 5.6.15-1~dotdeb+7.1~) but it is not going to be installed
        Depends: php5-common (>= 5.6.15-1~dotdeb+7.1~) but 5.6.6-1~dotdeb.1 is to be installed
So my question is... what is going on? Why am I missing a dependency and the system is ignoring newer versions?
@TheQuantumPhysicist Is there some reason you don't just ask a question on the site?
Not meaning to be unfriendly or anything, but that's how it is supposed to work.
Because I'm so, so stressed and it's 10 PM here and I'm so tired and my ignorance in linux is the only problem here...
@TheQuantumPhysicist Post the output of apt-cache policy php5-curl to start with.
8:49 PM
  Installed: (none)
  Candidate: 5.4.45-1~dotdeb+7.1
  Version table:
     5.6.15-1~dotdeb+7.1 0
         80 packages.dotdeb.org wheezy-php56/all amd64 Packages
     5.6.14-1~dotdeb+7.1 0
         80 packages.dotdeb.org wheezy-php56/all amd64 Packages
     5.6.13-1~dotdeb+7.1 0
         80 packages.dotdeb.org wheezy-php56/all amd64 Packages
     5.6.12-1~dotdeb+7.1 0
         80 packages.dotdeb.org wheezy-php56/all amd64 Packages
     5.6.11-1~dotdeb+7.1 0
@TheQuantumPhysicist Do you actually need to get this done now?
Yes! I need to get our experiment's website going... and I need curl to post from a php script
Ok, backing up a sec. I don't know what dotdeb is, but why do you need 5.6?
We have a tikiwiki website which uses php 5.6... though I regret using it cuz it's so crappy... but I'm stuck with it now
@TheQuantumPhysicist Ok. I don't know what tikiwiki is either, but Ok. Is upgrading to jessie an option?
8:51 PM
dotdeb is a repository with newer versions of php and mysql
not really... I tried... the university refuses that now because the system they use for controlling the server isn't compatible with jessie
@TheQuantumPhysicist So I gathered. But third party repositories can create more problems than they solve.
@TheQuantumPhysicist Ok. What is the default version of PHP on wheezy?
Well, I regret doing it to be honest
but I'm stuckl
I'm currently running jessie.
@TheQuantumPhysicist Regret doing what?
8:52 PM
Me too, on my personal server
but this is the university server
using dotdeb
@TheQuantumPhysicist And what is the package name for php on wheezy?
php package?
apt-cache policy php5 returns:
  Installed: 5.6.6-1~dotdeb.1
  Candidate: 5.6.6-1~dotdeb.1
  Version table:
     5.6.15-1~dotdeb+7.1 0
         80 packages.dotdeb.org wheezy-php56/all amd64 Packages
     5.6.14-1~dotdeb+7.1 0
         80 packages.dotdeb.org wheezy-php56/all amd64 Packages
     5.6.13-1~dotdeb+7.1 0
         80 packages.dotdeb.org wheezy-php56/all amd64 Packages
     5.6.12-1~dotdeb+7.1 0
         80 packages.dotdeb.org wheezy-php56/all amd64 Packages
     5.6.11-1~dotdeb+7.1 0
Ok. the answer to your question is that those other packages are being held back. Are you not familiar with preferences?
What surprised me here is why isn't debian using the latest version of php5.6 and all its dependencies
This system that you are on, did you install it yourself? You've got weird preference values.
8:55 PM
I have pinned with
Package: *
Pin: release o=packages.dotdeb.org
Pin-Priority: 1500
@TheQuantumPhysicist Wheezy isn't the current stable. It's oldstable.
It's the university's...
They have their pinning and I have to add mine in preferences.d
@TheQuantumPhysicist Eek.What is the reason for that?
That doesn't agree with what I have above. Can you post your preferences file, please?
Good question... I think they have their own software that they wanna prioritize
The main file is the following:
If you have a bunch of preferences stuff, you could just post apt-cache policy.
8:57 PM
Package: *
Pin: release o=Uni-Mainz
Pin-Priority: 1100

Package: *
Pin: release n=wheezy
Pin-Priority: 700

Package: *
Pin: release n=wheezy-updates
Pin-Priority: 700

Package: *
Pin: release n=wheezy-backports*
Pin-Priority: 90

Package: linux-image-* initramfs-tools burp check-mk*
Pin: release n=wheezy-backports*
Pin-Priority: 700

Package: *
Pin: release o=packages.dotdeb.org
Pin-Priority: 80

Package: *
Pin: release n=jessie*
Pin-Priority: 70

Package: *
Pin: release a=testing
Pin-Priority: 60
That would list everything with the preferences.
@TheQuantumPhysicist That looks pretty strange. You didn't write this, then?
The university's IT department
Ok. apt-cache policy, please.
you see that 1100?
@TheQuantumPhysicist I do.
8:58 PM
Can I override this?
P >= 1000
causes a version to be installed even if this constitutes a downgrade of the package
From man apt_preferences. Not commonly used.
@TheQuantumPhysicist Why do you want to?
00:00 - 21:0021:00 - 23:00

« first day (1857 days earlier)      last day (3151 days later) »