« first day (1493 days earlier)      last day (3483 days later) » 

1:38 AM
Hello
I can't edit any post or question. previously I was able to do so but It needed approving by an admin. Any change in policy?
 
@r004 Not that I know of. What happens when you try? Editing always needs approval if it isn't on your own post (and you have less than 2k reputation).
 
@Seth the edit link is disabled
 
what post is this?
hover over the link, it should give you a reason why.
 
@seth ok
 
slm
2:00 AM
@r004 - there's nothing disabled on your acct. Try clearing out cache
 
2:53 AM
@slm thank you for your attention; will do.
 
 
4 hours later…
6:35 AM
I am using Ubuntu (with Xfce) 14.04 ; after reading Free GNU/Linux distributions and Explaining Why We Don't Endorse Other Systems I'm thinking to migrate to gNewSense or Trisquel. Which is recommended to try ?
BTW Is Linux & Linux-libre are different kernel? (what is difference? or how Linux-libre differes?)
 
7:26 AM
@Pandya If you are used to Ubuntu I would try Trisquel first. gNewSense latest news update is from Feb 2014, that would make me a bit suspicious
 
7:53 AM
@Pandya You could use plain Debian. Apparently it does not meet the FSFs high standards, but they are a bit nuts.
If you don't want to use the non-free bits of Debian, you don't have to. Nobody is putting a gun to your head. And they are clearly labelled as such.
 
 
8 hours later…
3:44 PM
@FaheemMitha Gaaahhh! You seem to have taken over my aptitude...
 
4:05 PM
Hi @derobert. And huh?
Oh, mercurial. Hardly my speciality.
You use aptitude? I didn't know that.
 
4:16 PM
I thought everyone used aptitude
Except for those weird GNOME folks.
 
I don't, I use apt-get usually. aptitude sometimes.
 
aptitude is smarter than apt-get right?
 
I use apt-get sometimes too (and especially for release upgrades, where its been the recommended way for the last few). I got into the habit of using aptitude for almost everything when apt-get didn't have autoinstall tracking
 
@Ramesh generally yes, sometimes no. You'd better ask @Braiam for the details but I recently broke my system and entered deep dependency hell and had to use a combination of both to get me out again. Even the Debian guys recommend one for some things and the other for other things.
 
Come to think of it, I do some odd things. E.g., I always use apt-get update, but then use aptitude...
/me wonders if everyone is switching to that newfangled apt command now.
 
4:24 PM
Not yet, I need to try it out though.
WTF? We have an tag?
 
Wow. Another tag to kill :-(
 
Holy meta tags batman!
 
At least we don't have or
 
Is this a dup of this one?
 
Not sure. The new one is really about the arguments list too long error. OP already knows to use cat.
 
4:29 PM
Thanks. I will probably give this as a suggestion for the OP to verify.
 
6
Q: Error and crash tags, are they really useful?

BraiamI've seen this question but I'm still not convince about the usefulness of those tags. The meta Question itself recognize that the tag could not survive alone in any question which is specifically prohibited by the tag creation page: ... tags that cannot stand alone as the only tag on a quest...

@Ramesh depends...
 
4:50 PM
 
5:05 PM
@Ramesh Define smarter. Definitely less actively maintained, that is for sure. And it still uses that wacky dependency algorithm that Daniel Burrows came up with. Though Daniel is no longer with us. (In the inactive Debian maintainer sense, not the dead sense.)
 
@Ramesh I just closed it as a dupe of this:
3
Q: Solving "mv: Argument list too long"?

DominiqueI have a folder with more than a million files that needs sorting, but I cant really do anything because mv outputs this message all the time -bash: /bin/mv: Argument list too long I'm using this command to move extension-less files: mv -- !(*.jpg|*.png|*.bmp) targetdir/

mv or cat, makes no difference, it's the same issue and the same solutions
 
@derobert Lots of people don't. I'm one of them.
I've thought of writing a blog post called "Debian and the inverted pyramid", where I give a list of basic Debian packages, and the people currently contributing to it.
Spoiler alert: it is not a lot of people.
 
 
2 hours later…
7:31 PM
Wow, a question that actually provides everything we need to answer! Give the man some upvotes!
1
Q: Function that calls another function with list of arguments doesn't work

KoverasIn my .bash_aliases I have defined a function that I use from the command line like this: search -n .cs -n .cshtml -n .html SomeTextIWantToSearchFor /c/code/website/ /c/stuff/something/whatever/ The function builds a grep command that pipes the result to another grep command (unfortunately con...

 
 
2 hours later…
9:18 PM
@FaheemMitha Well, I think you'd find its not really an inverted pyramid. There probably aren't many people contributing to any package.
Well, except maybe the team ones. Some teams nominally have plenty of members (often, it seems, most of them inactive)
 
just how many more answers do we need? unix.stackexchange.com/q/166220/41104
 
one miiiiiilllliiion, of course :-)
 
meh, they are repeating python, php and perl solutions
even bc'
btw, why OP keeps adding the bash tag?
 
well, 'protecting' it is the best we can do... AFAIk.
I also just added this to the question:
> NOTE: We currently have over twenty answers. Please review the existing answers before adding your own and be sure your answer adds something significant (for example, a way to do this on systems where none of the existing answers will work.)
 
@terdon or @slm can add a post notice asking for substantive answers
 
9:32 PM
Sure. Maybe Stephane can come by with the history of why POSIX didn't give us a pi command :-)
 
watch the birth of the next cow question
 
@Braiam that question will soon have more answers than cows have upvotes... IT MUST BE STOPPED.
 
9:57 PM
@FaheemMitha would look forward to it.
 
10:56 PM
@derobert POSIX does give us a definition of pi as 104348 / 33215 at pubs.opengroup.org/onlinepubs/9699919799/utilities/…
 
@St├ęphaneChazelas :-P
 
11:08 PM
@St├ęphaneChazelas No, it doesn't. It states that this is an approximation of pi, which is correct.
 
actually it just gives an example of how to approximate pi
 
11:21 PM
There are two solutions, and both can be used. 1) Remove the already installed packages comparing both lists using diff or any other method to compare files. 2) Using aptitude/dselect and mark all packages to install and append the auto-installed flag, then check which packages will be "automatically removed" and there you have your list of the top of dependencies. There is a tool that can generate software dependencies graph, but I don't remember the name or that it would be useful for this particular case. — Braiam 43 secs ago
^ fun!
 

« first day (1493 days earlier)      last day (3483 days later) »