« first day (3761 days earlier)      last day (35 days later) » 

4:11 AM
When I try sudo dpkg-reconfigure openssh-server I get the message that openssh-server is broken or not fully installed, and when I try sudo apt-get install openssh-server I also get an error message from dpkg saying that a post-installation script subprocess returned error exit status 1
should I make a question that includes all of the output I recieve? I'm just not sure because there are a lot of questions about the topic but it's an issue that is getting pretty specific now
@jesse_b when i was a toddler my grandmother took me to the park with bread to feed the ducks but i ended up getting the crap pecked out of me by a hoard of swans
 
 
1 hour later…
5:40 AM
all of the error messages are from sshd, first one is "Bind to port 22 on :: failed: Address already in use."
then "Bind to port 22 on 0.0.0.0 failed: Address already in use"
then systemd terminates ssh.service and then sshd "fatal: Cannot bind any address"
 
6:18 AM
oh ok i think i have found it in the community called super user
ah super easy for some reason i had installed a package called "tinysshd" and this is why it wasnt even letting me install the openssh-server package, which automatically was installed when i removed tinysshd
 
6:44 AM
@FaheemMitha regarding going for the front end, no i am definately happy with the time spent working with the ssh tutorials they have up for Debian, its mainly for the sake of exploring everything counter intuitive for me, ie encryption, I mean its embarassing to be someone into prime numbers to find that counter intuitive, but it is what it is, you cant make that level of ridiculous up
 
7:05 AM
@AdamL You mean a front end for a firewall?
That's separate from ssh.
@AdamL What is/was the message?
@AdamL I hear swans can be very aggressive.
 
 
2 hours later…
8:39 AM
@FaheemMitha no ...
(I cross-graded.)
 
8:54 AM
@StephenKitt I don't know exactly what that is, but it sounds complicated.
 
@FaheemMitha not really, I had an i386 installation, and converted it in-place to an amd64 installation.
 
@FaheemMitha yup, I was about to post the same link!
 
I see there is a package called crossgrader now.
 
yes, that’s a recent addition
 
8:57 AM
That doesn't look too bad, actually.
So it went smoothly? In 2013, when I wanted to switch to AMD64, I opted to reinstall.
I don't know if that page was available then.
Revision history for that page says it was created in 2013.
 
@FaheemMitha yes, it went smoothly; this would have been September 2013 at the earliest (that’s when I switched from a 32-bit-only Pentium 4 to a 64-bit-capable Haswell Xeon).
(But I’m not a good guide to whether something is easy or not, in Debian at least.)
 
@StephenKitt You did the crossgrading in 2013?
@StephenKitt Because you don't know what others would find difficult?
 
@FaheemMitha at the earliest. Probably 2013 or 2014.
@FaheemMitha yes.
 
@StephenKitt Ok. I'm fairly sure my switch to AMD64 was 2013.
 
 
2 hours later…
11:07 AM
Ok, I'm not seeing the problem here.
faheem@orwell:/usr/local/src/mercurial-evolve/mercurial-evolve_10.1.0.orig/debian$ DEB_BUILD_OPTIONS="nocheck" debuild -us -uc
debuild: found debian/changelog for package mercurial-evolve in the directory
/usr/local/src/mercurial-evolve/mercurial-evolve_10.1.0.orig
but this directory name does not match the package name according to the
regex PACKAGE(-.+)?.
Maybe it's lack of sleep, but I don't understand what this is telling me.
 
 
1 hour later…
12:19 PM
@FaheemMitha examine the regex: dashes are allowed, not underscores
your directory should be named mercurial-evolve-10.1.0
 
12:38 PM
@StephenKitt Oh. Ok. But it's always worked before. What changed?
I have a similar structure in earlier directories, and they didn't get me an error message.
E.g. mercurial-evolve_10.0.1.orig.
Do I need to change the corresponding filename too, namely mercurial-evolve_10.1.0.orig.tar.gz?
 
@FaheemMitha nothing that I’m aware of, that’s been the regex as far as I can remember
@FaheemMitha no
 
@StephenKitt Hmm. That's weird. And that directory was created by the Evolve package. There's a script, invoked by make deb-prepare.
It's always worked before.
 
@FaheemMitha using debuild?
 
@StephenKitt Yes, I've been using debuild for a long time. Probably 10 years. Maybe longer.
And I just ran debuild successfully in a directory with an underscore. Here's the log.
The directory here is mercurial-evolve_10.1.1.dev.orig/.
 
I think the key is this: using existing ./mercurial-evolve_10.1.1.dev.orig.tar.gz
I suspect that in the failing case, you don’t have an orig tarball, do you?
the regex check happens when the build needs to create an orig tarball, IIRC
 
12:48 PM
@StephenKitt I should. The same script creates it. And I have one in my directory right now, unless it was created later. Which I don't think it was. Namely mercurial-evolve_10.1.0.orig.tar.gz.
 
OK, that’s weird then
I mean the error message says what it means, which is what I said above, but it’s strange that it worked for you in the past and stopped all of a sudden
 
Funny, I changed it back again and it works this time.
So, is the orig tarball created if it doesn't exist?
I think it is.
Presumably the debian files are stuffed into a corresponding diff.
 
@StephenKitt It's possible that it didn't create the tarball this time for some reason. Let me try again.
 
@FaheemMitha that doesn't actually say what cross-grading is :/
 
12:53 PM
@AndrasDeak I think one is supposed to infer from the context.
 
@AndrasDeak it does, but it’s not obvious: “These are the steps for converting an i386 install to amd64
 
Debian think its users are already experts in everything and just require the occasional reminder.
To assume they don't know everything would be considered extremely rude and ill-bred.
 
Debian welcomes contributions from users who have ideas on how it could be better — especially to the wiki.
 
@StephenKitt that's helpful when I already know that's what it is ;)
 
@AndrasDeak yes, which is why I said it’s not obvious.
 
12:54 PM
Fair enough :)
 
1:09 PM
@StephenKitt Funny, I did it again and didn't get an error.
Those gremlin bugs are the worst.
 
@FaheemMitha definitely!
 
@StephenKitt It seems discriminatory to only do that check if there is no orig tarball, though.
 
@FaheemMitha that’s the only circumstances in which I’ve seen it fail, but the code suggests it always checks (but then it would fail for you all the time if it did)
 
@StephenKitt It would, yes. Does policy say there should be a dash?
If so, I could submit a patch.
 
@FaheemMitha I don’t think policy cares about the name of the directory from which a build is started
 
1:14 PM
@StephenKitt Oh.
I'm trying to do
> find . -type f -name "*.tex" -exec sed -i 's/attachments = concat([corr, doc], ignore_index=True)/attachments = concat([corr, doc], ignore\
_index=True, sort=False)/g' {} +
following the impressively comprehensive unix.stackexchange.com/a/112024/4671
But no changes are made. Does sed want double quotes around the strings?
 
@FaheemMitha sed doesn’t care, it doesn’t see the quotes
 
Nope, that didn't work.
@StephenKitt I have that all on one line, so it's not newlines messing it up.
 
maybe some of the spaces are tabs in the original?
 
I meant like
find . -type f -name "*.tex" -exec sed -i 's/"attachments = concat([corr, doc], ignore_index=True)"/"attachments = concat([corr, doc], ign\
ore_index=True, sort=False)"/g' {} +
@JeffSchaller There are many such fun possibilities. Though I wrote that code myself. But something could have crept in with cutting and pasting.
Which might be the source of all evil.
 
try confirming with grep -F 'attachments....' some-text-file.tex
 
1:22 PM
@JeffSchaller Ok.
Does sed have an interactive mode?
 
14
Q: Any way to have a "verbose mode" or "debug mode" with sed?

don_crisstiIs there a way to make gnu sed be verbose about what is run and what is done ? I'd like to have something like a "debug mode" so that I can see - for each line of input - the content of the hold space and pattern space before and after the script is run etc.

 
grep -F "attachments = concat([corr, doc], ignore_index=True)"  *.tex
gives lots of hits.
Some other problem with the syntax, perhaps?
 
ah you need to escape the square brackets
 
@StephenKitt Thank you.
@StephenKitt That must be it. But doesn't putting everything in "" fix that, though?
 
ahhh, glossed right over that -- nicely spotted! and Today I Learned about sed --debug!
@FaheemMitha quoting is just to prevent unintentional shell interference; the brackets are regular expression characters to sed
 
1:26 PM
I tried the "" already.
@JeffSchaller Oh, I see. Ok, then.
 
91
Q: Why does my regular expression work in X but not in Y?

Gilles 'SO- stop being evil'I wrote a regular expression which works well in a certain program (grep, sed, awk, perl, python, ruby, ksh, bash, zsh, find, emacs, vi, vim, gedit, …). But when I use it in a different program (or on a different unix variant), it stops matching. Why?

 
So \\[ and \\] everywhere?
Oh, bollocks.
 
only in the search text
 
Is this any better if I switch to Perl?
@JeffSchaller Ok.
What about the replacement side?
 
@FaheemMitha no, it gets worse (or, if you're terdon, better -- depends on whether you like more escape characters or not)
 
1:28 PM
@JeffSchaller Good to know.
 
1 min ago, by Jeff Schaller
only in the search text
 
@JeffSchaller Ok. Right, that worked. Thank you for the assistance, @StephenKitt and @JeffSchaller. It could have taken me a while to figure that out.
 
1:41 PM
So how do I write a backslash followed by a left (or right) square bracket?
One backslash disappears. Two display as two.
 
Sounds like it’s time to ask a question
 
@FaheemMitha two backslashes without code markdown work I think: \[
 
 
1 hour later…
3:09 PM
@AdamL my grandfather had geese on his farm when I was younger and you learn quickly that they will leave you alone after a swift boot to the chest
 
Probably less effective if you're a kid and they're swans, so weigh more than you do!
 
@terdon I was a toddler and about a foot shorter than the geese when my grandfather taught me that
 
3:31 PM
Fair enough
 
@AndrasDeak So \[ ?
But \\[ doesn't work.
 
I learned it while walking home from a night out on campus, and needing to navigate swarms of enraged geese in a state far removed from sobriety.
 
What about \[?
Ah, that works too.
Swans are more troublesome, I hear.
My personal experience with both geese and swans is very limited.
On a related topic, I hear peacocks are quite noisy.
 
we have swans at our huge lake, and they do get confrontative if you approach them on land or if you're in the water and their chicks are near
our as in Lake Balaton
 
@FaheemMitha My grandfather had peacocks as well, I don't remember them being overly noisy although they definitely make noise
 
3:46 PM
@jesse_b IME they’re less noisy than geese ;-)
 
@StephenKitt Yeah we had turkeys, geese, ducks, chickens, peacocks, and cows. Lots of stuff making noise
He had one goose that he got from a petting zoo and it would follow you around like a dog except it hated my grandmother. She never had the heart to kick them (which you generally only ever have to do once for them to learn who is boss) so it would pretty aggressively attack her so much that she kept a broom on the front porch dedicated to shooing this goose away when she would walk to her car
 
4:05 PM
 
@jesse_b hah, a farmer once told me people need to be careful when stroking cows, because they sometimes like it so much they’ll lie down on top of whoever is stroking them
there’s the opposite problem too when stroking a cow lying down, sometimes they’ll suddenly get up
so you can choose whether to be squashed or knocked out
 
I mostly only ever touched them through the fence, if there is not a fence between you and them it's best to give them their distance
 
indeed
 
we did have one cow that would let me ride it though
 
I’m always more awed by horses than by cows, horses tend to be quite a bit higher, and their heads are huge
bulls are another story of course
and some cows can be mean
 
4:11 PM
Horses are known for being intelligent but cows are pretty intelligent as well. The biggest thing I remember is that the bulls were particularly aggressive around the females and children. You could approach a bull on it's own without much issue, or a group of cows, but if the bull was with the cows it would become defensive over them
 
4:24 PM
Being the aboriginal urban kid that I am I was 17 when I first saw a horse from up close. It was huge. I mean, it was as large as a horse.
 
The town I grew up in as a child would have a saint patricks day parade every year and budweiser would always bring cyldsedale horses which are obnoxiously big even compared to other horses I've seen
 
So for St. Patrick's day, a traditional Irish feast, you had American beer and Scottish horses?
 
@terdon In america st patricks day is just an excuse for everyone to get drunk and vomit all over my town while simultaneously littering everywhere
 
@terdon for some value of “beer”
 
4:45 PM
@jesse_b Yes, which is why I was surprised at the non-Irish beer and equines. You seem to have kept the spirit and traditional nature of the thing intact apart from that!
@StephenKitt I... didn't want to get into that :)
 
@terdon oh, definitely, I wouldn’t want to get into American “beer” either
at least there are now quite a few decent microbreweries in the US
 
psh. Microbreweries are so annoying
Nobody wants to try your 30 different flavors of IPA. No matter how much cranberry nut crunch you add to it, it still tastes like eating a handful of rotten hops
PULL UP YOUR PANTS
 
IPA? urgh
give me smoky ale any day
or a nice triple or quad
 
I've found that most microbreweries specialize in IPAs and in a lot of cases have nothing else
And they usually only sell their own beer so they alienate people that don't like crappy beer
 
ha ha yes
at one of the conferences I used to go to we had a beer club where people brought their favourite beers from around the world
there were usually quite a few non-IPA US beers that were quite quaffable
but everyone knew we had rather high standards
 
4:55 PM
I usually only drink whisky. Beer has too much variation for me, if I am to drink beer I almost only get either heineken or stella artois
 
@StephenKitt IPA, mmmmmmmmmm, tasty!
 
@jesse_b smoky ale is basically ale that tastes of whisky ;-)
 
I found a nice "dessert" drink a few years ago -- an apple pie whiskey
probably blasphemous to anyone that likes whiskey, but that's taste for ya
 
@jesse_b Whisky has LOADS of variation!
Even if you just stay within Scotland.
 
well except for glenmorange I've yet to find one that I don't like. It's easy for me to find beer that I don't like
 
5:07 PM
glenmorange? Which one? Their nectar d'or is a favorite of mine. Glenfiddich I can't stand: overpriced, low quality.
 
the one that tastes like oranges and trash
:)
 
my favourite is Tobermory, although I haven’t tasted their new batches since the distillery re-opened
 
Ooh, I haven't tried that one. I know the Islays relatively well. Haven't really delved into the mainland ones.
And Tobermory's from the Isle of Mull, not the mainland. Damn! I'll have to check it out.
 
I quite like Laphroaig, Lagavullin (on the more peaty side), Aberlour ...
 
Yeesssshhhh whiskysssss precioussss issssslaysssss
 
5:11 PM
heh heh
one day I want to visit my patch on Islay
 
I've moved away from the heavy hitters like Laphroaig in recent years and have been more drawn to the less heavily peated Caol Isla and Bowmore.
@StephenKitt your what now?
 
ah yes, Bowmore is good too
@terdon buying a bottle of Laphroaig gives you a lifetime lease on a square foot of Islay
 
@terdon Lord Stephen Kitt
 
if you visit the distillery, they’ll lend you a pair of boots and give you a dram to drink on your patch
 
@StephenKitt Whaaaa? Then I have a few too!
I've been wanting to do a tour of Islay for years.
 
 
1 hour later…
6:42 PM
@AndrasDeak aboriginal?
BTW, that looks like a big lake. Can you go boating on it?
600 sq km. That's big.
 
6:57 PM
This line adds a comment at the end of a line. But I only want it added if the comment isn't obviously there (obviously).
find . -type f -name "*.tex" -exec sed -i 's/\\AfterEndDocument{\\immediate\\write18{pythontex \\jobname.tex}}/% \\AfterEndDocument{\\imme\
diate\\write18{pythontex \\jobname.tex}}/g' {} +
Is it worth asking a question about such a trivial thing?
 
@FaheemMitha I couldn't come up with a better word. Endemic? Something like that.
@FaheemMitha people can; I get seasick very fast :P
 
@AndrasDeak Endemic? What are you trying to say?
 
there are annual swimming competitions (across the short side) and sailing competitions (across the long side)
 
@AndrasDeak On a lake?
@AndrasDeak Well, as long as the water is clean.
 
@FaheemMitha I was hoping that context made it clear. 100% city boy, things like that
@FaheemMitha yup, on anything that's faster than a canoe. Maybe even on a canoe; I've never been canoeing.
 
7:01 PM
I like the idea of boating. But my experience of boating is super-limited.
 
@FaheemMitha it is, usually.
 
@AndrasDeak Then neither of the words you used are correct. Look them up.
 
I actually looked up endemic and first meaning is "Native to a particular area or culture; originating where it occurs." which seemed good enough for me
 
@AndrasDeak Well, it's clear you're not a native speaker. :-)
It basically means commonly occurring. It's usually used in a non-human context.
So for germs, plants, animals. That sort of thing.
 
To be honest I just wanted to colloquially express what I meant, and I didn't anticipate a linguistic thesis defense. Now that we've clearified what I meant I'm happy :P
 
7:48 PM
"We're not happy until you're not happy!" --Despair.com
 
oh no, now we'll debate if I meant "content" instead of "happy" :P
 
8:06 PM
when you say debate, do you mean ...
:)
 
Is this a 5-minute argument or the full half hour?
 
Treatment usually works in 7 days, but in some cases takes a full week.
 

« first day (3761 days earlier)      last day (35 days later) »