« first day (3471 days earlier)      last day (45 days later) » 
00:00 - 14:0014:00 - 22:00

12:03 AM
@Kusalananda I'll assume that you are mounting your shares with `bg,intr,soft`
https://unix.stackexchange.com/questions/31979/stop-broken-nfs-mounts-from-locking-a-directory

Otherwise, NFS will block.
 
 
6 hours later…
6:15 AM
@Isaac (just checking these now), I'm using the equivalent of bg,soft (-b and -s with OpenBSD mount_nfs). I don't need my mounts to be interruptible, really.
 
6:33 AM
@duhaime These issues shouldn't happen in a properly functioning system. It's normally a sign you are mixing sources. So if you want to ask a question on the site, list your sources. apt-cache policy will do. Alternatively, showing your /etc/apt/sources.list + any files on /etc/apt/sources.list.d would work.
Or you could ask on AU, of course.
Where I said "any files" above, I should have written "all files".
 
6:50 AM
Also, @Isaac, good modification of your answer there. +1
 
7:04 AM
what is the code called that is used in this if condition?
if [ "`id -u`" -eq 0 ]; then

complain "The Tor Browser Bundle should not be run as root. Exiting."

exit 1

fi
the content of the [] brackets I mean
 
7:25 AM
@AdamL a test?
A test on the output of the id -u command.
 
ah ok gotcha thanks so it's just a matter of me looking at man id
 
@AdamL Yes. The test is for checking the user ID of the current user. If it's zero, then the current user is root.
The intent is to not allow the root user to run the Tor browser. This seems sane to me. One should not run browsers in general as root, or do any non-sysadmin task as root.
 
so an external call has to be enclosed in "``" and -eq is the relation operator what others can be used? -neq? I don't get how the 0 can be entered I would have thought you have to declare what variable type you are writing the if condition to test
yeah no my question is not context based I already knew about me being vulnerable if I run any non system task as root
 
8:16 AM
@AdamL Enclosing a command in backticks, or better in $(...) (which is preferred over the antiquated backticks) will replace that bit with the output of the given command. It is a "command substitution".
The -eq is a test operator that tests for integer equality. -ne would be for integer inequality. See man test or help test in bash.
 
In my never-ending quest to understand what constitutes “not an answer”, I’m curious about this answer. I flagged it as NAA, and my flag was marked helpful, but the question wasn’t deleted; I understand that as meaning that the answer is enough of NAA for my flag not to be rejected, but not enough of NAA to be deleted — what’s the distinction?
(Perhaps that should be a Meta Q.)
 
@StephenKitt Yeah, this bugs me too actually. I think @terdon and the others have a better grasp of it than I do. The answer that you link to is definitely an "answer", but it may miss the point. I did not act on your flag, as far as I can remember.
 
@MichaelHomer ah, that explains it!
 
@StephenKitt Thank you again for your help last night/this morning. I belatedly realised that locally amending a cset probably creates a problem with pushing to remote, assuming Git doesn't keep track of the relationship between the original cset and the modified cset. And it probably doesn't. Though I still don't understand how the resolution for this works.
 
8:21 AM
In general, I wish flagging was accompanied by commenting.
 
I mean, how Git handles this issue.
 
@Kusalananda but the question is “How to figure out cause of high kernel/kworker CPU usage?”, and the answer merely repeats that the answerer is seeing high kworker usage, without explaining its cause or how to find it...
 
@Kusalananda No comment box?
 
@Kusalananda yes, I sometimes leave a comment on the answer before flagging it, to explain why it’s NAA
 
@FaheemMitha There is a comment box beneath all answers.
 
8:22 AM
It's not an answer at all, it was just also badly formatted
 
@Kusalananda I meant, when flagging.
 
@MichaelHomer This particular one has been flagged NAA three times.
@FaheemMitha There's still that comment box below the answer though.
 
@Kusalananda Sure.
 
I guess they don't accumulate then
It is deletion-eligible now anyway
 
Flagging is for bringing the answer to the attention of mods and reviewers. If acomment can make the user aware of what's wrong, that would definitely be better than them suddenly having their answer deleted.
 
8:24 AM
@MichaelHomer yes, that’s something I also generally do for deletion-eligible NAA answers — flag them as NAA so they go to the LQP queue, and vote to delete
 
(NAA-flagged answers also end up in the mod review queue)
 
@Kusalananda answers usually get at least one of the canned comments from the LQP queue, but I guess that’s not really all that helpful
 
Only at the point when someone else reacts to the flag.
 
@Kusalananda right, so it’s a race between LQP reviewers and mods ;-)
 
The idea that people are going to write comments saying an answer is irredeemable and that those comments are going to be well-received seems fanciful at best
 
8:26 AM
@Kusalananda yes, I’ve often wished we could add LQP comments to answers when flagging NAA
 
You end up with enough pointless arguments directed at you just by using the site normally without going out of your way to invite it
 
Depends on formulations.
@MichaelHomer As Stephen said, he sometimes leaves a comment before flagging. I think that's ideal. Then just leave it. The comment additionally serves as a help for any reviewer.
 
That's a systemic issue that the system should address, rather than insisting on resolving it through still more unpaid emotional labour of volunteers
 
One of the big problems is that new users have very limited options to interact with posts, other than leaving answers — they can’t even upvote!
 
There's no reason at all the system couldn't provide active feedback to authors when their post is flagged, so that they aren't just surprised by its being deleted, but a deliberate choice has been made not to
 
8:31 AM
I did sudo apt autoremove and it removed linux-modules-extra-4.4.0-176 which resulted in low resolution display with no support for network. I have manually fixed this by re installing the package. Any idea how/why apt removed a required package?
 
That, and the fact that on many forums, you add a post to a thread to signal your interest (and sometimes, even to be able to be notified on updates to the thread).
@Pandya technically, because it ended up being marked as automatically installed, and nothing else depended on it
but that doesn’t explain why it ended up in that situation
 
The reason I don't post on the site any more is that it's treated as an invitation for some belligerent asshole with more confidence than competence to insist on endless inane arguments that ping me incessantly
 
@StephenKitt Yes, I am also surprised to find that it broken some driver functionality.
Presently apt says:
> The following packages were automatically installed and are no longer required:
linux-headers-4.4.0-173 linux-headers-4.4.0-173-generic linux-image-unsigned-4.4.0-173-generic
linux-modules-4.4.0-173-generic linux-modules-extra-4.4.0-173-generic
But I am afraid of executing autoremove agian
Should I blame the repository maintainer? (e.g Trisquel)
It happened to me second time. Earlier Trisquel upgraded network-manager package from its backport repository and my ethernet stopped working. Since then I never active backport repository.
 
@Pandya that looks fine, it means it wants to remove a kernel you’re no longer using
 
@Pandya What distribution is this? And where is this package from?
@Pandya And how are you doing? Still in India, right?
 
8:42 AM
@FaheemMitha Trisquel, and the package is part of the standard kernel packages
 
@StephenKitt Oh. Not familiar with that one.
Oh, another Debian derivative.
@Pandya Check and see if the apt logs still have the record of installation. Though I think they get removed after a while. I can't remember what the period is.
 
@StephenKitt ok.
@FaheemMitha Yes. I am fine. How are you? :)
 
@StephenKitt I deleted it. As Michael explained, it looks like the edit kicked it out of the queue.
I try to leave comments explaining why when I delete though. For precisely the reasons discussed.
 
@Pandya Ok. Kind of stressed. Bombay is officially a hotspot. We've got some of the highest rates of infection in India.
 
> Hi and welcome to the site. Please take a moment to visit our help center or take the tour to understand how this site works. This is not a forum, and we don't do discussion, only strict questions & answers. So please only post an answer if it is actually answering the question asked.
 
8:53 AM
@terdon right, I’ve seen you use that a few times ;-).
 
Which reminds me. I really should add that to my stock comments. I keep re-writing it each time.
 
@FaheemMitha Yes, Let's hope we will survive through this pandemic.
Btw, I forgot where are you from?
@terdon Sounds good. I links How to Answer also sometimes
 
Ah yes, good point.
 
9:08 AM
@Pandya From Bombay. :-)
There is now talk about extending the lockdown. Where are you now?
 
9:21 AM
@FaheemMitha Gujarat.
@FaheemMitha Yes, I think there are chances of development of scarcity of some essentials things.
 
@Pandya Where in Gujarat? Not far from me, then? I somehow had the impression that you were further north.
@Pandya The world isn't actually ending. But it's not good, either.
It's an unpleasant reminder of how fragile our human "civilization" is, that an unremarkable virus can wreak such havoc.
 
@FaheemMitha Yes, I used to be in Saurashtra but presently I am in Anand.
 
10:11 AM
@Pandya How are things looking there?
 
@terdon good +1
 
@FaheemMitha the graphical install of Debian seems to be going smoothly on my laptop, however it did notify me that non-free firmware files are missing that some of my hardware need to operate, and lists these filenames saying that I can supply them on removable media
 
10:26 AM
@terdon Huh, select ignores SIGINT...
 
@FaheemMitha Moderate. Since 3 positive cases are deleted in the city in last two days. Actually Ahmedabad is hotspot in Gujarat.
 
@AdamL I think official media exist which include non-free firmware. You might want to look into those. Though I forget the context. Were you trying to install Debian on something?
@Pandya We've got hundreds of cases here. Including some practically on our doorstep.
This city is not a good place to be right now.
@AdamL Oh, was it you trying to install Debian on a laptop which you had successfully installed Ubuntu on before? HP? Or maybe Dell Inspiron?
@Pandya Coming up to a thousand cases for Bombay.
 
10:44 AM
@FaheemMitha Oh. Take care
 
@Pandya We're trying.
 
@FaheemMitha Yes, I know Most of cases reported in Mahabharata are from Bombay only.
 
@Pandya Maharashtra. Large State.
Also Pune. But Bombay seems to be pulling ahead.
 
@FaheemMitha no one have reliable answer when this pandemic will end. :(
 
@Faheem Mitha I added the output of apt-cache policy to my question: unix.stackexchange.com/questions/579070/…
any ideas?
 
10:47 AM
No, it looks like Bombay is way ahead of everything else in the state. Cases here are more than most Indian states. Not surprising, but not comforting, either.
@duhaime You should also add that error message you reported in chat earlier. I don't see it there. That's quite important.
 
those ppa.launchpad.net values seem like outliers
 
> Error while unmounting /dev/covid_19. This device can't be unmounted at present. Try after couple of months!
 
@duhaime Adding random PPAs is a good way to create problems. I'm not clear why you need them. Perhaps explain that in the question too.
Your distribution should have NVIDIA stuff, surely.
 
well my situation was that I couldn't uninstall my last nvidia driver. Now I've uninstalled it, but running nvidia-smi results in NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
I'd like to remove those ppas
 
@duhaime Oh.
 
10:50 AM
is there a way to see all installed packages that come from those ppas? so I can start to clean up the mess I've made?
 
@duhaime You could first uncomment those lines in your sources. Then run apt-get update. Then remove the packages from your system (if any) that were installed from the PPA.
 
how can I learn which packages in the system come from the ppa?
 
@duhaime I don't know the answer to that off the top of my head.
 
no worries
 
There might be. That would actually be a reasonable question, in itself. Though someone has probably already asked it.
 
10:52 AM
when you say uncomment those lines, you mean I'd uncomment /etc/apt/sources.list?
 
@duhaime The relevant lines inside sources.list, yes.
 
@Kusalananda Yeah, I saw your edit (thanks), that's odd isn't it?
 
Also check if you have anything under sources.list.d/.
 
I guess this little beauty finds all packages installed by ppa: `apt-cache policy $(dpkg --get-selections | grep -v deinstall$ | awk '{ print $1 }') | perl -e '@a = <>; $a=join("", @a); $a =~ s/\n(\S)/\n\n$1/g; @packages = split("\n\n", $a); foreach $p (@packages) {print "$1: $2\n" if $p =~ /^(.*?):.*?500 http:\/\/ppa\.launchpad\.net\/(.*?)\s/s}'
`
 
@duhaime Eek.
I was thinking something which could list all packages installed that come from a particular source. That would probably not be hard to program using the apt API, though I don't know to do that either.
 
10:58 AM
@duhaime That seems needlessly complicated. Try this instead:
apt-cache policy $(dpkg --get-selections | grep -v deinstall$ | awk '{ print $1 }') | perl -lne 'if (/^(\S+):/){$name=$1}elsif(m|//ppa\.launchpad|){print $name}'
 
hmm that seems to list the names but not their ppas?
 
More than complicated, I don't think yours will work. There are no consecutive \n\n characters in the output.
 
my soul is dying
here's a question: how can I remove a ppa I want to remove?
 
@duhaime Oh, you want the ppas as well? one sec
 
I've got these two:

```
500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main i386 Packages
release v=18.04,o=LP-PPA-graphics-drivers,a=bionic,n=bionic,l=Proprietary GPU Drivers,c=main,b=i386
origin ppa.launchpad.net
500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main amd64 Packages
release v=18.04,o=LP-PPA-graphics-drivers,a=bionic,n=bionic,l=Proprietary GPU Drivers,c=main,b=amd64
origin ppa.launchpad.net
```
I'd like to remove them
but sudo ppa-purge http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu didn't work
neither did sudo add-apt-repository --remove ppa.launchpad.net/ppa
 
11:01 AM
apt-cache policy $(dpkg --get-selections | grep -v deinstall$ | awk '{ print $1 }') | perl -lne 'if (/^(\S+):/){$name=$1}elsif(m|//ppa\.launchpad|){print "$name: $_"}'
@duhaime What's the output of this?
grep -R ppa /etc/apt/sources.list*
 
dhlab@threadripper:~$ grep -R ppa /etc/apt/sources.list*
/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-bionic.list.save:deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-bionic.list.save:# deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-bionic.list.save:# deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
/etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-bionic.list.save:# deb-src http://ppa.launchpad.net/graphics-d
 
Just rename or delete the files:
sudo mv /etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-bionic.list /etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-bionic.list.bak
 
ah solid
 
Then run sudo apt update
 
@FaheemMitha that's correct HP pavilion sleekbook 2012
 
11:04 AM
Are you sure you want to remove those though? Those should be the standard way of getting the nvidia drivers on Ubuntu.
Why do you want to remove them?
15 mins ago, by duhaime
well my situation was that I couldn't uninstall my last nvidia driver. Now I've uninstalled it, but running nvidia-smi results in NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
 
yes, that's my goal
 
If you've removed the nvidia driver, you can't use nvidia smi. Removing the ppas won't make a difference.
 
I'm not sure I do want to remove them
so here's my situation
I believe there's now an nvidia-driver installed. I'd like a bulletproof way to verify
 
@duhaime inxi -G
 
the only way I know to verify is by trying to install another driver from one of nvidia's driver installers (a .run file), which will bark if there's a driver already installed
 
11:06 AM
Add the output to your question, by the way. That will be very helpful.
 
@FaheemMitha yeah well I am only missing two firmware files, I will look on their homepage for how I can buy them
 
I should run that and post the output in my question?
 
@duhaime Yep. You might need to install it first, but it's a really useful little tool.
You can also check if you are currently using nvidia with:
lsmod | grep nvidia
 
@terdon mosvy think it's a bug (unix.stackexchange.com/a/513498/116858)
 
awesome, thanks very much for your help, I'll update my question
 
11:09 AM
@terdon His drivers might be installed from some random PPA. I don't know the details, but that is/was where we were at. Though to be honest, I was not paying much attention.
@AdamL You wouldn't need to buy. You could just download them from wherever. Possibly the non-free section.
 
@FaheemMitha Not random, the official NVIDIA ppa.
 
@terdon There's an official NVIDIA PPA? How can a PPA be official? It's an add-on.
 
Perhaps the question would be better on AU, if it's very Ubuntu-specific.
 
@terdon all three ppa commands worked for me (on Kubuntu 18.04) including the first one. Its output was quite decent.
 
11:12 AM
@FaheemMitha Many are official.
 
you think so? It's already migrated from stackoverflow
I'm putting the max bounty on this thing as soon as I can
 
@DKBose really? You had consecutive newlines in the output? I don't see that on my systems.
 
I have two titan RTX chips that should be in use right now
 
@duhaime Yes. This sort of thing is usually better on Ask Ubuntu. But it's OK, you've asked here.
This should be helpful though:
244
A: How do I install the Nvidia drivers?

Luis AlvaradoUpdated - January 25, 2020 1. The quick way Before adding this PPA, please read the PPA's Description on their page which mentions important information about using it, which version is right for your Nvidia card and more. This is for desktop users who want the latest version of the driver or t...

But yes, ppas are very standard in the Ubuntu world. Quite a few are officially maintained by the devs of the relevant projects.
 
@terdon, here's a little of the output:
boot-repair: yannubuntu/boot-repair/ubuntu
boot-sav: yannubuntu/boot-repair/ubuntu
boot-sav-extra: yannubuntu/boot-repair/ubuntu
dus: mkusb/ppa/ubuntu
fonts-opensymbol: libreoffice/ppa/ubuntu
glade2script: yannubuntu/boot-repair/ubuntu
guidus: mkusb/ppa/ubuntu
libjuh-java: libreoffice/ppa/ubuntu
libjurt-java: libreoffice/ppa/ubuntu
libreoffice-base-core: libreoffice/ppa/ubuntu
li
 
11:14 AM
thank you. To make sure, is it possible to verify from what I've posted that there are no nvidia drivers currently installed?
 
@DKBose Of the first one?
 
@terdon, yes, of the one posted by duhaime.
 
@DKBose Oh, I see. Yes, it adds the \n\n. OK. Still pointlessly complicated though
@duhaime your output shows you're not using the nvidia driver. Which explains why the nvidia commands aren't working for you.
Presumably you want to use nvidia though, right?
 
definetly
 
@Kusalananda He's probably right. He knows this sort of thing.
 
11:18 AM
should I sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt install nvidia-driver-440?
 
@duhaime Just rename the file. add-apt-repository isn't anything complex, it just copies the files.
But don't just do this blindly
Follow one of the many, many guides on adding nvidia drivers to Ubuntu
 
the thing is, at this point I have read many
 
You might need to remove the open source ones and/or blacklist them. Have a look at the answer I posted above.
 
like 200+ yesterday and today
sorry what should I look at?
 
Heh. OK. Well, Luis's (the one I linked to) should be good and recently updated.
8 mins ago, by terdon
244
A: How do I install the Nvidia drivers?

Luis AlvaradoUpdated - January 25, 2020 1. The quick way Before adding this PPA, please read the PPA's Description on their page which mentions important information about using it, which version is right for your Nvidia card and more. This is for desktop users who want the latest version of the driver or t...

 
11:21 AM
yes it's enormously thorough, thanks very much
I mean my command sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt install nvidia-driver-440 is just what he leads with
 
True, true. Go for it.
 
word
so here's a question
after running just the add-apt-repository line, I get this in the bottom of my output:

```
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:50 and /etc/apt/sources.list.d/cuda.list:1
W: Target Translations (en_US) is configured multiple times in /etc/apt/sources.list:50 and /etc/apt/sources.list.d/cuda.list:1
W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:50 and /etc/apt/sources.list.d/cuda.list:1
W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:50 and /etc/apt/sources.list.d/cuda.list:1
do you know why that is or if that's a problem or clue to what's going on?
(I've configured these drivers lots of times before but have never had any trouble like this)
 
Those are warnings, you can ignore them. They mean that you have duplicate repositories. Specifically, line 50 in /etc/apt/sources.list is the same as line 1 in /etc/apt/sources.list.d/cuda.list.
You've probably added whatever repository holds the cuda stuff to sources.list and then also ran a command that adds the repository as a separate file in sources.list.d
 
I'll just clean them up really quickly as other poor souls will use this machine too
k done
alright, I ran sudo apt install nvidia-driver-440 as per the linked thread, then rebooted, then ssh'd back in and nvidia-smi still returns NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
 
@duhaime inxi -G output now?
 
11:31 AM
that returns:

```
Graphics: Card-1: NVIDIA Device 1e02
Card-2: NVIDIA Device 1e02
Display Server: N/A drivers: fbdev,nouveau (unloaded: modesetting,vesa)
tty size: 128x11 Advanced Data: N/A out of X
```
 
yep, you're not using it
 
haha confirmed
do you have any notions as to things I could try to get more information on what's going on?
 
Back in the day, you had to blacklist the nouveau driver and configure the xorg.conf file to use nvidia instead. Dunno if that's still the case.
@duhaime I'd suggest asking a question, but explain that you've run the apt install command and see the same output in inxi -G.
Or, hang on. What do you have in /etc/X11?
 
hmm I have:
app-defaults  default-display-manager  rgb.txt	xkb	Xreset.d    Xsession	Xsession.options  XvMCConfig
cursors       fonts		       xinit	Xreset	Xresources  Xsession.d	xsm		  Xwrapper.config
out of curiosity, what should I have seen in the response from inxi -G?
 
 $ inxi -G
Graphics:
  Device-1: Intel HD Graphics 530 driver: i915 v: kernel
  Device-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 440.64
  Display: x11 server: X.Org 1.20.7 driver: nvidia
  resolution: 2560x1440~60Hz, 1920x1080~60Hz, 1920x1080~60Hz
  OpenGL: renderer: llvmpipe (LLVM 9.0.1 256 bits) v: 3.3 Mesa 19.3.4
driver: nvidia
 
11:36 AM
@terdon Strange. Why isn't the driver (whatever it is), in the main repository?
 
@FaheemMitha Presumably because it's maintained by nvidia or the community and has the newer versions.
 
hmm why isn't intel listed for me? is that a problem? I feel X used to be handled by intel
 
@duhaime This is on my laptop. I have two graphics cards, nvidia and intel, so each has its own driver.
 
also why is my display server showing n/a?
ya for sure
 
@duhaime Presumably because this is a headless machine that isn't running a GUI
 
11:38 AM
haha, this seems a clue
the machine should have a gui
but I've clearly smashed it
 
Yeah, it's probably relevant, but I don't see why you would need a GUI necessarily. Maybe you do, maybe you don't.
@duhaime Oh, it should?
 
it's remote from me, but it used to have a gui
 
OK
 
yes indeed, it used to serve X so you could sit in front of it and log in and see the screen etc
also the graphics cards on my host are showing up as totally generic NVIDIA Device 1e02 instead of specifix RTX chips
 
I wonder if this is down to using wayland instead of Xorg. OK, look, this really is better asked on Ask Ubuntu where folks are much more familiar with the Ubuntu internals. I suggest deleting your question here, posting it again on Ask Ubuntu, but explain that i) you have run these commands (apt install etc), ii) your GUI doesn't seem to be working and iii) inxi -G is reporting that you're still using the nouveau driver instead of nvidia.
@duhaime That will probably be fixed by the nvidia driver.
 
11:40 AM
I see
for my own edification, what is the nouveau driver?
 
@duhaime The open source driver for nvidia cards, which is maintained by the comunity as opposed to "nvidia" which is the proprietary driver developed and maintained by nvidia itself.
 
I think I'm just going to take up farming and leave all this behind
2
Your comments have been super helpful, thank you
 
You're welcome.
You might also want to check out the Arch wiki on this. As a general rule, the Arch wiki is one of the best resources out there, no matter what distro you're running.
 
11:58 AM
alright I moved the question to askubuntu.com/questions/1225886/…
if you have any thoughts of things I could try, I'd be super grateful!
a quick follow up: askubuntu.com/questions/927199/… suggests that prime-select query should return at least nvidia and intel (as I thought). But on my machine I only get nvidia. Is that a clue
 
Tim
The chat has been helpful
good good day!
 
@duhaime Would you actually prefer to use the Intel graphics chip? And did you use it before?
@terdon I'm not familiar with these details, but ideally a question would include that context.
@duhaime If you are asking questions about the Nvidia drivers, it would be helpful to explain why you need to use a PPA rather than something from the distribution itself. And make sure the PPA drivers match your distribution version, obviously.
 
12:23 PM
ah sorry I'm just seeing this. I don't need to use a PPA! I'm just trying to get this sorted and have been trying what others have recommended
my linux foo is very weak
I believe before the intel graphics chip was used for the graphical interface yes. The nvidia chips are just for computing
(machine learning)
if you have ideas on what I could try @FaheemMitha I'm totally all ears
 
@duhaime Ok, so you would like to use the Intel chip if possible? And you say you did so before, without problems?
Note that generally Intel drivers are less problematic than Nvidia, because Intel supports free drivers. Often they are in the kernel.
 
sure, I'm happy to use intel for the graphics
I only need nvidia chips for computing
they don't have to serve the graphical interface
 
@duhaime Ok. Well then, you could post a question about that. Do you happen to know what the chip is?
 
really this machine is miles away and noone will interact with an interface for weeks or months, but I'd like to get the nvidia chips "online" and ready for action swiftly
 
And what driver it used?
 
12:28 PM
the intel chip?
I don't know. Is there a way to query it?
 
@duhaime Yes. I'm confused. You don't have this machine with you?
@duhaime There a bunch of things you can try. A plain lspci will often work.
 
no, this machine is miles away, I can only ssh to it
 
@duhaime Doing maintenance on a machine that you don't have available is tricky.
 
okay lspci returns:

```
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) I/O Memory Management Unit
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge
00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge
 
So you want to Intel card for X? But not for yourself?
Are you trying to run X over ssh?
 
12:31 PM
hmm what do you mean for myself?
no
just trying to set it up so that once we're back in the physical space users can run X
truth is I won't need it for months
my main goal is to configure the nvidia driver so I can run some tensorflow code
I'll know that's sorted when I can run nvidia-smi and get the status of the two Titan RTX chips that are connected to the machine
 
I see your NVIDIA card:
0a:00.0 VGA compatible controller: NVIDIA Corporation Device 1e02 (rev a1)
 
@FaheemMitha there really isn't. PPAs aren't some weird edge things, they are an integral part of the Ubuntu world and this ppa is the standard way of adding the drivers.
 
yes, there should be two of those
 
@duhaime I doubt it. Not unless you know you have dual graphics and have used nvidia prime
 
@terdon Oh. Very different from Debian then.
 
12:34 PM
@FaheemMitha Yes.
 
Tim
@duhaime are you running deep learning on GPU?
 
I'm positive there are two TItan RTX chips with an nvlink on that device
yes
I'm running deep learning on the gpu
 
@duhaime You could also try dmidecode. See man dmidecode.
 
Tim
maybe other people running similar algorithms on GPU have the same problem. How did they solve the problem?
try datascience.stackexchange.com
 
Alternatively, you could do a search for things to try - e.g. cyberciti.biz/faq/linux-tell-which-graphics-vga-card-installed
 
Tim
12:36 PM
or still stackoverflow.com, tagged with deeplearning, tensorflow
 
I've read hundreds of links. This issue occurs frequently and is quite system specific
 
@duhaime yeah, there's there in your lspci output
 
@Tim That would be off-topic there.
 
I originally asked my question on SO. They asked me to move it to Linux & Unix. They in turn asked me to move it to Ask Ubuntu...
it's kind of a cross-disciplinary question I guess
 
Yes, please don't use SO or datascience for this. AU is the best place for it, or here.
 
12:36 PM
I think so too
 
Tim
Was your original question on SO tagged with tensorflow?
 
no because this doesn't have much to do with tensorflow per se
 
No, and it shouldn't be, this isn't about tensorflow but about installing the right driver.
 
Tim
Yes, it is. It is part of installation of tensorflow
 
tensorflow sits on top of the nvidia drivers (optionally), or can just run on cpu cores
no it's not
tensorflow has no real connection to this
 
Tim
12:38 PM
I am telling you that a lot of your collegues have solved the problem, you have to find a way to reach out to them
 
I happen to wish to run tensorflow downstream but one can run tensorflow with no gpu
ya, I hear that
 
@Tim please don't confuse matters. Installing tensorflow is a much later step.
 
you're both right. The tf community is vast, and many of them happen to use nvidia chips
 
The issue duhaime is facing is getting the nvidia chips to work with the nvidia driver.
 
but really this question is prior to tensorflow
yes, I think you're both right but terdon is more right :)
that said, I'm happy if a tensorflow user or shaman or whomever can offer insight here
 
12:40 PM
Hmm, dmidecode doesn't look particularly useful for finding video chips.
 
I'd be happy to pay someone for help if that expedites matters
 
@duhaime if you don't get an answer in a couple of days or so on AU, ping me and I can offer a bounty for you.
 
well thank you
I'll offer all my rep too
 
Tim
I wish I can convert my reps into dollars
 
I just feel bad because I totally botched this setup and I want to set it aright for the others in my research lab
 
Tim
12:41 PM
1 rep 1 dollar
 
@duhaime Try lshw -class display if you haven't already.
@duhaime Oh, you're at Yale? How are you folks doing? I hear much of New England is in lockdown right now.
 
ya we're totally locked down. We've been working from home for a month!
okay `lshw -class display` returns:

```
*-display UNCLAIMED
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:0a:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: iomemory:480-47f iomemory:480-47f memory:ba000000-baffffff memory:4820000000-482fffffff memory:4830000000-4831ffffff ioport:2000(size=128) memory:bb000000-bb07ffff
*-display UNCLAIMED
(I ran that as sudo)
 
Tim
So I don't have to worry about food and shelter
 
thinking more about the machine, I'm not positive intel was being used before. The graphics may in fact have been driven by nvidia
 
@duhaime Ok, so maybe that's a red herring.
 
12:47 PM
@duhaime meh, I have enough rep on AU that it doesn't make much difference. And you've put in a lot of effort!
 
@duhaime Just to recap, your original problem was that the drivers were not installing properly, correct? Did you solve that, or not?
And I thought the problem was that you were using third party drivers, specifically the some random PPAs. But according to terdon they're not so random.
 
yes, the problem is the nvidia driver (I believe there's only one needed?) is not installed correctly
 
@duhaime Ok. That should be a fixable problem, provided you're clear what driver needs to be installed. And the correct driver for your system should install without fuss.
 
here's a major clue. I have a screenshot of the nvidia chips running. This screenshot is from yesterday, from right before I borked everything to try and get some streaming algorithm running:
 
And put information about your chip in the question, if you haven't already. It's certainly relevant.
 
12:50 PM
 
@duhaime Was that using your distribution's drivers?
The lshw output doesn't actually say what the chip model is. Weird.
 
I'm actually not sure how the 435.21 driver was installed or where it came from. Another member of my team installed that driver
 
@duhaime Did you check your apt logs? How long ago was that? Do you back up the logs?
 
hmm I haven't consulted the logs but I can check them and post the output. Are they in /var/log?
they're probably not backed up unless ubuntu 18.04 does that automatically
 
@duhaime /var/log/apt. But they don't stay there for very long. If you happened to have kept backed up, that would be helpful.
@duhaime No, they just get rotated for a bit, and eventually deleted.
 
12:55 PM
lord there's also /var/log/aptitude that might need investigation
all this chaos went down yesterday so they should still be present
 
I've got mine going back around a year.
 
ha
 
But I don't do a lot of installations.
Anyway, afk for a bit. Back later.
 
okay `/var/log/apt/` has a bunch of files:
```
eipp.log.xz history.log.1.gz history.log.3.gz term.log term.log.2.gz term.log.4.gz
history.log history.log.2.gz history.log.4.gz term.log.1.gz term.log.3.gz
```
well thanks for your thoughts!
 
@duhaime Check the dates. ls -lah
@duhaime You want history, not term, usually.
 
12:57 PM
I get:

```
ls -lsah /var/log/apt/
total 556K
4.0K drwxr-xr-x 2 root root 4.0K Apr 10 08:01 .
4.0K drwxrwxr-x 13 root syslog 4.0K Apr 10 07:29 ..
64K -rw-r--r-- 1 root root 62K Apr 10 08:01 eipp.log.xz
64K -rw-r--r-- 1 root root 59K Apr 10 08:02 history.log
4.0K -rw-r--r-- 1 root root 1.6K Mar 26 06:58 history.log.1.gz
4.0K -rw-r--r-- 1 root root 3.1K Feb 27 16:23 history.log.2.gz
4.0K -rw-r--r-- 1 root root 1.7K Jan 31 06:09 history.log.3.gz
40K -rw-r--r-- 1 root root 37K Jan 15 16:37 history.log.4.gz
woooah I didn't realize history was kept there too!
well I'm happy to paste the logs somewhere. There's a lot of tomfoolery in there though
is it a clue that I have:
```
/lib/modules/5.3.0-46-generic/kernel/drivers/i2c/busses/i2c-nvidia-gpu.ko
/lib/modules/5.3.0-40-generic/kernel/drivers/i2c/busses/i2c-nvidia-gpu.ko
/lib/modules/5.3.0-45-generic/kernel/drivers/i2c/busses/i2c-nvidia-gpu.ko
```
 
@duhaime markdown doesn't work in chat. The ``` have no effect. To have something appear as code (which just means fixed width font) inilne, you can use single backticks: `this is code` renders as this is code.
 
ah that's helpful. What about multiline code?
 
For multi-line things, just paste what you want to post and then move the cursor back, that will make a new button appear on the right, "fixed font". Click that and it gets formatted as code.
Alternatively, prefix what you want to say with four spaces:
this is code
 
excellent, four spaces is easy enough
 
(there's a small "help" link in the bottom right of your screen here)
That button appears if you hit shift+enter to have a newline without posting. It also appears if you move the cursor after pasting a multi-line thing.
 
1:13 PM
oh nice, I never noticed that before
 
1:40 PM
@FaheemMitha In Ubuntu, 12 months is the default. I changed it to 60 months by editing /etc/logrotate.d/apt to have 60 instead of 12. I did the same for /etc/logrotate.d/dpkg.
 
00:00 - 14:0014:00 - 22:00

« first day (3471 days earlier)      last day (45 days later) »