« first day (3320 days earlier)      last day (71 days later) » 

4:33 AM
@JeffSchaller Looking good! I'll put some notes in the Google Doc.
 
4:54 AM
@Biswapriyo That depends if you want to write actual graphical applications usable by an end user, or you just want to play around with programming and have graphical feedback.
@Biswapriyo The easiest (and probably the most fun) way to draw triangles, lines, shapes, etc., is with the Python "turtle" module.
@FaheemMitha I'm curious; why do you recommend Mercurial over Git?
 
 
1 hour later…
6:08 AM
@Wildcard Because I use it, and think it is better.
 
7:05 AM
You can also find discussions with people here. Particularly Anthony.
 
 
3 hours later…
10:19 AM
@Wildcard I assume you use Git?
Most people seem to. Often because of GitHub.
 
10:42 AM
hey all, porting a question from another room:

if I have x.com and y.com, with two different applications running on port 443, can I host them from the same server?

simply pointing x/y.com to server and opening the applications on the same port won't work, because the applications can't both use the same port on the local machine

I'm sure this is possible, but not sure how

maybe a 3rd application running on 443 that looks at the address the clients are connected to, and acts as a proxy to other ports that those applications are running on? Can nginx or similar do that?
 
@towc This chat isn't a suitable place to dump random questions. You should ask questions on the site. If you've asked a question somewhere else, you could link to it.
 
it's more useful as a conversation, I think. It's mostly a curiosity
 
10:55 AM
@towc That's a Python room? Hardly on topic.
 
it's not, but I hang out there, some of them are network-knowledgeable, so I thought I'd ask
 
Ok. If you actually post it somewhere, you might want to mention your use case.
 
curiosity. If this was for something more specific, I'd post a proper question
I'm sure it's already on SE either way, but I have no clue how it would be worded
 
@towc I don't see how you can be sure of that.
 
let me rephrase to "I think it's highly probable"
 
11:33 AM
Ok.
 
 
5 hours later…
4:11 PM
Is this question on-topic to U&L?
0
Q: Version '5:19.03.4~3-0~ubuntu-bionic' for 'docker-ce' was not found

overexchangeDocumentation provides syntax to install specific version of docker-ce: $ sudo apt-get install docker-ce=<VERSION_STRING> docker-ce-cli=<VERSION_STRING> containerd.io On same lines, below dockerfile uses the above syntax: FROM jenkins/jenkins:lts ENV DEBIAN_FRONTEND=noninteractive USER roo...

 
4:25 PM
@overexchange if I'm understanding everything correctly, it's an Ubuntu issue, so is best asked at ... Ask Ubuntu. I'm not entirely sure I understand the actual problem -- whether that's a docker-specific error, or Ubuntu/apt error.
 
apt-get -y install docker-ce=${DOCKER_VERSION:-5:19.03.4~3-0~ubuntu-bionic} docker-ce-cli=${DOCKER_VERSION:-5:19.03.4~3-0~ubuntu-bionic} containerd.io fails because of apt error
Can I check the available version? just for testing...
@JeffSchaller am not sure.. how to check available version here...
Because we are downloading from here... as per dockerfile
apt-get -y install docker-ce docker-ce-cli containerd.io works fine
Created a question in askubuntu
0
Q: apt-get error: Version '5:19.03.4~3-0~ubuntu-bionic' for 'docker-ce' was not found

overexchangeDocumentation provides syntax to install specific version of docker-ce: $ sudo apt-get install docker-ce=<VERSION_STRING> docker-ce-cli=<VERSION_STRING> containerd.io On same lines, below dockerfile uses the above syntax: FROM jenkins/jenkins:lts ENV DEBIAN_FRONTEND=noninteractive USER r...

deleted from SO
 
4:46 PM
@overexchange thank you for removing it from SO
 
thank you for guidance in categorising the problem
 
 
1 hour later…
6:02 PM
@JeffSchaller jenkins plugins are not getting installed after launching jenkins... I raised query on SO...
0
Q: jenkins failed to install plugins - jenkins docker image

overexchangeBelow is the relevant snippet from jenkins image(2.190.2 version): FROM jenkins/jenkins:lts #...... # ...... # Add jenkins plugin COPY plugins.txt /usr/share/jenkins/plugins.txt RUN /usr/local/bin/plugins.sh /usr/share/jenkins/plugins.txt where plugins.txt is: git:latest git-client:latest ...

Because I feel this is programming question... Isn't it?
 
@FaheemMitha yep.
 
stackoverflow.com/help/on-topic includes "software tools commonly used by programmers" so it should be on-topic there
In general... if you want to know what kind of questions are appreciated on different SE sites, each site's help center is a good place to start.
 
@Wildcard Despite appearances, it's not the only game in town.
 
6:25 PM
@overexchange we have jenkins questions here (all 88 of them), but SO may have more expertise (37,000 questions)
 
@FaheemMitha reading up on comparisons between them. How accurate is this description re Mercurial? (It's accurate about the Git part.)
> I believe this is where mercurial has gone wrong. A head in mercurial is inferred... it's just a point on the DAG where there are no children. A branch is inferred to be inactive when it's not a head.

Contrast to git where all heads are explicit.
 
@Wildcard Very out of date. Mercurial has (at least) 4 different notions of branch. At least one of them didn't exist in 2008.
I haven't read the linked article yet.
From a technical POV Mercurial and Git are quite similar, I think. Though Mercurial is clearly out in front in terms of usability (in part because of Evolve), and is probably also more flexible (in part because of Python).
Git is slightly faster for most common operations, I think. They shoving Rust into the picture to reduce startup times and other things. Not sure how I feel about that.
> mercurial attempts to provide a linear history
 
hey, Wildcard, while you're "here" -- is there any interest on your part in sharing the LaTeX doc on something like github or gitlab?
 
Not sure what he means by that. History in both Git and Mercurial is a DAG. That aspect is virtually identical.
Though Mercurial provides local integral revision numbers. Which I personally like. I think it's a nice feature and miss it when I'm trying to use Git.
 
@JeffSchaller I don't object to that. I prefer GitLab to GitHub. (I use GitLab self-hosted a lot of the time.)
 
6:35 PM
@Wildcard I should have said "I'm perfectly fine with google docs, and would have to learn things to move it to git*"
 
@FaheemMitha the article mentioned that. I'll take it with a grain of salt since it's such an old article, but:
> In both git and mercurial, the history is just a directed acyclic graph, but mercurial attempts to provide a linear history and this has a negative effect in a few places. For one, the rev number is displayed a lot and people try to use it, but it varies from repo to repo and probably does little more than cause confusion.
@JeffSchaller LOL, no problem.
 
(things worth learning, but an extra hurdle for me, personally)
 
@Wildcard I don't really know what he's on about. And the whole "History is a DAG" section is very unclear.
 
@JeffSchaller I actually have developed a training for Git. Delivered it at several different conferences, after refining it at meetups. If/when you ever decide to learn Git, let me know. :)
 
To a first approximation, Git and Mercurial are very similar in how they present themselves. They're both DVCS projects, started at approximately the same time, drawing inspiration from the same prior work, notably Monotone, and both founded by kernel people.
 
6:38 PM
@FaheemMitha I'm thinking I probably should spend some time using Mercurial, just for the experience of it. But I'm surprised you find that section unclear. Do you know what a DAG is? Do you understand how it relates to version control history?
 
It's not really surprising they look alike.
@Wildcard Of course I know what a DAG is.
 
@FaheemMitha well, good, I would also think that's an "of course" but just checking. :)
 
I've been using Mercurial since around Feb 2006.
I didn't just get here.
And I posted some bug reports in late 2005. At that time, Mercurial was like 6 months old.
 
But then, which part do you think is unclear? That section seems clear enough to me.
 
@Wildcard For example
> git will show you from a particular point all of the changesets that led up to it by following the history backwards, but otherwise it represents what happens in the real world. From a given point, there's a change. That change may be desirable or may not be. It may have been at one point, but isn't any longer. The only thing that matters is a head.
I admit I haven't really used Git much, but I don't know what he means here.
 
6:40 PM
@JeffSchaller by the way, you can use GitLab exclusively through the GUI, and never bother to learn about all the Git underpinnings.
 
And then he says, as you've already quoted:
> And I believe this is where mercurial has gone wrong. A head in mercurial is inferred... it's just a point on the DAG where there are no children. A branch is inferred to be inactive when it's not a head.
What does an explicit head mean?
 
@FaheemMitha in Git, a "head" or "branch head" is a pointer to a commit object.
 
You can ask Mercurial where the heads are. Or just look at the graph. He he means heads can be topological, but presumably that's the same with Git too.
 
Literally the entire implementation of a "head" is just a file that contains a 40 character SHA1 for a commit object.
 
@Wildcard I don't know what that means.
 
6:42 PM
@FaheemMitha So, let me try to back up a couple steps.
 
@Wildcard Oh. Does that mean that a head is an "object" in the API, which you can reference, for example?
 
@FaheemMitha I'm not really sure Git can be said to have an API. :D
 
If so, I don't think Mercurial's heads are designed like that. They're just csets that don't happen to have children. Nothing special.
But I don't know much about Mercurial's internal workings.
@Wildcard You should probably watch that Evolve video. Let me find the link.
 
@FaheemMitha the thing is, when you look at the graph in Git, it's generated by first looking at the heads.
Each commit object contains a list of its parent commits, if any.
 
6:45 PM
(A typical commit object has just one parent, but the initial commit has zero parents, and a merge commit has two or more.)
 
@Wildcard I imagine that Mercurial is similar.
 
So when you run, for example, git log --graph --all, Git looks at all the heads to find the commit objects they reference, and then looks up the parents for those commits, etc.
 
Though I don't know the details.
@Wildcard I see. I don't know how Mercurial handles such things.
 
@FaheemMitha thanks, I'll watch that sometime later.
 
Anyway, watch that video.
Like I said, not really familiar with Mercurial's internals. Though I've read some of the documentation and fiddled with it a little bit.
 
6:48 PM
@FaheemMitha the keynote is that in Git, you can create a branch starting from any arbitrary point in the history. Because a "branch" is really just a "branch head" or "head", and creating one only requires writing 40 bytes to a single file. It doesn't affect any other head. Which means that you could start from a cset that currently doesn't have children, and make more csets, and still leave some branch right where it was.
@FaheemMitha thanks, I will.
 
@Wildcard I don't entirely follow this.
 
I definitely know Git internals quite well. It will be interesting to get a real handle on how Mercurial does things, too.
@FaheemMitha I'll probably be able to explain better when I fully understand Mercurial and how it does things.
 
@Wildcard The machinery described in that video has been in process since 2013 or so. Maybe a bit earlier. It's only recently become usable.
@Wildcard Ok. When you do, feel free to explain it to me. :-)
 
@FaheemMitha :-)
 
Does anyone know what this "default" value in getopt is?
https://github.com/openssh/openssh-portable/blob/master/scp.c#L514
what condition causes it to fire
 
6:57 PM
@Jesse_b geeksforgeeks.org/switch-statement-cc "code to be executed if n doesn't match any cases"
 
Thanks
Meh I wish I knew c
 
so many things to learn, so many International Obfuscated C Contests to enter
(look at some of those winning entries and that will scare you away from C for life)
 
I honestly don't think I could even tell the difference between obfuscated c and regular c lol
 
@Jesse_b you'll know it when you see it (e.g. ioccc.org/2019/adamovsky/prog.c)
 
hah
 
I think I would be able to deobfuscate that though, seems just like liberal application of ;
But then I still wouldn't understand what it does
-1
A: scp does nothing than printing `usage`

Poete MauditFinally, what I did is to manually type from scratch everything in this command and it worked. Hence, it must have been some hidden characters that I was carrying with (and I could not see) - initially I was copy-pasting this command from a file instead of typing it manually. P.S. Guys I was ex...

(ノಠ益ಠ)ノ彡┻━┻
 
@Jesse_b deep breath, VTC, and move on :)
 
@JeffSchaller But he expected more of me and I disappointed him :p
 
What's wrong with that question?
Why did everyone come down so hard on the OP?
They obviously thought they had the syntax wrong. Finding non-printing characters is hard.
 
@terdon I suspect (Jesse can say for sure) that it's because the OP lashed out at them: unix.stackexchange.com/revisions/551628/1
 
7:17 PM
Ah
Did not see that
Fair enough then.
 
@terdon I'm probably not innocent in the matter, I often read my comments and think they are hostile even though I didn't originally intend them to be that way, although as soon as OP is asked for clarification on something and refuses to provide it I actually become hostile
 
Jesse: 1, Table: 0
 
So many people in the comments though were asking about/suggesting that there may be something wrong with the path and then OP answers their own question saying they figured it out and we were all of no help. Kind of ticked me off lol
 
hmm
 
@Jesse_b actually, they didn't figure it out, either. They just did something else that worked and then assumed that they now know why the other approach didn't work. They didn't bother to find out if their assumption is correct. Poor troubleshooting skills.
 
7:30 PM
@Wildcard My assumption is that there was a glaringly obvious error in their command that they realized and are ashamed to admit it
The age old "I changed nothing on my end" solution
 
@Jesse_b :D I actually think it's more likely that they didn't look closely enough to figure out what the error was.
That requires a certain ability to observe.
 
If they had a non-breaking space between the paths, it would cause exactly that, just the usage message with no other error
but
I don't think an NBSP passes through SE, it changes to a regular space
 
But then re-typing it exactly (without quoting it) would have produced a different error.
 
so anybody copying the command from their question couldn't see it
@Wildcard well, they said in their "answer" that re-typing it made it work. But the comments were full of people asking for a reproducible example, but if it was indeed a non-breaking space, they couldn't have provided one even if they tried to.
 
@Wildcard Well OP said when they retyped the command it worked
 
7:39 PM
@Jesse_b right, which means it couldn't have been a non-breaking space.
What's funny is that we're probably putting more thought into the possible causes than the OP did.
 
So yeah, I know, sometimes they don't tell exactly what they're doing, but in this case I don't think it was their fault.
 
@Wildcard That's what we do
THIS IS WHAT WE TRAIN FOR war cry
 
@Wildcard Why not? They had that nbsp somewhere, probably because someone mistyped it. And as long as they copy-pasted the command, it couldn't work.
but when they retyped it, they typed a regular space.
(because, you know, that's what they saw and knew should be there)
 
How they would have originally got that nbsp, that I don't know. I still have it in alt+space, so I sometimes get one after typing a | (because also behind alt)
 
7:45 PM
> What this basically tells me is that I should never, ever, copy anything from a web page and paste it into a terminal application
 
@ilkkachu you mean a space between the one path and the other? I guess that could be...I was thinking a space in one of the paths.
 
@Wildcard a non-breaking space between the two paths, yes. then it would actually be just one path, not the two that scp expects. Additional regular spaces would just cause it to see more than two paths, but that wouldn't be an error since it can have more than one source file
 

« first day (3320 days earlier)      last day (71 days later) »