« first day (1496 days earlier)      last day (3510 days later) » 

1:55 AM
@TylerMaginnis - ???
2:51 AM
@TylerMaginnis sounds like something that gets auto-filtered from my inbox into the pit of despair and bayesian learning
5 hours later…
8:21 AM
@casey Wow, that's poetic.
@TylerMaginnis Good for you. Playing poker?
5 hours later…
1:23 PM
@TylerMaginnis I'm afraid to ask!
1:36 PM
@slm Be Brave, Bold and Fearless. Like Tarzan. Or Linux Torvalds.
@slm Tyler would need to put on a dress for that.
2 hours later…
3:17 PM
Q: How to remove last character from grep output?

KasiyAI have a text file with following content in it (for example): In first line the "One", second"Two " & " Three " and also"Four ". In second line also nested "foo "bar" baz""zoo" patterns. I tried to had all strings between a pair of quotes and finally I ended up by this command: grep -Po ...

@KasiyA Why are you insisting on grep? It just isn't the right too for the job.
Also, that is likely to get closed since it's cross posted.
The UNIX philosophy is to use many small programs in a pipeline, why are you objecting ti this? Also, grep -o is GNU-specific, it only works on Linux systems and you can't rely on it.
@KasiyA now they're nested? Forget grep, it's just not made for this.
3:35 PM
/me puts on a dress
3:51 PM
Hi. @terdon It's not cross post.
and they was nested also on AU.
@KasiyA I know, I realized after posting that, you now also want nested quotes. Why do you insist on using grep?
@KasiyA Ah, yes, so they are. So what's the difference between the two questions? Why is it not cross posted?
I close to find the command grep -Po '"\K[^"\W]+' file
Does anyone use ubuntu 14.04 here?
@KasiyA That doesn't work if any of the quoted strings contain spaces or other non-word characters.
How to find all patterns between two characters? AU
How to remove last character from grep output? SO
3:58 PM
@KasiyA ? But it's exactly the same question.
If you just wan to remove the last character from grep's output, pass it through something like sed -r 's/(.*)./\1/'
$ grep -Po '"\K[^"]+"' file | perl -lpe 'chop'
if it was easy I was able to find it by myself. And I know I can solve it by using multiple grep command:grep -Po '"\K[^"]+"' file | grep -oP '[^"]*' or another command combination with grep. So I could not solve it by using just one grep. and I asking on SO. — KasiyA 6 hours ago
@KasiyA Yes, I know that you want to do it with grep only. I and many others have explained why that is not possible and why grep is not the right tool for the job. You still have not explained why you don't want to combine grep with something else. Why is it that you want to stick to grep alone?
On AU I mentioned How can I achieve/print all of my patterns just using one command? (every command you can answer) I tried with grep for myself. On SO I want to remove character at the end of result . If you are sure both of question are same, so I don't have any problem about that. thank you for attention :)
@KasiyA fine. You keep insisting on using the wrong tool, but it's your choice. Do as you will.
@terdon one more: If it's not possible then why the users like to answer me for another command. I hope you don't upset from me. I'm sorry
4:12 PM
@KasiyA I'm not upset, I don't care. It's your work, not mine. Users are answering you offering different tools because those tools can work. You keep insisting to use grep for this and grep can't do it. I just don't understand why you insist this way.
@KasiyA I tried, but I've failed too: the closest is grep -Po '"\K[^"]+(?=")' or grep -Po '"\K *\w+ *'. There are many problems here - your quotes are nested, starting and ending points are not necessary alphanumerical (you want spaces too if I correctly understand), and also you need to use perl regexp together with -o option. It is very hard to fulfil all those needs.
@KasiyA if you cannot find a solution to your problem using tool X then that's telling you that you're probably trying to do something that you shouldn't be!
@KasiyA - I urge you to take the advice of several others and stop trying to force a round peg in a square hole.
@psusi around?
@jimmij thank you no spaces isn't important. I don't have problem with existing space or removing them. thank you any more.
shit the nested
4:52 PM
@Braiam Your new job?
2 hours later…
I was running make test for python and I had to close my laptop, so my PuTTY session ended on my side. If I do ps -aux or users on the box, however, I see that my session is still there... how can I know when make test is done running? I wasn't sure if this was post worthy
7:52 PM
@Gilles @derobert @slm and anyone else who cares: is now blacklisted.
8:03 PM
Q: How to change language interface in Xfce?

pprI installed Debian sid with Xfce and I would like to change the language used in the interface. I would like to set the language to English (US) and not French anymore. The following command works only for root: # dpkg-reconfigure locale which has now the good locale: # locale LANG=en_US.UTF...

@ppr please don't paste your questions into the chat room. New questions appear in the feed and we all see them anyway.
Also, please edit and explain whether you want the new locale to affect the GUI only or the CLI environment as well.
@terdon ok (sorry). Pasting question on the chat is a common pratice on tex.SE which I used to particpate
@terdon I would like the all system to be in English language (GUI and CLI). I will update my question
@ppr No worries, in general, on most SE sites I'm active in this is called "Question Dumping" and is frowned upon. Just letting you know.
Can't you do this in the xfce-settings-manager?
On the contrary to gnome (or xfce on ubuntu), I have no option regarding language in xfce-seetings-manager
Yes, I was just looking at it and strangely enough it doesn't seem to be there.
OK, have a look at wiki.debian.org/Locale
8:10 PM
@terdon I think Locale is probably the solution. I changed my locale to EN.US with the dpkg-reconfigure locale but the change is active only for root. And the dpkg command does not work launched as a normal user
and the Debian wiki webpage about locale doesn't indicate how tho set the locales for normal user (just root)
It does, further down. You would need to either select the locale from GDM or whatever you use on login or set the relevant variables in your ~/.profile.
Well, it doesn't say it's for regular users explicitly, but it should work if you change it in ~/.profile.
I am trying the following solution : create a .dmrc file with the locale inside
@terdon cool!
@ppr that should work.
@terdon I didn't work (after reboot).
8:19 PM
@derobert It left 15 questions untagged which I've retagged to the best of my abilities. Turns out, I had to create some new tags.
pierre@nil2:~$ cat .dmrc
trying locale-gen solution
@ppr Add these things to your question. Two of our top users are quite good at locale stuff, if you add more details they might take an interest. En plus, ils sont français donc peut être ils ont déjà vécu çà :)
@terdon merci. Ton français est bon !
@ppr Hang on, that won't be enough. You need the [Desktop] line and the Session.
@ppr :) Il faut, j'habite a marseille.
@terdon en effet, j'ajoute le [desktop] et je teste
8:24 PM
@ppr Session too!
Well, in your case:
I add these line (remplacing gnome by xfce) but I still have the menu in French
ok I am trying xfce4
no change with Session=xfce4
I update the question
@Gilles if you have a second, can you help change the default locale?
8:38 PM
@terdon Not surprised. There were a few in there which I knew about... but mostly it was an unfixable mistagged mess.
8:51 PM
@derobert did you see that JH quit?
@FaheemMitha ?
if only they'd managed to keep a backup copy in git-annex, they could just restore a pre-systemd version.
9:14 PM
Q: Can someone be so kind as to setup a cronjob for me?

Eli ReidI've been trying to get cron to execute these two scripts to schedule and post on twitter, tumblr, facebook and linkedin. It worked once and never again. <?php require '/opt/bitnami/apps/wordpress/htdocs/wp-load.php'; include('/opt/bitnami/apps/wordpress/htdocs/wp-content/themes/yeelloe/schedu...

Such a question always tempts me to ask for the root password to their server...
@Anthon LOL. Indeed. I wonder if we have a "my cron job isn't working, how do I troubleshoot?" post. Then just close a duplicate...
1 hour later…
10:25 PM
@FaheemMitha I don't follow Debian politics. What drove him away?
10:44 PM
@Gilles according to him, he doesn't understand Debian's decision making process, or so he says
11:18 PM
im experiencing slow uploads when scping a file to remote server in a qemu VM, anyone have any clues why my uploads are getting stalled?

« first day (1496 days earlier)      last day (3510 days later) »