« first day (2300 days earlier)      last day (1591 days later) » 

6:02 PM
Hmm, so I know there are language interpreter challenges out there, but what about a HQ9+ interpreter challenge? HQ9+ doesn't meet our criteria for a programming language, and given how it works it'd really be more of a Kolmogorov Complexity challenge than an actual language interpreter challenge
 
I think that's been done before
 
Anonymous
24
Q: Creating a HQ9+ interpreter

ProgramFOXThe goal of this code golf is to create an interpreter for the programming language HQ9+ There are 4 commands in this programming language: H - prints "Hello, world!" Q - prints the source code of the program 9 - prints the lyrics of the song "99 bottles of beer" + - increments the accumulator ...

 
Right, fair enough
 
HQP9+, however, is an entirely legitimate programming language.
P being the primality test
 
@TuxCopter is "le seul chose qui compte est si vous faites de votre mieux" OK?
 
6:06 PM
sacre bleu
 
"la seule"* because gender
 
Anonymous
@JanDvorak If + stands for "add two numbers" rather than "increment the accumulator"
 
true
 
Anonymous
Then it meets the barest definition of a programming language
 
It does indeed :-D
 
6:07 PM
@TuxCopter I don't need to use c'est though right?
 
yup don don't need to
 
And the si also make sense?
 
why is it "qui" instead of "que"? (French teacher taught us but I forgot)
 
qui - which
 
@KritixiLithos because la seule chose is le sujet
 
6:08 PM
is "que" even a French word?
 
Yes very important one too
 
@Downgoat ah, then "que" is used when it is the object?
 
oh. Oops.
 
@KritixiLithos yes it'll be the complement objet direct
 
0
Q: Capitalize! Statement

Riyas RandhavaYou are given a string S. Your task is to capitalize each word of S. Input Format A single line of input containing the string, S. Constraints 0 < len(S) < 100 The string consists of alphanumeric characters and spaces. Note: in a word only the first character is capitalized. Example 12abc ...

 
6:28 PM
@KritixiLithos I was about to comment before you deleted your post, but vU is equivalent to vgU
4
A: Tips for golfing in vim

DJMcMayhemThere are three "change case" operators, gu "Convert to lowercase gU "Convert to uppercase g~ "Toggle case Since these are operators, they take a motion, so to convert the current character to lowercase you would use gul Here's where the fun trick comes in. :) If you want to change...

 
@DJMcMayhem Aw...
 
@DJMcMayhem Try it online!
look at the last character
 
Yeah, I know
I was just giving you a tip for vU in general
@Dennis What?
 
so is the solution invalid, or is it just V?
 
@DJMcMayhem I was just about to post a sed answer. :P
I kinda like the new challenge better. No restriction to full programs, no weird edge cases with underscores and hyphens, no arbitrary penalty on regular expressions...
 
6:31 PM
@KritixiLithos It's just vim. You could do f<space>, that'll fail earlier
 
@BusinessCat Hmm, I think you would have to just use the ∙* component (which vectorizes) to create arrays filled with 2 copies of each element, flatten onto the stack, and wrap the stack in an array.
Might be a better way to do it, but I'm not sure.
 
0
A: Sandbox for Proposed Challenges

Stephen SProve the Undecideability of the Halting Problem code-challenge halting-problem More information on the halting problem. Either: Create a program that, when given an input, no single program (which receives your source and your input) can determine if your program terminates, or Create a fun...

 
@Dennis :shrug: feel free to switch it up, I probably need to go now
 
I'm not sure I like this one better is enough to reverse the dupe status. Certainly not unilaterally.
 
@KritixiLithos BTW, I have two completely different 6-byte solutions. See if you can find them :)
 
6:36 PM
@DJMcMayhem There's a 4-byte solution, no?
 
An Invalid one >_>
 
How come?
 
I get 5 bytes
 
Maybe I just don't understand V well enough, but òvUW appears to pass all test cases.
 
It capitalizes the last letter (same as kritixi's original)
 
6:38 PM
\o/ I outgolfed you
 
@DJMcMayhem Then codegolf.stackexchange.com/a/83333/12012 is invalid too, is it not?
 
@KritixiLithos don't tell me it yet
 
time to use go for this, should be easy enough
 
@Dennis Yes, I just hadn't realized until now
@KritixiLithos Ha, I found your version right before you edited lol
 
I need to learn V...
 
6:42 PM
1
Q: Correct peoples grammar

Okx(yes, that title was intentional) Your task is to correct common grammatical mistakes. You must: Capitalise the first letter of each sentence, ie the first non-whitespace letter after any of .!? and, additionally, capitalise the first letter of the input Remove repeating punctuation, such as ...

 
>> JSON.stringify({a: Infinity})
<< "{"a":null}"
wtf
 
Is prior knowledge of vim required or just helpful?
@TuxCopter Infinity is not supported by JSON.
 
hm
 
at least JSON knows what's real and what isn't
 
6:45 PM
@Dennis Well Leaky learned it with no prior knowledge, but it'd definitely help a lot. The tutorial is written for those who don't know vim.
 
And since JavaScript doesn't adhere to the In the face of ambiguity, refuse the temptation to guess. motto, it does whatever instead.
 
Of course, feel free to ping with any questions you have
 
Anonymous
@Dennis Instead JS follows Guess anyway, even when it's not ambiguous at all
6
 
@NathanMerrill unlike Lily Allen :-D
 
7:02 PM
I didn't get that reference.
 
7:13 PM
@NewMainPosts Don't these just boil down to "who can write the best regex for this"?
 
Testing the new cross-platform HTML renderer in Dyalog APL, I try running a Game of Life app. Unfortunately the global variable WORLD seems to be gone:
 
Anonymous
@Adám That seems bad. How can you have global variables if you don't have WORLD?
 
@KritixiLithos Just a coincidence that the error happened in thread number 42.
 
> coincidence
 
7:20 PM
What are some simple challenges I could try to do with a new language? I've already done fibonacci.
 
project euler
 
@JanDvorak I think you mentioned that before. What is it?
 
I'm on problem 11
 
Ah, I was hoping to get some answers towards my and badges. I am in desperate need of more answers.
 
7:22 PM
No, you're not.
 
Ok desperate might be a bit of an overstatement.
 
7:44 PM
CMC: Write a program which runs forever and does not exit when the user presses Ctrl+c, that is SIGINT.
 
Don't know if this counts, but running the Röda interactive mode (after it started) does this task
 
Anonymous
@Phoenix Python REPL does that
 
@Phoenix Just once or do we have to support multiple SIGINTS?
 
Multiple
@Mego in which case your submission to the CMC might be Bash + Python, 6 bytes: python. But that's really boring.
 
Anonymous
Python, 31 bytes:
 
Anonymous
7:47 PM
while 1:
 try:pass
 except:pass
 
Dyalog APL, 5 bytes: {∇⍵}1
 
I think the lowest you can get it to by that method is sh in bash.
 
Basically calling an infinite recursive loop
 
Anonymous
It's technically possible to Ctrl-C out of that Python program, but it requires precise timing
 
@KritixiLithos The basic infinite loop catches SIGINT by itself?
 
7:49 PM
CMC: Write code that writes valid code that will run without errors in the same language
Quines are allowed but really, it's probably easier to get it shorter
 
apparently so. It doesn't quit until I SIGQUIT it using the Hard Interrupt (Soft Interrupt is SIGINT).
 
Huh.
 
@totallyhuman Carrot, 0 bytes
It outputs nothing and that is a valid Carrot program
 
...i should've thought of that
pls think of more interesting stuff :P
 
Carrot, 1 byte: 1 :P
 
Anonymous
7:50 PM
@Phoenix sh on Linux: stty intr \^i
 
Anonymous
@totallyhuman Literally any Actually program
 
haha
(oh wait, I need to get back to doing homework...)
 
@Christopher I'm resuming work on the duel. What are the new commands?
 
@Mego wat how?
 
@Mego what's that do?
 
Anonymous
8:03 PM
@Riker Remaps SIGINT to Ctrl-i
 
o_O
lol
 
Anonymous
@totallyhuman All strings are valid Actually programs. Actually has no errors.
 
@Mego o0 golfers are nuts
 
Anonymous
No I'm a penguin
 
Anonymous
Who may or may not also be a robot
 
8:04 PM
where can i find the actually docs/code?
 
looks at url | seriously? | clicks link | wait wat
oh
renamed ah
 
0
A: Sandbox for Proposed Challenges

Stephen STrim a String code-golf string Given text, remove leading and trailing whitespace (spaces, tabs, and newlines). Input ASCII text, in whatever format you would like. Output The same text in the same format, but with trailing and leading spaces, tabs, and newlines removed. *Note: If your lan...

 
@totallyhuman Yes, Seriously is actually Actually. Seriously.
3
 
8:22 PM
:D
 
@WheatWizard I think p is the only one. Lemme check.
 
eh, still better than "".
 
Yeah. P sets stack to equal vars
Also 0 increments numbers
 
C:\Users\Pavel\alwsl>alwsl.bat install
alwsl (warn): There's already a WSL rootfs installed. We need to remove that. If you have data there,
alwsl (warn): cancel this and backup your rootfs.
Proceed with alwsl install and remove old rootfs now? [Y,N]?Y
alwsl (info): Cleaning old files.
alwsl (info): Installing base lxss fs from trusty server image. This will take A WHILE.
-- Beta feature --
This will install Ubuntu on Windows, distributed by Canonical
and licensed under its terms available here:
@mınxomaτ alwsl seems to be installing Ubuntu and not Arch
 
Maybe, you know, wait til it's actually done.
 
8:28 PM
@Phoenix stty raw;yes The output is quite pretty too.
 
@mınxomaτ Well, it takes a long time, and I wanted to make sure that it isn't doing something wrong by accident, because I wrecked my old WSL install.
 
Anonymous
WSL is meant for Ubuntu. alwsl installs Arch instead.
 
Right, but alwsl is downloading Ubuntu first, which confused me abit.
 
@Mego Golfing language design tip #1: Every possible error is just a wasted opportunity to do something useful
15
 
Wrong. Every possible error is an opportunity for a future expansion.
 
8:46 PM
i set out making an overlay for a readable golfy simplified python and then realized...
 
8:56 PM
@Christopher You've done the challenge right? Its possible now
 
TFW you spell correctly on the first try...
8
 
this deserves stars
 
0
Q: Tips for Golfing in Japt

ShaggyNow that I'm thoroughly addicted to Code Golf, it's probably about time that I try to pick up a few golfing languages. Given that I play almost exclusively in JavaScript Japt seems like the logical language to start with. I'll be diving into the documentation at the next opportunity I get but, i...

 
9:12 PM
@ETHproductions Kolmogorov is not hard to spell
 
Anonymous
I dropped the third o for a long time
 
i always thought it was kolgomorov o0
 
^ same, until I realized that gives no results
 
@WheatWizard yes. I have working code using the current version
 
9:16 PM
@Mego "kolmogrov" sounds hilarious
 
@Christopher I can't seem to get p to work
 
Which language are you talking about?
 
what's the difference between lisp and common lisp o0
 
@TuxCopter opls kolomorogorov is like hardest word to spell
 
@Downgoat clearly :P
 
9:28 PM
"kurzgesagt" is harder to spell IMO
 
Opls easy to sound out
 
@Christopher I think I found the problem shouldn't if(b[i]==="q"){numbers.push(stack);}be if(b[i]==="q"){numbers.push(stack);lastNum++;}?
 
@NewMainPosts Wow, how did I completely miss this until just now >.<
 
7 mins ago, by Kritixi Lithos
Which language are you talking about?
 
Newline, Christopher's language
 
9:32 PM
where's the interpreter?
 
You have to put the program at the bottom
input is near the top
var numbers =...
 
if it's JS you could probably use github pages...
 
so how do you add two numbers, for example?
 
You can't
 
welp
 
9:36 PM
Only the last number in the input is readable
Oh wait no
You can add
use +
 
I don't understand the thing about the newlines
 
wait no nevermind
one of the numbers has to be on the stack
@KritixiLithos Just put newlines between every command
¯\_(ツ)_/¯
 
CS terminology question: What do you call a tree node that does not have any children?
 
@DJMcMayhem Leaf?
 
Ahh, thanks
 
9:41 PM
someone spin-offed Newline
 
@WheatWizard no. I made it like that. Use 0 to increment numbers
If you need
 
Ok well I have a solution
We take input to numbers right?
 
Yes
 
I'm pretty sure this is not TC btw
 
You cam share. I will link mine (time stamp included for proof)
@WheatWizard idk it may not be
It is going to be redone soon. Written in python. Real ways to run
So your code?
 
9:54 PM
21 bytes "g\n[\nd\nq\n0\np\ni\na\n<\ng\n]"
 
Now we can use Kotlin to develop Android apps.
 
chat.stackexchange.com/rooms/58874/… mine is there. (on mobile so can't copy paste)
 
We can already use C# for Android dev, I don't know what's more surprising than that :P
 
@Christopher Whats with the |?
 
Prints stack so zero
I think you won :/
 
9:57 PM
Ehats the difference between | and <?
 
Will double check in a bit. I gtg for now
Idk I think they are dupes
 
You don't need to print zero btw
your extra two bytes are because you print zero
 
@Downgoat Kolmogorov is literally written as it is pronunced
There's no weird silent letters or digraphs
It's really simple to spell
 
Yeah but I never pronounce it
It's one of those words I silently read
 
@KritixiLithos Java was the only "official" language tho. Now Kotlin is one too.
 
10:11 PM
@TuxCopter but what if you do not know how to pronounce kolormorgorovov complexity
 
Anonymous
It took me an embarassingly long time to notice the third o
 
10:26 PM
Do Vim people actually use hjkl to move the cursor
Everything about that feels wrong
 
You're supposed to but I still use arrow key
 
@Downgoat Everything about that feels wrong
:P
@Phoenix We use lots of things to move the cursor
 
:set mouse a
:P
 
I use the arrow keys because I never exit insert mode.
 
Well then you might as well be using nano or something.
 
10:29 PM
I do use nano a lot.
 
@WheatWizard Oh so we tied?
 
Poll: init or ClassName for initialisers?
 
:set mouse a
E518: Unknown option: a
@Phoenix Like that?
 
@Christopher Yeah pretty much.
 
@DJMcMayhem wait what
 
10:30 PM
I only use vim for editing Latex
 
@WheatWizard Dang
 
@Downgoat Whoops, accidentally edited
Fixed now
I tried to mock the bad command but fixed it to the correct command without realizing, haha
 
That is funny. Well our duel ended with both of us dead :/
 
Ok that make more sense
 
Bit new around here,could someone confirm if my answer here is valid please? codegolf.stackexchange.com/a/121268/68029
 
10:31 PM
@DJMcMayhem I forgot how it works
I put something like it in my .vimrc a while ago
 
:set mouse=a
 
right...
 
(But FYI it doesn't actually do anything to set that since a is already default)
 
@DJMcMayhem is not for me
 
Wait, sorry GUI vs terminal
 
10:32 PM
@Notts90 I think it is technically ok, but imo its super cheaty
 
I think it's Windows vs Unix
 
Sort of
 
On Windows, <C-a> is select all and not increment
 
Technically right is the best kinda right...right? Lol
 
Which is why whenever I test something I find on PPCG I open Vim in WSL
Which I know is terrible
 
10:34 PM
@Phoenix By default, yes, but not always
 
Yeah, you can rebind it in the .vimrc, but I don't know if there's anything else like that I need to deal with.
 
No, you don't need to. There's a way to avoid all windows specific garbage
I don't remember what it is though >_>
 
10:48 PM
@Phoenix pls gist your .vimrc on Windows
 
The default one.
function! SetStyle()
  let l:fname = expand("%:p")
  if stridx(l:fname, 'libsanitizer') != -1
    return
  endif
  let l:ext = fnamemodify(l:fname, ":e")
  let l:c_exts = ['c', 'h', 'cpp', 'cc', 'C', 'H', 'def', 'java']
  if index(l:c_exts, l:ext) != -1
    setlocal cindent
    setlocal tabstop=8
    setlocal softtabstop=2
    setlocal shiftwidth=2
    setlocal noexpandtab
    setlocal cinoptions=>4,n-2,{2,^-2,:2,=2,g0,f0,h2,p4,t0,+2,(0,u0,w1,m0
    setlocal textwidth=80
    setlocal formatoptions-=ro formatoptions+=cqlt
 
Eww
@Phoenix Why the heck do you wrap that in a function to call it once?
 
I didn't
It's the default .vimrc
 
And you haven't changed it to something sensible?
 
@Phoenix do you have a _vimrc
 
10:51 PM
I have a _viminfo
 
0 of those settings are worthwhile, except for maybe textwidth
Honestly, you'd be better off with just
set nocp
syntax on
 
congrats on 50k rep @LuisMendo!
10
 
Woah. I just found my first .vimrc
 
"Black hole shortcut
nnoremap     "_d
vnoremap     "_d
inoremap     "_dd
what's that mean?
 
@WheatWizard We should duel once more. Same stakes/language different challenge with a bigger chance to have different bytecounts.
 
10:56 PM
@Riker Do you know what "_ is?
 
@Dennis Every once in a while I forget you have a sense of humor :P Now I remember.
 
@DJMcMayhem Comment?
 
No
Compare dd and "_ddp
 
@Christopher Ok
make sure it can be done though :P
 
@Christopher did you think Dennis was a robot or something >_>
 
11:03 PM
@Mego Haha, nice. I now see I only said "kolgomorov" three times: chat.stackexchange.com/… (three of those were ETHbot repeating me, 1 was earlier today)
 
Does anyone know if this program is reliable and not a virus?
 
@Phoenix Looks like malware to me
@Phoenix use sfc /scannow
 
I think I know what the problem is, because there are 4 files specifically mentioned in this one error log I'm getting, but I have no idea how to fix.
 
@Phoenix pls name one of them
 
16:05:46: Starting BattlEye Service...

16:05:48: Launching game...
16:05:50: Note: File blocks can be ignored if they don't cause problems with the game.
16:05:50: [INFO] Blocked loading of file: "C:\Windows\syswow64\uxtheme.dll".
16:05:50: [INFO] Blocked loading of file: "C:\Windows\syswow64\edputil.dll".
16:05:50: [INFO] Blocked loading of file: "C:\Windows\syswow64\urlmon.dll".
16:05:51: [INFO] Blocked loading of file: "C:\Windows\System32\dinput8.dll".
 
11:06 PM
@Phoenix do they exist
 
Yes
 
@Phoenix then it seems like a permission issue to me
 
Well, I shouldn't have to be running Rainbow Six as admin for it to work.
 
@Phoenix yeah no i mean changing the read permissions of those files to normal if they're different from permissions of other files in the same folder
 
Do you know what the command for that is?
 
11:09 PM
@Riker ¡Muchas gracias! :-)
 
@Phoenix open in windows explorer -> right click properties -> security tab :P
 
Read and Read & Execute were already ticked.
 
I can now protect questions! Yay!
 
@Phoenix for your account (not admin) right?
 
For every group and user
PS C:\WINDOWS\system32> sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection found corrupt files but was unable to fix some
of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For
example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not
supported in offline servicing scenarios.
PS C:\WINDOWS\system32>
 
11:14 PM
CMC: 2-lang polyglot that outputs the name of the other language when run in one language
 
Won't paste log file to being incredibly massive
 
@DJMcMayhem comment?
@LuisMendo de nada :)
@WheatWizard the last one was impossible? lol
 
According to VirusTotal, DLLCare doesn't seem to be a virus.
Hmm...
 
@HelkaHomba A & K, 7 bytes: "KA"[1]. Explanation: A uses 1-based indexing, K uses 0-based.
 
A?
 
11:23 PM
@Phoenix Precursor to A+, a dialect of APL.
 
@Riker Nope
 
A+ is an array programming language descendent from the programming language A, which in turn was created to replace APL in 1988. Arthur Whitney developed the "A" portion of A+, while other developers at Morgan Stanley extended it, adding a graphical user interface and other language features. A+ was designed for numerically intensive applications, especially those found in financial applications. A+ runs on many Unix variants, including Linux. A+ is a high-level, interactive, interpreted language. A+ provides an extended set of functions and operators, a graphical user interface with automatic...
 
@ASCII-only please send help, I think the DLL file might be corrupted, how to fix.
 
@HelkaHomba was this not a challenge on main but simpler?
 
11:28 PM
@ASCII-only Don't have permission to replace the file, even though I'm admin. ._.
 
@Phoenix ok wtf
what did you do
 
@Adám Actually, that might not have worked. A may have used 0-based indexing like A+. Kind of hard to find out.
 
@Phoenix maybe that's your problem
 
It prompts for admin then says "You need permission to perform this action"
 
I can't run windows apps on my home computer because I accidentally made my account the default administrator account.
 
11:31 PM
Doesn't let me edit the permissions on the file either, the boxes are greyed out.
 
@Phoenix oh yeah forgot, they are system files, you need to make yourself the owner first (in permission -> advanced), then probably best to set original owner back after
 
@ASCII-only That is possible. Mainly I have been on the mod receiving end from him several times (visit my profile about me)
 
@ASCII-only Set myself as owner, same error.
 
@WheatWizard Yeah this time lets have it so we both go at the same time whenever you finish you just say so. And post the your code in a different room (like I did) then you can golf until the other person finishes. In case of a tie first to be done wins.
 
Ok
I can't now though
 
11:37 PM
I can't figure out how to set the owner back to TrustedInstaller, either.
 
@Phoenix D: oh no
you can't just type in TrustedInstaller?
 
No.
 
Wheat you know when you could?
 
Maybe the save one bot won because everyone expects the reload and throw strategy, but not the reload reload throw reload throw etc. strategy
 
11:41 PM
I think I sense another Windows reinstall comming.
 
maybe don't reinstall...
 
IDK How to fix tho
 
(I mean get another os)
 
The entire reason I'm trying to fix this is because Rainbow Six Siege stoped working. So.
(Yes I tried reinstalling the game and all)
 
@DJMcMayhem string?
 
11:51 PM
Wait nvm system restore is a thing
 
@Christopher probably tomorrow
 
System restore fixed literally nothing
But it did break chrome
So I had to reinstall that
Lovely
 

« first day (2300 days earlier)      last day (1591 days later) »