« first day (1779 days earlier)      last day (2181 days later) » 

4:00 AM
B/c shut up, golfmastah :P
> th'instant
Cheating. :P
Our Bard did that too. Also talk'd about that a day prior
why e?
Y'alls r judging my typography too much, Ithinks
Are you allowed to use e in code?
4:09 AM
Not until 2016
… so hardcor
How about E?
@ Small caps guy - I consid/x65r that, in addition to using /x45, to b/x65 ch/x65ating
@Ampora You can ping him like @Cᴏɴᴏʀ and you could say "I thought about that" rather than "I consid/x65r that."
@Dennis wth
... do you have an encoder? :P
@Dennis Why are you doing this to us
4:19 AM
@Dennis ... are those non-ASCII chars supposed to be there
Why do I think that's a brand spanking gnu programming lang
> gnu
> spanking gnu
@AlexA. EeeEeeEeeEeeEEEeEEeEEeEeeEeeeeeeEEEeEeeeEEEeeEeeEEEEeeEeEEeEeeEeEEeEEEeeEEeeEEEe‌​eEeeeeeeEEEeEeeeEEeEEEEeeEeeeeeeEEEeeEeeEEeeEeEeEEEeeEEeEEEeEeeeEEeEEEEeEEEeeEeeE‌​EeeEeEeeEeeeeeeEEEeEeeeEEeEeeeeEEeeEeEeeEeeeeeeEEeEeEEeEEeeeeEeEEEeeEeeEEeEEeEeEE‌​eEeeEeEEeeeEEeeEeeeeeeEEeeeEeeEEeeeeEeEEeEEeeeEEeeeeEeEEeEEEeeEEeeeEEeEEeeEeEeeEe‌​eeeeeEEeEEEEeEEeeEEeeeEeeeeeeEEEeEeeeEEeEeeeeEEeeEeEeeEeeeeeeEEEeEEeeEEeEEEEeEEEe‌​EEEeEEeeEeEeEEeEEeeeEEEeeEEeeEeEEEe
This has been Kinky Wildlife with Ampora
4:21 AM
@Dennis $´ÑÉ她œ to restorIHHØ\›X–2&Ææ6R½˜Ñ¡”Ù½Çels.
10/10 would encode again
@ AlwaysWrong
OK, chat's whitespace insertion makes this impossible.
@AlexA. zwsp corruption, I suppose
The way of the samurai is strong with Dennis
@Ampora Oh gross, Homestuck.
4:23 AM
@ Wrong - And my chat tag and pic didn't hint you in? :P
Idk what a chat tag is but I figured your avatar was related to Homestuck.
However unfortunate that may be. :P
Although I would b first to say that HS is in fact total trash
What's Homestuck?
@Ampora This pleases me
@Dennis Total trash
Wait, I think I read that once.
4:25 AM
I'm sorry
^ I in addition
My girlfriend used to like it
1 min ago, by Alex A.
I'm sorry
Still no answers to my question! :(
4:27 AM
"HS is trash" says I, who has an avatar and chat tag of it and also cosplays it and brings into xistanc TikZ art of it.
@Ampora ಠ___ಠ
So you're saying you enjoy trash? :P
@AlexA. sometimes it can be quite tasty
@Ampora I find not a single redeeming quality about Homestuck.
@Cyoce Gross
4:32 AM
I ask to not talk about HS, as this is PPCG, not SFF ;)
It's not like this room is ever on topic anyway, nor is anyone else talking about anything at the moment, but I'm quite happy not to discuss Homestuck. :P
Considering this is the topic:
> General discussion for codegolf.stackexchange.com | abandon all work, ye who enter here —aditsu
@Dennis Ah yes, the topic is abandoning work.
I was trying to push a mimi to th'stack of my ipad and upload it to this but I did not do it and now I'm sad.
Upgrade to Android.
4:40 AM
That sentence confuses me so much
It's a uphymism
iOS > Android
for mak*
@quartata cav-gno-fem-neu done ;)
@AlexA. lies
4:41 AM
@Doorknob OS X > Debian
more lies
@Dennis OS X > Fedora + openSUSE
Are you comparing prices or quality?
4:41 AM
Also, I no longer Fedora.
Well anything you pay for is going to cost more than free + free.
I'm pretty excited to try out openSUSE 42 though.
4:42 AM
But I maintain that my Mac is the most reliable computer I've ever had the pleasure of using.
My Mac is 60 months old and still works as good as th'day I bought it... not that good
Mine is from early 2011 and still runs like a champ. It's on its fourth OS now.
Maybe that's just because it's so bad, it can't get any worse.
16 mins ago, by Alex A.
@Ampora ಠ___ಠ
16 mins ago, by Alex A.
@Ampora ಠ___ಠ
Btw I'm buying a MacBook for uni this coming 12 month .
4:45 AM
Good choice.
@Ampora Sorry for your loss
16 mins ago, by Alex A.
@Ampora ಠ___ಠ
I just #FF0000 that as Flag Ass Spam... ugh
@Doorknob What version of vim are you using?
....I just realized that the spaceships in Spacewar! (at least, in the clone I play) are a Star Destroyer and the Enterprise.
4:48 AM
Also what is the proper capitalization of vim? Is it ViM? VIM? vim? Vim?
@AlexA. 7.4.826
@AlexA. depends on whom you ask
@Doorknob Whom asking you
@Doorknob I has 7.3 is that old
I spell it vim
@AlexA. probably ¯\_(ツ)_/¯
root@llama:/home/llama# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  aptitude aptitude-common cups-filters cups-filters-core-drivers
  libgnutls-deb0-28:i386 libllvm3.7 libmono-2.0-1 libmono-2.0-dev
  libmono-accessibility4.0-cil libmono-c5-1.1-cil libmono-cairo4.0-cil
  libmono-cecil-private-cil libmono-cil-dev libmono-codecontracts4.0-cil
  libmono-compilerservices-symbolwriter4.0-cil libmono-corlib4.5-cil
Apparently I have many many updates
but vim is somewhere in there
so even mine isn't the latest version
4:52 AM
I don't think you directly upgrade the Mac system vim. I keep hearing that one should use Homebrew to install MacVim with the override-system-vim option
@Doorknob That's a lotto mono
@AlexA. Or install an OS that makes sense
I guess I could just replace the binary in /usr/bin but that scares me
Why would you do that? Custom binaries go in /usr/local/bin (or ~/bin, if you must).
Why would I do it? Because I don't know what I'm doing.
It would be an attempt to upgrade the system's preinstalled vim.
If OS X is anything like Linux, you should never ever create, replace or delete files in /usr/bin.
5:01 AM
It's based on FreeBSD if that means anything.
I don't BSD.
I figured BSD was just another kind of Linux.
waits to be hit over the head with something
@AlexA. I finished the upgrade (not the entire dist-upgrade, though...) and vim is now 7.4.963
Assuming OS X respects the Unix file hierarchy, anything installed by the user (rather than the system) goes in /usr/local/bin, to avoid conflicts with the system's version. Give /usr/local/bin a higher precedence in the PATH and you're golden.
I usually use ~/bin for symlinks to other stuff in my ~.
5:04 AM
@AlexA. I read once that Mac OS X were Linux and believed it, so I won't throw the first stone.
Because I know stuff like node and gem use /usr/local/bin and I don't want to mess with automagical stuff :P
@Dennis It does respect the Unix file hierarchy and /usr/local/bin does have precedence over /usr/bin in my PATH.
@Doorknob If your account is the only one, that works just as well.
Why would anyone have multiple user accounts on one computer?
@Dennis Right, and it does come with the side effect that firefox is inaccessible by normal means when I'm root. :P
5:05 AM
2 mins ago, by Alex A.
waits to be hit over the head with something
(then again, it is very, very rare that I would have to run firefox as root)
@Doorknob Why would you ever have to?
@AlexA. For desktops, family computers.
@AlexA. Probably never, actually. :P
@Dennis I was kidding
5:06 AM
And with the latest version of vim in home folder, my wife wouldn't be able to use it. Not that she'd ever want to...
@Dennis Does your wife do any programming?
Couple's CJam
If you count LaTeX, yes.
She learned a little MATLAB during her Master's too.
Nice :)
@Doorknob inoremap <Tab> <C-X><C-O> bad idea?
Does that mean I would never be able to indent? o__O
@AlexA. yes
Okay. I won't do it then.
Looks like julia-vim assumes you have 7.4 ._.
5:26 AM
How was the pizza, Alex?
@BrainSteel Incredible.
We used to get eat there fairly regularly when we lived in Seattle proper. But now it's a bit of a trek.
Oooh, pizza without guilt? Sounds like my kind of pizza.
Do you usually feel guilty about pizza?
Well, it depends on how many times I've had pizza that day...
5:32 AM
Or if I have any friends who point out what I'm eating. Gah!
Friends that guilt you for eating pizza aren't true friends.
Well, they get angry at me for being able to inhale food without gaining weight, so I guess I deserve it a bit.
gets angry with you for being able to inhale food without gaining weight
I gotta enjoy it while it lasts, man.
5:34 AM
Oooh, it's 11:30. I wonder if it's time to go to the park :D
I still find it so strange that you work out in the park at midnight. :P
It's 64 degrees in December. I really think I should take this opportunity.
Have a good time! :)
> the park
I just turned my AC back on today. It was 75 in the apartment
> the
> e
@Rainbolt Good lord
5:37 AM
@Rainbolt Wow. And I thought I was having good luck. What kind of location?
Wow, just saw that a lot of bad words contain no #65.
East Texas. I have my desktop on, and it spews out hot air
Ah, that makes sense. Maybe this weather will last until 5 am...
We just got a flash flood warning a couple of hours ago
5:38 AM
What kind of hours do you sleep, @BrainSteel?
@Rainbolt Oh no! Be careful!
@AlexA. The convenient ones.
You wish you had 80˚ as I do, Brain.
@BrainSteel Uh... ok
@Ampora Wow. That is crazy.
All things in Florida r crazy so...
5:39 AM
@Ampora You're in Florida? Better go hang out with Geobits.
@AlexA. During finals week I got in this bad habit of alternating between a couple hours of sleep and twelve hours of sleep. Not healthy. We're trying to ease out of it :D
Huh. I guess you could say @Geobits is hot again.
My desktop is being weird...
I don't want that ngativity in my lif
@Rainbolt It's a graveyard!
@Rainbolt Beautiful wallpaper. Where was that taken?
5:41 AM
@BrainSteel Not healthy but sounds about right for finals week. :P
The guy is probably most well known for Fluorescence
I used to see a lot of people using it as their avatar
Oh I've seen that
@AlexA. I could've done worse, that's for sure.
USACO Silver 1 is pwning me right now
5:45 AM
@ThomasKwa What does this mean
The 1st problem in the Silver level of the USA Computing Olympiad
Sounds fancy.
2 hours ago, by Thomas Kwa
It's a programming contest
@Ampora Have you seen Eunoia? Fancy wordsmithing using one vowel at a time.
5:48 AM
Unrelated to everything currently being discussed: I really wish Xcode wasn't a 2 GB download. :/
(updates, that is)
@AlexA. I feel you there. It's quite a hassle. Is there a new update I should be downloading?
Disgusting to lay my i's on. It lacks #65 so it's hard to look at :P
@BrainSteel I'm currently upgrading to 7.2 after having been nagged about it for a while by the update reminders. :P
Greetings, fair @Geobits.
@AlexA. OS X sure likes to nag. All things considered, though, it's one of the less obtrusive update schemes out there. I don't mind it.
Oh definitely.
But I still find things to complain about.
5:51 AM
That's only human :D
How right you are, my friend.
I just realized I started a challenge and an explanation several weeks ago that I never finished.
@AlexA. ello. I've been down the rabbit hole that is Xenoblade Chronicles X. I don't see the light at the end yet...
@Geobits I don't know what that is but I'm glad you've managed to escape the hole long enough to stop by.
I got pinged ;)
5:52 AM
Sounds painful
Xenoblade Chronicles X, known in Japan as XenobladeX (Japanese: ゼノブレイドクロス, Hepburn: Zenobureido Kurosu, pronounced as "Xenoblade Cross"), is an action role-playing video game developed by Monolith Soft and published by Nintendo for the Wii U home video game console. Part of the Xeno series of video games, it serves as a spiritual successor to Xenoblade Chronicles on the Wii. The game centers on the player's customizable avatar, who works to coexist with the indigenous creatures on a hostile alien planet while striving to protect humanity. Similar to its predecessor, the game features an open-world...
So this is your hole?
5 hours later...
^ Lies!
10 hours earlier...
6:02 AM
Are they onion rings?
I can't tell if I'm sweating because I'm angry or because of the temperature. Boyfriend snores me out of the bed, and I wake up only to discover that it's 75 degrees inside.
I've resigned myself to the couch, which is actually more comfortable than the bed
Does your boyfriend have sleep apnea?
You could get him one of those mask things
I don't think so
He breathes quite well and quite constantly
That's good.
and... loudly
6:05 AM
Less good.
What does he do for work?
He teaches
Oh, no reason. I was just curious.
6:18 AM
> If an integer between -128 and 255 inclusive is provided, it is interpreted as the ASCII value of a single character (negative values have 256 added in order to allow characters in the Extended ASCII range). Any other integer is interpreted as a string containing the decimal digits of the integer.
Type casting in PHP:
@Rainbolt Try snoring him out of bed
Or just grab an airhorn
+1 to the airhorn idea
Sometimes I do
Sometimes he snores, then I fake snore, and we do this back and forth for about five minutes
Then I give up and get angry
Separate bedrooms! Why sleep in the same room if you are just going to get annoyed and if it might fray your relationship?
That's probably what will happen when we get a house
6:32 AM
I always thought it would be weird to sleep in a different bed than my significant other.
Finally finished this after thinking about it off and on since about noon today. :P
Well, I solved problem 2 in five minutes, but after an hour I still don't know how to do problem 1.
If the licensing is permissive enough you could post it as a challenge here and have someone else solve it for you. :P
Yes, that's definitely a legal way to qualify for the next round.
Oh, you want a legal way?
7:34 AM
Congrats to Mitch Schwartz for winning the second bounty on Sums of Two Squares with a streamlined 44 byte solution:
A: Count sums of two squares

Mitch SchwartzPython 2, 44 bytes f=lambda n,x=1:+(x>n)or(n%x<1)-f(n,x+2)/4<<2 This is almost the same as xsot's solution (which is based on Peter Taylor's solution), but saves 8 bytes by simplifying the way signs are handled. Note that for a full program, we can save 2 bytes in the function without incurri...

When you install an installer that installs an installer for the toolset that helps you install packages that help you install programs
By the way, has anyone seen TanMath lately?
I haven't seen them since last week
@ThomasKwa OH I completely forgot about USACO
Man, do I have time to compete?
7:53 AM
Hey guys, have fun! :D
@El'endiaStarman omg wow
Hi everyone
@xnor thank you!
8:12 AM
it's been a great journey from the earlier 70-ish byte solutions to this
cut out around a 1/3 of the characters
i'm impressed how many layers of improvement there were for such a straightforward-sounding problem
The bonus can be achieved in fewer bytes than it's worth:
A: Numbers that are actually letters

isaacgPyth, 43 - 40 = 3 bytes ?&K@J.HQG-JG"Mix"%"Only %sers"?K"lett""numb Test suite This achieves the bonus. Only numbers and Only letters fortunately only differ by 4 letters. printf-style formatting is used with %. The selection system is done by both taking the intersection of the hex with G, ...

2 hours later…
10:08 AM
The last message was posted 2 hours ago. ???
10:43 AM
@Sherlock9 You just need to start before 12pm (GMT) on Tuesday
That is unfortunate timing as I am busy right through Tuesday
Next year perhaps
12:21 PM
It's Sunday and the weather is really nice... let's get some work done on Retina!
1:01 PM
I had a pretty weird dream last night, that I had color -> grapheme synesthesia.
that one is new :D
Isn't it? :D
hm, not very interesting on the starboard
I can't find anything on meta about it (only the use of soft hyphens to circumvent the minimum comment length)
might be worth reporting
But then, when I mentioned it to someone else in the dream, they explained that it wasn't possible, so I concluded that I must be dreaming. Then it got really weird.
1:26 PM
lucid dreams are sweet
2:06 PM
@SuperJedi224 nice
2:58 PM
found a major bug in scg, has no idea how to fix
3:09 PM
oh wow the fix was really dumb
3:47 PM
@mbomb007, @NinjaBearMonkey, @randomra, @Sp3000, @TheNumberOne, @Dennis: I've just released Retina 0.7.0 with two major changes. a) single-file mode is now the default. the old mode can be recovered with -m. to fix the linefeed problem, linefeeds can be escaped with $n in substitutions or with pilcrows, , everywhere. b) I've rewritten replace mode from scratch so that it doesn't use Regex.Replace, which means I can now add more substitution syntax. :)
i like seeing how much retina has evolved. iirc originally the whole language was a way to stop people from commenting "this answer is invalid, regex isn't a language" but it's so much more than that and it's kind of beautiful
before i edited in that comma, i had accidentally written a garden path sentence. neat
now I have to work on actually making it good
3:52 PM
@undergroundmonorail thanks :)
(the list of open issues on github is still quite long ^^)
@MartinBüttner your thoughts on my language/fizzbuzz answer?
@anOKsquirrel that you should use a proper comment block instead of backticks ;)
(4 spaces of indentation, or just select it and hit Ctrl+K)
@MartinBüttner whaaat?
why so?
I'll have to take a look at the actual content later
but whyyy
3:53 PM
@anOKsquirrel just compare it to all other answers and tell me it doesn't look ugly :D
@MartinBüttner Huh, I've updated TIO and now it prints nothing...
It doesn't.
I see no difference.
actually you're right
of course, the reason for this is that a) no one uses pb b) even if they did it's almost more bug than feature at this point so why bother
Same for my lang.
3:57 PM
i'm not good at git, almost everything happens on the same branch
i've only ever merged two pull requests
this is one of them
Yesterday during my exam I came up with a neat math trick regarding dot and cross products (this is probably a widely-known trick). My question was: if I computed the dot and cross products of two vectors by hand, how can I double check it without doing the cross product a second time? Let's say that I had the vectors [1,2,3] and [1,-3,2], then the dot and cross products are 1 and [13,1,-5]. I just check that (1^2+2^2+3^2) * (1^2+3^2+2^2) = 1^2+13^2+1^2+5^2.
I'm not sure if that actually saved me any time, though.
saturday exam
:) :/ :(
4:09 PM
i have an exam on friday
it's mostly about derivatives and antiderivatives which are easy
i'm totally fucked on the part about limits though
The one I took yesterday was a combination of easy and hard.
Easy being the basic vector and matrix stuff they've retaught me for the third time.
that makes sense
Harder being the 6-option multiple choice about materials science and finite element modelling.
4:13 PM
i don't know what that means but it sounds a lot harder
speaking of thingns i don't know: where my phone is
i found it
i bet that was easier than learning materials science and finite element modelling
I don't really think my professor was that good at all.
That sucks
Mostly because he didn't really know how to use the COMSOL modelling software that our final project was based on, and had someone else teach us how to use it.
The final project was really harsh. I mean, it was meant as a weed-out type thing, but I think spending 2 and 1/2 class periods on how to use the software and then expecting us to create a multiphysics model, with research paper and presentation, was a little extreme.
@Sherlock9 I think there's still time. You can look at their website.
> @Sherlock9 You just need to start before 12pm (GMT) on Tuesday
> That is unfortunate timing as I am busy right through Tuesday
4:33 PM
@Dennis have you removed the -s from the invocation of Retina?
@MartinBüttner Yes, I have. Subtitutions print nothing, patterns never match.
that is... odd...
maybe one of my changes broke it on mono?
can you save a file on your disc which contains only . and then run echo "abc" | ./Retina test.ret?
Not right now, unfortunately. Is the .ret extension required?
it seems more likely that it's a problem with the input, not the source
the empty pattern matches
(and substitutions using the empty pattern also work)
Same issue locally.
$ echo abc | mono Retina.exe <(echo -n .)
4:46 PM
that's odd, so it doesn't read input any more ... that's something I haven't touched for a while
which commit were you using before?
Whatever was the latest when I added Retina to TIO.
oh, I think I may have made this change on the replace branch and not in master so it would have been added today: github.com/mbuettner/retina/commit/…
(this prevents Retina from blocking for input if nothing is piped in... maybe that doesn't throw in Mono if you do pipe something in)
I'm not sure how to fix that right now, particularly because I can't test with mono here...
That's the problem, yes.
using System;
class P
    static void Main()
            bool tmp = Console.KeyAvailable;
            Console.WriteLine("No pipe.");
        catch (InvalidOperationException)
this should be able to distinguish between console and pipe input
I got rid of the try block and it works now.
4:55 PM
hm, yeah, but of course that's not a good fix in the long run :P
would you mind compiling and running that program up there to check if that also doesn't work in mono?
dennis-notebook:~$ mono P.exe
No pipe.
dennis-notebook:~$ echo | mono P.exe
No pipe.
I'll ask on SO

« first day (1779 days earlier)      last day (2181 days later) »