« first day (3310 days earlier)      last day (371 days later) » 

12:46 AM
I guess everyone is sleeping :(... I voted to reopen above without waiting for input!
1:11 AM
Whoa, in a span of a couple minutes, I got nine upvotes on answers that previously had no votes. It'll be interesting to see if the system reverses that as serial voting. Ordinarily I'd assume it would. But five of the nine answers were community wiki. I don't know if or how that affects the serial voting reversal script.
@WinEunuuchs2Unix I'm not sure. When the question first entered the reopen queue, which I believe was well before your reopen vote and due to an edit (not by me), I clicked Leave Closed. But you have a fair point about how they seem different.
I guess this means I should think harder about whether or not it's really a duplicate, in light of your point about generality, so that I can vote to reopen it if I end up deciding I think it is not.
If the question isn't a duplicate, then I think that would perhaps be related to how its OP is presumably unfamiliar with standard error and not clear on why some output should be sent to standard output while other output should be sent to standard error. So I don't know if you think it would be worthwhile or appropriate but you might consider expanding your answer to cover that further.
Or maybe I should just vote to reopen it and (if it is) post my own answer covering that. I'm not quite convinced the closure is wrong at this point, though. (I'm not convinced it's right, either.)
Speaking of questions that can go either way, I'm inclined to think Are there any options for getting help with Ubuntu 14.04? should be considered on-topic and reopened.
1:30 AM
@EliahKagan On Stackoverflow it resides as it's own unique question: echo >&2 “some text” what does it mean in shell scripting but the answers aren't in simple English as I think our student would like.
I'm starting to wonder if "What does & mean?" is too broad with all the possible combinations of 1, 2 and user defined file descriptors not to mention piping to files, etc.
Do we have a question along the lines of "What is standard error?" or "Why are there two standard streams for output?"
The point of is people will google "what is >&2" and they will end up going to Stack Overflow and not Ask Ubuntu which more suited for googlers. I think another way of rephrasing your new question is "Why do Standard Error and Standard Output both go to the terminal screen?"
So would this be a duplicate too?: One=1; Two=2; echo Hello>&$One; echo World>&$Two
2:00 AM
The title of the master question makes it seem like they are duplicates, but none of the answers directly address the question asked in the dupe. Could you discern it from the master? Potentially, but there's definitely no direct answer there.
That really leaves two possibilities: reopen the first or edit the second.
The second is also asking "What does &> do?" and no one answers. The first asks "What does >&2 do?" which is very explicit and a common practice but only answered in Stack overflow.
> What is the best way to understand & and what it means exactly?
Besides not having "echo Hello World >&2" the second also doesn't have "echo Hello World >&1". So you could be editing the second question with all kinds of answers.
I don't really see a problem having more specific questions with specific answers that also link to more broad questions, so I'll throw it a reopen vote, but it'd still be nice to see the other question edited to better answer the full breadth of what was asked there.
Is the OP still active though?
NOPE not for over a year
Thanks for voting to reopen Seth, unfortunately I can't vote a second time
2:08 AM
@WinEunuuchs2Unix OP doesn't need to be active. We have a lot of leeway for shaping questions into the most useful thing they can be. Editing is great!
absolutely the most underrated feature here on SE sites.
@Seth Yeah you should see the edits on the one you just voted to reopen. I had to edit it to change the line count
@WinEunuuchs2Unix I saw. Not really sure what you were going for with that one tbh. The OP didn't have a question about 3 lines, just a small section of one line. The rest of the lines don't effect the answer either.
In other news it's been a while since I've cast a reopen vote and the question wasn't immediately reopened lol
The OP original posted one line and asked a question about one line. Then someone edited and changed one line to three lines for readability.
@Seth LOL yes you lost your hammer :P
@WinEunuuchs2Unix It wasn't edited just for readability. As written originally the single line wouldn't actually run.
That was not proper single line if syntax, but it was proper multi-line if syntax. OP probably just did not know how to add formatting.
@Seth Oh well I never actually tested the single line when I posted my answer. That didn't seem important at the time.
2:14 AM
Right, it's not. Which is why I was a little confused why you changed the question to "a question about 3 lines" when it wasn't ;)
Was a semi-colon missing or something to make it a valid one-liner?
Why don't you roll back my edit?
ack, but I'm supposed to be working on a writing assignment that does not involve bash so I should get back to focusing on that :P
Still doing Structured Query Language?
@WinEunuuchs2Unix It wasn't a big deal. At first I thought you changed the wording to get it into the reopen queue (?) which probably wasn't great. but I realize now that wasn't your intention so it isn't a big deal.
@WinEunuuchs2Unix Not recently. That class was a few years ago at this point :P
Were you the one that was interested in my hw for that class?
You offered me your text book or notes or something but I was only casually interested in SQL since 1984. Still on my to-do list just not right now.
I'm thinking of Gnome Java Script for Ubuntu 20.04 though....
2:19 AM
gotcha, gotcha. One of those todo items haha. I've got a few myself.
@Seth I messed up on roll back. I wanted to get rid of mine but I got rid of Pablos :(
nope, you're fine! Pablo's is still there. You did it right :)
Phew. GTK. I'm nervous around editing stuff.
I can understand that feeling. It feels very important and final, but there's nothing you can do that isn't easy to fix. The editing system here really is fantastically designed.
2:46 AM
@WinEunuuchs2Unix Though it's closely related, ultimately I think you are right and that it is not quite a duplicate. I cast the fifth and final reopen vote. I also added a "Related:" comment pointing to the question it was duped so, so readers are still prominently made aware of that question.
3:41 AM
Thank you @Seth, @EliahKagan and all the other voters.
1 hour later…
4:42 AM
@terdon I've removed my yesterday's comment, so feel free to remove yours now that things are edited. Fun stuff, I noticed that only by accident, because of comments under another answer, where comments almost got out of hand
Yeah, and . . . Hi . . .
2 hours later…
6:15 AM
@EliahKagan re. the changed behavior of sudo -H in 19.10, aside from updating existing answers, could this please be documented as a separate Q&A? I didn't even know anything had changed until I saw your chat message. Is this documented anywhere?
6:27 AM
@DKBose Yes, I think it would make sense to have a separate Q&A specifically about this. As for where it is documented, there is the Launchpad bug report about it, Ubuntu patch to add HOME to env_keep makes custom commands vulnerable by default. I suspect there may be other official sources of information about this change--perhaps one of the Ubuntu mailing lists?--but I am not sure.
@SergiyKolodyazhnyy hi!
They changed how sudo -H works? I want to read that Q/A when it comes out.
@Seth Well, they changed how sudo works without -H. Starting in Ubuntu 19.10, sudo resets $HOME even without -H.
ek@Kip:~$ lsb_release -d
Description:    Ubuntu 18.04.3 LTS
ek@Kip:~$ sudo printenv HOME
ek@Cord:~$ lsb_release -d
Description:    Ubuntu 19.10
ek@Cord:~$ sudo printenv HOME
@WinEunuuchs2Unix sql takes 10 minutes to learn :=)
to master it a lifetime
@EliahKagan Upstream sudo, and sudo in most other OSes (including Debian) has behaved this way for some time. Ubuntu is patched to keep the very old sudo behavior that's been changed everywhere else, because that was considered valuable by some users. The view that this was beneficial has been reconsidered and it is now widely regarded to have bad security implications.
So starting in 19.10, it's no longer patched to do that. The behavior of sudo in earlier releases will be kept the same, though a note may be added to the documentation.
@EliahKagan Would this fix issues launching GUI applications with sudo?
@Rinzwind This is very true.
6:43 AM
@Seth Yes, in the specific (quite important) sense that running commands like sudo gedit is exactly as good or bad as sudo -H gedit, starting in 19.10 -- rather than sudo gedit being much, much worse, as in earlier releases. I want to at least make sure that my understanding that the change applies in all the (common) upgrade scenarios is correct before modifying my answer about that, though.
(I don't plan to radically change the answer, mainly since people will be using Ubuntu releases earlier than 19.10 for a long, long time. But it should be edited to make note of the change in 19.10.)
@EliahKagan oh, wow, you linked to a terrific post here: stackoverflow.blog/2012/03/22/…
Hopefully it becomes a more viable solution for GUI applications. Last I checked pkexec was still a PITA to use correctly.
@JacobVlijm Indeed. This paragraph in particular is a special gem:
> As members of a community, your first loyalty should be to that community. When evaluating a question, you shouldn’t be looking to push it off on some other site; instead, ask if it could be appropriate and on-topic for you, the experts who the author decided to ask. Be a bit jealous of your site – don’t blithely turn askers away simply because their question could be asked somewhere else. Don’t hit them over the head with your scope, help them tailor their question to fit into it
^^^ this!!
@JacobVlijm Oh, in that comment. Yes, that post by Shog is a good one indeed. In this case, I actually linked it to clarify that I don't think the network-wide policy it articulates forces our hand in that particular case--that is, I linked to avoid overstating my own case.
But there are many situations to which it applies directly and fully. I've linked it on meta and in comments a number of times, though I haven't ended up doing so all that much lately.
I don't want to soapbox here, but this is something that has come up more than a few times in past months. Always remember edit, edit, edit. There are lots of opportunities to turn something into great content instead of just pushing it away.
6:50 AM
Couldn't agree more!!
A couple of examples of questions that either were or almost were closed that I managed to turn around are Where can I go for live chat support? and Please remove the installation media and press enter.
Remember we're the experts. If someone comes to us with a very basic question then we're doing ours jobs right! Answer it :D
Ok, I'm off the soapbox.
Aaaand I just tried to click the mod button on a question and it wasn't there anymore lmao. Time for bed xD
@EliahKagan TIL this. I thought that sudo behavior was standard everywhere. Do you have a source or article I could read more about why this was the case for so long?
@Seth I don't know much beyond what's commented and linked in that bug report relating to the recent change. There's some quite useful info there, though.
Part of the story of why (and when, and in what operating systems) the old behavior was kept can be found in this older bug report asking for it to be kept, but part of the story is upstream and in other distributions, especially Debian, and I don't know the details or the best sources for that.
The "$HOME changed by sudo" thread on the ubuntu-devel mailing list in February 2011 -- for convenience, here's the first message -- appears to be one of the relevant discussions in deciding to patch the sudo package in Ubuntu to keep the old behavior. (The change made in Ubuntu 19.10 has been in upstream sudo for a long time.)
7:11 AM
@EliahKagan then would you be so kind as to ask the question and answer it? It's clear that this is news to a lot of people.
Reworded to be nicer :D
In "... you should change your calling of sudo to include the -H param which will force sudo on Ubuntu to change HOME to the target user's homedir, instead of leaving it as the calling user's homedir." there's a distinction between the target user and the calling user. What does that mean if I'm the only user? Does that mean that sudo -H gedit would work as it did before?
@DKBose I think it is fairly likely that I will end up doing that. I'm going afk for quite a while pretty soon, though, so I wouldn't be able to get to it immediately.
@EliahKagan will gladly wait!
@DKBose If you run sudo without the -u option, the target user is root.
But yes. sudo -H will continue to work. One way to look at it is that the change in 19.10 just makes it so that when you run sudo without any options, it's as though you passed -H.
That is, in Ubuntu, before 19.10, sudo COMMAND and sudo -H COMMAND do different things. Starting in 19.10, they do the same thing, and it's what sudo -H COMMAND did before.
7:28 AM
@EliahKagan thanks!
This can be reconfigured globally, in either direction, on any release, in /etc/sudoers or a file in /etc/sudoers.d/ (either of which should be opened via visudo if one is to edit them).
One of the things want to do before adding information to that long-standing answer of mine or making a self-answered question about the change will be to research or test (or both) to make sure that I am correct in my belief that essentially all systems upgraded to 19.10 get the change.
I believe I have observed this to be the case, but I've never upgraded to 19.10 in any officially supported way. (On the systems I have with 19.10, I upgraded pretty early on, when it was still in development.)
8:22 AM
@SergiyKolodyazhnyy Done, thanks. And hi! :)
8:45 AM
I need one more close vote from a reviewer to close this question correctly according to the OP's self-answer as a duplicate of How to install Wi-Fi driver for Realtek RTL8821CE on Ubuntu 18.04?.
8:56 AM
1 hour later…
10:10 AM
@Seth You sure are a great user of SE.
10:23 AM
@damadam Do you have any feedback like if anything I should add or change?
I am asking to you since you're the only one who visited my site. :D
since it was the regex page that i only watch, i would say :
a summary with direct link to each part
it would help to find faster the part needed
link you can see on Wikipedia @TheLittleNaruto
another advice : you could explain why we use regex in general at 1rst (filtering informations, blocking some typing - numbers not allowed for example, ...)
and also, you didn't explain - (minus) and , (comma) rules, but you used them
@WinEunuuchs2Unix I'm still a newbie about regex x)
10:43 AM
@damadam regex is so complicated everyone gets to be a newbie for a long long time...
@WinEunuuchs2Unix when it comes to verify a mail address typed, ergh
10:59 AM
@damadam Not sure if it is there to enable on Medium; will check that out. Did you also check the 3rd blog?
/cc @Zanna
11:22 AM
@guiverc, Lubuntu's download page mentions a magnet link but the link seems to be a .torrent link: cdimage.ubuntu.com/lubuntu/releases/19.10/release/….
1 hour later…
12:23 PM
@karel @EliahKagan can you explain me why my answer on this question was deleted? After reading it a few times, I didn't understand and also, it's a suitable answer for the OP (and I just add my experience on it); I didn't got any comment before removing (posted 25/07/18 and remove 4 days ago, there were plenty of time to inform me about it). Link below :
@DKBose I've never really used magnet links so have no idea what they are (I was asked to test a magnet download once for Lubuntu; I went to piratebay to find one not knowing our site had one/some) so to me the torrent connection seems valid.. If something is wrong, I don't know enough to explain to tomreyn/tsimonq2/wxl/kc2bez so I'll need more sorry...
The answer is out of scope because it's not about Ubuntu. Ubuntu is very configurable to such an extent that's it's probably possible to get similar results by modifying vanilla Ubuntu.
just because the name didn't contain Ubuntu?
It's unlikely to help future readers. If it was a modification of vanilla Ubuntu OTOH it is likely to help future readers.
so should I modify my answer to include that field ?
CrunchEee is a lighter version of CrunchBang, that is an Ubuntu derivative using OpenBox (like LXDE); it's also a version specially optimized for this kind of computer
or is it still off-topic because it's now based on Debian (and there is not some difference between Debian and Ubuntu) ?
CrunchBang Linux (abbreviated #!) was a Linux distribution derived from Debian by Philip Newborough (who is more commonly known by his username, corenominal). CrunchBang was designed to use comparatively few system resources. Instead of a desktop environment it used a customized implementation of the Openbox window manager. Many of its preinstalled applications used the GTK+ widget toolkit.CrunchBang had its own software repository but drew the vast majority of packages from Debian's repositories.Philip Newborough announced on 6 February 2015 that he had stopped developing CrunchBang and that users...
12:59 PM
@damadam yep. In fact, the scope here is limited to official Ubuntu flavors only.
Basically, whatever you see here: askubuntu.com/help/on-topic
> Using and administering official Ubuntu flavors: Ubuntu, Ubuntu Budgie, Ubuntu MATE, Kubuntu, Ubuntu Kylin, Lubuntu, Ubuntu Studio and Xubuntu.
If it isn't listed on ubuntu.com/about/about-ubuntu/derivatives, it isn't on topic here.
It would be absolutely on topic on Unix & Linux though!
Was CrunchBang ever an Ubuntu derivative? I thought it was always based on Debian.
Jep debian based.
probably my sources were wrong, I had read somewhere that Crunchbang was initially based on Ubuntu, but they had switch on Debian after
also crunchbang is ended, there is 3 (almost a 4th one, but it's just script application that are done) successors : crunchbang++, crunchbang monara (these 2 are based on Debian Jessie) and GoBang Linux (this one is based on Ubuntu)
Until October 2010 there also was a "Lite" version with fewer installed applications. The "Lite" version was effectively discontinued after the distribution on which it was based – Ubuntu 9.04 – reached its end-of-life and CrunchBang prepared to switch to a different base system. CrunchBang 10, made available in February 2011, was the first version based on Debian.
Q: Reading stdout stream while the process is still in execution

vishnu vardhan reddyI have a python file similar to #somefile.py print("before while loop") while(True): print("inside while loop") The above program prints output to the console every 10 sec. I am executing this python file from a script file like #!/bin/bash exec 1> $"/usercode/logfile.txt" exec 2> $"...

1:36 PM
@damadam putting things somewhat differently, being based on Ubuntu doesn't make it on-topic. It needs to be an official flavor.
@Kulfy wow, many not relevant for live knowledge.
@Kulfy Ah, so it was based on Ubuntu. Huh! Where's that quote from?
CrunchBang Linux (abbreviated #!) was a Linux distribution derived from Debian by Philip Newborough (who is more commonly known by his username, corenominal). CrunchBang was designed to use comparatively few system resources. Instead of a desktop environment it used a customized implementation of the Openbox window manager. Many of its preinstalled applications used the GTK+ widget toolkit.CrunchBang had its own software repository but drew the vast majority of packages from Debian's repositories.Philip Newborough announced on 6 February 2015 that he had stopped developing CrunchBang and that users...
Cool, thanks
Scroll down to "Editions"
1:51 PM
But most of the crunchbang.org links are now broken unless maybe they're archived somewhere.
I used to visit the Crunchbang site quite a bit when I was using the Openbox session of Lubuntu 12.10+.
1 hour later…
2:56 PM
Q: how to connect to open network in linux

Aman TurateI am making a python wifi utility which executes nmcli command in linux. Issue is when i am trying to connect open network (i.e. one which doesn't have password). First time it is getting connected, but when i disconnect and connect it gives error already trying to set essid. is there a way to d...

3:39 PM
I remember crunchbang. Good distro.
3 hours later…
6:38 PM
Q: How to solve 'rsync' errors?

P. KeshavarziI have been trying to cross-compile Raspberry Pi applications from Ubuntu 18.04.3 to the Raspberry Pi 3 with Qt 5.12.5. The guide I used is from here: https://mechatronicsblog.com/cross-compile-and-deploy-qt-5-12-for-raspberry-pi/ I'm getting rsync errors at step 7, when I enter in the follow...

3 hours later…
9:20 PM
Q: Reading n lines at a time from a named pipe in Ubuntu

skr_roboI am experimenting with named pipes in Ubuntu and have no prior experience with them. I did the following: mkfifo pipe ls>pipe& cat pipe This enters a list of all files in my folder into pipe and displays them. I am trying to read the pipe 2 lines at a time. So, I want a command when executed ...

Q: Difficulty in using persistent storage for Ubuntu 18.04 live usb

na88I've managed to set up an Ubuntu 18.04 live usb with persistent storage (I have casper-rw and usbdata) but can't seem to save my settings and added software... Can anyone help?

What kind of information do I need to post a question?
From what files should I get that information?
1 hour later…
10:35 PM
@LuisVictoria In the title summarize the problem or put the error message. In the body state your operating system, version, machine specs. If you have terminal output showing command you entered and error output copy and paste that into your question. People will ask for more details as needed. There's actually a link somewhere on how to ask a question but don't know it...
11:34 PM
How many times does this answer has to be flagged as NAA before we are given opportunity to gleefully vote to delete it?
A: Setting global environment variable for everyone

user269065/etc/profile.d files are not executed on boot. I tried this in file pythonpath.sh contents: export PYTHONPATH=$PYTHONPATH:/opt/openEMS/share/openEMS/python export PYTHONPATH=$PYTHONPATH:/opt/openEMS/share/CSXCAD/python While I was able to get this to work by $ cd /etc $ source ./profile It does ...

11:48 PM
@Kulfy I think my VTC duplicate is older with more votes:
Q: How to install Java 8 in ubuntu 19.10

Itachi_Uchiha I am unable to install java8 in Ubuntu 19.10. I used sudo apt update sudo apt install openjdk-8-jdk openjdk-8-jre And got Reading package lists... Done Building dependency tree Reading state information... Done The following additional packages will be installed: ca-certificates-j...

Plus the duplicate you nominated doesn't even have the error message in it....

« first day (3310 days earlier)      last day (371 days later) »