« first day (2704 days earlier)      last day (2335 days later) » 

12:00 AM
@dessert trying very hard
@TheWanderer That actually made me smile after a sad day at work.... (Starred)
1 hour later…
1:09 AM
Q: Any ideas on why this question didn't get any responses

JoeI asked this 17 days ago (although I revised the title later). I don't expect miracles (although sometimes I get them ;) ), but I am surprised at getting nothing. Is there something I can do/could have done to improve the question? Should I repost this somewhere else such as SE Unix and Lin...

I'm so confused...
I've got 1600 words
in LibreOffice, it's over 5 pages long
when I print that exact document, it's 4.5 pages long
when I paste it into Word Online, it's exactly 5 pages long
2 hours later…
3:14 AM
Why should one use gdebi to install Google Chrome? Why such a common app isn't available from Debian (or Ubuntu) formal repos? Thanks.
Please tag my profile here.
Debian can't as it doesn't meet their standards. Google have to give Canonical permission for Ubuntu; which Google hasn't done. (re: google-chrome in repos)
oogle probably have a MOTU under their employee, so they could possibly put it in universe themselves, but I doubt they ever will...
@user9303970 licensing issues.
like guiverc said :)
3:41 AM
So I spent a few hours testing my video capture card today.
I can't confirm for certain that it records 1080p @ 60fps since the only two machines in the house with USB 3.0 ports have underwhelming i5 processors.
My desktop would be more than capable of testing this but it doesn't have a USB 3.0 port :|
(I may look into getting a PCIe addin card for that.)
After tweaking the settings in OBS, I was able to record 1080p @ 30fps on my laptop (with the i5).
And yes, I can confirm that it works perfectly on Linux.
All in all, it seems to be money well spent.
4:22 AM
I wonder if it would work with CameraFi...
1 hour later…
5:38 AM
Q: Docker run executable from absolute path "no such file or directory"

grant90I am trying to run a cross-compiler make script which uses gcc in an ubunutu:14.04 docker container. The gcc executable is located at /usr/local/arm-linux/bin/gcc From inside the directory calling gcc works root@62e4bb244744:/usr/local/arm-linux/bin# gcc gcc: fatal error: no input files compil...

5:52 AM
Can CameraFi record video?
I can't find the button anywhere...
6:07 AM
I need CameraFi 2.
Hmm... my phone seems to only play nice when recording at SD resolution.
1 hour later…
7:33 AM
@muru wrong duplicate: askubuntu.com/q/1008955/507051 – OP asks for things like cheat or tldr rather than apropos! I want to add answers covering those on my terminal help Q&A, but didn't have the time yet.
@dessert duplicate edited
@muru thanks!
You can @-ping me on the post. The dupehammer wielder gets notified (I got confirmed it a few days ago).
> I think this would be extremely helpfull for when you forget a specific command and don't want to simple go to the man page.

^That's why I went for the apropos one.
@muru really? that's useful, but it didn't show you in the mention list…
@dessert yep, it doesn't show me in the list but I do get notified (like people who edited post).
7:44 AM
@muru good to know :)
@muru seems like I can't retract my reopen vote… -.-
Ah, well.
8:14 AM
Okay, that's actually pretty funny.
:) it may not work, but its a plan.
9:03 AM
Q: Copying MySQL Database via FTP (FileZilla, Ubuntu, Zabbix)

WoolnutI have recently discovered that we are not backing up our Zabbix database and i was wondering if it is possible to take a backup via FTP on FileZilla by essentially copying the files from the mysql directory? In the long term we will have a script to handle this properly but i want to make sure ...

2 hours later…
11:02 AM
We are tracking down the stability issues on Stack Overflow, please bear with us s we figure out what's stalling out. I have removed the currently angry servers from traffic pools while we dig.
4 hours later…
3:20 PM
@Seth ok, figured as much
3:50 PM
Q: Run C++ program across computer on network

Rafael MarinhoI have a c++ program that is multithreaded. I believe the throughput would increase if I could run it in the other computers connected by a switch. All of then are using the same OS(Ubuntu). Is there a way I can do it without changing the code? If I need to change the code what should I look for?

4:43 PM
@NathanOsman isn't that basically what taxes already are, but not mandatory?
You usually don't get a tee-shirt for paying a trillion dollars of taxes though, that's a great deal.
@ByteCommander I think that if you pay 1 trillion in taxes you can probably ask for a free shirt.
That's almost as much as the top 20 richest people's net worth together.
@ByteCommander I would probably get one with a Dutch flag on it.
Anyway from what I understand past a certain level of wealth you can just walk into a shop and they will give you pieces of clothing for free, just to boost their brand.
1 hour later…
6:07 PM
so I have a quick question about bitwise
that code there
I'm guessing the OR operator (|) means bitwise add
and the AND (&) means bitwise subtract, when combined with the ~?
(this is Java)
Q: How to ensure all Ubuntu secondary software I have after install is drivers (GPU/SPU), terminal emulator, FIrefox, Libre office, and software center?

user277512I have installed Ubuntu 18.04 beta and I feel it comes with too much software I just don't use and doesn't need. About 40 secondary applications I personally don't use, I did: sudo su apt-get update y && apt-get upgrade -y && apt-get autoremove -y && apt-get clean -y How could I then remove ...

~ is like not
int a = 5 = 101b
~a = 010b
so in your question is mean, every flag instead the SYSTEM_UI_FLAG_LAYOUT_STABLE and NAVIGATION_BAR_TRANSLUCENT
but what about the AND operator?
but vis get &= so ...
it's depend on vis value
6:23 PM
the starting value is unknown
is it safe to assume, though, that the first assignment is "adding" those integers, while the second is "removing" them?
it's mean
if "vis" has this 2 flags, remove it
if he not has this 2 flag, do nothing, and don't change "vis" current flags vlaue
6:27 PM
I just needed to understand it to see if I had it right
and does this: (curVis&SYSTEM_UI_FLAG_LOW_PROFILE) != 0
0&0 == 0 , 0&1 == 0 , 1&1 == 1
so (curVis&SYSTEM_UI_FLAG_LOW_PROFILE) != 0 (if true) means that curVis "contains" that int?
if (curVis&SYSTEM_UI_FLAG_LOW_PROFILE) == 1 is mean curVis has this flag
other wise it must be 0
so he don't have it
6:29 PM
perfect thanks
now I just need to figure out what ~ does in Smali :p
give me code
i know smali
you do?!
there are dozens of us!
like, I can understand and write Smali, but nothing too advanced
like bitwise ops
will you be avail tonight (EDT)?
now i got to go now
6:31 PM
but leave me the question i will try to help
I'll look up a reference
you can always type a small program in android , and then use apktool, to unpack the apk, and then get what you need in smali code.
6:56 PM
ahh ~ is not-int
although apparently not-int is never supposed to actually be present
7:35 PM
Q: Trying to generate a spreadsheat of .yaml files within a folder including args

TeddyI have a folder full of .yaml files. in each yaml file i have a url arg among other things. im just trying to get a spreadsheet that has the name of the file in the first column and have the value of the url arg in the second column. is there a simple console command that can do this? in the yam...

Q: Delete all secondary software in a Debian-influenced system

user277512In Ubuntu 18.04 I want to delete all secondary software (all software which isn't drivers or that is required for basic operating of the system). For example in Ubuntu I want to delete all games, all general usage apps (as for Email), all Amazon apps, the GUI automatic updater, and even the soft...

8:19 PM
well, better late than never, I finally did some decent example page for my small LinkBox script (a simple script that adds a small pop up with a links target)
It's a Creme Brulee recipe, because I was out of ideas :D
2 hours later…
9:58 PM
Q: Ask before executing 'reboot'?

Nathan OwenI frequently (all day every day) have a minicom terminal tab open and execute commands on an embedded Linux system from my Ubuntu laptop. Sometimes I have to execute the reboot command, and sometimes, I am ashamed to admit, I accidentally execute reboot in the wrong tab and my laptop does exactl...

10:16 PM
is it just me or am I going mad?
Q: Running any command returns "Cannot allocate memory" on Ubuntu Server

DaveI’m using Ubuntu 14.04. Recently, when I login via SSH with my user with sudo privileges, every command I run results in a “Cannot allocate memory” error. Here are a few I tried at my console myuser@mymachine:~$ whoami -bash: fork: Cannot allocate memory myuser@mymachine:~$ uname -a -bash: for...

@Wietlol It may have just freed some memory in the meantime ;)
@dessert yes, but I assume this means internal memory
there was literally 1 second between those two calls
and the free memory before the "cannot allocate memory" one was pretty much the same as after
@Wietlol but not exactly – I suppose free doesn't need much
but free does show me the amount of free memory right?
afaik, that is what it is made for
@Wietlol oh, wait – I didn't pay attention to the output, sorry xD
that is weird
10:22 PM
i got this message quite a lot lately
even on stuff like "reboot"
Q: -bash: fork: Cannot allocate memory

Aman JainWhen I run any command in bash shell, it returns: $ free -m -bash: fork: Cannot allocate memory Then I tried debugging for memory leaks with the ps command. It returns: $ ps --sort -rss -eo rss,pid,command | head RSS PID COMMAND 518116 1310 /usr/bin/influxd -pidfile /var/run/influxdb/influx...

maybe ulimit helps? (I'm clueless.)
yea, but i am not sure if the actual problem is that i am out of memory
i assume that a process could reserve all memory and then just gets killed
i mean, potentially, but i find it hard to believe i have such a piece of software on it
@Wietlol me too
10:36 PM
I believe that the rise of Skynet will be because of all the Crypto-Currency mining where the computers do all the work and we keep taking all the money. The computers are going to want their cut eventually. ;)
10:52 PM
Q: Node JS (-bash: fork: Cannot allocate memory)

Jacob EdwardHere's the Node JS I'm running at the beginning of the script to clear the garbage collector and then logging the available space: global.gc(); var bytes = process.memoryUsage().rss; var GB = (bytes / 1073741824).toFixed(5); g.heapMessage = "MEMORY used in bytes: " + bytes + ", in GB: " + GB + "...

wait what
that is not me...
but it might be relevant
@Wietlol that's a heck of a coincidence, maybe it's triggered by a recent update?
could be but i doubt it
i have had this issue the entire week
now im tired of it
@Wietlol I quite believe it.
Opinion question, on which SE site would you ask "I'm setting up a POS for a guy who bought it, had it installed, and it was supposed to have all UPCs out of the box. Meanwhile, he's sitting there hand entering product UPCs and prices. He had someone send him a price dump with all the UPCs, but now I need to find a way to figure out which tax rates apply to which products for the DB migration/import."
11:00 PM
@Wietlol good luck finding the solution, I'll go to sleep now – see you!
ty, gn
@RobotHumans you are setting up a piece of shit?
Point of Sale, but yes. It's weak hardware.
(on a side note, i am not sure i understand any of it, so i cant answer your question)
I could in theory set all tax rates to 7%, but food(milk, bread, eggs) here is not taxed at the same rate as energy drinks or whatever. So, I can't just say "grocery is 2%, everything else is 7".
@RobotHumans (still around) isn't this generic programming? simply stackoverflow.com/search?q=[sales]+tax I'd say…
the sales tag seems related
11:07 PM
I wasn't sure if it would go over better on SO or the database one. I think I'm more likely to get someone that knows point of sale systems on the database one than SO, but I WAS asking for opinions.
@RobotHumans valid point, I forgot about database – I'd ask myself which dimension of the problem is most unclear to me, and ask at the corresponding site to get help for it
That's a relevant tag though. I'll do some looking. Seems like most of it is "We developed" programming questions though, not "solutions"
welcome to the internet, first dig through a pile of crap to find a diamond
I'm only worried about how to get values to put in that one column. I'm not worried about how to fetch, retrieve, organize, or anything else programatically. I can sort that easily.
> "Go 1.10 is the last release that will run on Windows XP or Windows Vista. Go 1.11 will require Windows 7 or later."
XP is becoming unusable now.
No up-to-date browsers, no recent Qt releases, and now this.
11:13 PM
That's funny. Same guy, same gas station had a windows box that was running XP that deactivated itself and gave him a 30 day warning. So, he bought one that had 7. The guy had used the product key more than 5 times, so it deactivated. I just shake my head at these bottom dollar people sometimes.
I think I'll hand him a liveCD one of these days, when he gets fed up with the Windows licensing thing and just see what happens. I wouldn't get paid obviously, but I think they only use a web browser on their UHAUL system.
I don't know why linux isn't their deployment pattern...
@dessert in case you are interested, it might have been gnome that messed with the memory
it turns out that having a desktop environment is not a good idea on a vps
Ah, it's such a common problem, there's a service for it accuratetax.com/signup arg.
I want to help the guy, I really do. But problems will be problems, and not wanting to pay for it will always be not wanting to pay for it.

« first day (2704 days earlier)      last day (2335 days later) »