« first day (2360 days earlier)      last day (2676 days later) » 

1:22 AM
Yes. So much this.
He also invented Go.
should i stay or should i go
It's a trillion dollar revenue in computers being complicated over the last two decades.... Think of all the jobs they created and FIAT currency they circulated :)
You should go back to polar bear :)
1 hour later…
2:45 AM
Dear funny person who tried to perform a password reset on my Facebook account,

Nice try.

fakebook is overrated (by a few hundred billion dollars or wo)
I need a new bash script to write... hard to think up new ideas tonight
@WinEunuuchs2Unix It sure is. Nevertheless, I must use it for business purposes.
@NathanOsman Understood. You have to visit the marketplace.
Speaking of work, I was sad today at work the Software Development Department at work still hasn't contacted me a month after I announced my 20 years of experience in the field to them.
And this new company that bought us out bragged how they promoted within...
...I'm not sure of the best way of expressing my dissappointment
some subtle yet obvious way
3:30 AM
What the heck? --^
@NathanOsman - I thought Marshmallow was supposed to have good standby power efficiency? 'cause I'm getting horrible battery drain. See above screenshot
3:45 AM
Actually, I'm on Nougat.
@NathanOsman And this is a clean flash of the factory image... And Wi-Fi was off, too!
Do you have any apps installed?
(Other than stock.)
Only a few. But the same thing happened before I installed any apps.
Well, maybe it's time to give Lineage OS a try, since CM is no more
sigh Why did they have to kill CM?
3:56 AM
Wow, we are getting a terrific thunderstorm here.
Lightning, booming thunder, hail, etc.
The whole works.
@NathanOsman This looks really interesting: linuxfestnorthwest.org/2017/sessions/…
4:13 AM
I was hoping there'd be a rust talk :(
4:53 AM
This one looks good: linuxfestnorthwest.org/node/4476
I was actually thinking of doing something like that with my light display.
Although, admittedly not in JavaScript.
5:15 AM
SpaceX launch has been pushed back to 11:00 PST.
Kinda stormy tonight. Too bad I didn't get a walk in.
I love stormy walks.
5:32 AM
5:44 AM
SpaceX webcast is live. Liftoff in 15 minutes.
@NathanOsman ping so you don't miss it
Yup, I got it up.
3 minutes!
The thing that really blows me away with these launches is the amount of planning that goes into them.
One of the hosts is a firmware developer
1 minute!
5:59 AM
I think you're a few seconds behind.
It's so cool how the rocket is so hot it literally lights up the entire launch area on its own.
6:21 AM
Q: Reputation reduced without any reason

Dhaval SimariaWhy my reputation is reduced by 10 without any appropriate reason? I didn't post any answer or question that I can expect downvotes. The reputation suddenly decrease from 643 to 633. I didn't shutdown my laptop yesterday and had this one AU tab open (which had not reloaded). It shows my reputa...

7:00 AM
[ SmokeDetector | MS ] Link at end of body, link following arrow in body: TestX Core - Improve your Stamina and Strength by asharagonzales on askubuntu.com
@Seth I've got image uploads to i.stack.imgur.com working in my Go chat package now.
1 hour later…
8:22 AM
Q: cp -rv * /media/usb copies 0kb files

vkubreAfter update of Ubuntu 16.04 it boots to kali linux and only in command line mode. but when I login to my Ubuntu it still shows my all files so i decided to take backup I find way to transfer those file to USB but when i connect USB drive to another pc it shows files with 0kb size the command I...

9:03 AM
@Seth D'oh!
9:13 AM
Hrm. 3DMark stopped working on my OP3.
4 hours later…
1:03 PM
Q: Please don't be too eager to delete duplicates

Jacob VlijmTo the occasion of this question, about losing rep over deletion of this one Rubbish does not belong on the site. After a question has been marked as unclear, off-topic or too broad, one might consider to delete the question afterwards. However, specifically if a question was marked as a dupe...

1 hour later…
2:10 PM
1 hour later…
3:19 PM
That's only half way :)
Someone quickly upvote me 32 times, and I am on 50.000 (DON'T DO IT, I would be a crook) <-- very necessary to say haha.
hmm 20 today, 12 tomorrow
Oh yeah, forgot about the rep crap...
Good afternoon ! :)
3:27 PM
Hey Cl
@JacobVlijm Hey Jacob ! :)
@NathanOsman ooh, nice.
@JacobVlijm and other users reading this : Have you seen my new answer from about two hours ago ? I don't wanna post it here (you know why), but it has some important and useful information I think ... :)
3 hours ago haha. You obviously have knowledge on subjects I don't have :)
@JacobVlijm 3 hours ? oh ... hahaha ... so does this knowledge deserve some upvotes ? What do you think ? :) Well, you have knowledge on other fields where I don't have any clue ... :)
3:36 PM
Yeah, that's the advantage of answering questions everyone understands (rep-wise).
@JacobVlijm Anyway ... let's hope that this will not happen more often and that Canonical does not try to catch up on Microsoft patching policy ... :D
@JacobVlijm rep-wise ? then your answers must be much, much more understandable than mine as it seems :D
You think? then I deserve 1000 upvotes on each of my answers <-- obviously kidding
@JacobVlijm sure you deserve them ! :) your answers are mostly awesome - I couldn't do that ! :)
^ I was kidding, really.
@WinEunuuchs2Unix : I tried your server version of the selectively remove kernel script, rm-kernels-server. I tried it 3 different ways: Via ssh from my working directory; Via ssh with it installed in /usr/local/bin; Via a terminal physically connected to the actual server. I always get the same error:
doug@s15:~$ sudo rm-kernels-server
/usr/local/bin/rm-kernels-server: line 55: /usr/local/bin/rm-kernels-server:: syntax error: operand expected (error token is "/usr/local/bin/rm-kernels-server:")
@WinEunuuchs2Unix : I think you are at work now. I am trying to figure out the problem.
3:44 PM
@Serg You should read my latest answer Sergiy ... this kernel might be buggy ! :)
@DougSmythies There's a syntax error. What's line 55 of the script?
@terdon : j=$(( 1 + (select - 1) * 3 ))
@DougSmythies You sure that's the right line?
Note sure, it is line 55 though.
don't know if there is some offset for comment lines or whatever.
"server" version in the above referenced context.
@DougSmythies Yeah, I was looking at the other one.
OK, the problem is the name of the variable.
You can't use select as a variable name, that's already the name of a shell builtin command:
$ help select
select: select NAME [in WORDS ... ;] do COMMANDS; done
    Select words from a list and execute commands.

    The WORDS are expanded, generating a list of words.  The
    set of expanded words is printed on the standard error, each
    preceded by a number.  If `in WORDS' is not present, `in "$@"'
    is assumed.  The PS3 prompt is then displayed and a line read
    from the standard input.  If the line consists of the number
    corresponding to one of the displayed words, then NAME is set
Change all occurrences of select to Select or whatever you like and it should be OK.
3:51 PM
@terdon : Thanks. Will report back shortly.
@terdon : Still the same error. new code segment below:
for zzzz in $selections ; do
j=$(( 1 + (zzzz - 1) * 3 ))
choices[i]=$(echo ${item_list[j]} | cut -f1 -d"!")
OK. Sorry, but I don't have time to investigate further now. I'll try and have a look after work
@terdon : Thanks for your help. I was just wanting to report back to @WinEunuuchs2Unix was all.
4:31 PM
@WinEunuuchs2Unix : The server version works fine on a desktop computer. In my case an ubuntu 16.04 Desktop VM guest on my test 16.04 Ubuntu server host.
@terdon stop breaking things
It's my fault
Good afternoon @Zanna ! :) Hi @Zacharee1 ! :) How are you ? Everything good ? :)
so you are a mod sockpuppet! :D
the retroping!
what are people's thoughts on this?
Q: Ubuntu on Dell XPS 15 9560 (2017)

pzkpfwThere are other questions about the XPS 15 (such as this one) but they all seem to be several years old and relate to an older XPS model. This question is specifically about the XPS 15 9560 released in 2017. I am considering buying this laptop and I am, as always, concerned about dual boot suppo...

I know generic hardware recommendation questions are off-topic, but this is very specific and would seem to be objectively answerable. He might not find his answer here, but that's no reason to close it.
4:36 PM
@Seth it's a pronoun that's pretty useful for referring to local objects or relvant ideas
@Seth also, I thought our policy was to avoid hypothetical questions; if you have a problem, ask; if you think there's the possibility of a problem, try Ubuntu Forums.
@Seth I agree - especially because DELL ships XPS models with ubuntu pre-installed. :)
@cl-netbox well, only a specific few, but yeah.
@Zacharee1 I'm not sure how it's hypothetical. "does this work" is pretty concrete.
@Seth I think this question is OK
we have quite a lot of questions like that, and they are alright, they have decent answers and upvotes
@Zanna that was my thought too.
so keep it
4:40 PM
it's not so much asking for a hardware rec as asking if a particular device will do a particular thing on Ubuntu - that's not POB
@Zanna good to read this opinion from you :)
and the answer will be durable, not like "buy this, it is the best thing on the market" etc
which will be out of date next month
gtg to work folks, later :)
@Zanna well, we'll have to wait until someone who owns such a machine is going to write an answer ... :)
4:48 PM
That's ok :)
Better give it an upvote so it doesn't die
Hey @ParanoidPanda - nice to meet you ! :) Good afternoon ! :) Have you seen the meta post about the tag you've created ? Makes you even more famous ... hahaha :D
@cl-netbox: No... Which tag? :D
@ParanoidPanda gnome-boxes ... the question I answered ... @jokerdino told me that you created the tag ! :)
By the way, must have been a bad day for you yesterday @jokerdino ... but next season is a new season - right ? :)
@cl-netbox It was a good night. Loss doesn't matter, if we are moving forward.
@jokerdino well, I would never ever had bet on that one ... it was Monaco ... so ... :)
5:02 PM
@cl-netbox: Ah yes! I saw it! And some other stupid guy answering it! :D
@cl-netbox: Answered? I don't see an answer from you...
@ParanoidPanda We had a discussion about it here in the chat room yesterday ... :)
@cl-netbox: Ah yes, I may have seen something about that briefly... :)
@ParanoidPanda What ? You accepted the answer ... hahaha :D
is this cricket or football? because:
5:03 PM
Oh! That one! I thought you meant the Meta post! :D
That's football haha
@Seth looks like Lionel ... :)
@cl-netbox Pep's away record not so good. So, fingers was crossed.
@jokerdino I think they need new players, some that fit more into Pep's general conceptional ideas. :)
5:11 PM
I think Pep needs to adapt as well.
@jokerdino also true ! :)
5:23 PM
@cl-netbox I added my response to that meta post.
Hello all
Linux is having huge issues with Thunderbolt DMA...
5:39 PM
@KazWolfe I wish I had a Thunderbolt interface/device to play with.... Not in the budget this month. Oh well.
My system contains a Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter which is on usb3 bus in my docking station (Dell TB16) which is attached to my laptop (Dell XPS9550) via Thunderbolt 3. I get usb related kernel error messages when I initiate a high speed transfer (by issuing wget http://cdimage.ubuntu.com/daily-live/current/zesty-desktop-amd64.iso) and the download fails. This does not happened when the Ethernet adapter is connected to a 100Mb/s switch, but only when connected to 1000Mb/s. It also does not happened with slow traffic (e.g. web page browsing). This is not a new bug with kernel 4.10, but has been going on since at least 4.7 and maybe (probably?) since forever. I'm aware of several others with this configuration (RTL8153 on usb3 behind thunderbolt 3) that have the same issue. This bug is also not specific to Ubuntu; I also get it on Arch Linux. I've also tested and seen this bug with several different models of thunderbolt 3 docks. Here are the releva
linux (Ubuntu)
Medium / Confirmed
Machine: Dell XPS 15 (9560) - released 2017 January Install: disk completely erased Ubuntu 16.04.1 installed over wireless with: - download updates while installing ubuntu - install third-party hardware - full disk crypto+luks Note 1: Installation process did not realize there exists a GTX 1050 so we are solely using Intel integrated graphics. Note 2: Installation done not on Dell TB16 Dock to isolate wireless problems alone first. First Boot: update/upgrade/dist-upgrade'd after first boot and rebooted -------------------------------------------------------------------------------- After testing wireless problems and being able to reproduce them, machine was rebooted to the login screen, and then plugged into a Dell TB16 dock. 1. Turn down wireless networking. 2. Turn up wired networking. 3. Browse things until this happens, after which the wired interface no longer works and can sometim
linux (Ubuntu)
Medium / Confirmed
@jokerdino thanks! :D
Q: How can I share Internet Connection among two Linux computers using firewire running Ubuntu 14.04?

RogerI have two computers (let say "A" and "B") that are already pinging and sshing each other via firewire, both with static ip. Computer A is connected to the Internet and I want it to share its internet connection to computer B. I have no idea of how this can be done via firewire interface. Any ide...

@jokerdino Upvoted ! :) Both - question from @Zanna and your answer ! :)
@cl-netbox :) thanks
5:48 PM
@Zanna oh, by the way, "Someone in chat told me I shouldn't have done that" ... this couldn't have been me ! :) So, who was it then ? :) I remember to having had said : Out of curiosity ... hahaha ! :D
@Zanna You're welcome ! :)
@KazWolfe Messy. I wonder if the XHCI/EHCI debate is related. Sarcasm on: I love Dell, honest I do. Sarcasm Off:
@ElderGeek No, it's DMA.
The XHCI ports on the actual machine work just fine.
@Zanna I just answered another DELL XPS question a few minutes ago. :)
@KazWolfe any similar issues reported on non-Dell hardware? Just mildly curious.
Well, so far, I'm only aware of Dell using this hardware config.
I'm pretty sure it exists wherever we go, though. This is a chipset issue, not a Dell hardware thing.
5:55 PM
Would someone like to turn that comment into an answer? askubuntu.com/questions/748760/…
@cl-netbox I believe I paraphrased what I felt had been said to me (not only by one person)
No names and no quotes. Actually I was falling asleep when I wrote that meta post on mobile, it was written in lazy mode
@KazWolfe Digging into the bug report it appears that the problem is related to the ASMedia controller support. Apparently works fine with the same technology on the Intel Sunrise Point-H USB controller
yep, sounds right. my laptop uses that for wifi control, works fine.
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
@Zanna Either I'm not parsing that question the comment belongs to properly or it's off-topic
Time to fix the oven. Back later! :-)
6:10 PM
@Zanna okay ... what do you say to the other answer under the answer from @jokerdino ? :)
Just received a chat invitation from Seth but when I click it says page not found ??
@Seth u trol
6:26 PM
@ElderGeek you are reading more carefully than me :)
@cl-netbox haha total junk
i need my grumpiness medicine aka coffee
@Zanna true words spoken ! :D
@Serg grumpy because you installed that kernel ? hahaha ... Hi Sergiy ! :) Don't forget to put some "magic" into your coffee, medicine might not work without ! :D
@Serg I need to figure out what my grumpiness medicine is haha
@cl-netbox nah, grumpy because i just had exam and also did not have much sleep
@Serg hmmm ... not much sleep again : not very good my friend, you urgently should change it ! :) Beside this, did you see my message regarding the kernel ?
6:46 PM
@cl-netbox i did but didnt.have time.to review it properly
@Zanna tea perhaps ? but serg that is british stereotype
well, sometimes i think my ukrainian stereotype aka.vodka would be.better.than coffee
git drunk && mv exam /dev/null
7:04 PM
@Zanna Haha, and again a satisfied customer leaves the building :)
That moment when a customer gets their invoice and tells you it isn't big enough and to charge them more money.
@NathanOsman O_O
That's a good customer.
7:25 PM
rip my computer fan
@Zacharee1 laptop or desktop?
it's not dead yet, but it's close
Hmmm annoying fix...
luckily, MSI uses generic parts
@TheXed nah, it's just 7 screws total
7:26 PM
yeah but you still have to take the entire thing apart...
there's a panel on the back I can take off to get to the RAM, HDD, SSD, CPU, GPU, heatsink and fan
it is already taken apart?
it's a pretty repairable laptop
Hi, I'm building a DEBIAN package. I have de "DEBIAN/control" file already and the rest of my program in "usr/bin". How can I do it, to create a file in init.d? Using a script? Where do I put this script? Thanks
7:33 PM
@MarcosAguayo I'm not sure I understand what you're asking.
A debian package is going to need all of the source within the package.
@MarcosAguayo is this using debuild or are you manually assembling the package?
I'm confused in where to install the files in order to create the SERVICE
@MarcosAguayo Adding a service, just drop it into whatever folder services go to
DEBs just extract themselves over the root, so wherever...
I want to do this when the END USER installs the .deb
@JacobVlijm yep :/
7:39 PM
So I have to create a etc/systemd/system/ inside my debian package
@Serg chocolate possibly. Hugs definitely
I think so, yeah
correction, /lib/systemd/system
Then, you need to have systemd register and (optionally) enable the service, which (I think) needs a script or a hook or something.
But that's where the files themselves go.
Thanks a lot for your help, I've been trying like 20 hours
7:49 PM
god this server is loud....
@Zacharee1 servers are like that
still annoying
and why isn't it getting an IP?
and I still don't understand why this thing has 22GB RAM, but I can only count 12 in DIMM
There must be some incompetence on one side of the screen. Your task is now to find out which side.
@Zanna slams into Zanna with biggest hugs ever
@ByteCommander well POST reports 22GB too
7:56 PM
that suggests you can't count
the modules have their values on them
I think this server has hardware RAID
You got a server?
PowerEdge 2950
gonna put ubantu on it
Is it loud?
7:59 PM
And what size? 1U? 2U?
so loud
@NathanOsman idk
it's about 5" tall
3U is 5.25".
Wow, that's a big one.
what's 2U?
I think I need a tape measure
@Zacharee1 That's not too bad then.
How many CPUs and what kind?
I think just one Xeon 3GHz * 8
that or Ubuntu Live doesn't see the second one
Nah, Linux should see the second one if present.
what's the terminal command?
cat /proc/cpuinfo
8:06 PM
grep -c proc /proc/cpuinfo
it only sees 8 cores
I'll look in the BIOS setup later
Yup. So either your motherboard only has one slot or the other is empty.
Or something.
the license key is for Server 2008 1-4 CPU
I hope it can support more than one lol
Yup. Consumer editions of Windows don't support more than one IIRC.
Usernames have to start with lowercase letters? o_O
8:08 PM
@Serg :D thanks
@Zacharee1 O_o
That isn't a Linux requirement. It must break some installer script.
I've literally never noticed that before...
I've never tried.
I know it's a server, but this is a terrible video card: techpowerup.com/gpudb/2102/es1000
Sees ATI.
Yup, it's terrible.
8:10 PM
ES1000 -- 64MB max
You'd be better off with an APU.
or my USB video card
that's at least 256MB
Did you see the video of a guy playing HL2 on an Intel Compute stick?
With settings turned to low, he was still pulling 40fps or so.
The stick is like $100.
8:13 PM
it is two CPUs
they're just both 4 core
why is everything so slow?
how do I get DIMM info?
I guess I did count wrong
dmidecode -t memory
8:38 PM
a local or public IP?
it's on LAN
default gateway set properly?
dhclient isn't getting anything
it's just doing autoassign
althought the router does see it...
it would be helpful if the source cable were actually plugged in I guess
Android makes it so difficult to open a folder in another app.
all good now
9:12 PM
Impossible, in fact. No standard MIME type and ES won't even open the one it recognizes.
@Serg have you seen Mark's latest Oxygen Not Included video?
9:42 PM
Q: Linux Ubuntu Invalid PCI Rom header signature

Marko KocicI wanted to switch to windows 10 since i have ubuntu and 10 on dual boot but accidentaly pressed suspend instead of shutdown. I was in a hurry and i pressed power button since i just wanted to shut it down. It turned back on and i manually turned it off. I did my thing on windows 10 and when i tr...

@Zacharee1 no, i haven't, but will check it. It's been pretty nice series so far
it has
10:19 PM
@WinEunuuchs2Unix : O.K. I got your selective kernel purge script, server edition, working (sort of) on a server. The issue was that the "dialog" package is installed by default on desktops but not on servers, and I did not have it installed. Servers only seem to have "whiptail" installed by default. I am now looking to into why the dialog box looks odd via an SSH connection, but fine from a physically connected terminal
11:11 PM
@WinEunuuchs2Unix : To fix the odd looking boxes when using an SSH connection, I added a ---no-lines directive to the dialog command.
cmd=(dialog --backtitle "rm-kernels-server - Version: $current_version is excluded." \
--title "Use space bar to toggle kernel(s) to remove" \
--column-separator "!" \
--separate-output \
--no-lines \
--checklist " Kernel Version - Last Access Date- Size" 20 60 15)
11:26 PM
Q: Finding all directories that match criteria, but stop checking the rest of that subtree

Adam PlocherIf I run the command find / -name "node_modules*" I would get back results similar to: /backup/2016-01-01/node_modules /backup/2016-01-01/node_modules/something/node_modules /backup/2016-01-01/node_modules/somethingelse/node_modules ... /backup/2016-12-12/proj/node_modules /backup/2016-12-12/pro...

@DougSmythies Hi just got home had to do some overtime... I'm looking into it now.
@WinEunuuchs2Unix : seems O.K. now. See all of my messages, there were a few.
Terdon's suggestion of Select worked?
I was going to suggest a $ sign in front based on some reading.
@WinEunuuchs2Unix : No, it did not work. "select" works fine. I'll have to figure out how to point you to other messages I posted here during the day. Bottom line is that servers to not have "dialog" package installed by default.
@DougSmythies I think I've read the old messages now... So line 55 wasn't the error after all?
11:36 PM
No, line 55 was not the problem. For whatever reason, it flags line 55 if "dialog" is not installed.
Got it. Would you prefer it rewritten using whiptail then?
I think it would be better for the existing installed base actually.
In the mean time I've updated the code with the --no-lines directive and I'll update the Q&A with a note to apt-get install dialog Was that the right command to install it?
@WinEunuuchs2Unix : I started to look into using whiptail, I see that some of the command options are not available with whiptail. Somehow I got back to the line 55 error when trying with whiptail.
I use apt, but yes.
OK lets stick with dialog as it is now, I'll update the code online and put in a note that they need to install dialog.
@WinEunuuchs2Unix : O.K. great. I have only deleted 2 kernels so far, I am going to now delete about 30 to 40.
Wow that is alot :)
11:45 PM
@WinEunuuchs2Unix : 0 upgraded, 0 newly installed, 79 to remove and 0 not upgraded.
After this operation, 12.2 GB disk space will be freed.
It is going to take quiet awhile.
Starbucks might be open :D

« first day (2360 days earlier)      last day (2676 days later) »