« first day (2177 days earlier)      last day (1185 days later) » 

user136984
9:00 PM
@DavidCole-GrammarPolice: I was until I found out how sour these grapes are! :D
 
@Zanna you deleted your answer to that ls question?
 
@edwinksl yeah no point
Pilot answered it... it didn't need 2 answers
is it getting a million upvotes?
 
Whenever I save a file with gedit my desktop icons disappear and the file doesn't save GAHHHHHHHHHhh
 
@Zanna yeah the question is, uhh, bad
like, do u even google bruh
 
user136984
9:01 PM
@DavidCole-GrammarPolice: Ah yes, I didn't think you were talking to my grapes there. :P
 
haha @ParanoidPanda XD
 
@edwinksl yup... I shouldn't have answered it, I'm procrastinating & trying to figure something else out :)
hey wait you can't see my deleted anwer... you must have been watching
 
@ParanoidPanda did someone say grapes? youtube.com/watch?v=MtN1YnoL46Q
 
@DavidCole-GrammarPolice if the output of the script is too fast, maybe xterm is closing before you can read it, try running it from a bash as "sh -p script" to see if there is any output
but before you run
could you post the script here?
 
I kinda think Pilot should mention that --color is irrelevant but now I'm lazy
 
9:03 PM
Yea sure one sec
gotta rewrite the script >_>
 
user136984
I need to test something, can someone post a link please and then delete it in a few seconds? Also, would be helpful if nobody commented until the message is deleted and my test is complete.
 
user136984
Ok, the same annoying bug still remains in Firefox! :D
 
user136984
If I go over the link with my cursor and then the link is removed the little thing which shows the URL in the bottom left corner of my screen remains until I hover over another link.
 
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
sudo apt install -f
sudo apt autoremove
sudo apt-get clean
@IanC
 
9:06 PM
:32318685 ?
 
I was trying to help @ParanoidPanda ?
 
I think was doing it for Paranoid @edwinksl
 
oh
 
delete all sudo from the script
since the script is root, it doesn't need to call sudo
 
It isnt anymore lmao I think the perms messed with its functioning, new name, new script, gonna run the commands again
 
user136984
9:08 PM
@DavidCole-GrammarPolice: I don't what the script is for, but why do you have clean in there rather than autoclean?
 
What's the dif?
 
user136984
       clean
           clean clears out the local repository of retrieved package files.
           It removes everything but the lock file from
           /var/cache/apt/archives/ and /var/cache/apt/archives/partial/.

       autoclean (and the auto-clean alias since 1.1)
           Like clean, autoclean clears out the local repository of retrieved
           package files. The difference is that it only removes package files
           that can no longer be downloaded, and are largely useless. This
 
Hm okay
@IanC after running sudo chown root:root /home/david/UpdateScript.sh
and sudo chmod u+s /home/david/UpdateScript.sh
it still asks for password
 
you removed all "sudo" from the script and called it like "sh -p /home/david/UpdateScript.sh"?
 
0
Q: Is data decrypted and re-encrypted by the OpenVPN server when sent between clients?

Alexis WilkeWe just created a cluster of 12 nodes and wanted to have OpenVPN for many of the communications need to be 100% secure between each computer (we do not have access to a 100% secure/private environment so we have to have encryption between computers.) So we have a setup that looks like this: ...

 
9:14 PM
@IanC It's being called by a .desktop file, would that affect it?
@IanC Currently, running the .desktop file opens Xterm for a bit of a second then closes
 
what is the command on the .desktop file?
try testing the script from bash first
"sh -p script"
 
david@david-desktop:~$ sh -p /home/david/UpdateScript.sh
W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Operation not permitted)
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)
 
do ls -l again on the script folder
 
my home folder?
or the script itself?
 
yeah
ls -l and print the line with your script here
 
9:21 PM
-rwSrw-r-- 1 root root 88 Sep 14 17:13 UpdateScript.sh
@IanC
 
this is surely a bad thing to be doing...
 
nah
its an update script
 
I agree with @Zanna
the script isn't executable though
"sudo chmod 4755 UpdateScript.sh" would set the right permissions
 
or rather bad, bad, bad permissions
 
Guys omfg
It's an update script
also it still asks for my PW -.-
 
user136984
9:32 PM
Goodnight! :)
 
goodnight @ParanoidPanda!
 
Gnight man!! @ParanoidPanda
 
goodnight :)
 
Should I ask a Q about this on AU?
 
@DavidCole-GrammarPolice it's not about what the script does, sudo was created as a security feature to handle permissions and avoid unecessary root escalation. This is a bad idea in my opinion. But since you want to do it anyways, it's fine by me. Are you calling the script as I said? sh -p /home/david/UpdateScript.sh? Does the output of ls -l /home/david/UpdateScript.sh have srwxr-xr-x? Did you remove all sudo calls from the script?
 
9:37 PM
@Zanna "moved images to i.stack.imgur" about time ;D
 
I'm making slow progress doing maintenance on my old answers haha
haha you really see everything!
 
That 1st one is the .desktop file
@IanC
 
you don't need sudo on your desktop file if the permissions are set right. And before trying to call it from desktop try to run it from bash as I said sh -p /home/david/UpdateScript.sh. If it works without asking for a password, then you go back to the .desktop file
damn, I can't figure what is going wrong with the indicator program! -.-
and the libappindicator documentation is not really the most detailed one
 
9:53 PM
david@david-desktop:~$ sh -p /home/david/UpdateScript.sh
W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Operation not permitted)
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)
@IanC
 
@DavidCole-GrammarPolice is the output of `ls -l` something like?
`-rwsr-xr-x 1 root root 0 Set 14 18:56 UpdateScript.sh`
 
-rwsr-xr-x 1 root root 103 Sep 14 17:32 /home/david/UpdateScript.sh @IanC
 
@DavidCole-GrammarPolice I made a quick search here, and apparently linux ignores suid root interpreted executables for security reasons. No workaround on this except patching a kernel. If you know C or some other compilable language you could make a program that called those commands and then set it as suid. Here is the answer I found unix.stackexchange.com/questions/364/…. I didn't read the full answer yet but the first paragraph says it
 
This wasnt a thing before
I could do it without all this
 
10:06 PM
@DavidCole-GrammarPolice what do you mean?
 
this was easy to setup before
I had this done at some point
didn't need any of this fancy permission editing stuff
 
@edwinksl nice :)
you can see my laptop's stickers here roseannastar.files.wordpress.com/2016/07/gardenlaptop.jpg
 
#!?
 
haha shebang
 
@Zanna or is it hahashbang?
:p
 
10:11 PM
maybe
it looks like something is about to occur
 
i want a sticker that says sudo apt remove python
 
noooo
chmod -R 777
 
chown -R user:user /
 
let's stop, it's not good to write dangerous commands everywhere
 
10:13 PM
I feel like there should a special flag for any modification command that is run at /
@edwinksl ur mum
@Zanna really? I had no idea....
:p
 
my bad
 
let's not pull a terdon
 
wat
 
@edwinksl lol way to get all the permissions
 
:(){:|:};
 
10:15 PM
noooo
 
@IanC doesn't work anymore :p
 
really? :O
 
they did some sort of isolation magic or something I think
 
I've read somewhere that there's a fork limit now right?
 
yeah
Ah, I just LOVE writing ¿
 
10:17 PM
just for ubuntu?
 
probably something in the kernel
 
mah freedom tho
 
you can probably bypass it with something like --blow-up-my-cpu
@IanC does Portuguese have the ¿ ?
 
@edwinksl btw apparently you can't fix /etc perms the way we thought, because sudoers file can't be read... I edited my answer, you have to fix it in recovery. I should test it really hehe
 
no, just spanish
 
10:18 PM
@IanC time to learn Portuguese then!
@Zanna lol, well at least their system is already broken. I told someone to downgrade xorg on 16.04 and I haven't seen anything saying whether it works or not
 
@Zanna oh right sudoers is there :/
 
I ****ing give up on .desktop files
 
@Zacharee1 you probably broke their 16.04
 
@edwinksl We'll have to see
wow, two Maroon 5 songs in a row
 
@Zacharee1 only slightly broken - fixed with three commands really
 
10:20 PM
@Zanna yeah, but it's already there
 
@Zacharee1 I found it! ulimit -a, there's a limit for how many processes you can own
 
lol
 
but if its a large value the fork bomb can still get your system quite laggy
 
You know what's great for speeding up Windows?
 
@Zacharee1 to help you escape homework, perhaps you want to transcribe this askubuntu.com/questions/824488/…
 
10:21 PM
Go into Ubuntu and run sudo rm -rf /media/user/windows/Windows/System32/
 
@Zacharee1 downloadmoreram.com ?
 
@edwinksl that too
System32 method is easier
truzt meh it werkz
@edwinksl hm
 
@Zacharee1 they fixed it now anyway :) and hopefully my answer is accurate... maybe I will test... what do you think guys? should I do it?
 
BLOW IT UP
 
lol
 
10:24 PM
BLOW THE TOASTER UP
 
rip in pepperonis toaster
 
haha backing up backups...
 
@Zacharee1 thanks i haven't spammed maroon 5 for a while. here we go.
 
great
 
man, I feel so (censored word) stupid right now
 
10:26 PM
@IanC so you learned something, which is awesome
 
I've been trying to track a bug, posted a question on SO, found another thing being done wrong, tested a million things to find out the bug was such a stupid thing
I was calling Gtk routines before Gtk_init without realizing it :D
 
lol
@IanC meh, you can curse here just as long as you aren't dropping f-bombs every other message
 
I'm even embarassed to answer my question on SO now
 
xD
does it have votes?
 
2 upvotes
should I select my own answer after answering it?
 
10:29 PM
you'll have to wait two days, but yes
 
I'd select the answer of the guy that tried to help, but guess selecting my own could help on further reference to it
there is an ocean hangove coming tomorrow I guess
that could mean big surf :o
 
drive-by downvoters suck
 
@KazWolfe yep
 
in other news: today's challenge. Run a linux server with no hardware to put it on.
 
10:43 PM
Let's see if WSL can handle gitlab
 
@IanC you should select the answer that solved your problem and upvote the ones that tried to help
@KazWolfe I think I had one today
 
@Zacharee1 nice :)
 
also... wtf wsl?
 
I still haven't plucked up the courage to enter the dangerous command
 
give me a good terminal pls.
 
10:44 PM
@Zacharee1 wew, top lad
 
@Zanna This one's a good warmup: rm -rf /
@edwinksl that one wasn't hard
the first once was a lot longer iirc
 
@Zacharee1 I mean the one in the question you just transcribed
 
oh :p
wait, yeah
That's what I meant :p
@KazWolfe Try PowerShell
xD
 
@Zacharee1 WSL.
 
@KazWolfe I'm just telling you that worse does exist
 
10:46 PM
really good terminal emulator for windows.
but $70
and is really just a bunch of bundled freeware tools
 
@KazWolfe or, you know, the free version right there
or is this for work or whatever?
 
> Max. 2 SSH tunnels
Do you know how many SSH tunnels I have open at any given second lol
 
oh
ew
 
> Max. 360 seconds for Tftp, Nfs and Cron
> Max. 12 sessions
^-- that's not concurrent. that's saved.
 
lol
@KazWolfe what about Cygwin?
 
10:49 PM
be right back, will go grab something to eat
 
hm. should i call lol
 
@KazWolfe look up the error code in the notification
I wanna see if it returns anything
 
windows update error
that occasionally does happen with viruses.
 
Lol
 
i kinda want to call and drop them in Ubuntu.
 
10:51 PM
BWAHAHAHA I DID IT!!
 
Can you call them and cast to YouTube with audio?
 
I did it and fixed it
 
my internet would commit seppuku
 
I was gonna say @Zanna, that would've been the first time someone's laughed in victory after breaking a system
 
it has sound too...
 
10:52 PM
The creepy robot voice?
call em
give us a transcript or something
or start a discord call with us :p
 
"Warning. Yuor hard drive will be deleted if you close this page. You have a virus. Please call technical support now. Please call the toll-free number on your screen, then press 1 to speak with an agent to stop this process. Hard drive safely delete begins in five minutes."
 
@KazWolfe wow rare person who doesn't spell seppuku as sudoku
 
it's been five minutes and my hard drive i
 
@KazWolfe My friend's been getting this one from Adf.ly
 
[connection to kazwolfe@lolcode lost]
 
10:53 PM
@edwinksl sudoku is the joke spelling, at least in my friend group. "commit sudoku"
@KazWolfe FREEDOM AT LAST
lolnice
 
[connection to kazwolfe@lolcode established]
 
@Zacharee1 surely I deserve an upvote for that hahaha
 
So I have 10,163 now....
 
Hello. Did you know that Windows is the best operating system?
 
@Zanna link meh
@KazWolfe yez iz best @_@
 
10:54 PM
If you do not use Windows, you have a virus on your computer. Please call (888) 555-1929 to fix this virus.
 
you just edited the post!
 
@Zacharee1 yes i know
 
@KazWolfe is that the number?
@Zanna I'm lazy!
 
@Zacharee1 no.
 
10:55 PM
@NathanOsman we need you to call a scam tech support site and stream it
 
see screenshot above.
 
@KazWolfe give us the real one so Nathan can call it :p
@NathanOsman is your voice effect for George live? You could use that :p
thx
 
@Zacharee1 I woud pay to see this.
 
I should star the number so mods ban you for spam :p
 
hang on no. i need a windows image on my VM.
and then replace syskey with a nice popup
 
10:56 PM
wut
 
@Zacharee1 thanks! <3 and if you approve my tag wiki edit, I'll have 200 today
 
robo-review kicking in (not really!!!)
 
replace syskey.exe with a nice little present for my call center friends
 
lol
 
haha I'm still working on my auto reviewing, I have:
First post - skip
Suggested edit - approve
Late Answer - not an answer
Low Quality Post - recommend deletion
Reopen votes - leave closed

but for Close Votes I can't decide between "unclear what you're asking" and "dupe "how do I install Ubuntu?""
 
11:03 PM
omfg
 
sleep time, thanks for approving my edit :)
 
@KazWolfe omfgw
 
@Zanna night!
 
11:19 PM
@NathanOsman someone wrote an article about nitroshare recently: tecmint.com/nitroshare-share-files-between-linux-ubuntu-windows
3
 
I feel so honored to be in a room with Linux celebs :'D
:p
Yikes
the paragraph in my essay that I didn't want to be very long, ended up being 300 words (100 longer than the rest)
oops
 
lol
 
Once you start writing, it's easier to write long stuff than to stop early.
 
@ByteCommander no, I already had stuff written for this. It was mostly copy paste and adapt
I just ended up moving some of the stuff I had for one paragraph into this one because it fit better :p
oooh, yessss. I only need to write 276 more words to reach 1k.
 
11:36 PM
Sounds intresting if you developed anything for Ubuntu: lists.ubuntu.com/archives/ubuntu-app-devel/2016-September/…
2
> Canonical Web Team is looking for testers of the prototype for the new
developer.ubuntu.com website.
 
I'm back!
 
grrr.
does aoybody know anything about ruby and gems here?
 
@KazWolfe ask @James
 
i just need to require one that won't work lol
 

« first day (2177 days earlier)      last day (1185 days later) »