« first day (1632 days earlier)      last day (1732 days later) » 

5:00 PM
Sounds like the wrong version. Try getting the latest one, I think there was a link to documentation in the SO answer.
 
bytecommander@AlkaliMetal:~$ wget bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py -O - | sudo python
--2015-03-19 17:51:14--  bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
Auflösen des Hostnamen »bitbucket.org (bitbucket.org)«... 131.103.20.168, 131.103.20.167
Verbindungsaufbau zu bitbucket.org (bitbucket.org)|131.103.20.168|:443... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 11432 (11K) [text/plain]
In »»STDOUT«« speichern.

100%[===================================>] 11.432      --.-K/s   in 0s
Sorry that the wget part is in German...
 
I would try finding the version of setuptools that matches your python version
 
How do I pipe a command output into a new text file?
 
ls > new
 
user136984
Can someone please take a look at my question here:
 
user136984
5:07 PM
0
Q: Can't hear anything from Skype and nobody can hear me

ToroidalI am using Skype version 4.3.0.37-1 on Ubuntu 14.10, and I am not able to hear anyone, and neither are they able to hear me through Skype. I had a look at the answer to this question, but it did not help, and I still have not been able to find a fix for this: Can't hear people on skype I also do...

 
user136984
:)
 
@ByteCommander See here for the full list:
7
Q: What are the shell's control and redirection operators?

terdonI often see tutorials online that connect various commands with different symbols. For example: command1 | command2 command1 & command2 command1 || command2 command1 && command2 Others seem to be connecting commands to files: command1 > file1 command1 >> file1 What are these things?...

 
Thanks, it's done.
 
@Toroidal You probably need to choose the right device in skype's sound settings.
 
What is this?
bytecommander@AlkaliMetal:~$ /home/bytecommander/ez_setup.py
bash: /home/bytecommander/ez_setup.py: Permission denied
bytecommander@AlkaliMetal:~$ sudo /home/bytecommander/ez_setup.py
sudo: /home/bytecommander/ez_setup.py: command not found
Why does sudo not find the file???
 
5:11 PM
you are not in the sudoers.file
 
I CAN sudo!
 
@terdon I made mention of the same thing
 
@ByteCommander The permission denied is 'cause the file's not executable.
The second is weird though.
 
sudo command not found should be root issue
 
It just does not find the file in sudo, but I can list it with sudo ls /home/bytecommander/
sudo is working except on this file!
 
5:13 PM
@Virusboy No, sudo was found. It's sudo that's complaining about the py script not being found.
 
I chmod +x now.
 
@ByteCommander That should fix both issues.
 
Hi all
 
hi
 
bytecommander@AlkaliMetal:~$ sudo /home/bytecommander/ez_setup.py
sudo: unable to execute /home/bytecommander/ez_setup.py: No such file or directory
 
5:14 PM
I'm guessing that since sudo found no executable file there, it looked for something called /home/bytecommander/ez_setup.py in $PATH, failed to find it and gave that error./
 
i have KAOS as my kde os
 
@ByteCommander sudo python /home/bytecommander/ez_setup.py
 
bytecommander@AlkaliMetal:~$ /home/bytecommander/ez_setup.py
bash: /home/bytecommander/ez_setup.py: python: bad interpreter: No such file or directory
want to have the cat of the file?
 
@ByteCommander Yeah. The shebang line is wrong. That's why sudo couldn't find it either.
 
run it in GUI
 
5:15 PM
@ByteCommander Just run it with python as I said. Or show the output of head /home/bytecommander/ez_setup.py
 
bytecommander@AlkaliMetal:~$ cat /home/bytecommander/ez_setup.py
#!python
"""Bootstrap setuptools installation

If you want to use setuptools in your package's setup.py, just include this
file in the same directory with it, and add this to the top of your setup.py::

from ez_setup import use_setuptools
use_setuptools()

If you want to require a specific version of setuptools, set a download
mirror, or use an alternate download directory, you can do so by supplying
the appropriate options to ``use_setuptools()``.
 
user136984
 
hmmm
that drop down bugs me
 
Ah, yes. "python /home/bytecommander/ez_setup.py" works
 
are you running any vms?
 
5:16 PM
@ByteCommander Yeah, wrong shebang. That should be #!/usr/bin/python or, better #!/usr/bin/env python
@Toroidal Yes, you'll want to change from virtual device to whatever your actual sound card/mike is.
 
Do you know why awk sorts the arrays inside itself? for example I want to extract lines 2,8,5,6,3 from a file and print them in previous order but awk gives me the sorted lines. prints lines 2,3,5,6,8 instead of 2,8,5,6,3 that I want. Is there any option for awk to disabling its Sort? thanks
 
user136984
@terdon That's part of the problem, I am unable to change to anything else, I clicked the pull-down menu, and "Virtual Device" is all that is there.
 
bytecommander@AlkaliMetal:~$ sudo python /home/bytecommander/ez_setup.py -U setuptools
Searching for setuptools
Reading pypi.python.org/simple/setuptools
Best match: setuptools 14.3
Processing setuptools-14.3-py2.7.egg
setuptools 14.3 is already the active version in easy-install.pth
Installing easy_install script to /usr/bin
Installing easy_install-2.7 script to /usr/bin

Using /usr/lib/python2.7/site-packages/setuptools-14.3-py2.7.egg
Processing dependencies for setuptools
Finished processing dependencies for setuptools
Looks good, I think.
 
@Toroidal Ah, add that to your question. That's where the problem is.
 
But still the same error for pip:
bytecommander@AlkaliMetal:~$ sudo pip install pygiTraceback (most recent call last):
  File "/usr/bin/pip", line 5, in <module>
    from pkg_resources import load_entry_point
  File "build/bdist.linux-i686/egg/pkg_resources/__init__.py", line 3023, in <module>
  File "build/bdist.linux-i686/egg/pkg_resources/__init__.py", line 614, in _build_master
  File "build/bdist.linux-i686/egg/pkg_resources/__init__.py", line 920, in require
  File "build/bdist.linux-i686/egg/pkg_resources/__init__.py", line 807, in resolve
 
5:18 PM
but sound is coming out of other apps?
 
@ByteCommander yes, that was the same version as you tried before.
Seriously though, I don't know crap about python. I;m just shooting in the dark here.
 
user136984
@terdon Ok, I've added that information to my question. :)
 
user136984
@Virusboy Yes
 
@ByteCommander you need to check if the file can be run in GUI and what the error from that is
 
@Virusboy What GUI?
How can a GUI be more informative than the CLI anyway?
 
user136984
5:20 PM
@Virusboy Yes
 
Ubuntu-desktop
I ask Terdon for reason about python
 
@Virusboy Huh?
 
@Toroidal i dont know, never seen that happen is it a bug
nvm @terdon
 
What what what? What do I have to do now? I added the new error and what I did to my question.
 
ooooo that makes sense
 
5:24 PM
And I just wanted to listen to the radio -_-"...
 
do you have multiple ones installed?
 
multiple what? explain as if I was five, please... Never had to do with python before.
(And now I know why snakes are called evil.)
 
is 2.7.8 python the one and only one installed on your Ubuntu?
 
I don't know. How do I check? It's the only one I found and python --version puts this out.
 
hrmm i dont remember
i usually check the software center
 
5:28 PM
bytecommander@AlkaliMetal:~$ ls /usr/bin/ | grep python
dh_python2
dh_python3
i386-linux-gnu-python-config
i386-linux-gnu-python2.7-config
i686-linux-gnu-python-config
i686-linux-gnu-python2.7-config
python
python-config
python2
python2-config
python2.7
python2.7-config
python3
python3.4
python3.4m
python3m
@Virusboy Got something!
 
@ByteCommander Pro tip: ls /usr/bin/python*
 
Seems like python 3.4 is also installed.
 
@ByteCommander Try running python3 /usr/share/streamtuner2/st2.py
 
IT RUNS! ^_^ =D
It prints a lot of crap and warnings into the terminal, but it runs!
 
1 hour ago, by terdon
@ByteCommander In that case, I'm guessing you're either 1) installing in a place your python is not checking or 2) installing them for a different python version. I understand that python2 and 3 are both available and use different packages.
I guess it was option 2 then :)
OK, simplest fix is to edit the 1st line of the script and change it to #!/usr/bin/env python3
 
5:34 PM
okay...
 
That way,, the script will use python3 by default.
 
Thank you finally. I think that is working now.
I hope I did not mess up the whole stuff too much by trying to repair it.
What shall I do with my question now?
 
@ByteCommander I doubt it. You seem to have gotten it back to normal. Also, I'd delete that question since the actual issue was completely different and it will be hard to debug.
 
nuked.
But I just have another problem...
Are you still fit?
No snakes this time ;)
 
Heh, try me.
I'm always fit!
 
5:40 PM
What logs or whatever do I have to check to debug logout hangs? My brother logged out an hour ago and it got stuck with his blank wallpaper.
 
(That was not the word you wanted :)
@ByteCommander ~/.xsession-errors probably
 
I went to TTY1 (black screen without any words/underscore) and back to TTY7, which showed me a redirection message and pushed me to the login screen.
That worked, because my admin user was till logged in.
When I logged out of my admin user yesterday, it was the same, except that TTY changing to 1 and back to 7 left me at a black screen (did not reload the wallpaper or redirect to anywhere) with a mouse screen. Tapping the power button then shut it down
 
0
Q: How to prevent awk from sorting the array?

KasiyAI'm trying to extract those lines from data text-file: first second third fourth fifth sixth based on their lines numbers pre-saved in nums text-file: 2 6 3 and I ended up by the following awk solution but it gives me the lines which are sorted based on their line-numbers and not according ...

 
How are you logging out?
 
So at the moment, my brother's account is still half-alive in the background.
With xfce panel plugin, let me see...
It is an xfce session.
 
user136984
5:45 PM
Come on guys! Have a break and listen to some of this! ;D
 
@Toroidal I have a break and initiate my new webradio app when that problem is solved!
 
user136984
So still no one can come up with an answer to my question? :(
 
user136984
0
Q: Can't hear anything from Skype and nobody can hear me

ToroidalI am using Skype version 4.3.0.37-1 on Ubuntu 14.10, and I am not able to hear anyone, and neither are they able to hear me through Skype. I had a look at the answer to this question, but it did not help, and I still have not been able to find a fix for this: Can't hear people on skype I also do...

 
bytecommander@AlkaliMetal:~$ cat ~/.xsession-errors
openConnection: connect: Datei oder Verzeichnis nicht gefunden
cannot connect to brltty at :0
Skript für xim unter run_im gestartet.
upstart: unity8-filewatcher-main-Prozess (3954) wurde mit dem Status 127 beendet
upstart: unity8-filewatcher-main-Prozess (3963) wurde mit dem Status 127 beendet
upstart: unity8-filewatcher-main-Prozess (3975) wurde mit dem Status 127 beendet
upstart: unity8-filewatcher-main-Prozess (3979) wurde mit dem Status 127 beendet
Nothing seems related to the logout...
 
user136984
5:53 PM
And why do we keep on getting so many of these evil crackers here...? :D :P
 
user136984
-5
Q: Which one is best

Seyed MuzammilWhich is the best wordlist for cracking facebook passwords??? Cuz if u search wordlist on google or any other their are many different types of wordlist available so which one is best???

 
bytecommander@AlkaliMetal:~$ sudo cat /home/patrick/.xsession-errors
[sudo] password for bytecommander:
openConnection: connect: Datei oder Verzeichnis nicht gefunden
cannot connect to brltty at :0
Skript für ibus unter run_im gestartet.
Skript für auto unter run_im gestartet.
Skript für default unter run_im gestartet.
upstart: unity8-filewatcher-main-Prozess (21891) wurde mit dem Status 127 beendet
upstart: unity8-filewatcher-main-Prozess (21900) wurde mit dem Status 127 beendet
upstart: unity8-filewatcher-main-Prozess (21917) wurde mit dem Status 127 beendet
Maybe the last entry in the log of my brother's account?
@terdon Still alive? Or did I shock you with my messed up machine?
 
@ByteCommander What does beendet mean?
And who uses xfce? You or your brother? The other messages were unity. DO both have the same issue?
 
beendet = exited
Sorry, there is no auto-translate for logs...
Both accounts were running an xubuntu session.
But it is the unity-greeter.
Might that be incompatible?
 
No idea. I haven't touched unity.
 
6:00 PM
Hmmm... :-/ Ask a question?
 
@ByteCommander Probably :)
 
Does the list of still active processes of my brother's half-logged-out account help?
 
Try deleting .xsession-errors, then logging out again so you can see what errors were reported
 
How do I get a list of processes for an user?
 
@ByteCommander I doubt it. Could be anything
@ByteCommander ps aux | awk '$1=="terdon"'
 
6:02 PM
Maybe it helps to see which processes were not terminated yet?
 
Try it
I'm pretty sure he has logged out and the problem is that the greeter is not coming back though.
 
More than I expected. See:
bytecommander@AlkaliMetal:~$ ps aux | awk '$1=="patrick"'
patrick  21693  0.0  0.0  74372   996 ?        Sl   16:07   0:00 /usr/bin/gnome-keyring-daemon --daemonize --login
patrick  21695  0.0  0.1   7804  2088 ?        Ss   16:07   0:00 upstart --user
patrick  21834  0.0  0.0   5696  1792 ?        Ss   16:07   0:00 dbus-daemon --fork --session --address=unix:abstract=/tmp/dbus-f4CtVhgIj8
patrick  21847  0.0  0.0  42188  1056 ?        Ss   16:07   0:00 /usr/lib/i386-linux-gnu/hud/window-stack-bridge
But when I tried to shut down as only user logged in, it also got stuck.
Then the greeter should not have come up at all, right?
So that's probably not the cause.
 
user136984
Now that is odd...
 
user136984
If I say something in () and then remove it, and then type it again, it just disappears...
 
user136984
Even if I just do "()"! :D
 
user136984
6:06 PM
How strange...
 
still there.
remove manually...
(test)
still there.
()
 
user136984
You have to do straight after.
 
user136984
So do one, then remove, and then do another one.
 
(i want to be removed too)
erm... No?
 
user136984
It has to be the same message.
 
user136984
6:08 PM
:D
 
(hellooo)
 
user136984
I don't think that that was the exact same message...
 
yep, true. It just pops away until you spell it different!
 
user136984
:D
 
user136984
Why though?
 
6:09 PM
Strange.
But does not solve my logout problem!
 
And only in parentheses?
No, parentheses aren't needed.
They must be deleting by matching the user to the text so the next one is also picked up.
@ByteCommander And does it happen with any DM or only xfce?
 
Probably they think if you e.g. accidentally posted your credit card pin and quickly delete it, they can prevent you from accidentally post it again...
@terdon It occurred only the last two times with xfce. Unity never until it started, but xfce also was working until yesterday evening.
I don't know if it's broken for Unity too now.
 
Phew, that was close :)
 
terdon what are you doing?
 
@ByteCommander Does it survive a restart?
@Virusboy Posting my pin number. Obviously :)
Nothing more secure than 1234.
 
6:15 PM
0000
 
user136984
@terdon @ByteCommander: Ok, I have posted a question about the weird message disappearing act here:
 
user136984
0
Q: Next message (if same as previous removed message) just disappears too

ToroidalWhen in chat I type something and then I delete it. If I then type the exact same thing and send it right after I sent the one that I deleted, it disappears. Why is this so? Is this a bug? Or by design?

 
user136984
:D
 
@terdon My machine NEVER survives a restart, because my graphic card will present ma a blank white screen when it is (re)started hot.
 
@ByteCommander Oh, yeah. Forgot that.
You really should look into getting a new machine. You can get perfectly decent desktops pretty cheap these days.
 
6:18 PM
yeah, I will have to convince my parents after the final exams are over... But my mother is not the one spending much money on IT stuff...
 
<--- is trying out sirius
 
Ah, close. I thought the band was spelled "Sirius Black", but that's the guy in Harry Potter...
 
Please tell me this is a joke...
 
@terdon But that it stopped logging out should not be a HW issue, or yes?
@NathanOsman If you want me to: "Nathan, this is a joke!" - I told you.
 
@ByteCommander It shouldn't be, no.
 
user136984
6:27 PM
I wonder if he's the one caught somewhere in time, or whether I'm the one caught in time and stuck with him! :D :P
 
Evening!
 
Got a vob file which I want to convert in mpeg or so... How can I do that on Ubuntu?
I tried Package mencoder is not available, but is referred to by another package. -- tried to install mencoder.
 
user136984
It's shocking the amount of nude adverts (that don't allow me to skip) I have to go through before I am allowed to watch an Iron Maiden video on YouTube!
 
6:31 PM
@_@??
 
@Toroidal Watch it ASCII format. :p
 
so its nsfw
 
user136984
Oh, that reminds me... Need to install aview! :D
 
user136984
Just a quick question about something rather annoying:
 
user136984
0
Q: apt-get does not always ask for confirmation

ToroidalI have noticed that when installing software through sudo apt-get install <packagename> it does not always give me the: Do you want to continue? [Y/n] Why is this and how can I make it so that it asks me every time? I don't think that this has got anything to do with the size of the package as...

 
6:48 PM
@pengwynn This is even cooler: curl -sG https://api.github.com/octocat --data-urlencode "s=`fortune`" | lolcat http://t.co/m7L9FC2p4e
/cc @Lucio ^
 
@Toroidal I think it only asks if the package you're installing depends on other packages as well. Since that will cause packages you did not actually chose to be installed, it asks you.
A better question is why in the world you would want to be asked for confirmation every time?
 
user136984
@terdon Because sometimes I may miss-type the package name, or just somehow accidentally get the wrong package. So a confirmation would be nice. I might also notice that the package is much larger than I expected, which could mean that I may not want to install it, or that I will need to make changes to my systems before doing so. It would just be nice to be asked to confirm before it finally installs.
 
@Toroidal I answered.
 
@Toroidal Ugh. I hate confirmation. That's so Windows: "Users are stupid, let's protect them from themselves".
6
 
user136984
@ByteCommander So is there no way then to get it to ask you every time?
 
6:56 PM
@Toroidal You could always make it a function that repeats what you typed before running it.
@Toroidal post a question about how to force apt to always ask and I'll post a little script as an answer.
 
user136984
Ok, will do.
 
user136984
:)
 
user136984
0
Q: How to force apt to give you a "Do you want to continue? [Y/n]" for every install

ToroidalI understand that when running the code sudo apt-get install <packagename> it will only give me this: Do you want to continue? [Y/n] If that package will install additional packages. But how do I force apt to give me that confirmation dialog every time that I install a package no matter whethe...

 
0
Q: Nginx - access from a public ip address - ubuntu 14.04

ArcherAn nginx server is up and running locally on my system[ubuntu 14.04]. But i am having difficulty accessing the same server from my public ip address, or from any other system using my public ip address. I have just started looking into nginx, its been great, but am stuck at this point now. I...

 
@Toroidal Related to your issue, is it true that sometimes even I'm asked [Y/n] if i press Enter, the installation is aborted.
 
user136984
7:09 PM
@IonicăBizău Well, if anything else is typed instead of 'Y', even if that is nothing, then it should abort.
 
@Toroidal I will edit my answer after diner. I found something interesting!
 
user136984
@ByteCommander Ok, what's for dinner? ;D Broccoli?
 
@Toroidal No, just enter. It happened to me many times. Actually when doing upgrade.
 
user136984
@IonicăBizău No, that's what I meant, if you type nothing and then just press enter, it should abort. Probably a bug if it does not.
 
@Toroidal Do you want it to just show you the command you ran and ask whether you want to run it, or do you want all the info from apt?
 
7:12 PM
@Toroidal [Y/n] isn't supposed that Enter means Yes (default)?
 
user136984
@terdon All the info from apt would be preferable.
 
user136984
@IonicăBizău Enter should abort, and always does with me... I think... Oh dear! Now I'm starting to doubt myself! :D
 
@Toroidal Hmm... Isn't that a standard? Enter will run the default one (the one with uppercase): Y/n + Enter == Continue, y/N + Enter == Stop, y/N + Y == Continue and Y/n + N == Stop. That's everywhere... Isn't it?
 
user136984
@IonicăBizău Well, even if pressing enter without entering 'y', is meant to pass a confirmation, it just doesn't feel right... There should be only one confirmation option, and it shouldn't be as easy to type as just enter.
 
I'm getting some strange errors from dmesg on a new Ubuntu Server installation:
Failed to start unit user@0.service: Unknown unit: user@0.service
Glares in systemd's corner...
 
7:19 PM
@Toroidal Just pass the -y options. :)
 
Somebody please reject this: askubuntu.com/review/suggested-edits/391239
this is getting out of hand.
 
@muru I rejected it.
 
@NathanOsman thanks.
 
Ouch, not only did he get mplayer wrong, that would have been a bad tag excerpt even for .
Why do people thing that tag excerpts are used for defining things?
 
@terdon probably because he's hunting for that tag badge
i rejected two others for simply copy-pasting content from wikipedia without attribution
 
7:37 PM
Well I installed the latest build of Windows 10 and now my sound doesn't work... :-D
 
@TheX Maybe it will work if you install Ubuntu in a virtual machine. :p
 
user136984
Can someone please accept my edit for this tag. :)
 
@Toroidal link?
 
user136984
The "this" should be the link.
 
user136984
 
7:40 PM
Yeah, there was an "edit pending" I had to click on.
 
@IonicăBizău wouldn't surprise me... lol
 
user136984
@terdon I see no such button so would not be able to give you a better link I don't think... :)
 
Why does that tag exist anyway? It's an awful tag!
 
user136984
@terdon I created it because I could think of no other tag for one of my questions! :P :D
 
@Toroidal Oh. Well, that's a classic meta tag. It gives no useful information at all. Why not tag it with the name of the specific piece of software you are asking about?
 
user136984
7:44 PM
@terdon There was no tag for that software that already existed and for some reason I didn't think of making a tag for that software! :D
 
@Toroidal I retagged for you :)
 
hey. me still feeling lousy.
 
wat
oh nvm.
 
hey
 
8:05 PM
Rinz! what can we do to make you feel better?
 
nothing
 
Why nothing - nothing is the worst!
 
flue. sore throath. haven't slept a decent amount of hours since sunday
 
sssssh - that's too bad... the flu is around all over the place here.
 
haven't eaten any solid food since sunday either. living mainly on soup
haven't had flue as bad as this one :(
ever
and nothing seems to work :*
 
8:07 PM
Everybody appears to have it except me... I'll get in a weeks time when my holiday starts.
ClamAV won't help either.
When I was a kid somebody recommended the "Hat therapy".
Put a hat on your feet and drink so much rum until the hat disappears.
 
just had a nice chinese chicken soup :)
 
I dont get the flu
I get the cold
 
Aren't Chinese chicken the promotor of the Influenza virus?
 
@Takkat No, we are. You're thinking of avian flu.
Influenza is just the flu.
 
oh yeah - I remember faintly... it was the birds that had to be killed everywhere.
 
8:10 PM
@Takkat :P
 
Only that the flu did never come (they said it was because they killed all the birds)
 
if I die from it you can have my rep :=D
 
tsk - rep does not matter nowadays...
 
@Rinzwind Get some nice licorice tea and add a quarter teaspoon of cinnamon and a tablespoon of raw honey. Not only is it supposed to be really good for you it is quite comforting.
 
ok gonna go afk. screen hurts my eyes :P BB
@Seth tried all kinds of tea :( and milk and painkillers.
ok gone :D
 
8:12 PM
stay in bed and don't go to work
 
@Rinzwind but you didn't try that, did you? :D
 
@Seth It seems to be reopened now and someone's already voting to close it again :|
 
@NathanOsman Oh, I meant Vote to resolve, i.e. upvote the answer so the question gets marked answered by the system, not reopen. Thanks though!
 
Is @Toroidal gone already? I'm just writing an epic answer on his question...
Is someone with bash scripting knowledge here? I would like to pimp the command I found a bit. It contains sed and I would like to split its output (2 lines) and write a text at the beginning of each line.
sed -n -e 's/Need to get \(.*\) of archives./\1/p' -e 's/After this operation, \(.*\) of additional disk space will be used./\1/p'
Hi back Toroidal! o/
Who can I ping for that one? Know a good basher?
 
user136984
8:40 PM
@ByteCommander I'm back! ;D
 
Lol this build of Windows 10 is as buggy as a cockroach crawling up your pants...
4
 
user136984
@TheX Eww... :D :P
 
Just consider it for a moment :-D
 
@Fabby May I ask you for a hint for a bash script?
 
Go ahead...
Don't forget that I'm a beginner too!
(~1 year of experience now)
 
8:44 PM
A sed command gives me two lines output:
(two file sizes)
I want to write a short text before each file size to describe it.
 
I don't know sed yet... Haven't read that far in the Linux admin manual yet...
 
(sed command is written above ^)
 
what's the output?
 
Example:
bytecommander@AlkaliMetal:~/bin$ ./apt-install-checker.sh sudoku
28.4 kB
106 kB
The two sizes. I want to change it to something like:
Download size:  28.4 kB
Installed size: 106 kB
 
is cut good as well?
 
8:47 PM
Just piping the output above into something that splits the lines and inserts the strings at the beginnings.
I don't know?
 
mmh... lemme think for a minute
 
SCREW YOU GNOME3!
 
Is this helping?
83
A: How to slice an array in bash

Dennis WilliamsonSee the Parameter Expansion section in the Bash man page. A[@] returns the contents of the array, ":1:2" takes a slice of length 2, starting at index 1. A=( foo bar "a b c" 42 ) B=("${A[@]:1:2}") echo "${B[@]}" # bar a b c echo "${B[1]}" # a b c

 
YOU BROKE MY FIREFOX.
 
8:51 PM
above my knowledge level I'm afraid...
:(
 
Damn... The Array slicing thing does not inspire you?
 
... and it also broke Unity? WTH GNOME3!?!?
All of the desktop icons are gone and I can't right-click on the desktop.
ARGH! Why did I think it was a good idea to install it :P
 
@RPiAwesomeness Evil gnomes:
 
@ByteCommander Indeed.
 
Any knowledged bash-scripters in here??? PLease!
 
8:55 PM
Relogged and it's fixed...at least for now.
Ugh. GNOME 3. Y U HEF BE BAD?
Is it safe to remove Empathy?
 

« first day (1632 days earlier)      last day (1732 days later) »