« first day (1258 days earlier)      last day (2103 days later) » 
00:00 - 16:0016:00 - 00:00

Dan
4:00 PM
emails are sent as a digest, as opposed to a "push notification" of some sort
 
thanks Dan
 
@WildMan emails are only sent if you don't check your global inbox for a time, 3, 24, 48 hours
 
I still do not receive hardly any notifications at the top of Askubuntu anymore either, so I have to go looking to see if some one has replied.
 
@WildMan make sure you don't have your inbox dropdown open in any tab.
 
Okay I will thanks
 
4:04 PM
@terdon didn't they fixed that?
 
@Braiam not sure, I don't think so:
9
Q: Make the SE menu close when the tab it is open in is no longer active

terdonWhen I click on the Stack Exchange menu to get at my Inbox and click on one of the links, it will open on a new tab which is great. However, the menu itself will remain open in the original tab which means that I won't receive notifications of new messages until I remember to return to that tab a...

 
@terdon maybe it needs a bounty ;)
 
@Braiam why, thank you kindly sir!
 
Debian operating system means?
"Debian GNU/Linux 7"
 
@AvinashRaj Debian Operating System
 
4:12 PM
Actually, I'm not sure this is still an issue. I just noticed something. @Braiam, could you send me a message to test this please?
 
there's no hidden meaning
 
then @Braiam
OT
0
Q: Grub takes a long time to load and then it says no such device

ChuckNorrisI have a big problem with grub. After installing it I only get GRUB loading. After 1 minute I see a "Welcome to GRUB" After 10-20 minutes I see "No such device: UUID" I tried to repair this with boot-repair but it did not help. (Log http://paste.ubuntu.com/7068131/) I think it is related to ...

 
@terdon ready?
 
@Braiam yup
 
@terdon there
 
4:17 PM
@Braiam damn! It works and I had the menu open! They must have silently fixed it and you wasted a perfectly good bounty :( Sorry
 
meh
 
@AvinashRaj that one is worthless, unclear is the way to go... if he reads your comment fine, but that doesn't have the potential to drives traffic
 
@Braiam from that question, it clearly shows that he is a noob.So we have to redirect him with solution.
 
@AvinashRaj read terdon comment, being noobish is not excuse that you can't ask a reasonable question. Maybe he's reading that question but it fails somehow, and then the dupe wont help
 
4:23 PM
PPA's are always must be start with http://ppa.launchpad.net, am i correct?
@Braiam ^
 
@AvinashRaj not necessarily, a PPA can be hosted elsewhere too
 
depends, you are talking about the product PPA which is hosted in Launchpad or a Personal Package Archive?
 
@guntbert please give me some ex
 
sorry, I haven't used one but in principle there is no such restriction
 
4:30 PM
@karel pasting spam ain't ya? askubuntu.com/a/432328/169736
 
4:44 PM
 
reads question Why? Just why? D:
@terdon You run Debian right? Do you use gnome?
 
@Seth I run LMDE (Linux Mint Debian Edition) which is basically a pimped out Debian testing and Cinnamon. Why?
 
Hm. Just wondering if you could test something for me, but it requires the default gnome-settings manager.
Maybe I'll make a Debian VM to test it.
 
ponders why Seth don't ask him if he has Debian
 
@Seth I did test actually :) I don't have the fingerprint image files if that's what you're wondering about
 
4:58 PM
@Braiam I know you have Debian, but I thought you ran Openbox...
 
Dan
Should this question be cleaned? All that extra info is somewhat confusing. The problem was the second command after && was missing sudo
 
I think @Braiam's answer is spot on though, you have all sorts of images installed by default since the package cannot know what hardware you have or, even more so, what hardware you might acquire
 
@terdon Actually, I was wondering if this worked since that option doesn't exist in Ubuntu.
 
@Seth can't help, I no longer have access to machine with a FP reader
 
I was just wondering if the option existed, but that's ok, I'll test it myself.
Wow, debian-gnome is big.
 
5:02 PM
@Seth IMO, fingerprint options should appear in login/security/users sections
 
@Braiam actually, that should be login/false-sense-of-security/users :P
 
Oli
@JorgeCastro I am now for a little bit
 
Interesting. Seems the feature has been pulled in recent versions of gnome.
 
5:28 PM
I've seen this question several times already askubuntu.com/q/432100/169736
 
Yay, an Eliah answer.
 
--^ How I feel like editing a big post
 
Ell
5:48 PM
Afternoon everyone :)
 
6:09 PM
Friends my hard work
0
A: How can I fix a 404 Error when updating packages?

Avinash RajAutomated Removal of 404 Not found PPA's through script This is a script to remove automatically all the 404 Not found PPA's.Copy the below code and paste it into a file and name it as ppa-remove. #!/bin/bash [ -f /tmp/update.txt ] && sudo rm /tmp/update.txt; tput setaf 6; echo "Initializing.. Please Wait" || echo "No...

@fossfreedom ^
 
@AvinashRaj what is this supposed to do? echo "Initializing.. Please Wait" || echo "No update file"
 
@terdon i want to remove the update file and like to display "Initializing.. Please Wait"
only
For && part we must have to give || part
 
@AvinashRaj the || after the echo will only be run if the 1st echo fails. What's the point?
 
so i did that
@terdon plz correct that mistake only
 
I can't because I don't understand what you are attempting. WHen would you want the "No update file" message to be printed?
 
6:22 PM
no
is that possible to remove the || part
only
 
@AvinashRaj yes, that part is just irrelevant. I think what you want is this:
if [ -f /tmp/update.txt ]; then
    sudo rm /tmp/update.txt;
    tput setaf 6;
    echo "Initializing.. Please Wait"
else
    echo "No update file"
fi
@AvinashRaj good work and +1 by the way!
 
i will correct my code
plz give me some min
 
@AvinashRaj One more thing, uniq needs files to be sorted, use sort -u filename instead.
This is less important, but for next time, you might want to consider generating a temp file with mktemp instead of hardcoding the name, you never know, the user might already have a file called /tmp/awk.txt and your script will overwrite it.
 
@terdon
sudo rm /tmp/update.txt; tput setaf 6; echo "Initializing.. Please Wait"
this is enough
 
@AvinashRaj yes, all I'm saying is that to print a message when there is no update file, you should use something like what I pasted above.
There's nothing wrong with the code, it just won't print that useful error message the way you had it
 
6:32 PM
@terdon
i have to use sort -u filename instaed of uniq /tmp/awk1.txt
so it will be
sort -u /tmp/awk1.txt
am i correct?
 
@AvinashRaj yes
Or sort /tmp/awk1.txt | uniq > output.txt
 
@terdon i edited.
now it seems to be ok.I think.
 
6:48 PM
@AvinashRaj yup :)
 
@terdon Thanks for your help:-)
BBT AU :-)
 
Ell
Afternoon
I have an issue with file permissions
for some reason llvm won't allow me to make install into /usr/local after I have given myself rwx permissions with setfacl and I'm not sure why :/
file INSTALL cannot set permissions on "/usr/local/include"
But I don't know why this happens because I can do touch testfile inside /usr/local/include :S
 
7:05 PM
@Ell please don't do that. Anyway, what's the output of ls -ld /usr/local/include
 
Ell
@terdon Why not? And drwxrwxr-x+ 2 root root 4096 Mar 10 19:03 /usr/local/include/
 
@Ell just cause it's never a good idea to change permissions on a system dir, it is also never really necessary. Why don't you just do sudo make install or whatever you are attempting?
Anyway, you don't have write permissions or have you only given them to your user specifically via setfacl?
 
The beauty of StackExchange
1
Q: mounting bongos skin: which side

NiccolòI am replacing a bongos skin and I know that the smooth side of the skin should the one to play on. Problem is that I forgot to check and now the skin is already wet and both sides are smooth. However I can tell by the darker spots of the skin which side was actually the external one when it wa...

 
Ell
it's a pain to do sudo every time I want to install compiled programmes and I trust myself enough to not mess things up :)
@terdon I have. Here is getfacl /usr/local/include
# file: include/
# owner: root
# group: root
user::rwx
user:elliot:rwx
group::r-x
mask::rwx
other::r-x
(I am elliot)
I'm not sure if my setfacl command was correct, I only just discovered it
and can't believe I've been using regular unix groups for so long :P
 
@Ell the problem is not you but a malicious or just dumb third party program that attempts to do something dangerous and will be able to because of those permissions
 
Ell
7:11 PM
@terdon That is a fair point, but nothing of any importance is in /usr/local by default
so if something were to destroy it, I can repopulate it
 
@Ell strange. I guess that should work but there are weird things about facl that I've never been sure about.
 
Ell
in addition to that, I'm the only user of this machine so if something malicious gets hold of /home/elliot it'll be a fresh reinstall anyway:/
@terdon Okay, thanks anyway, I'll google some more and if I find a solution I'll post a question on Stack Exchange
I forgot what the quick link for ubuntu was :P
 
@Ell huh? post it here or on Unix & Linux
no, ubuntu.se: Ask Ubuntu
 
Ell
ah okay
 
@Ell actually, it sounds like what you are doing is trying to change the permissions of /usr/local/include, not write to it and only root or the owner can do that irrespective of what permissions you have set
It is probably making sure that the default permissions are correctly set or something
 
Ell
7:15 PM
Yeah I thought I read that but then I wondered why llvm would want to change the permission on install
maybe I'll just make myself the owner of /usr/local
hmm
 
@Ell why not just use sudo? There are likely various programs that expect specific permissions (I can think of ~/.ssh off the top of my head but there may be reasons for it in /usr/local as well)
 
Ell
It's a pain having to sudo any time I want to build libraries, etc. :/
but I want to keep my sources in /usr/local/src because I feel that's the logical place they should be
but I'm building new libraries all the time
 
Well, traditionally, you would have your stuff in something like ~/src, normal users would never install anything to /usr/local
 
Ell
I want to separate my dev stuff from my personal stuff
I guess ~/src isn't so bad
but then I'd want to separate 3rd party from my own dev
and I can't think of a nice name for that :P
 
3d party could go to /usr/local just use sudo for it :)
You could always set up sudoers to not ask for a password and make an alias like mkins='sudo make install'
 
Ell
7:28 PM
Yeah
I guess I'll just make a ~/dev folder
and put third party in usr local
 
That's what I have for the few times I write C stuff
 
8:24 PM
0
Q: Remove the link to the video tutorials from the help pages

BraiamDue recent changes to our help page I took a peek what was written there too. I found there was a link to some video tutorials, I checked out that was linked to meta.AU, and was in the disposition of watching some just to find they has been deleted of blip.tv. This produces some frustration of ...

 
9:01 PM
MOAR GIF'S FOR THE PEOPLE!!!
 
9:17 PM
@Alvar NOOOOOOOOOOOOOOOOOOOOO ;)
Seriously though, gifs can be added already. I don't see the point of that request.
 
What are we talking about?
 
-1
Q: Video tutorials on Ask Ubuntu

AhmadgeoThis is a feature request to suggest adding a Video Tutorial section on Ask Ubuntu. Primary target would be including videos to explain most common tasks like Installation, WUBI installation, identifying wireless card....etc Also; when -for example, I provide an answer on a question. User who a...

 
Oh that.
 
I don't see how it's even relevant to AU, that should be a request on Canonical's site. Nothing to do with SE
 
gifs can be useful, but in very limited circumstances.
 
9:23 PM
And they can already be added, just like any other image.
 
yep.
In my 200 answers, I've ever only found a use for them once. And that was because I was too lazy to type out the entire thing.
 
@Seth you seemed kinda lost there at first :)
 
@terdon he's taking his time :P
 
@terdon Nah, I was just trying to highlight certain bits (since there was no audio)
 
There is a general trend towards video tutorials and I, personally, really hate it. I don't think I've evr watched one in its entirety and whenever one of my search results is a video I just skip to the next. Now, that might be cause I'm older than the internet but that's how I feel.
@Seth and thank your favorite deity for that! Can you imagine what AU would become if all the newbie script kiddies started posting videos?
 
9:42 PM
well I've never created a GIF so that's why I've never used it..
will try it when I have the time O_O
@terdon What I meant by that answer is that a gif is a better solution than a video.
I saw your link terdon, will try it when I have the time ...
 
@Alvar I thought you meant a combination of text and animated gifs
Otherwise, the same issues with videos apply: can't search, can't edit
 
@terdon I meant that you can have a long tutorial of text and then a gif at the end doing the procedure and showing what it should look like
in my mind that is better than a video, because there is no room for audio.
 
@Alvar That's fine, that's what I thought you meant. However, that has nothing to do with the meta proposal. You can do that now, nothing new is needed
 
@terdon I meant it as a solution to using videos since videos create a lot of problems, and gifs are a better solution to the problem.
but I guess we agree now :P
well everyone can post videos now too, they will just be flagged as link only if they only post a video.
My idea was that this should improve a post and not be the base of the post... which is a big risk ...
 
@Alvar sure, it could improve it I guess, but nothing new is needed, the functionality is already there.
@Alvar you might want to link to that old solution you found. Someone might be able to fix it
Also, if you add an example file, I could try a couple of things and see if they work
 
10:04 PM
@terdon I didn't find an old post it was just an idea of what could happen with a post.
 
@Alvar I was talking about your Smarty question
Sorry, that was not very clear :)
 
oh
no it wasn't xD
@terdon done
 
@Alvar cool, can you give me a short smarty file example so I can play around with it? Just in case I figure something out. Also, I take it that changing editors is an option, as long as it is a straightforward, simple editor like gedit? (I've already found solutions for vim and I'm sure emacs can do this but I won't suggest them :)
 
10:28 PM
@Alvar I was about to tell you that your solution works when I saw your answer :)
The chmod shouldn't even have been needed, it was already executable for me
 
10:39 PM
well it was there in a tutorial I found when I googled , I ran it and it worked, but whatever it doesn't hurt.
like some people who use sudo apt-get update before installing a program, you don't have to but it doesn't hurt...
@terdon updated the answer a lot now, included the files...
 
@Alvar I'd upvote you but I already had. I tend to upvote self-answered questions as a matter of course. Anyone who took the time to come back and post their solution to help others deserves a vote.
 
well only if it's good enough to help others
been thinking of making a guide about BankId, it's a swedish way of identifying yourself. It's probably not only swedish people that use it, but it's quite hard to get it to work.
instead of using a random password for one time usage each time you log in you use a file on your computer. it's easier and harder at the same time, but it can be used as ID on other sites as well. So It would be a great guide for people who use it. Found a guide for it after I searched for several days. but it was a long time ago and haven't done it on this ubuntu install yet ...
I write too much.
 
:)
 
11:14 PM
thanks @Braiam that was left from rev 1, I thought I fixed that... :)
 
@terdon actually they can... meta.askubuntu.com/questions/5622/…
 
@hbdgaf ah, but no sound! Also, those are gifs, not videos.
 
@terdon potato potaaahhhto
still, i take your point. i think you see mine too ;)
 
@hbdgaf o no! Videos: 1) have sound 2) are much heavier 3) need plugins or 4rd party software
Anyway, the conversation was about including videos, as in implementing that into the site somehow. And I am dead set against that for the reasons outlined in my answer here
 
embedding youtube or whatever would be bad... but motion pictures is fine. it was settled a long time ago. you can still link to vimeo or wherever, but it's not EVAR going to be an embed.
i think i actually linked to vimeo once with a proof of video...
 
11:34 PM
@hbdgaf yeah, my argument is against implementing some special function for this. Last thing we want is for people to start posting videos instead of answers. Can't search'em, can't edit'em, they're no good for stack exchange.
 
i agree... and i always have. it's a nice tool to have, but it would develop poorly.
 
00:00 - 16:0016:00 - 00:00

« first day (1258 days earlier)      last day (2103 days later) »