« first day (3276 days earlier)      last day (32 days later) » 

12:22 AM
I gave up.
Restoring my backup and moving on.
 
My first rule of thumb is if it's working don't upgrade
 
It needs to be upgraded though.
For security reasons.
 
My second rule of thumb is clone the partition, upgrade on the clone and test for weeks. Get sick with the clone upgrade and wait until next years upgrade.
 
But, I can't for the life of me see what went wrong.
I upgraded from 16.04 to 18.04, and BOOM! PHP no longer works.
This, despite everything I can find indicating that nothing whatsoever is wrong.
 
My third rule of thumb is to not upgrade for security reasons :P. I upgrade for functionality and features. There will always be an attack of the week exposure. Look at the last round with reptoline it was a theory of memory leaks, no actual virus existed.
 
12:24 AM
No useful errors in the server log, nothing wrong with the configuration files, just random magic.
 
Perhaps do a fresh install of 18.04 instead of an upgrade and migrate your data over to it?
 
@WinEunuuchs2Unix Features are my primary motivation, honestly, but security as well.
@WinEunuuchs2Unix too much work, seeing as I'm one man.
Too much on my plate.
It could be done, but I'm not in the mood to wrangle with it.
 
@RolandiXor I kind of think NSA is the biggest spy and the criminals are second place. Can't stop the NSA with their budget so why bother with security.
 
@WinEunuuchs2Unix I sort of feel that way too lol
But, I gotta be honest... sometimes, the errors I come across really tick me off - just in general.
Technology DOESN'T have to be this complicated and confusing.
People CAN do better.
 
I'll use the same password on hundreds of websites which I remember. I shake my head at the people that make up special ones site by site and have to write them down on paper and slide into their desk drawer.
 
12:27 AM
For instance, if everything is in place as it should be (I checked configuration files, logs, etc), and I've followed the documentation word for word - then wth man?
Sorry for my rant.
 
sudo apt purge php then sudo apt install --reinstall php
 
12:45 AM
Didn't work
I'm telling you, it's magic.
 
1:01 AM
I don't know what to say learning Personal Home Page (PHP) and Structure Query Language (SQL) and HypeText Markup Language have been on my to-do list for decades but I'm kind of slow... still on grub, kernel and just started putting icons on any monitor...
 
1:24 AM
lol
 
Actually at little bit further, just got cron to call bash to download websites each morning and email me price changes. But still a long way from PHP and SQL.
 
2:00 AM
I only use PHP and even Javascript when I have to. I'm more of a HTML + CSS guy.
 
Still haven't got into those Complicated Style Sheets (CSS) yet either :)
I dunno only so many hours in the day so you have to pick and choose your battles. Besides I have my day job at the warehouse.
 
0
Q: Can't Start Fail2Ban

kyoLately I got 3 emails from Fail2Ban The jail nginx-http-auth has been stopped. The jail nginx-badbots has been stopped. The jail ssh has been stopped. Then I start SSH into my VM, this is the log └── tail -f /var/log/fail2ban.log 2019-09-17 21:06:06,201 fail2ban.actions: WARNING [ssh] Unba...

 
2:16 AM
@WinEunuuchs2Unix understandable. I want to get back into Python and C++ - but time, interest, and motivation.
 
@RolandiXor Python and C are different tools. What you need first is the goal, and then select the tool to get you there.
 
I know, but I used to use both tools, is what I'm saying. I want to refamiliarize myself, even if just for the sake of the general knowledge.
 
I have used C for caching HDD to SSD PCIe like Intel RST but in Linux. And I have used Python for managing Grandfather, Father, Son daily backup generations in gmail.com email attachments but that is it in Linux and only because they were the only tools to accomplish the goals. Other than that I don't use those tools.
 
Why has the network configuration software changed in ubuntu 19.04? It's not /etc/network/interfaces . Its cloud-init. Why?
 
2:36 AM
@WinEunuuchs2Unix fair enough.
 
 
5 hours later…
7:20 AM
Starting October I am going to be a Linux engineer, whoo.
 
 
1 hour later…
8:25 AM
@blade19899 I'd congratulate you but I did not believe it took that much effort did it? :D I got mine handed over by just saying I worked with Xenix, Unix, SCO, and Linux for more than 20 years :P
 
 
3 hours later…
10:57 AM
@Rinzwind I develop in Linux for fun. I can't imagine getting paid to do it too!
 
11:26 AM
I do :=) But I mostly use an interpreter for coding so it is a bit old skool. We are still switching and/or replacing our old software with equivalent python code.
 
11:50 AM
Well Python is interpreted too. I had thought Python would be in my Ubuntu desktop learning future but now they are switching over to Gnome Java Script (gjs) which hopefully I'll start learning in 20.04.
 
12:33 PM
@Rinzwind Really, I've been in the Linux world just a few years now, and they offered me a job as an Linux Engineer.Whoo
 
12:49 PM
gnome java script? never heard of that :-X
@blade19899 now that is worth a congrats :D so gratz! :D welcome to the working class.
 
0
Q: What makes this question on-topic?

mook765A couple of days ago, I voted to close this qestion as off-topic. It seems I'm still the only one who think it's off-topic, probably the question has been removed from the review-queue by another user. The question is, as far as I see, about terminology and not related with Ubuntu, so my questi...

 
1:07 PM
0
Q: Specify a home directory path for a user in /etc/passwd with spaces in it?

leeand00I have a path I want to use as a home directory in WSL, but it's also path that has spaces in it. I've tried escaping the spaces with slashes, and I've tried using single and double quotes with just spaces in the file, but it never seems to work I cannot specify a path with spaces in it within /...

 
 
4 hours later…
5:07 PM
0
Q: How to use cdc_ncm driver instead of cdc_acm in ModemManager

ZxCvBnMIn Ubuntu 16.04 I try to use a USB modem in NCM mode. But ModemManager uses automatically the cdc_acm driver which creates a PPP interface. lsusb shows 6 cdc_acm devices and 1 cdc_ncm device. How can I force ModemManager to use the cdc_ncm driver? mmcli -m 0 output shows that both drivers are ...

 
5:48 PM
0
Q: ldap home directory permission issue on debian/ubuntu

editinitI have joined the debian9 machine to microsoft AD when i run su - test1 it create the home directory but with below permission. root@debiantest:/home# ls -ltr drwxr-xr-x 2 test1 data 4096 Sep 18 22:47 test1 added the umask=0077 in below files but still it create the file home dir with drwxr-...

0
Q: how to create 3-way handshaking packets per second?

shadiI created 3-way handshaking packets (syn,syn+ack,ack) with scapy. but I want do this for example 10 connections per second. how can i do that?

 
 
2 hours later…
8:08 PM
0
Q: How to remove multiple HTML files in batch

mintoUbuntu 16.04 LTS, Gnome version 3.18.2 My desktop filled with multiple html pages (GHex editor output). binary00000000.html binary00000001.html binary00000002.html ... binary00043310.html How to remove these HTML files from desktop in batch?

 
 
2 hours later…
10:29 PM
0
Q: resolv.conf on host overwritten every time a Docker container is started or stopped

beechfuzzEvery time I start or stop any Docker container, the /run/systemd/resolve/resolv.conf file on the host (Ubuntu 19.04) gets overwritten with: # Generated by dhcpcd from enp30s0.dhcp # /etc/resolv.conf.head can replace this line nameserver 127.0.0.1 # /etc/resolv.conf.tail can replace this line ...

 

« first day (3276 days earlier)      last day (32 days later) »