« first day (3185 days earlier)      last day (526 days later) » 

12:00 AM
Am I making sense now??? @WinEunuuchs2Unix
That was just an example (don't take it literally) of how you can change the gmail message subject in your cron daily backup script when you revise it.
Well, with partial information, you get partial answers.
Garbage in, garbage out
@Fabby The point of the project is to convert dailies into weeklies, monthlies and yearlies. The point of the project isn't to give up :P
Yeah I know about GIGO and Foo Bar too :P
So if you want to prune, prune weekly, monthy and yearly.
You could keep 2 weeks of dailys, though if this is personal, I don't see why you would...
I will be pruning Weeklies, Monthlies and Yearlies. But first they have to be created from pruned Dailies :)
12:02 AM
Yup: so prune weekly, monthly and yearly.
I have screenshot set for 28 dailies but user can easily change.
I have 12 weeklies defined but I wonder if it should be 16 or 20 instead?
Or even 52 for that matter
OK, so if 28 daylies: prune daily.
yeah cron will run daily
@WinEunuuchs2Unix No, as that would make you run into the monthlies and totally mess up everything!
For the monthly: prune monthly
for the yearly: prune yearly
so 3 prune jobs
Am I making sense now?
A given backup would be daily, plus potentially future weekly, monthly or yearly as screenshot above shows.
No one super job that does everything :)
12:05 AM
33 mins ago, by WinEunuuchs2Unix
user image
yup that one
@WinEunuuchs2Unix Nope: KISS: Keep it Simply Stupid.
If I was KISS I wouldn't be here :)
It will be iof you have 3 prune jobs.
people at work say I'm crazy writing software for points :P
12:06 AM
or one job with 3 functions, or ...
@WinEunuuchs2Unix I don't doubt you're bat-shit crazy!
So am I!
:D :D :D
I would:
Days to keep: Max=31
Weeks to keep: Max=24
The user can put in any number of days or weeks they want.
Also don't forget there are 5 years of sent messages taking up 15 GB space quota in gmail.com so there are tagging algorithms for those too. Not to mention promotional messages unread from 2015 on that need to get pruned (trashed) by the program.
Years to keep, max=122
linux problem is date ends in 2032.
@WinEunuuchs2Unix LONGINT32 does
LONGINT64 doesn't...
Linux doesn't have 64 bit epoch yet???
12:10 AM
start using longint64
@WinEunuuchs2Unix Yeah, so what???
Because all the lemmings go over a cliff you need to too???
I should wait for Linus T to figure it out.
@WinEunuuchs2Unix No you don't: the answer is obvious: LONGINT64
I already invented my own date "Rickle" which is number of days after Jan 1, 1900 for ACCPAC Plus. It's a headache.
@WinEunuuchs2Unix Don't re-invent the wheel, just use LONGINT64!
I used Julians back in the 80s.
they go from -3000 to +3000
That was all we needed for software development...
We never had a Y2K issue!
I should just go text "9999-12-31" is good for another 8 thousand years.
12:13 AM
@WinEunuuchs2Unix That's good too.
Waste of bits, but good too.
Yup I just tell the user 8,000 years is max for a backup.
you always need maxima.
If they complain refund them their free software purchase price.
Once you define your parameters, you make your job easier.
@WinEunuuchs2Unix Starred!
Hey, it's 02:14 here now...
Can I go sleep???
0:-) :P
yeah man hit the hay. Thanks for chatting it was nice sharing my problem!
12:16 AM
1. define maxima
2. 3 prune jobs / Functions / Procedures ...
Good night!!!
haha noted. Good night :)
@WinEunuuchs2Unix Hey, I just thought of something:
(bear with me)
If a user has 4 weeklies, he can have 11 monthlys.
Q: How to backup the whole desktop β€” without backing up junk?

Daniel RI'm looking to take a whole system backup and store it on S3. Something that could be good enough to restore my entire system. But I've been told that using dd/rsync to capture the root directory will save a lot of extraneous files that I wouldn't need to restore the system. In the event that I ...

If a user has 8 weeklies, he can only have 10 monthlies
16W = 8M
52W (the max) = 0M, 1 Y
so you just decrease the monthly value by 1 for each INT(W/')
same with dailies...
chronologically weeks should be longer than days, months should be longer than weeks and years should be longer than months. I should put that rule in the software.
12:24 AM
How about that for a genius solution???
And now: Good night!
(smoking on the toilet does help!)
good night
@YufenyuyVeyehDider Good night to you too!
@Fabby, good night!
And keep up the good work!!!
Thanks, @Fabby.
12:31 AM
@dessert I was well chuffed to get a gold badge all of a sudden. That badge seems like a winter hat they decided was worth making permanent haha
Q: If I run a command with `sudo` is it still "invoked by an ordinary user"?

finefootQuote from manpage of davfs2.conf for mount.davfs: There is a system wide configuration file /etc/davfs2/davfs2.conf and user configuration files ~/.davfs2/davfs2.conf. When mount.davfs is invoked by root, only the system wide configuration file is read. When invoked by an ordinary use...

@Zanna You must have a ton of golds :)
I was thinking today of a query of all users with accepted answers with fewest upvotes. I might get a badge for that :P
Me too... I'm sure about that.
Good night to everyone!
4 hours later…
4:39 AM
Q: Ubuntu 19.04 icon resize

Ali I have Just upgraded my ubuntu 18.10 to 19.04 via do-release-upgrade. In ubuntu 18.10 i could right click on each desktop icon separately and resize the icon of that file.(Using GNOME) But this is removed now and i cannot resize each icon "separately". I want to know how can i have it back?

5:19 AM
Q: Get Ubuntu font name from Mac font name string

cd-rumGiven this string: font = "Helvetica Neue LT Std 45 Light" I have this font installed on a macOS system and a Ubuntu system. I need to refer to it on the Ubuntu system by the font string, but fc-list | grep Helvetica returns this information: /home/ubuntu/.local/share/fonts/HelveticaNeueLTStd...

5:50 AM
I need one more reopen vote from a reviewer to reopen this question which has an accepted answer and was closed as due to a software bug, however no such software bug was reported by anyone. One reviiewer such he "guessed that it is a bug". We don't close questions with accepted answers because someone guessed that it was a bug even though it isn't and he guessed wrong.
2 hours later…
7:26 AM
^ done
Thanks. πŸ™‚
1 hour later…
8:40 AM
Q: How to resolve problems connecting to Samba4 Active Directory Domain Controller on Ubuntu Micro AWS Instance

Jack HoltbyI'm trying to set up a Active Directory Domain Controller on an Ubuntu 16.04 instance on Amazon's EC2 micro services. I do everything right (following at least three different tutorials) and get all the server side tests to run and go fine. My most recent attempt used this tutorial:https://wiki.s...

5 hours later…
1:30 PM
@YufenyuyVeyehDider Approved! Much better!!!
1:46 PM
Ah, sorry!
Let's decamp to another (more private room)
2:22 PM
Q: Problem unlock disk encrypt

Alexandre Mário de FreitasI've got a problem while unlucking my laptop hd encrypt. The Caps Lock isn't working while I try to unlock. Its strange because the capslock does work before they ask to unlock the disk encrypt. How do I fix this bug? I use Ubuntu with Linux 5.0.0-16.

3:02 PM
Q: How to run lxc inside of a chroot

Sir l33tnameI'm trying to run lxc inside of a chroot. $ lxc-start -n instrument --logfile=/dev/stdout lxc-start 20190619141851.659 ERROR lxc_cgfs - cgroups/cgfs.c:cgfs_init:2359 - cgroupfs failed to detect cgroup metadata I tried to mount (where target the path to my chroot is): /bin/bash -c "sudo mou...

3:27 PM
@Fabby Thanks, I'll try to improve again.
4 more reopen votes needed as OP has an answer ready to be posted...
(see revision history)
3:42 PM
Q: Process freezes when using plotting with multiprocessing in Python

Schlator BorgensonI'm parallelizing a process by using the multiprocessing module. The function that is parallelized does plotting and using savefig module saves the plot in pdf format. However, when the code is run, only one of the iterations results in an image while other images although created are of size 0...

3:56 PM
@Rinzwind can you please star the 4 more reopen voted needed above?
4:37 PM
@Fabby Although I've also casted my reopen vote but I think that question was indeed off-topic. Also, OP has an answer is not a good excuse for reopening an off-topic question. Educate me if I'm wrong here :-)
A question without an answer is a lost question.
A question with an answer will help someone else down the line.
But that is my personal and subjective opinion.
@Kulfy Feel free to disagree with me and retract your reopen vote, but I'm pretty sure it will make OP a happier person and anyone finding his answer a happier person too.
It's not B&W, but 50 shades of grey...
4:54 PM
@Fabby Oh no no. If OP is happy, I'll be happy. If this makes AU more welcoming and help future readers of Ubuntu with Cinnamon desktop too, I have no objections.
E.G. I run Nemo (just Nemo, not the entire Cinnamon Desktop)
@Fabby I don't know about Nemo. If it works, I'm OK with that :-)
5:57 PM
@Videonauth I posted that a couple of hours ago :=D
but nobody cared :-)
@Fabby I already have it seems :=)
@Rinzwind I think it was an inevitable step, but completely dropping multiarch will make Ubuntu unsuitable for gamers like me
as wine, steam and so much mor rely heavily on 32 bit libs
yeah the last survey on this has 32bit listed as less than 1%(?)
how can i count lines in a bash output?
wc -l
counts lines
on my system i have 232 packages for the i386 arch
out of 4000+ packages
Well in the worst case there are other OS options tho
6:03 PM
hmmm what command did you use
dpkg -l | grep i386 | wc -l
all but 1 are libs
232 / 3568 packages
so that will fix itself
yeah here too most are libs
6:04 PM
is the other one
But to be honest Canonical is already since a few years pursuing more the server and IoT market as the desktop OS market
so this decision was easy to foresee
6:46 PM
dpkg -l | grep i386 | wc -l
well install steam and see that number going up by a lot :D and wine as well add's onto it
dpkg -l | grep i386
ii  libc6-i386                                    2.23-0ubuntu11                                              amd64        GNU C Library: 32-bit shared libraries for AMD64
ii  syslinux-legacy                               2:3.63+dfsg-2ubuntu8                                        amd64        Bootloader for Linux/i386 using MS-DOS floppies
7:07 PM
This is interesting:
Q: desktop empty: no icons & folders, no mouse actions

RolandMy desktop fails for one of the users (2) only: No icons No action upon right mouse button (For user 2 all is fine. Users can be switched during session, then no issues for user 2. Back again to user 1: same problem again) Only way to operate under user 1 is by general menu.

We don't have any tags that would really fit this.
Since we nuked for being misused.
@Seth how about
hm, probably best to just tag it then.
is for non-specific questions.
yeah the new gnome desktop has removed the desktop icons completely, what i still can not understand
7:23 PM
Q: Ubuntu 18.04 CPU governor in powersafe mode getting in the way of performance

Lucas BustamanteI have an Intel i7 6700HQ. Min frequency: 800 mhz Max frequency: 2.7 Ghz Max frequency with turbo-boost: 3.5 Ghz Using Geekbench 4 to stress and benchmark CPU, I got VERY different results with /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor set to powersave or performance: Geekbench CP...

8:04 PM
Q: How to install 32-bit python package on 64-bit system with conda install

user358688I am running ubuntu 16.04 and using 64 bit version of anaconda. I am looking to create 32-bit python virtual environment in a 64-bit machine. Is it possible to do this?

3 hours later…
10:57 PM
@Seth How about <tag>desktop-icons</tag>

« first day (3185 days earlier)      last day (526 days later) »