« first day (3094 days earlier)      last day (90 days later) » 

2:58 AM
2
Q: How do I build the mainline kernel with all default Ubuntu modules?

FmstratMy normal way of building a mainline kernel has been: $ sudo apt build-dep linux $ git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git $ cd linux $ make localmodconfig $ make -j`nproc` deb-pkg And off I go. However, I'd like to build a kernel that includes the same modul...

 
3:41 AM
@AskUbuntuMeta no!
 
 
4 hours later…
7:13 AM
Interesting message after many years of Ask Ubuntu and at 65,000 rep. Must be a tiny bug. ^
 
 
2 hours later…
9:32 AM
LOL
 
Happy Purim!
 
 
1 hour later…
10:57 AM
0
Q: About the use of sshfs between multiple servers

Allen ZhangFor now, I can use ssh -p 2222 username@ip1 to login in a jumpserver, which will have a option to login in target server with ip2 by 1) Enter ID directly login or enter part IP, Hostname, Comment to search login(if unique). 2) Enter / + IP, Hostname or Comment search, such as: /ip. 3) Enter p...

 
11:37 AM
0
Q: uArm movement through python 3

tpkimport pyuf import time from time import sleep from pyfirmata import Arduino from uf.wrapper.swift_api import SwiftAPI swift=SwiftAPI() port = '/dev/ttyUSB0' board = Arduino(port) swift.set_position(x=250,y=0,z=50,speed=1000000) I have written a code in python,ubuntu environment to set position ...

 
 
3 hours later…
3:02 PM
Quick Question: A line in my Dockerfile is:

    mkdir -p /opt/company/services/{apps,conf,bin}

But the directory structure formed in the container is like following:
    drwxr-xr-x 2 root root 4096 Mar 20 14:56 apps
    drwxr-xr-x 2 root root 4096 Mar 20 14:56 bin
    drwxr-xr-x 2 root root 4096 Mar 20 14:56 conf
    drwxr-xr-x 2 root root 4096 Mar 20 14:56 {apps,conf,bin}

I don't want the last one, what should I do?
 
a downvote on a 293 upvoted answer. weird :P
@Shubham 1st guess: you are not using bash. { and } is bash brace expansion
 
@Rinzwind This command is inside a Dockerfile and the base image that I am using is Ubuntu 16.04
 
sure but what is the shell used. bash zsh and ksh should understand {apps,conf,bin}
and expand it to 3 dirs. Other shells might take {apps,conf,bin}
literally
 
But they are being expanded in this case also, its just that along with being expanded, they are being considered literally.
I tried one more thing, I ran docker run in my base image and started bash. I executed

mkdir -p /a/b/{c,d,e}

and it created only the expected directories, i.e., /a/b/c, /a/b/d, /a/b/e
Interestingly, I again ran the base image with `sh` command and ran the following:

mkdir -p /a/b/{c,d,e}

It took the argument literally and created one directory, i.e., /a/b/{c,d,e}
 
3:37 PM
sh does not do expansion. That docker file probably executes the command twice. Once with bash/ksh/zsh and once with sh.
 
 
1 hour later…
5:02 PM
0
Q: CTRL, ALT & ALTGR dead on Fujitsu CELSIUS H770 with Linux Mint 19 Tara

HannoMy CTRL-L, CTRL-R, ALT, ALTGR & NumPad keys don't work anymore. The German layout keyboard was fully functional after installation, but the keys got lost after some reboots. I had problems with the touchpad, but that could be temporarily solved by applying sudo modprobe -r psmouse sudo modprobe ...

 
 
4 hours later…
8:34 PM
0
Q: the command don't run in crontab

mohammad zahedihi I have problem with runnig this command in crontab mysqldump --defaults-extra-file=/var/www/xxxx/backup/database/.sqlpwd dbName > /var/www/xxxx/backup/database/database-dump-"$(date '+%F').sql" I run it in console and its work prefectly but when I put it in /etc/crontab * * * * * root m...

 
 
2 hours later…
10:29 PM
-1
Q: Install Ubuntu as a second operating system

mohammed jobanI am trying to install Ubuntu on my drive as a second operating system, so I setup my usb drive to be bootable so I can install linux. Now I got boot error message and I can not start windows or access bios, I tried functions keys but it keep restarting and go back to the same message. Tried tur...

 
10:45 PM
@NathanOsman can you tell me which was the site for stack exchange pearls ?
 
@ByteCommander yes thank you
 
No problem. However, I'm not sure, but it looks pretty dusted and unmaintained to me these days....
/shrug
 
11:03 PM
yeah
 

« first day (3094 days earlier)      last day (90 days later) »