« first day (596 days earlier)      last day (2887 days later) » 

12:49 AM
LOL! I found an old version of AO sitting around on my hard drive. Wow... Just.. WoW
It's pretty epic
Maybe I can find some new energy from this
Boo yeah
Anyone here use mercurial?
I have some questions about the ignore filters, and wondering if there's a way to have 2 ignore filters: one that's included as part of the repo, and one that's client-side only
 
1:09 AM
Does the server side one do anything?
 
It replicates to all other clients
 
So... if I have a file in my directory that I want to ignore, but don't expect others to have
 
This should do it
 
Sweet
hmm... They could have thought that out better imo, but it will work
 
 
8 hours later…
9:14 AM
There we go. Game engine + testbeds successfully compiling and being assembled into an OS X application bundle via cmake. Now to test it under Windows.
 
@TrevorPowell so I guess you originally work on linux.
did you test it on different machines?
 
Depends on when you're counting from. :)
 
I'm ok with both linux and windows, but I don't really appreciate mac.
 
I've only tested on Mac so far. Mac was a lot harder than Windows or Linux will be; lots of extra requirements for building a Mac-style application bundle.
 
and for the last question, do you want me to test engine for you? I guaranty using engine capacities to their extreme.
 
9:24 AM
You're certainly welcome to give it a go! There isn't nearly as much documentation as you'd want, though.
 
no need,
it certainly isn't more mess than my own codes,
so I can handle it.
 
Do you have a preference re: subversion vs. git?
 
nope
I have got support for both, either in linux or windows
 
9:45 AM
Well, the current git repository is here: https://gitorious.org/vectorstorm/vectorstorm
That contains both the engine and same games/tech which uses it. It doesn't contain the CMake build system, since I haven't finished testing that yet.
Er, I meant "sample" games, not "same" games.
 
cloning
 
Right now, it has Xcode and Visual Studio projects. Have never tested under Linux (beyond testing that Wine can successfully run a Windows build). But it's just OpenGL, really. And some external libraries. (Think the only requirements are SDL, SDL_mixer, SDL_image, and GLEW)
 
10:37 AM
@TrevorPowell I like iPhone folder there!
but why is your project VC2008?
 
Oh, yeah. iPhone port is mostly done, too. Works except for sound.
VC2008? Because I never got around to installing anything later than that. No good reason. Should autoconvert up without trouble, as I recall?
 
np
I've got both 2008 and 2010
but 2010 is really nicer to look at!
what is glew?
fixed that part
 
Glew is a transparent wrapper layer around OpenGL. Handles version checks and things like that. http://glew.sourceforge.net/
 
just out of curiosity, why your glew is in glew folder?
I mean when I download it automatically put in gl folder!
 
Reasonable question. It's a library naming issue; under Windows, it automatically goes into gl. On the Mac, it goes into glew. Easier to move the headers under Windows, since on the Mac it goes into a static framework object.
That's my one big complaint about glew, that discrepancy in how the headers are placed on different platforms.
But one of my goals for going to the cmake build system is sorting that out, so it can be placed in the default spot on all platforms. :)
 
10:50 AM
also about SDL_image and SDL_mixer
for me they both are inside SDL folder.
 
Yeah, same issue.
And again, going to be sorted out by cmake. Yay for being able to search for headers! :)
 
are you alone? I mean working on this project
 
Yes, just me.
But I've been working on/around it for about six years part time, so.. there's been plenty of time to work on it.
 
yep, I can see.
that's why I was surprised when I saw it was only you committing and pushing.
also I guess "vec" file format is your own creation
 
Yeah. It's not a great format.. just simple text fields. Been evolving over time.
The whole system is build around display lists, which are strings of render commands. A "vec" file is really just a display list in text format.
 
10:59 AM
I guess I like it, but not very much.
it seems too messy.
 
The library is definitely designed as a prototyping engine. It's intended to let someone throw code together really fast, rather than to be a really good platform for big games.
 
no I mean it's obvious that you just added a feature once at a time.
there is no general idea behind it's format.
though it seems to have very good features.
 
Ah, yeah, it's definitely barnacles on top of barnacles, that file format. I'm not really using the "vec" files for anything any more, in my current projects. Eventually I'll start on a project which requires me to use 3D models from an art package, and I'll finally get around to implementing a model importer. But I haven't done that yet.
 
you can use already defined file formats.
 
Absolutely.
 
11:05 AM
for example "X" works good for 3D objects
or colladda "DAE"
 
Yep. Just haven't needed to import models yet, so never actually wrote the file parsing.
 
the whole point is to use importers out there.
remember the best programmers are the one who know what is the best code they can import for each task!
 
Okay. Regardless, I haven't needed to import models yet, so I haven't gone looking at file formats at all. All my current projects are built around procedural mesh generation, or are 2D wireframe things which you can't really model in a 3D package anyway.
 
I've got some problems link time
do you heard anything about libcmtd?
 
libcmtd is the debug version of the c runtime library used by Visual Studio, as I recall.
 
11:16 AM
yep,
but I'm not sure why VC conflicts with itself!
1>------ Build started: Project: Testbeds, Configuration: Debug Win32 ------
1>Linking...
1>msvcrt.lib(ti_inst.obj) : error LNK2005: "private: __thiscall type_info::type_info(class type_info const &)" (??0type_info@@AAE@ABV0@@Z) already defined in LIBCMTD.lib(typinfo.obj)
1>msvcrt.lib(ti_inst.obj) : error LNK2005: "private: class type_info & __thiscall type_info::operator=(class type_info const &)" (??4type_info@@AAEAAV0@ABV0@@Z) already defined in LIBCMTD.lib(typinfo.obj)
1>msvcrt.lib(MSVCR90.dll) : error LNK2005: _isspace already defined in LIBCMTD.lib(_ctype.obj)
 
Ah, I know the problem.
Try going into the project properties dialog. Under C/C++, choose the "Code Generation" page, and change the "Runtime Library" field to Multi-Threaded Debug DLL.
 
I'm trying to compile using VC10 if it didn't get fixed, i'll try that one.
 
For my Windows releases, I link the c runtime library statically, instead of via a DLL. Means that I don't have to distribute the VS2008 runtime libraries for Windows users. But it requires me to compile all the libraries I use (SDL, etc) the same way, to avoid linker errors.
 
11:36 AM
i should really statically link the gcc libraries and libsnd libraries so i don't have to worry about including dlls anymore...
 
11:53 AM
@TrevorPowell now I've compiled it successfully, but there is runtime error
msvcp100d.dll!std::_Debug_message(const wchar_t * message, const wchar_t * file, unsigned int line) Line 15 C++
Testbeds.exe!std::basic_string<char,std::char_traits<char>,std::allocator<char> >::operator[](unsigned int _Off) Line 1440 + 0x17 bytes C++
> Testbeds.exe!RemoveLeadingWhitespace(std::basic_string<char,std::char_traits<char>,std::allocator<char> > & string) Line 66 + 0xa bytes C++
Testbeds.exe!fsToken::ExtractFrom(std::basic_string<char,std::char_traits<char>,std::allocator<char> > & string) Line 181 + 0x9 bytes C++
 
The trick with statically linking libraries is that you end up with separate allocators for all dlls. And that means that you need to make sure each library destroys its own data; no passing data around between libraries and deallocating each others' stuff.
 
an empty string was passed to function RemoveLeadingWhitespace .
and that's causing the problem
 
Hm.. interesting. I can see that doing the "string[0]" on an empty string would cause problems.
Try moving the call to "RemoveLeadingWhitespace" inside the 'if' statement.
(So moving line 181 to before 185)
No idea why I'm not getting that problem, though. Maybe it's something subtle that's changed in the runtime libraries between VS2008 and VS2010, which has resulted in getting into that situation where it wasn't doing so before..
 
I've added these two lines just before 181
if ( string.empty() )
return false;
 
That should work.
 
11:59 AM
now it also handles the case string is just whitespace.
now there is another runtime error.
when setting preferences validate preference causes an exception.
m_max == 0
but I'm not sure what does it mean, and why there is such a problem
 
Can you find the "m_label" value on that vsPreferenceObject? That'll tell you what it is.
 
"CID_MouseLeftButtonId"
 
Hm.. gimme a moment to look into that.
 
m_value is 1 while both min and max are zero
 
Oh interesting. I see the problem.
Er.. I think I do, anyway.
You have a joystick of some sort connected to your computer. Or gamepad or something.
 
12:04 PM
nope
 
Looks like you'd get that misbehaviour if a joystick was detected, but it was reporting that it had no hats, buttons, or axes.
 
it's just a wireless mouse, and also laptop keyboard and touchpad.
 
Hm... did you change the button mappings?
Or is that happening on initial startup?
 
nothing that I can remember.
 
I mean, in the in-game preferences. Don't know if you got far enough in to see the preference screens.
 
12:07 PM
when i run the game.
it just give the error before I can do anything
but now that I read console log,
it seems engine really is finding a joystick.
now I got it.
WII-Mote driver is installed on my laptop.
that should be causing the problem (since that's the name your application is listing)
 
Aha!
Yeah, that'll be it. It's still a bug in my code, but at least now I understand why.
 
Found 1 joysticks.
Using Nintendo RVL-CNT-01, 0 axes, 0 buttons, 0 hats, 0 balls
Failed assertion: Preference value too high!
Failed condition: (m_value <= m_max)
at c:\users\ali\documents\visual studio 2010\projects\trevor\vectorstorm\vs\util
s\vs_preferences.cpp:164
 
Okay. Two changes for you:
SYS_Input.cpp. Line 198 and 224. The final parameter of those ("maxId" for the first one, and a "vsMax()" function call for the second) should both be replaced with CID_MAX.
 
so it should look like this?
int maxId = vsMax( m_joystickHats, vsMax( m_joystickButtons, CID_MAX ) );
 
...yeah, actually, that's better than what I was thinking. Handles the case where you have an absurd number of buttons on a joystick.
 
12:16 PM
if I understand what is that part doing correctly, I don't like changing it!
I would like to have support for devices with zero buttons
 
It's manipulating a "preference object". The preference object stores an integer value, along with a "minimum" and "maximum" legal value. Those min/max values are only there for sanity checking (and for building GUIs to manipulate the preferences).
 
what's the problem with "libstdc++-6.dll"?
now the game start, and I can get into astroids sample.
when i press "w" it says :
---------------------------
MainMenu: Testbeds.exe - System Error
---------------------------
The program can't start because libstdc++-6.dll is missing from your computer. Try reinstalling the program to fix this problem.
---------------------------
OK
---------------------------
 
Hm... not sure, really. I guess when you try to start a game of Asteroids it tries to start music playing, so it might be some dependency of SDL_mixer?
I wouldn't have thought that'd be a problem, though. I don't install libstdc++ in my Windows builds and have never had that complaint before.
 
everything work perfectly before I press "w"
does it have to do something?
 
Gajet, are you using mingw to compile c++ programs?
 
12:23 PM
it just gives that error and the application restarts.
@thedaian nope.
but now that you mention it I think SDL_mixer used mingw to compile their library.
 
that could be it
strange that it fails for you, though :(
 
Hm.. I built it myself. :/
 
it's definitely a mingw thing
0
Q: libstdc++-6.dll not found

MolmasepicI have been working on a project(a game to be specific) and I feel that I should start over with different libraries. So when doing this I reinstalled Code::Blocks and setup my new libraries and includes. But as of now Im having a problem starting u[ my new project to test if all of the include...

 
I don't even use the 'w' key for anything in VectorStorm.
 
other samples also don't work.
only preferences, asteroids, and physics demo work.
also I've found out another thing. only when entering main-menu I get libc++ error
but effects still play in main menu.
it seems 'w' is also a shortcut to return back to main menu
 
12:29 PM
Hm.. that's "q" on my keyboard. Are you on a non-qwerty keyboard?
 
no
:D
my bad
I was pressing 'q'
 
Ah, phew! xD
 
1:23 PM
@TrevorPowell
 
Ah, interesting.
 
also there is one other thing.
when I press "alt" key in main menu, everything disappears
but menu still works.
 
That's only in debug, I think. I should have removed that.
It's shader debugging stuff. You should see blurrier versions of the menu, if your graphics card supports the necessary OpenGL extensions.
 
it should.
it's nvidia 230m
 
(It's line 275 in GM_MainMenu.cpp)
Check the console output during startup. Mine says:
Successfully detected all required extensions for bloom shader.
Screen Ratio: 1.333333
OpenGL Context:
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce 9600M GT OpenGL Engine
Version: 2.1 NVIDIA-7.18.11
Shading Language Version: 1.20
 
1:31 PM
mine has too many more information
 
The key point is "Successfully detected". If it didn't, it'll print out all the missing extensions it needed.
 
VectorStorm engine version 0.0.1

Loading preferences...

Checking supported resolutions...

Available Modes

0: 640 x 480
1: 720 x 480
2: 720 x 576
3: 800 x 600
4: 1024 x 768
5: 1280 x 720
6: 1280 x 768
7: 1360 x 768
8: 1366 x 768
Initialising [800x600] resolution...

Support for GL 2.1 found
glDrawElements supported.
WARNING: Failed to initialise swap control
Successfully detected all required extensions for bloom shader.
Screen Ratio: 1.333333
OpenGL Context:
Vendor: NVIDIA Corporation
 
Yup, all looks normal.. (apart from the trouble loading mp3s)
 
mp3 problem was also fixed (along with libstdc++)
the problem was my sdl_mixer library was newer than yours (or maybe older)
 
Newer, probably.
 
1:35 PM
anyway updated "smpeg.dll"
 
Also, I compiled my own from source, so it probably didn't require that external library anyway.
 
I guess it was the problem with sdl_mixer itself.
smpeg.dll is part of their package, but their's is 209KB.
and the one I placed to fix that problem is 230KB
 
Hm, interesting.
 
1:54 PM
Okay, long past sleep time. Chatting more tomorrow!
 
 
5 hours later…
6:28 PM
wheeee... last day at my current job
starting a new job next week!
 
Weee! No more C#!
 
pure javascript from here on out, baby!
 
Weee! Torture!
 
lol
 
Because C# was bad?
I do C and C++ windows kernel level code.
C# would be a break
Congrats though, that would be fun
 
6:47 PM
C# isn't bad, but I'm not really familiar with it, combined with having to learn a giant code base
although it's also that working on media websites and possibly gamedev stuff is more interesting to me than working on medicare billing/businessy type stuff
 
ooh
you were in medicare billing?
where at
 
eh, we more just had to work with places that did medicare billing, though there is a lot of interfacing with some of their systems.
also, Vertex Systems
 
Cool, you're moving to game related job?
 
sadly, it's not purely game related
 
Oh or probably if the company you work for does a website for a game company
 
6:52 PM
but, i think there's more chances at doing some games where i'm going than where i am/was
 
Right
That would be nice
I don't remember the last time I was paid to do something I liked doing :(
 
sounds like time for a career change
 
Well, paying the bills is pretty nice too :)
 
i suggest skydiving. gets you out in the open, lots of fresh, clean air, office with a view, only time you're in danger of losing your job is when you forget to pack your parachute.
 
7:09 PM
Heh, I did that when I was younger, before my 20's. 54 jumps total.
And I agree. It's awesome.
 
My wife works for an organization that put out an educational video which incorrectly used velocity as a scalar quantity (among other mistakes.) I casually mentioned this to her, and she mentioned it to her boss. Now the whole organization is upset about the ordeal, and called in a Ph.D in Astrophysics to clean things up. Even the professor got his shit wrong, referring to distance as a vector quantity in his results.
 
awww, should have done 2 more jumps
 
I told my wife to pull in a game developer next time.
 
lol
 
Well, back the I was only Byte54
 
7:19 PM
I registered the domain 0x5353.com a while back... my initials are SS
 
ha, nice
and insanely geeky/nerdy
 
Psh, 111000.com is taken
I guess there's www.00111000.com
aka byte56
 
which would actually be better
 
Indeed, byte size
 
Yeah, no one likes unaligned binary! >:/
 
7:27 PM
Man, windows calculator is pretty nice with it's programmer mode
conversions and you can click bit locations to set the value
 
....whoa, you can click bit locations?
that is awesome!
 
haha
 
I use it all the time when working with bitmasks.
Since C# lacks the 0b prefix for binary numbers.
 
ouch :(
 
My hacker productivity just increased 64%
 
7:35 PM
That's almost 65%! :O
 
I'm not sure I ever really need to work with binary literals
 
Perhaps I should have said 0x64%.
 
you mean 163/256
 
heh, yes you should have
 
if there was a good symbol for 1/256
 
7:36 PM
it's extremely rare to have to work with binary literals.
but sometimes it happens, so it's useful to have an easy way to do it
 
well, I do use hex literals reasonably often
it's not that hard to read hex and mentally translate to binary
 
Here we go, now he's showing off again...
 
:P
 
yeah, hex -> binary is easy.
 
Yes Jimmy, you're a special boy, just like your mother always said.
 
7:38 PM
same with binary -> hex
 
see, even an Ohioan can do it
can't be that hard
 
Jimmy's right...it just takes practice--like anything else.
 
it's converting to dec that's tricky...
i learned to count in binary before any sort of programming.
thanks, Issac Asimov.
 
I used to impress my friends by writing their names in binary ascii form.
How it impressed them I don't know.
I guess binary is like magic for those simpletons.
 
7:41 PM
"secret codes"
 
@thedaian converting to dec isn't tricky. it's just time consuming.
 
converting binary to decimal or hex to decimal is harder than binary/hex :(
it's easier for me to convert binary to decimal, though
 
Why did we have to be born with 10 fingers?
 
so if i have to convert hex -> dec, then I tend to go to binary first
 
for hex->dec is simpler
 
7:42 PM
(or i just use windows calc to do it)
 
"According to a 1987 study on the so-called High-Rise Syndrome, published in the Journal of the American Veterinary Medical Association, cats who fell from higher floors fared much better because they can spread themselves out like a parachute and slow the impact."
 
but I go straightly from bin->dec too.
@thedaian that's mostly when i need to use oct
 
That part sounds awefully a lot like someone has been throwing live cats off tall buildings.
 
and when I need to convert dec->hex/bin
 
i'm just not very good at converting to dec...
 
7:44 PM
@JohnMcDonald don't count with finger.
try using hands, eyes, ears, and so on...
 
i count in binary with my fingers
 
that's why you can't convert to dec
you need your fingers for converting!
 
but it's so easy! i have 10 bits on my fingers, i can count to 511
 
Wait, Ohioan's have 10 fingers?
Who would've thought.
 
Yeah, well my logic is that (most) Humans use base 10 because it's how many fingers we have. Actually, in some parts of the world, different bases are/were used, but I still think the world chose base 10 because we have 10 fingers
 
7:47 PM
but yeah, that's basically where the base 10 came from
 
if you can count to 511 you might only have 9 fingers
 
:This article aims to be an accessible introduction. For the mathematical definition, see Decimal representation. The decimal numeral system (also called base ten or occasionally denary) has ten as its base. It is the numerical base most widely used by modern civilizations. Decimal notation often refers to a base-10 positional notation such as the Hindu-Arabic numeral system; however, it can also be used more generally to refer to non-positional systems such as Roman or Chinese numerals which are also based on powers of ten. Decimals also refer to decimal fractions, either separate...
 
@Jimmy well, obviously I need one finger to point at what i'm counting :P
(actually I messed up... twice)
 
I thought you used one for sign
 
7:51 PM
d'oh. that would have been a better answer....
 
Ohioan's are always in debt, so they don't need the sign, they assume all numbers are negative.
2
 
or maybe it's the parity bit
also that's not just Ohioans, that's anyone in the USA :P
 
not only in USA, I guess that's anyone in the world.
except a few people.
 
I'm the few people. Cabbies live life!
 
I seems also to be one.
 
7:58 PM
Why buy a car when you practically live in one? And groceries isn't an issue either, I never have any time to eat! It's great!
 
for it's a different story, why should I be in dept when I've got a father who to for me.
base-20 system numbering :
Kaktovik Inupiaq numerals Inuit, like other Eskimo languages (and Celtic and Mayan languages as well), uses a vigesimal counting system. Inuit counting has sub-bases at 5, 10, and 15. Arabic numerals weren't adequate to represent the base-20 system, so students from Kaktovik, Alaska came up with an Inuit numeral system that has since gained wide use among Alaskan Iñupiaq, and is slowly gaining ground in other countries where Inuit is also spoken. The numeral system has helped to revive counting in Inuit, which had been falling into disuse among Inuit speakers due to the prevalence of ...
I guess they used both the hand and feet fingers to count
this one also is base 20 en.wikipedia.org/wiki/Maya_numerals
 
I was hoping the auto-wiki thing would show the section in the link, not the start of the wiki page
 
@JohnMcDonald I've already tried that one.
@JohnMcDonald I guess that's the origin on ohioan's people
and how they can only count up to 511 with their fingers
but still they need to count something else...
 
 
4 hours later…
11:59 PM
Weeee, documentation is fun
 

« first day (596 days earlier)      last day (2887 days later) »