« first day (1810 days earlier)      last day (36 days later) » 
00:00 - 22:0022:00 - 00:00

12:01 AM
RELOAD!
[rubberduck-vba/Rubberduck] 1 issue comment.
[rubberduck-vba/RubberduckWeb] 6 commits. 1 issue comment. 124035 additions. 51195 deletions.
[Minesweeper] Games Played: 73, Bombs Used: 47, Moves Performed: 10424, New Users: 10
[rubberduck-vba/Rubberduck] build for commit a4122213 on unknown branch: AppVeyor build failed
BUILD FAILURE!
 
 
11 hours later…
11:37 AM
@this thanks. I've got a pile o'work in front of me now...
wow, kinda quiet last night...
carp - Just realized there's that SSIS error in the event log. I wonder if that's going to prevent SSIS from working on the new server... sigh...
opens Hosch's SU link for safe keeping
 
11:58 AM
SSMS regex question: I've clicked the "square-star" button to use RegEx, I've entered NULL,'\n in the search box, but it's not finding it. I've got hundreds of lines that end in this text. I've tried highlighting and copy/paste into the search box, but it's not finding the newline. What am I missing?
It tells me: "The following specified text was not found: NULL,'\n"
It is a backslash, not a forward slash, right?
this answer says it is
MS Docs says that \n is a new line. It also indicates that $ anchors the search to the EOL. Neither seems to be able to find anything at the end of the line.
If I type in NULL,', I get hundreds of highlighted results as soon as I add $ or \n all the highlights go away.
I've toggled Alt-e (RegEx) on an off multiple times.
#justgottabedifficult :(
Is it because this is shown in the Reference List section
and this is shown in the Find What section?
How does it know which usage to apply?
RegEx itself is working, I was able to find: \t and replace with ',' just fine.
 
So happy the website no longer needs Rubberduck.dll to list inspections and update the reported latest build version! The /build/version controller method uses the tag names to parse the version number, so as long as our tags look like "v0.0.0[.0]", everything should "just work" =)
@FreeMan save the .sql file and edit it in Notepad++?
 
12:15 PM
0
Q: Import and copy paste to template table

C.EdoMy code works fine when I've written it last week and this week when I got new file and run my code, it didn't work to copy paste to another sheet. Can someone helps me please? Option Explicit Sub Import_ClientRating() '1. First Import data 1-to-1 to Table template '2. Used Find function to ...

 
yeah, might have to do that... I discovered that \n will find the EOL. That's all I really need... I replaced it with '),\n and got everything double spaced! I'd have thought that S&R would work the same as it normally does - "Find this replace with that", but not, apparently with newline.
N++ found \n, but replacing it with '),\n gave me \n'),
?????
That was using N++'s "Extended" search mode. Using "Regular Expression" mode doesn't improve things.
 
@FreeMan Find can only find text inside a single line. If you want to find something spanning multiple lines, you need Find in file or whatever it is called.
 
oy, really? that work on open files?
 
It has options like current document and all open documents.
I regularly use it to generate CTEs out of some input copied into the query window.
 
Nope still going from
...','
...','
to
...','
'),
...','
'),
It's insisting on leaving the newline, adding my "replace" text, then another newline
and both SSMS & N++ refuse to find ','\n. They'll both find ',' and \n just fine.
won't find \t\n either, even though I know there are some there
back to Manuel pasting...
started the day with a good attitude. It's slipping rapidly
 
 
2 hours later…
2:44 PM
Hi folks :-) I see you've updated inspections on website. Good job :-)
One little thing about inspections though.
Few days ago I wanted to disable all inspections within my TestModule.
From what I found on the Wiki, I had to do multiple @IgnoreInspection ThisInspectionName (or something like that) on each line within that module.
And the 'ThisInspectionname' I found from Inspection window - look on the name - fire up the site - ctrl + f that name - that returns the inspection short name and that I added to the line.
Is there an existing proposition to add Inspection shortnames to the RD Inspection Results window?
 
Inspection short names? That's news to me!
 
3:01 PM
@FreeMan What is your search pattern and what is your replace pattern?
 
3:12 PM
@Hosch250 the class names, basically
 
Oh.
I thought we used to have that in the inspections pane?
 
@SonGokussj4 you can do @IgnoreModule FirstInspectionName, SecondInspectionName, ThirdInspectionName, ... at the top of the module, too
 
Also, what happened to the Ignore quickfix?
 
?
it ignores results, not inspections
@SonGokussj4 to disable all inspections in a module IIRC you can just do @IgnoreModule (no list of names) and all inspections will ignore that module
 
Oh.
I thought ignoring an inspection was the same as ignoring results at a module scope.
 
3:16 PM
but the ignore quickfix isn't module scope, it's per-result
 
3 hours ago, by FreeMan
and both SSMS & N++ refuse to find ','\n. They'll both find ',' and \n just fine.
 
3:28 PM
have i ever mentioned how much i dont like crystal reports?
and using logicity to open them
-_-
i dont freakin understand why this POS doesnt wanna work
its tellin me database login failed, but i explicitly gave said user access to the database
 
@FreeMan Your problem is that the windows style line ending is \r\n.
 
im pretty sure if i can SSMS into the freakin db, i should be able to login via CR
if i have explicity select perms, i should be able to open this stupid report...
 
@IvenBach Need to add the XML serialization attribute to the property you want to record.
 
@M.Doerner according to the docs, \n is OS agnostic. However, I wouldn't put it past the docs to be wrong...
I'll give that a try
4 hours ago, by FreeMan
MS Docs says that \n is a new line. It also indicates that $ anchors the search to the EOL. Neither seems to be able to find anything at the end of the line.
 
\r?\n ftw
 
3:42 PM
and... docs are wrong!
bows to @M.Doerner
Thank you. Thank you! THANK YOU!!!!
 
@FreeMan psst. <whisper>This is why I don't question the big ducks. They know what they are talking about.</whispser>
 
@IvenBach OY!
how dare you not question us?
 
Question for you oh great and knowledgeable fowl Vogel.
 
~googles "fowl"
 
public ToDoMarker[] ToDoMarkers has its member attributed with [XmlArrayItem("ToDoMarker", IsNullable = false)]
 
3:49 PM
@FreeMan You are welcome!
I just tried the one thing I could imaging why it would not work.
 
@IvenBach ftfy
 
#TIL \] to escape for markdown.
 
@M.Doerner and I learned to not assume the docs are correct because we all know what happens when you ass-u-me...
 
Still @Vogel612's version is the safest one.
 
What attribute should I use for my added class that's encapsulating the column indices? public ToDoExplorerColumnHeadingsOrder ColumnHeaderIndices { get; }
 
3:51 PM
@M.Doerner of course Apple couldn't help but fuck that over, but alas
 
XmlElementAttribute Class comes closest to what I'm looking for.
 
@IvenBach well... ReferenceSettings#_pinned supports that, but e.g. HotkeySettings doesn't have any attributes at all ...
soo ... I personally would just not annotate it
 
 
1 hour later…
5:23 PM
> **Justification**
The `VersionCheck` feature is currently sending an asynchronous HTTP request to http://www.rubberduckvba.com/build/version/stable, which responds with the version number for the latest "green release".

With the website's recent update, that version number is now coming straight from [releases](https://github.com/rubberduck-vba/Rubberduck/releases), through the GitHub API - rather than returning the assembly version of the Rubberduck.dll assembly depoyed to the website, it
 
@Duga that one should really be 01-duckling... I think.
 
I'm partial to radios :)
 
why 3-state?
 
@MathieuGuindon mumble mumble slightly misleading difficulty mumble.
 
5:26 PM
Check pre-release
Check release
Don't check
I like combos at about 5 items.
 
@IvenBach not really... the feature is already coded, it's just a matter of adding more meat. doesn't delve very deep into RD's internals at all
 
I've heard that before. Hopefully that one is an easy fix.
 
@Hosch250 I'd do a combobox, but I wouldn't chew your head off if you made a PR that introduced it with radiobuttons :)
 
LOL.
 
Mug's nudges are not-so-subtle.
 
5:30 PM
=)
 
Even if they do take you into the inner bowels of the cathedral duck it's to expand your knowledge.
 
FWIW when I hear "3-state button", I think of the checked, unchecked and grey box versions.
(or black box, depending on version of Windows)
those are FUN to use.
 
What other option is there? A group box containing 3 radio buttons? :derp: must read chat more closely.
 
@this me too
 
@MathieuGuindon yes, no, undecided. ;)
 
5:37 PM
Except, that's not what is being presented as options
Heck, even if it's literally just Yes/No/Undecided the triple state is still questionable.
And that's coming from a SQL guy who works with tertiary logic all the time
 
tristate Boolean. says it all.
2
 
DOES NOT COMPUTE!
 
I think I read somewhere that it was very much frowned upon in the UX community
 
The only legit use is for treeviews where the parent has a partial selection.
but as a 3rd option? Hell, no.
Even in the treeview example, clicking on the parent node collapse into one of 2 binary states.
 
@MathieuGuindon "Trillian" <-- ftfy
 
6:27 PM
> Radio buttons can work too.
 
@Duga more like what @Hosch250 actually meant
 
wee. I love it when they play hide'n'seek with their features.
I was working on automating an external program and looked in 100 different places trying to find out how to open a search dialog. Even mashed some common keyboard shortcuts. Asked and was told, "just start typing the number and dialog will pop up automatically."
INTUITIVE!
 
6:47 PM
-_- so i have a wierd thing poppin up
we moved our ERP software from Sql server 2000 to 2008 r2
 
@this ummm... so what if you're just actually, I dunno, entering data???
 
off server 2003 to server 2008 r2
then we go and relink the tables on this access app that has been working
 
@KySoto wow... I thought we were behind the times!
 
suddenly... it fails
its just too much money to update it to a version that can run on in support database software
sadly
anywho this disgusting mass of nested queries stopped working
and its throwing a wierd error
so, the two base queries to this query work, pull up data etc.
SELECT qry_Operation_20_good.BASE_ID
	,qry_Operation_20_good.PART_ID
	,qry_Operation_20_good.OPERATION_SEQ_NO
	,Sum([SumOfGOOD_QTY] - [QTY40]) AS Waiting_For_Glass
FROM qry_Operation_20_good
INNER JOIN qry_Operation_40_total ON qry_Operation_20_good.BASE_ID = qry_Operation_40_total.BASE_ID
GROUP BY qry_Operation_20_good.BASE_ID
	,qry_Operation_20_good.PART_ID
	,qry_Operation_20_good.OPERATION_SEQ_NO
HAVING (((Sum([SumOfGOOD_QTY] - [QTY40])) > 100));
BUT i get an invalid operation error when it hits this part
which causes queries that use this mess to silently crash to restart access
 
@FreeMan it's on a main menu of some sort, so no data to enter; but you have to be typing into "nowhere", not into one of various filtering textboxes.....
because it's a thing everyone does, typing stuff into any random non-text controls, right?
@KySoto, it's an Access query?
 
6:57 PM
-_- yes
-_- theres gotta be like 50-60 queries tied into this mess
 
these aliases though no aliases?
 
nope
its access generated code
 
most ppl don't alias their Access queries
 
yeah
 
6:59 PM
@KySoto delete the query, then create a new query, then try again.
 
heh
 
you know the standard IT response. ;)
 
i created a new query, dumped the text in and ran it
failed in the same way
 
I'd go with delete the query, create a view on the source db, do as little as possible in access-sql
 
@MathieuGuindon when you're given a graphical builder, you get to get away with fugly code.
Which would be even better but if the source are also Access queries, he'll have to migrate them all
 
7:00 PM
awww @MathieuGuindon you assume that all of the databases are on sql server
 
(which should happen anyway)
 
idk you had linked tables the other day
 
actually, now that im looking, most of it is
 
to confirm - the data was on the sql server 2000 previously, right?
 
i guess im lucky here
the ERP data was
we have lot tracking databases that are on a different sql server instance
 
7:02 PM
@this yeah. just look at any drag-n-drop generated xaml :)
 
it looks like only one table is an access table
 
Guindon
I'd go with *delete the ---query--- access db, create a view on the source db, do as little as possible in access ---sql--- *
bah, format fail
but you get the point ;-)
 
lol yeah
 
hating on Access is easy. and fun!
2
 
tis!
but i cant do that as not all tables have been migrated to sql server yet
 
7:04 PM
@this tbh there weren't enough extraneous parentheses for me to tell it was generated sql :)
 
but either way
trying to rewrite these... 60? queries...
 
@this guess I'm not "most people" yay!
 
welll fuck
the VBE isnt accepting keypresses anymore
like, i can click buttons, but not type in the code pane, or immediate window
 
Have you tried rebooting the machine right out the window?
 
@FreeMan Or having a coffee accident?
 
7:08 PM
lol
i dont have a window where i work
just factory floor
 
See, I don't drink coffee.
 
also, i was wrong on hte query count, its about 96
i dont wanna rebuild 96 queries
 
So if I ever get a machine that I need to have a coffee accident on, I just need to drink some, then immediately and violently puke on my machine.
 
or try to refactor that hot mess
 
@Hosch250 meh. Coke will work about the same. Ruining hardware and cleaning your engine block is about all that stuff is good for anyway...
 
7:09 PM
welp, an engineer started monkeying around with some of the queries, and linked in some other random query and suddenly the queries stopped crappin themselves
 
I'll save that for round 2.
 
so, hey, screw it. let the engineer have the fun this time
2
 
I don't drink pop either.
@KySoto What kind of engineer?
 
one day when they ask me to go and add some xyz functionality, i'll rebuild it from scratch
uhhh, i forget his actual degree
 
I mean, just what does he do for work.
 
7:11 PM
but he's part of the manufacturing process of diodes
 
Software? Chemicals? Electrical?
Oh, probably electrical.
 
yes
to all 3
i think
 
LOL.
All good engineers know something of everything.
 
i know hes in charge of the etching area
 
Chemical for sure, then :)
 
7:12 PM
he does a buncha stuff
 
Anyway, time for first aid training. See you tomorrow.
Training until 6PM, and supper afterward. Not getting out until LATE.
 
7:30 PM
great. SSMS quit responding. This is what you get for making fun of @KySoto
and... it crashed again!
about time to reboot this thing out the window.
 
7:47 PM
Is there an article or documentation I can read to educate myself about the provider pattern?
 
@IvenBach a Provider is basically the same as a Supplier
it's exactly what it says on the tin
 
rebooted. made a fresh pot o'coffee. SSMS crashed again. :(
that means it's time to go home, right?
 
@FreeMan xD trolololol
i give it one more crash before it starts behaving
 
well, it got 2 in before you responded.
I've learned, though. type a character, Ctrl-S. type a character, Ctrl-S.
 
true
 
7:55 PM
productivity is through the floor, but I'm not loosing anything!
 
xD
 
this is a first:
> The number of row value expressions in the INSERT statement exceeds the maximum allowed number of 1000 row values.
for me
ummmm... could that be what's making my INSERT INTO ... SELECT * FROM OPENROWSOURCE... puke?
 
wow. yeah so you are limited to 1k fields
actually, huh. why not make an SSIS package that can just take in a CSV and dump the data in?
you pass the thing a filename parameter or something like that
 
read the last 2 3 4 days of my laments. It's a long story...
 
are you actually inserting 1000+ columns?
 
8:09 PM
> The number of row value expressions in the INSERT statement exceeds the maximum allowed number of 1000 row values.
no, there are about 26 columns. I had oh... 2500 ish rows.
fortunately, I really didn't need them all, only the newest couple of hundred made it into the final table. That was just the load to the temp table.
I just peeled the oldest stuff off until I was under the threshold
and, to answer my own question, no, this isn't the problem. At this point, my first file loaded has 400 rows of data, the 2nd has 300 rows. Since they're each loaded individually, that's not causing it to puke.
though, when it gets to this big'un (my bad, 3200 rows), it might struggle, but it loaded it last month on the old server with roughly 2700 rows
finishing up the manual loads, then the reports, then chucking this baby with the bath water & finding a new plan
 
> **Rubberduck version information**
Version 2.4.1.4719
OS: Microsoft Windows NT 10.0.17763.0, x64
Host Product: Microsoft Office x64
Host Version: 16.0.11629.20136
Host Executable: WINWORD.EXE



**Description**
As per the title. I have a number of Modules and classes with the '@IgnoreModule annotation. Where the Module is a '@TestModule, it is hidden from code inspections. Where '@IgnoreModule is in a normal Class or Module the respective Class or Module is not ignored for code in
 
@FreeMan not everyone is ready to be a parent... :P
 
@KySoto Please tell that to all dem Pineapples out there.
 
FWIW no one is ever ready to be a parent
in other news this weekend I found out that the maintainer of Octokit is father of triplets
 
8:49 PM
> Version 2.4.1.24543
OS: Microsoft Windows NT 6.1.7601 Service Pack 1, x64
Host Product: Microsoft Office 2013 x86
Host Version: 15.0.5023.1000
Host Executable: EXCEL.EXE

**Description**
Export option for settings window doesn't export settings.

**To Reproduce**
Steps to reproduce the behavior:
1. Display settings window from IDE Rubberduck>Settings
2. Click on `Export` in top right of window to choose directory and filename
3. Navigate to directory and there is no file

**Expe
 
9:04 PM
> File is exported to %appdata%\Roaming\Rubberduck\rubberduck.config
 
@IvenBach "Export settings command isn't exporting to specified path" then?
 
AFAICT it's always defaulting to the same fixed location.
 
sounds like a bug indeed, but the issue title is misleading
 
I just figured out it's actually exporting something.
 
9:08 PM
:+1:
 
I'm just struggling with ToDoExplorer stuff... Don't feel like I'm making any progress.
 
if it's any consolation, earlier today I responded to a YT comment saying block completion wasn't working
 
It's making the jump from the abstract idea to the actual implementation.
Integrating that jump with everything feels way beyond what I can comfortably accomplish.
There's a lot going on I don't fully understand as well.
Just figured out that RD shutting down exports the config file. Now to noodle out how to include the column header ordering.
 
wouldn't that be just like adding any other new setting?
 
I don't know how to add a setting.
 
9:22 PM
start here
probably simpler to just add new properties to WindowSettings
depending on what this is all about
 
Should the addition go together as part of the ToDoListSettings?
 
where are you envisioning the new settings to be shown in the settings dialog?
are they going to be in that dialog?
or just stored alongside other settings?
 
This is for Issue2947 and the column heading reordering.
 
gosh, it's been far too long since I PR'd. Life getting in the way :-(
 
yeah, probably best to put them with the ToDoListSettings
@mansellan I know the feeling :)
 
9:29 PM
@MathieuGuindon very nice job on the inspection docs. Is there any value in reusing some of that for in-app docs? not everyone has permanent internet access...
 
@MathieuGuindon lol of course not.
some people are more ready than others though
 
@mansellan thanks! I don't think we can; xml-docs aren't localized
 
ah yeah, good point
 
it's really just to provide the website with content (and makes in-code explanation of what the inspection does)
 
well, for English speakers it's all kinds of awesome :-)
 
9:32 PM
I noticed a number of typos and errors though
 
Heh, I wonder if we should assign id's like the code analysis ones... RD1000: Do Not Use Hungarian Notation :-)
j/k
 
lol
BooleanAssignedInIfElse is completely wrong, that's not what the inspection does at all
 
I think github.com/rubberduck-vba/Rubberduck/blob/next/Rubberduck.Core/… is where the markers are being exported for the config file. How to add exporting the column ordering DelegateCommand with the ToDoMarkers is a mystery.
 
it's newing up a ToDoListSettings object; once that class has a ColumnOrdering property, that's where you'd assign it
 
Is the DelegateCommand Expecting only to be exporting a single thing?
 
9:38 PM
no, it means to export all todo settings
and then ImportSettings needs to grab the ColumnOrdering deserialized from the file and, well, load it in
 
It looks like it's just exporting the TodoSettings.
 
that's the idea
that command is wired up to the little tab-specific "Export" button in the UI
i.e. if there's something in that settings tab, "Export" should export it
 
gah, the other project is 12 in front :-(
 
now, you probably don't need a UI for that setting - the column ordering in the todo explorer itself is the setting UI
 
you need to get hansleman to blog about us :-)
 
9:42 PM
LOL
 
How do I ensure that the setting I've added for the column ordering gets serialized?
 
treat the todo explorer as the settings UI for it?
IOW when a column changes position, persist the change to settings
start with having a serializable property for it in the ToDoListSettings class
then take the ToDoListSettings as a dependency on the ToDoExplorerViewModel or something
no wait, that'll only store it in-memory, no on disk
you'll want to take the same service that the settings dialog is using to write to the config file
 
@MathieuGuindon I've found out where to handle the event for this. The what is where I'm stuck. Don't know what do once the ordering event is raised.
 
how are you thinking to store & retrieve the column ordering?
 
> Linking #4852 - component types icons in the CE are broken in general atm.
 
9:50 PM
<GridColumnOrdering>Column1,Column2,Column3</GridColumnOrdering>
?
 
Any time the column ordering changes store it in the config file. How exactly to store it I can't figure out.
 
there isn't one right way to do this
 
public class ToDoExplorerColumnHeadingsOrder
{
    public int DescriptionColumnIndex { get; set; }
    public int ProjectColumnIndex { get; set; }
    public int ModuleColumnIndex { get; set; }
    public int LineNumberColumnIndex { get; set; }

    public ToDoExplorerColumnHeadingsOrder(int descriptionColumnIndex = 0, int projectColumnIndex = 1, int moduleColumnIndex = 2, int lineNumberColumnIndex = 3)
    {
        DescriptionColumnIndex = descriptionColumnIndex;
        ProjectColumnIndex = projectColumnIndex;
 
Okay, that works too
 
You work way faster than I can articulate.
 
9:52 PM
so you're looking at <GridColumnOrdering><DescriptionColumnIndex>0</DescriptionColumnIndex><ProjectColumnIndex>1</ProjectColumnIndex><.../></GridColumnOrdering>
 
That class I've added to ToDoListSettings
Something like that in the XML yes.
[XmlElement(nameof(ColumnHeaderIndices))]
public ToDoExplorerColumnHeadingsOrder ColumnHeaderIndices { get; }
Has been added as well but I can't figure out which attribute to use to have it also serialized.
 
how it looks in the XML determines how you're going to serialize & deserialize it
 
I don't understand serialization well enough at present to have an idea of it's representation.
 
XML serialization "just works" - you only need to have a parameterless/default ctor, and {get; set;} properties
 
I just know that I do want it to serialize and subsequently be available for deserialization.
 
9:55 PM
that needs to be { get; set; }
and then ToDoExplorerColumnHeadingsOrder must have a parameterless ctor, and its properties must also be { get; set; }
 
One sec. Mind needs to catch up to you.
There also needs to be the set; so that when the deserialization occurs it can be assigned the deserialized (in memory) result?
 
public class ToDoExplorerColumnHeadingsOrder
{
    public int DescriptionColumnIndex { get;set; }
    public int ProjectColumnIndex { get; set; }
    //...
}
@IvenBach yes. deserializer needs to be able to write there
^^ the above would serialize to individual elements
you can have them be xml attributes with a [XmlAttribute] on top of the properties
 
public ToDoExplorerColumnHeadingsOrder()
{
}
 
the default ctor is redundant ;-)
 
I need to add the default parameterless ctor to allow for deserialization to work?
 
9:59 PM
no
you just need to not have an explicit parameterized constructor (which would remove the default ctor)
 
@IvenBach only if you have other constructors
 
public ToDoExplorerColumnHeadingsOrder(int descriptionColumnIndex = 0, int projectColumnIndex = 1, int moduleColumnIndex = 2, int lineNumberColumnIndex = 3) then needs to be removed?
 
00:00 - 22:0022:00 - 00:00

« first day (1810 days earlier)      last day (36 days later) »