« first day (3482 days earlier)      last day (103 days later) » 

5:17 AM
3 hours later…
7:59 AM
hmmm wtf youtube just told me to restart my computer.
/me restarted chrome and that fixed it
8:53 AM
I get that sometimes when something happens with the audio renderer
or when I mass upgrade packages
is there a way to live-swap the default card in ALSA?
usually my spakers are default
but rarely it seems to select my headphones
user image
or is the answer to "how to change the default audio device in ALSA?" something along the lines of "use pulseaudio" ?
oh hmm
it appears the mobo audio is't in /proc/asound/cards
9:11 AM
@bertieb there should be
9:25 AM
@djsmiley2kTMW "Tell me, Mr Anderson... what good is being able to swap cards, if one of them isn't there?"
I could try and figure out why the onboard audio sometimes fails to show up
or I could reboot in those... ~5% of occasions
the latter is unsatisfying but also much less likely to take up a full day of diagnosing ;-P
Does it only show up, when a headphone is connected?
My speakers are plugged into the mobo audio; HS is a usb G930
Both are always plugged in
but sometimes the usb doesn't show up?
9:32 AM
Sometimes there is no audio when I boot; I had assumed that was because of card default switching, but I checked there and there was no onboard audio reported by /proc/asound or aplay -l
@djsmiley2kTMW Other way 'round
onboard audio sometimes doesn't show up
ooo, weird
a quick grep of dmesg didn't show anything obvious
but my analysis was hardly forensic
deffo weird.
I'm inclined just to ascribe it to a random BOFH excuse calendar reason
solare flares! (french ones no less!)
9:42 AM
B-bu-but Brexit!!
@bertieb I thought you Scots were going to vote again to stay in?
'twas a joke
kinda like Brexit, a bad joke
And Scotland probably would vote to rejoin
Dunno though, politics is notoriously fluid
@DavidPostill dude! you've changed your face
@Burgi Yeah, got bored with the old one ;)
like it :)
10:01 AM
Last one was a passport photo so a bit formal and posed. This one is more edgy ;)
11:08 AM
I have an ssh pubkey on a jumphost, and the target machine
and ~/.ssh/config set up correctly
so ssh target works using my private key without prompting for a password
<waits for punchline>
ie: it uses the key to log in to jumphost and target
all that works correctly
why does it prompt for the password on jumphost if I do
ssh -i <id_rsa> -j jumphost target ? (as root)
it's asking for the password, for target?
aaah y u ssh as root ;)
Because this is a service (borgmatic)
which runs as root
I think, because you haven't loaded the .ssh/config when you're connecting
so it doesn't know about the key too maybe
/me hasn't used -j
11:12 AM
@djsmiley2kTMW it shouldn't need that as I've specified the jumphost using -J
accidentally had it as -j (lowercase) in example above
does it load the key from the jumphost, or locally?
the identical command runs correctly if I run it under my own user
okay, so -vvv shows me that it doesn't seem to want to load the privkey when connecting to the jumphost
question is... why not?
### Host to jump to via jumphost1.example.org
Host contabo
HostName contabo.example.org
ProxyJump contabo
I'm confused as I've got nothing to test on atm :P
So if I set User and IdentityFile in root's .ssh/config, and use that instead of -J, it works
which is grand, and will work for my purposes
but I am curious as to how to specify the same options on the command line
or why one cannot
As the resident expert on ssh jumphosts, would you mind weighing in on the above when you see this ping, @CanadianLuke ?
Thanks in advance :)
12:12 PM
@DavidPostill i saw that
3 hours later…
2:57 PM
Starlink launch in -8min
The Community Team on February 17, 2020
In this post, we’d like to talk about some of the initiatives that are happening internally at Stack Overflow aimed at addressing and repairing our relationship with our community.
2 hours later…
4:54 PM
Q: Accuracy of FSIN and other x87 trigonometric instructions on AMD processors

bwDracoOn Intel processors, x87 trigonometric instructions such as FSIN have limited accuracy due to the use of a 66-bit approximation of pi even though the computation itself is otherwise accurate to the full 64-bit mantissa of an 80-bit extended-precision floating-point value. (Full accuracy for all v...

I haven't posted on Stack Overflow in ages...
5:23 PM
introducing the youngest to the wonders of colin furze
Of the, uhh, Furzels
do you not know who...
> Colin Furze is a YouTube personality
I feel okay about not knowing that :D
Shocking News! Youtubers Have Personalities!
More on BuzzFeed
he's awesome tho
engineer and madman
not much engineering in this video, admitidly.
rocket powered tuktuk!
5:31 PM
I am the Garth Marenghi of YouTube
In that I have created more videos than I've watched
man, I miss Darkplace
do you make anything off them?
Does "the warm fuzzy feeling knowing that literally DOZENS of people worldwide have watched some of my videos" count ?
if so, then... no
YT changed monetisation in the last few years, now you need minimum 1000 subscribers before you can start cashing in on that sweet sweet Alphabet dolla
oh yah
@bertieb I'm back. What's the issue with your jump host? That it's not loading your key automatically?
5:46 PM
@CanadianLuke Pretty much
Linux client -> Jumphost -> Target server?
# ssh -i id_rsa user@jumphost user@target (root; does not use key)
$ ssh -i id_rsa user@jumphost user@target (user; does use key)
Is user the same on the jump host, as on the target machine? Same as your user on the Linux client?
# ssh target (all config done in /root/.ssh/config; does use key)
@CanadianLuke Yes, although first case it is root that is running ssh client, though connecting as user
What all is in your /root/.ssh/config file, in relation to the jump host and your target?
5:50 PM
@CanadianLuke Nothing, in the case of wanting to specify all on the command line (via -i and -J)
and <appropriate entries>, in the case where it works
I should make clear that I have this working using .ssh/config
I am just curious why it doesn't work when specifying options on the command line
Not sure if that's intended behaviour / perhaps .ssh/config can specify things that the command line cannot
my impression was that the config file was there for convenience
and that anything one could do there could also be done via command line
It can, but you can also use -o SettingNameFromSSHConfiguFile Value on the command line as well
But I use -A to pass my agent from my client through to my target machine
Ah, maybe that's what's needed
I never heard of -J
seems like a convenience switch for jump host
-J destination
         Connect to the target host by first making a ssh connection to the jump host described by
         destination and then establishing a TCP forwarding to the ultimate destination from there.  Multiple
         jump hops may be specified separated by comma characters.  This is a shortcut to specify a ProxyJump
         configuration directive.  Note that configuration directives supplied on the command-line generally
         apply to the destination host and not any specified jump hosts.  Use ~/.ssh/config to specify conโ€
> Note that configuration directives supplied on the command-line generally apply to the destination host and not any specified jump hosts.
there's your problem! (dot gif)
So try with -A when you have the keys loaded in your ssh agent
6:02 PM
Q: SSH config option to use ProxyJump gateway's `/etc/hosts` lookup?

golmschenkI'm attempting a gateway hop through servers A -> B -> C, and would like to have this connection as an entry in my SSH config. SSHing from B into A works. And then from B to C works. As does ssh B -t ssh C. However, when I attempt use the following SSH config file, it fails. Host B Hostnam...

@bertieb u socking?
Also HarryMC seemingly doing genuine debugging with a user!?
@djsmiley2kTMW Yeah, so he post an answer and earn the bounty ... :/
if it actually helps the user...
its more effort than he normally gives
6:19 PM
That's a positive ๐Ÿ˜
6:31 PM
I just ran the utility here on a laptop with a Ryzen 7 2700U and it looks like AMD Zen indeed uses 66-bit pi, because the output of fpuaccuracy examples for the "sin near pi" case is the same as the example output supplied with the program, which was run on an Intel Core i7-2600 (Sandy Bridge). I'm presently away from my Zen 2-based desktop (Ryzen 9 3950X) but will test it when I get a chance. I doubt the result is going to be any different, though. — bwDraco 5 mins ago
3 hours later…
9:29 PM
@CanadianLuke me neither.
and I know about tunnels and such, never ever heard of jumphost option, is it newish? :S

« first day (3482 days earlier)      last day (103 days later) »