« first day (1756 days earlier)      last day (3344 days later) » 
00:00 - 15:0015:00 - 00:00

12:04 AM
The top right corner of the tablet gets very hot very fast. The Tegra K1 sure runs hot...
The backlight bleeding issue people have reported is nowhere near as bad as they say
I do notice a little bit of bleeding on the edges but it's not really an issue.
quick. What is the bar across legacy programs which are accessed by the alt+char combination called? ( quickly if you don't mind )
don't make me statup VS :$
menu strip :4
12:29 AM
@Ramhound Menu strip? :V
Sorry i already got the points
and the car apparently, ;-)
12:58 AM
> phone
TIL that the Nexus 9 is the largest phone in the world
Yeah, that's odd
It's the same message on any Nexus device.
same code :P lazy, but still
@allquixotic: threw a wallabag instance on puppy yesterday
(also, for some reason both my lighttpd/ubuntu installs use less memory than I remember)
1:02 AM
@allquixotic It's part of fastboot. I don't have the bandwidth to pull it up as I'm installing and updating lots of apps on my N9, but you might want to look at the AOSP source code to understand it better.
The Nexus 9 is a bit different as it's built by HTC and therefore has HBOOT (and the Android robots on skateboards on the menu), but fastboot is provided as well.
@TomWijsman that's only after several screens worth of busybox prompts and manual zpool import and zfs mounting.
I still think it's something wrong with the kernel params
1:23 AM
Unlock bootloader?

If you unlock the bootloader, you will be able to install custom operating system software on this phone.

A custom OS is not subject to the same testing as the original OS, and can cause your phone and installed applications to stop working properly.

To prevent unauthorized access to your personal data, unlocking the bootloader will also delete all personal data from your phone (a "factory data reset").

Press the Volume Up/Down buttons to select Yes or No and continue.

Yes (Volume Up)
1:36 AM
Somebody tell me to do my work for the bug spraying, ugh!
A: Secuirity concerns from Windows 8 login screen

JameMake sure you don't set up a PIN or picture password. If you've set up a PIN or picture password, Windows will also store your local password in a reversible form that can be decrypted with Mimikatz. To block a thief from booting off your computer with a CD or USB, you can set a BIOS password to...

Don't be fooled.
Post looks neutral, but points to a spam blog promoting a password recovery tool. — DragonLord 2 mins ago
Spam can be far sneakier than you think.
2:10 AM
I wasn't fooled
damn you Sandboxie for being so helpful once every 30 days :
So tempted to get the 3-lifetime pack
2:26 AM
@JourneymanGeek what is wallabag?
@allquixotic Some kind of sack for carrying Wallabies, I guess?
> wallabag is a self hostable application for saving web pages.
@Ramhound Does Sandboxie alert you when a program tries to make changes?
2:42 AM
@allquixotic: essentially a bookmarking webapp. I can pop links in at work, and take a look when I get home or on my phone or...
@JourneymanGeek does it actually download and save the content?
@MichaelFrank - No; the program works like normal just in a protect region of memory
@allquixotic: It tries to save some of the text.
Dosen't work on password protected stuff (like say tt-rss)
Want to mess around with it?
(I mean its your server and all ;p)
ahh, it does save full text on passwordless things. So the ttrss extension is slightly useless, but otherwise, it works well
@Ramhound Okay, so how does it deal with things that change the registry? Does it just remember what was changed and then roll them back?
Great for when you have an installer that does adware installers
3:08 AM
"The following classes of system objects are supervised by Sandboxie: Files, Disk Devices, Registry Keys, Process and Thread objects, Driver objects, and objects used for Inter-process communication: Named Pipes and Mailbox Objects, Events, Mutexs (Mutants in NT speak), Semaphores, Sections and LPC Ports. For some more information on this, see Sandbox Hierarchy. "
Basically it keeps everything in a small subset of memory. The best part if there is a conflict with Sandboxie and an app, it will basically bail out, because it bails out in a protect subset of memory :-)
@Ramhound: I wonder how it compares to application virtualisation
Used to run something called SVS for the same thing
Given there is a huge exploit in a major commercial hypervisor
that allows the attacker to escape the VM, granted, its the server hypervisors not stand alone clients that has this exploit
They both have advantags.
The best thing is it does conflict with any of the security software i use ;$
I don't suggest a great deal of software to anyone. But when I do .. alright I won't actually say that whole line, but Sandboxie actually is i suggest ( only about 5 pieces of software on my list )
Of course how Sandboxie works its magic can also present problems, reading it actually breaks Chrome's sandbox, by overriding certain polcies apparently
@Ramhound:Unlike me, who recommends lots of software ;p
which isn't a big deal since it doesn't escape sandboxie, basicaly, if something targeted snadboxie it could in theory escape but thts true with a vm too
3:42 AM
@allquixotic (@TomWijsman) removed the ro from the params, and it's not chucking the errors anymore (still need to manually mount)
the console screen is cleared and I end up with a black screen... hm. I suppose that's progress
You didn't just post a picture of a black screen, did you? o.O
thats cause i only look at the pictures
4:00 AM
He might have
like my picture better
4:17 AM
If I have a 4 bay NAS that I want to run in RAID 1, is there a standard way that the drives mirror?
hm, shouldn't that be in the manual? ;p
@MichaelFrank generally you pick a way
@JourneymanGeek This is a hypothetical NAS :P
But anyway, it's not important.
4:44 AM
@allquixotic: anything up with your server?
(can't seem to connect to puppy over http, and I can't ssh to check from work since my keys are on my home box)
4 hours later…
8:54 AM
Phone is rooted... Just waiting for first boot.
9:18 AM
Q: Windows 8 Dewktop wont start up

Th3No0bMy Windows 8 PC won't start up. When I power it on, I see the Acer splash screen, but then I get an error screen with a code 0xc000021a and then it reboots and tries to repair diskfiles, but fails then gives me the option to refresh/reset/more advanced options. I've tried to refresh my PC but tha...

2 hours later…
11:06 AM
@MichaelFrank I posted a screenshot of the VM. Whether it's blank or not is somewhat relevant :P
11:17 AM
Can anyone in here help me find a consumer router than is compatible with my VDSL2 modem and has one-to-one NAT? I have looked at the TP-Link TL-ER604W but i am unsure if it will work with my VDSL2 modem?
11:52 AM
@JamesTrotter: In general if its a normal 'modem' with a single ethernet out, any router should work
Not too familiar with 1:1 nat
1:1 NAT?
Why oh why...
Fair enough, that's what confused me most. How does the authentication work then? as currently i enter my broadband login details via the router and have no access to the modem.
@djsmiley2k why not? I have 4 useable IP's and I want to use them for my servers separately.
Not running iptables/some fire wall on each?
if you've got 4 servers, why are you not looking at proper routers?
build a pfsense box/appliance is my suggestion
is the TL-ER604W not a "proper" router?
I'm not a great fan of the DIY router approach is all.
I have used it in the past, but i do prefer dedicated hardware, mainly for initial cost/power consumption benefits.
Nexus 9 runs surprisingly hot
I'm getting considerable thermal throttling under continuous heavy load (e.g. HTML5 Fishbowl)
Even battery charging gets throttled because the battery gets hot, refusing to pull more than 0.5A from the USB port when the battery exceeds 40 °C
12:08 PM
if that's the same for my nexus 7 it explains a lot
Then again, Tegra K1 throttling under load isn't all that surprising
@djsmiley2k 2013 model?
very early model, so yeah maybe?
tablet, not phone... (*not sure if theres a phone too)
@djsmiley2k 2012 or 2013?
derp I'm unsure? :>
Is the Nexus branding on the back of the device horizontal or vertical?
12:10 PM
I don't have it with me :/
/me tries ot think
There are two different Nexus 7 models.
The 2012 model shouldn't be subject to throttling.
horizontal I think.
Okay, is there a rear-facing camera?
That's the 2012 model.
Mine doesn't exhibit any thermal throttling.
It gets warm but never actually overheats.
The SoC is pretty old, a Tegra 3 T30L. It's a low-clock, power-efficient bin of the chip.
The unit does lack any real thermal throttling on the CPU, though.
The Tegra K1 T132 on the Nexus 9 does have thermal monitoring, and quite extensive monitoring for that matter.
The CPU is capable of hitting 2.5 GHz but is limited to 2.3 GHz on the Nexus 9, most likely because of thermal constraints
12:22 PM
@JamesTrotter depends what kind of layer 2. PPPoE? PPPoA?
The Tegra K1 can exceed 10 W during extreme loads but that's not happening on the Nexus 9
Honestly not a clue, can't even hazard a guess.
notebookcheck.net/… says 9.2 watts peak draw (which is probably overall system power)
That suggests about 8 watts peak power from the SoC
@JamesTrotter look at the current configuration
...which is about right for the Tegra K1.
12:24 PM
@Bob currently at work so haven't got access
@JamesTrotter At least with ADSL, it'll be some kind of PPP
VDSL is probably similar
The WordPress meet up I'm helping to host happens tonight
@JamesTrotter The authentication is usually some form of PPP, which most routers (that support auth over a birdged modem) will support. The choice of PPPoE or PPPoA depends on what your ISP uses between their DSLAM and their BRAS.
The actual DSL modem <=> DSLAM connection is probably ATM. And I think that's the same no matter which DSL connection you use (ADSL, VDSL, etc.)
12:36 PM
@Bob So you think it will be a PPPoA connection?
@JamesTrotter No, the choice between PPPoE or PPPoA depends on the DSLAM <=> BRAS connection.
They're both over ATM between the DSL modem <=> DSLAM.
At least, that's how I understand it.
@Bob I'll drop an email to my contact at the ISP and see if he can tell me.
@JamesTrotter Don't need to. Look up your ISP's config online, they'll either have a webpage or someone probably mentioned it on some forum, or even look at how it's currently configured.
Your modem probably has an option for PPPoE and PPPoA, one will be selected.
Or just try both and see which one works.
Some ISPs accept both.
IIRC PPPoA is preferred if you can use it - slightly less overhead.
@JamesTrotter e.g. my ISP has this: tpg.com.au/support/modemsetting.php
And generic instructions => tpg.com.au/helpdesk/pppoe/Generic.pdf
And a third-party forum => whirlpool.net.au/wiki/tpg_faq_dslsettings (they have most Au ISPs there)
12:42 PM
@Bob its a relatively small ISP, not many talk about it on forums and their support pages are basically "call us and we'll tell you".
Are they xkcd 806 compliant? ;p
ugh. Not having a good day with computers today.
puppy's down, and I'm trying to update my home server, which has a certain chance of borkeness
@JourneymanGeek haha might as well be, they all seem pretty knowledgeable and as soon as I show i know come of what I'm doing they usually drop the scripted "have you tried turning it off and on again" spiel
!!/xkcd 806
Chatbot's down again.
@DragonLord chatbot's on the same physical box as puppy.
@JourneymanGeek haha might as well be, they all seem pretty knowledgeable and as soon as I show i know some of what I'm doing they usually drop the scripted "have you tried turning it off and on again" spiel
@Bob Lol, i just emailed the guy at the ISP and he sent me back my login info... "I hope this resolves any problems."
12:50 PM
(there's one ISP that actually is)
@JamesTrotter Ask him what config settings to use?
Hm, apparently VDSL2 doesn't use ATM.
1:29 PM
@Bob It's PPPoE
I want the terminal bell in my PS1, am i mad :/
2:03 PM
> In preparation of this migration, starting on June 9, the following
changes will also be implemented by the registry:
- limiting the renewal period to only 1 year (it is currently possible
to renew up to 9),
- increase in the renewal price to $102.60 (€85.50 / £) excl. VAT per
year, (it is currently $19 (€14 / £12.50) excl. VAT in A rates),
- halting of new registrations until further notice
Fuck :(
who or what?
That note relates to .so domains
Nice way to get existing customers to quickly take out a 9 year lease.
Yeah, indeed
wait hwat
2:04 PM
I have 2 .so domains :\
from like ~$20 to ~$100?!
So you might as well buy 2 x 5 years right now
the fuck
before it costs you that much for 1 year after.
@djsmiley2k Right
Well, I'm thinking of just renewing both domains for 9 years
But you can do the math :P
Spending that much money on a stupid domain name... :\
is the domain vital? screw that cost.
2:08 PM
@JamesTrotter It's salzburg.so, so, yeah, you could say it's critical ;D
And, oliver.so
Those names are not easy to get
I'm on an RDP session from my Nexus 9 to my laptop
My laptop, away from my laptop
@OliverSalzburg yeah i suppose, but man that price tag
2:31 PM
(You need to kick your dedi ;p)
@JourneymanGeek what's wrong with it? O_O
@allquixotic: Its down from what I can tell ;p
puppy's not connectable, and Cavill is down too
*hastily reevaluates plans to get an ovh box*
2:34 PM
nah, it's not down
phys is responding
but it's ridiculously slow
@Bob Does your application actually require a dedicated server?
@DragonLord No, I just want one for fun.
(You decide if that was sarcastic or not. I'm not too sure.)
If not, why not use a VPS instead?
I have a dedi cause it was cheap as anything
In all seriousness - a VPS doesn't give me the ability to spin off isolated VMs so easily, nor enough control, and the cheaper ones have bullshit restrictions, and the expensive ones are more expensive than a physical box anyway.
2:38 PM
£80 for 16GB ram and 2 dual core 3GHz CPUs
Restrictions like "you can't use a single CPU core for more than 5 mins"
@JamesTrotter "dual core 3GHz CPUs" means nothing. you need to consider the specific CPU model, or at the very least the architecture and maybe the amount of cache
and that's quite expensive per month for that hardware, depending on location...
Actually the funny thing is, with my current stuff, I can probably consolidate everything into my 128 mb vps...
(I'm still shocked at how low the ram usage on puppy is)
2:40 PM
I'm nowhere near the 2GB available on my Linode VPS
@JamesTrotter The problem is, a modern "dual core 3GHz CPU" can easily be >2x faster than an older one
@Bob i meant 2x dual core 3GHz cpus, they're an old generation of xeon, but they do the job, and thats not monthly i own the machine and collocate it in a nearby datacentre
@Bob Yeah they're not great, i'll have to find the generation.
@DragonLord: the big thing for self hosting or a dedi is flexibility
I can spin up a VM at no extra cost to test something.
@JamesTrotter e.g. my current dedi has 12 cores (dual L5539). I'm planning to move to a single E5-1620v2, which should have similar multi-threaded performance across four cores - approx 3x the single-threaded perf
@DragonLord From the Linode ToS:
> Misuse of System Resources: Intentional misuse of system resources, including but not limited to employing programs that consume excessive network capacity, CPU cycles, or disk IO.
define "excessive"
@Bob oh i know, by no means was i attempting to show off the thing is ancient but for what i paid for the machine at the time it was a steal.
2:44 PM
In practice, it's only an issue if the workload is far beyond what is reasonable.
@Bob make -j4
@JamesTrotter I'm just saying you need to specify specific CPU models
I see that far too often
A decade ago, people were judging CPUs by clock speed
Now they judge by a combination of clock speed and core count.
That is far from enough information to determine just how the CPU performs.
lol, that reminds me of my +96 upvoted answer that has like 30 downvotes
And people still do it. Everywhere.
@allquixotic so I can't run gentoo? :(
2:46 PM
@Bob indeed it is, but when you dont know the model no.s all i have to go by is clock speed, core count and its age
@JamesTrotter age (generation) plus clock and cores is reasonable
@Bob or a custom kernel, or a custom phantomjs, or...
Someone did get in trouble for slamming more than 10,000 IOPS continuously on the server.
specific model is still best, but those three together lets people make an informed guess
nothing beats the guy on ebay who just x's clock speed by core count, so he slaps like "16GHZ CPU" on his machine listings
2:47 PM
@Bob technically the most accurate way is an apples-to-apples benchmark, but that only works on the same CPU architecture because of the way compilers and assemblers work; it wouldn't be fair to penalize, say, ARM, if gcc has a worse ARM assembler than x86.
@allquixotic or perhaps it would be fair, if gcc is the compiler you're using for your project
but, absent a benchmark, you have to consider CPU generation, # of cores/HT threads, cache, instruction set architecture, maybe MHz if all else is equal, and TDP (since there are now some Intel CPUs that look damn awesome on paper until you realize the TDP is 4.4W; oops)
you can't necessarily say that CPU is shit overall, but you can say it's unsuitable/worse for your purposes
@allquixotic: nothing wrong with that tho ;p
2:49 PM
@allquixotic if you look at base clock (ignoring 'turbo' clock), you won't necessarily need TDP
@JourneymanGeek yeah, unless you need performance akin to a 45W Ivy Bridge CPU; you're not gonna get that with a 4.4W Core M
I've never really looked at TDP
so 4.4W is what, hot? cold?
@djsmiley2k it's very very little power
@allquixotic: my home server's around that tdp ;p
Does ok
ultrabook ULV CPUs were 15-17W
4.4W is pretty much tablet class
2:49 PM
tablets are 2-5W normally
a traditional desktop CPU is around 100W
@djsmiley2k looking at TDP in isolation is not especially useful, but the large differences in TDP between "mobile/SoC-like" chips and desktop-grade chips and then, on the high-end, full-scale server chips, is telling of performance categories
enthusiast and server goes up to 150-200W
Now, if it had one more gig-e ethernet port....
traditional laptop/mobile is more like 50W
no idea what goes into phones
@allquixotic I look at gen first, then cores, then (base) clock
2:50 PM
in broad brush strokes, there are 3 TDP "ranges" for CPUs:
<5W: SoC
22W-65W or so: mainstream full-scale desktop CPUs or "real" laptop CPUs
higher: full-scale (e.g. Xeon EP)
and usually end up using them to find a close passmark score :P
I'm kinda tempted to pick up a J1800 brix
then I actually compare with the passmark score
ok cool thanks :)
@Bob Tegra has a TDP around 5W, but smartphones running Qualcomm or Apple processors have average power draw closer to 1-2W, and maybe peak up to 4.4W at max load
2:51 PM
sure, synthetic benchmark and some CPUs are better at some tasks - but unless you know the application, that's just too much work
@allquixotic well, Tegra fits into tablet-class, not phones
2 mins ago, by Bob
tablets are 2-5W normally
of course many phones share CPUs with tablets now, but there's still some distinction
in battery life and heat dissipation if nothing else
that looks like a reinstall to me, of at least the system / (which doesn't include anything running on the VMs, since they're on ZFS)
@allquixotic that was a fast failure
but if the ZFS is borked too, I'll be reloading the whole box
2:53 PM
oh dear
thankfully my old box is still up so I haven't lost any data
@allquixotic so the hdd conked it?
@allquixotic: what does happen with hardware failure on dedis?
@JourneymanGeek you message the owner, they replace it
2:54 PM
they don't charge you
you're renting their hardware
also, if they fail to meet SLA you get some credit
(the harsher the SLA penalty, the better, but you won't get a good one unless you pay a lot :\)
You're paying for the service. The hardware replacement is part of this service. It's not an extra charge.
99.99 is pffft
so is 99.999
@djsmiley2k I'm talking about the penalty for breaking SLA
heh, what a day
@Bob I don't know.
2:55 PM
not what the actual SLA is
Phoebe is down for a pretty major upgrade
@allquixotic smartctl?
I'm not sure if there's a hardware failure or if this is due to some problem software-related
You need ALL THE 9's!
@JourneymanGeek urk, every time you mention phoebe...
2:56 PM
if the ZFS is intact, I will just reinstall Ubuntu and won't lose any of my VMs
the system is unresponsive so I'm going to reboot... I doubt I'll be able to actually boot but I'll load up a rescue system
@Bob: moving my home server to fedora 22
and hoping it can boot ;p
Jan 3 '14 at 17:35, by Bob
@allquixotic I'm testing on phoebe
I stole your server naming scheme :P
Aug 24 '14 at 14:16, by Journeyman Geek
(and eh, managed to get into Phoebe, after looking up the ip address so I can check stuff)
I'm kinda hoping this issue is hardware related
2:57 PM
though I got to that name a good half year before you did!
that would give me relief that it's not me
@allquixotic I'm still struggling to get ZFS to do anything sane
I'm still toying with the idea of a storage box/bigger home server
@allquixotic: hm
looks a lot like a hardware issue
00:00 - 15:0015:00 - 00:00

« first day (1756 days earlier)      last day (3344 days later) »