« first day (3090 days earlier)      last day (180 days later) » 

1:07 AM
> Its an office laptop
Bring it into support. after backing it up
.... Why do your office laptops not have backups?
Interesting. Kingston is doing variable BOM and they're not shy about it; perhaps this is the solution that will bring NVMe to the entry-level and eliminate hard drives from cheap prebuilt desktops?
speaking of backups....
I might have a fun question coming up - I need to backup and restore a windows 10 mail instance
though I'm on imap, and the old machine still works so....
1:26 AM
1:53 AM
@rahuldottech lol
@CowperKettle .... 1gb?
1 hour later…
3:03 AM
@JourneymanGeek The traditional answer is ... upload to server over IMAP and download again.
@bwDraco Ehm. If SATA/AHCI didn't do it, what makes you think (the more expensive) NVMe will? Yea I know they say below SATA pricing, buuuuut...
@Bob its already imap ;p
@CanadianLuke Cause work IT is often ... suboptimal :P
I'm debating adding a (old/spare) SSD to the new box though.
ships with a 1tb drive.
3:28 AM
Seems... legit?
3:42 AM
oh, razer owns a payment system/cryptocurrency
4:03 AM
@JourneymanGeek s/razer/everyone and their granddaughter/
@MichaelFrank "waste electricity while your PC is idle"
@Bob oh. True but they also actually might have a chance of surviving
@Bob or heat your room
@JourneymanGeek I might want that if it can do negative heat
4:20 AM
@Bob to be fair, heat is needed sometimes here (it's winter now and getting very cold), and putting my 2080-watt Space Heater Ti to work earning useful useless Razer Silver might be easier than trying to mine a block myself or joining a scam pool
at least if Razer runs away with my 0.0000000001 BTC I have someone to sue and/or someone to request a refund of my RB15 to :P
what happened with your RB15? 0_0
5:06 AM
@allquixotic obviously we just need to set up a heat pipe over the pacific
6:05 AM
@allquixotic - You wouldn't even be mining worthless BTC, you would be mining worthless Silver, which only Razer wants. Sort of like how you could get a plane from Pepsi if you collected worthless Pepsi points back in the day.
^^ This really happened by the way
Besides the fact I remember the commercial, I recalled the case, in my business case law course.
6:48 AM
@Bob did you read about that Chinese ultra high voltage (12 million volts IIRC) ~2000 km, 12 GW power line?
@Ramhound he would be generating heat :p
@allquixotic .. 12 jiggawatts?
It's basically like that. I bet the losses across that distance are measured in megawatts, but they're still doing it. The amount of nuclear reactors (reactor cores, not power plants) required to generate that amount of energy is probably around 30.
They're sending 30+ nuclear reactors worth of power across one of the longest stretches of China (from the NW to the SE).
@JourneymanGeek - What?
The heat, right
@Ramhound yes
6:56 AM
Trying to decide if I should upgrade to First Class on my business trip making sure to stick my tongue out at my coworker when he walks by :$
@Ramhound sounds like a plan :p
(but then again, I stick my tongue out at everyone)
Good to know :-)
I am a tall guy so I need the extra leg room, which I already upgraded to that seat, just deabting if i should treat myself.
7:45 AM
@Ramhound by sticking your tongue out?
Yes; If you stick your tongue out at people the Airline will upgrade your seat :-)
No; just friendly batter with coworker.
@Ramhound the one time we got upgraded....
Mom had a crate with a musical instrument and they probably assumed she was famous
@allquixotic it's only 1 kA
@allquixotic nope not heard of it
8:03 AM
Man, I love my Drobo, best money I spent, a very long time. Just wish the larger capacity drives would come down in price :$
8:15 AM
@Ramhound I've got a ReadyNAS, it's pretty sweet. Except it's only two bays...
The only thing I don't like about the Drobo is how Windows reports free space.
The trick is to build your own :P
Perhaps...I think I went with Drobo because I determined I couldn't build one for less
I also at the time had personally been a victim to a Samba share configuration. Let's just say the Engineer who configured this particular system, made some changes, which were not documented. The system stability is so bad, the service, had to be restarted once every 36 hours at least. The configuration with the AD server could not be recreated....
RedHat doesn't even support the configuration that was used. 6 months was spent on trying to recreate the configuration. They had to move to Windows Server....
8:45 AM
RH and samba's a pain
9:11 AM
I have a batch script which fires up a vm
"C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" startvm "991fc173-6689-4a7f-b1e3-2873acb119a9" --type "headless"

sleep 30
"C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" guestcontrol "Gentoo" run "/etc/init.d/net.enp0s8" --username root --password test -- "restart"
sleep 30
"C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" guestcontrol "Gentoo" run "/etc/init.d/net.enp0s3" --username root --password test -- "restart"
hmmm y no indent
Anyway, even afte sleeping 30 seconds it's still not started.
> VBoxManage.exe: error: Error starting guest session (current status is: starting)
9:27 AM
60seconds? no change, Doesn't work :/
oh wow, caused a kernel panic :D
That'll be why it doesn't work then :D
Still, bad gateway in ngnix, I'll have to fix that :)(
10:07 AM
> >>> Emerging (2 of 75)
o_O basshunter dota was 2006
it's 13 years old
You're old
I'm old
We're all old. other than @rahuldottech who needs to get off my lawn
lol, I'm probably (?) the second youngest here
@djsmiley2k ew polling :P
10:29 AM
@djsmiley2k polling status in a loop rather than waiting for events/callbacks
10:45 AM
Ah right
well, not really doing that either
just blind 'it should be ready by now'
11:25 AM
@djsmiley2k that's even worse :P
@Bob I think I'm the second oldest XD
@Bob :D
it's mostly just proof of concept stuff @bob
just trying to make it so I don't have to manually shutdown / restart my vm each boot.
11:46 AM
Well holy shit, recovered my password in the end. Turns out I was remembering it correctly all along
@FMLCat but... why didn't it work?
@djsmiley2k on linux .... ;p
@JourneymanGeek Just failed to enter the exact combination?
(I can think of half dozen ways to do that)
@FMLCat ... which might have the same root cause as why you thought you had it wrong, just saying ;p
@JourneymanGeek not really. Guess I just ran out of patience when trying to enter it, takes 30 secs to a minute to verify each attempt in the Veracrpt bootloader.
11:53 AM
In the end, managed to grep it out of memory dumping all my running VM's, one of them had the password still in running memory from having entered it during the boot process several years ago
@FMLCat w0t u say m8
@Bob I think @BenN is, when he comes online.
But otherwise very possibly you. Dunno the ages of most people here. Burgi?
Also, @bertieb is still a student.
@JourneymanGeek I think it was what I was suspecting all along, keyboard/language mismatch. Since it all displays as * when entering
especially if it has an @
12:13 PM
Also possible one of the target systems I was trying it on is compromised and somebody changed my encryption password, though that would be strange of them, to change the disk encryption password and not the login password
Nope, just keyboard language mismatch.
Entering the password into Xencenter locally doesn't work for some reason, but over remote desktop it does...
Probably time to delete all those memory dumps, since FBI forensics will now know exactly where to look if they do seize my server...
nginx documentation (i.e. for running things on nginx) y u so crap?!
So I have a git server setup, I have a local git repo, which if i use git instaweb --start fires up a lightttpd server which works fine
I 'could' move everything over to lighttpd ;D
12:31 PM
@djsmiley2k lighttpd is a dream to configure if you just need a web server
@JourneymanGeek without PHP or the such, right?
@rahuldottech I used to run PHP with it
but if you wanted to run other stuff behind a reverse proxy ngnix is a better option
journeymangeek.com/?p=46 this is my old (@Bob disapproved) setup
if you're running https with LE- ngnix or apache are easier since cert renewals are baked in
12:48 PM
any time i think 'this is it, i'm finally getting a handle on things' something comes along and makes a mess
@JourneymanGeek yeah, that's why i fired up nginx, to just see how to do a simple web server
cept now it's that and trying to do gitweb, cept.... gitweb isn't happy
@djsmiley2k proxy?
@rahuldottech openwrt? N00b
@rahuldottech also, not all "smart" stuff sucks
just that its mostly walled gardens
1:00 PM
@djsmiley2k lol. I find nginx docs probably the best out of the major ones
@rahuldottech apache can gdiaf
1:17 PM
@Bob Lol, I only keep bringing it up to annoy you
I'm going to star what Bob said to annoy you
@JourneymanGeek It doesn't annoy me. I use all sorts of software for hosting stuff
More the starring
I mean my first web server was xitami
1:40 PM
Apache has it's terrible flaws too
they all do
but my problem is, I don't know wtf these programs are doing. They don't seem to publish a working config that I can find, I can find people who've shared configs that 'worked for them' but with no clue why, and those don't work either ;D
So the likely outcome is apache wouldn't work either, because I don't know wtf is wrong.
1:55 PM
ironically linkedin doesn't allow hotlinking of images
2:10 PM
@djsmiley2k lets break it down
what program is doing what? ;p
2 hours ago, by djsmiley2k
So I have a git server setup, I have a local git repo, which if i use git instaweb --start fires up a lightttpd server which works fine
However, as I already running nginx, and I don't want the web server to be dependant on me remembering to run git instaweb --start...
What, How, When, Why, Who, Where?
Options are: 1. script running git instaweb --start
2. fix nginx
3. just run it manually when I need it, which likely won't be often anyway.
I'm onto an entirely different problem now :D
Can I sed, back into the file it's reading from?
Sure I can test this, but....
@Burgi train station?
3:10 PM
@djsmiley2k gotta learn what each line does, not just copy-paste :P
what are you trying to do?
what kind of git server do you want to host?
'dumb' http is pretty simple (webserver config is basically just serve the directory)
'smart' http needs server side script
which means you either need one of the git web thingies (language depends, e.g. gitlab uses ruby on rails) or the basic cgi script
pxe looks good for booting multiple computers
alternatively you can just set up nginx as a reverse proxy pointing towards another server (e.g. git instaweb)
I went with gitlab cause I wanted proper user permissions/management over http and ssh
@Bob that's what I'm thinking is cool.
doing the reverse proxy thing, but tbh I'm not sure I care enough to set it up.
3:14 PM
@djsmiley2k yea I went reverse proxy into gitlab
It doesn't help I have the added complicate of vmware eating all the networking ;D
but for something simplier (short-term, few users, etc.) dumb http could work
along with, dealing with mundane tickets too.
it's really for me to see wtf I've done in git
i.e. history
rather than cli.
then you'd want one of the git web thingos
or just view it locally in one of the git history browser things
I prefer a local client tbh
@djsmiley2k windows or linux?
git extensions is by far my favourite but it's mainly targeted at windows gitextensions.github.io
linux host.
3:17 PM
@Bob linux host
@djsmiley2k I mean where you want to view it :P
errr, linux guest in vmware, running the git server :P
Oh, don't really care
You did just point out I could point my windows git gui at it instead
that'd work too
I just expected the git-daemon to have some kind of web front end I could enable in nginx as well.
I've moved onto working with sed :D
@djsmiley2k the core git stuff is veeeeeeeeeeeeery simple, last I checked
I think gitlab is your best bet for a full-fat self-hosted one with fancy commit graphs
but I still find them less flexible than a good local gui client
and the bigger ones are a bit of a pain to set up and maintain
1 hour later…
4:34 PM
@Bob See, I didn't care about any of that stuff, I just wanted a 'here are the files, here is the history of the files' but I'm thinking that it maybe easier to setup
Ok, this weirdness gets weirder
the file creating the routing table? 600~ lines.

The routing table? 2100 lines....
Something is very wrong here, I don't yet know what
5:16 PM
me too.
the file creating it 3200 lines?
The table, 8540 line?
The weirdness gets more weirder for linux
I don't know why those numbers are so big.
of course Git is simple
@djsmiley2k takeout apparently
me too
Morning all
> Combined 32/64 bit version, supports Win 98SE/ME/2k/XP/MCE/2003/XP64 and Vista/Windows 7/Windows 8.x/Windows 10 x86/x64
Holy frik
Q: Issue with installation of Mendeley plugin for Microsoft Word 2019

user3885535I am trying to install Mendeley plugin for Microsoft Word 2019 v16.01 via standart menu Tools in Mendeley Desktop 1.19.3 and it just hangs and no respond. Then I tried to install it manally by copying .dotm file into Autostart folder of MS Word. Mendeley recognizes it as installed but if you try ...

5:23 PM
@Bob Well, sucks for that company then
6:03 PM
@zixuan lol yes it's weird
part of it is due to the fact the routing table lists broadcast and loopback addresses
but i removed them and there's still 3x too much
Yeah, I still have 4x lines after I removed all the extra things.
1 hour later…
7:39 PM
wait wut
are you doing the same thing as me o_O
8:18 PM
@bwDraco Nice shot!
Thanks :)
We had a very large moon near the horizon, but it was just bright yellow. No redness at all. :|
That was... ~12 hours ago though, so probably a bit after the eclipse.
Moon photography is a pain in the ass though. The bloody thing keeps drifting out of frame.
8:34 PM
I feel I need my school to give me a bigger office... If not for imaging, then at least for my image
Go vertical! Start expanding in the roof crawl space.
8:52 PM
@Burgi The geezer on the left looks like Bill Gates :)
What does @Bob normally say about cheap VPS deals? Contabo has some offers with numbers that look too good to be true but I am pretty sick of my super-cheapo one falling over all the time
Also... also... didn't I swap out apache2 for ningx on that VPS?
So why are you running, apache, and ngix is sitting quietly in the corner waiting to be started
9:29 PM
@CanadianLuke As a student in university, I also feel the same way.
@bwDraco You win!
@MichaelFrank And you can't use shutter speeds longer than about 1/2 to 1/4 second (at 300 mm equivalent). That's when motion blur starts to impact the image.
And it's a really dark subject.
Hey, quick question, can I open a .txt file and type something in there and convert it to an image file like .jpg or .png? I'm sure this has been asked before.
yeah but it won't be an image and just be corrupt when you open it in an image viewer
just change the extension to jpg or png
I want to type in a red pixel dot, and incrementally type different colors in until it becomes an image.
9:41 PM
I'm sure Clippy will be happy to help
This should be possible, in theory.
@bertieb yeah! he popped up but 0 search results for that.
9:59 PM
maybe no
@Nick No. The file headers will still say it's a text document.
Or whatever the equivalent terminology is.
@MichaelFrank so, handcoding an image file is not possible?
Sure, just not through a .txt file.
Whoo, 36 laptops imaged in my office.... I'm ready for a break!
@MichaelFrank if I touch a new file and open in it vim or something, what do I type in to get a proper image file?
10:12 PM
... Images are not ASCII files, they're binary
@CanadianLuke so, 1010011...?
.... No
You can have ASCII files, or Binary files. Binary files look like gibberish if you cat it out to the console
Look up how to make .BMP images from text first. That'll introduce you to the HEX used, then you can move up from there
meaning you can't type in binary and expect the file system to retain it just like that? is that it?
@CanadianLuke ok, thanks for the direction!
10:14 PM
When you type binary (1's and 0's) into a text file, it encodes it as ASCII characters
@Nick onlinehexeditor.com - Try comparing some ASCII and binary files.
you can use pxe
10:29 PM
does this mean I can encode this into pixels?
@zixuan how so?
In computing, the Preboot eXecution Environment (PXE, sometimes pronounced as pixie) specification describes a standardized client-server environment that boots a software assembly, retrieved from a network, on PXE-enabled clients. On the client side it requires only a PXE-capable network interface controller (NIC), and uses a small set of industry-standard network protocols such as DHCP and TFTP. The concept behind the PXE originated in the early days of protocols like BOOTP/DHCP/TFTP, and as of 2015 it forms part of the Unified Extensible Firmware Interface (UEFI) standard. In modern data centers...
Well, I mean network booting.
10:46 PM
oh, for imaging multiple systems over the network.
1 hour later…
11:49 PM
@Nick you need a hex editor
Or to convert the file to text, edit it and back

« first day (3090 days earlier)      last day (180 days later) »