« first day (1756 days earlier)      last day (2011 days later) » 
00:00 - 15:0015:00 - 00:00

3:00 PM
Also btrfs is probably not the best choice for a boot drive
has had issues with some kernels not booting
 
@JourneymanGeek LSI spitfire
 
ooh
14.04?
MAY be kernel related
er
the link isn't kernel related
 
Bob
ok, attempt to get ZFS up, round 2
 
o_O
the system booted
dafucque
 
@allquixotic hot spare kicked in?
 
Bob
3:09 PM
Ha, VMware emulates some ancient BIOS firmware:
 
lol
and a 440bx chipset if memory serves
 
@djsmiley2k there is no hot spare.
(nor spoon)
 
weird.
nor cake?
 
there is cake
wait; that's a lie
 
Bob
@allquixotic Congrats, you might have managed to install a system less stable than mine! :P
 
3:12 PM
okay, this is weird
 
Bob
I really need to build a Debian live disc with ZFS and EFI support :\
 
the zpool is "online" with "no known data errors" but it's not showing up under /z
 
Bob
But I also don't want to spend the time learning how.
@allquixotic zfs mount?
 
@Bob I just have a raw zpool, not an actual ZFS slice
 
Bob
o.O
 
3:16 PM
nice, fsck.zfs immediately exits with 0 status
 
I didn't think fsck.zfs existed.
The whole point being 'it can't go wrong'
At least that's what ryao told me
 
Bob
more like "the only way it can go wrong is so horribly that you might as well pull the backups out"
 
well, it's online now and it works
 
Well his views on that were a little more than disturbing too
@allquixotic it's back?
 
yeah, i rebooted and everything is fine O_O
 
3:19 PM
That's what it wants you to think ;)
 
~# btrfs scrub status /dev/sda2
scrub status for 4aeb8f2b-ed97-476b-858e-2a73b7698499
        scrub started at Thu May 28 11:17:27 2015 and finished after 18 seconds
        total bytes scrubbed: 3.77GiB with 0 errors
both btrfs and zfs have checksums for data and metadata, so the likelihood of the checksum being corrupted in exactly the right way to coincide with the random corruption of the data is exceedingly low, unless I'm being hacked by someone who proved P=NP and has exploited that to trivially crack hash functions like md5
the zfs scrub is going now, but I doubt it'll find anything, since the original crash was due to a btrfs error
hmm
 
and yet it did??
 
now I'm tempted to change my / FS to XFS (with checksums), since XFS is a lot more stable than btrfs
~# zpool status -v z
  pool: z
 state: ONLINE
  scan: scrub repaired 0 in 0h6m with 0 errors on Thu May 28 11:25:07 2015
config:

        NAME        STATE     READ WRITE CKSUM
        z           ONLINE       0     0     0
          sda3      ONLINE       0     0     0

errors: No known data errors
and I trust ZFS's scrub even more than I trust btrfs's
I think what happened was a transient in-memory corruption with btrfs
basically, it tripped over itself while doing something in the kernel data structures, but never wrote out that corruption to disk
 
Bob
@allquixotic Why not ZFS? :P
 
@Bob because I'm too chicken to do it "The Right Way"
and I have hardware RAID anyway
 
Bob
3:27 PM
@allquixotic Well, "The Right Way" of ZFS is don't use Linux, or don't use it for root, apparently.
 
@Bob right, but "don't use Linux" translates to "don't successfully use hundreds of open source programs that only compile cleanly on Linux and maybe Windows and BSD, but not Solaris" (unless you VM Linux, but eh)
Linux = compatibility with code I need
ZFS = reliability and performance I need
hardware RAID = CPU offloading of parity calcs I need
btrfs = I could easily replace it with something else, but it's there, so meh
lxd = container isolation I need (though Solaris/SmartOS containers work great, too)
leaves me with few options
I hate having that crash be a mystery though
wow; lxd is actually patched now to support my work environment! :P
awesome - github.com/lxc/lxd/commit/… - lxd 0.10 is out
 
I really hate it when I have to review borderline questions. Like I guess this is a question it just feels like there should be more.
 
Bob
>
Error 503 No healthy backends

No healthy backends
Guru Mediation:

Details: cache-iad2130-IAD 1432827630 1321203751

Varnish cache server
 
Bob
welp imgur died
 
3:41 PM
@Bob what do? Do I accept the question since I can't mark duplicate from outside site? Or do I flag?
 
Bob
@Griffin we don't consider questions on other sites as dupes
you can point them to it for more info if you want, but they cannot be closed as dupes by design
 
are verifone's on topic? stackoverflow.com/q/30488124/792066
 
@Bob So it's a valid question? It seems.... low quality but a decent question.
 
Bob
funnily enough, I was searcing for a meta topic on this and I forgot I answered it o.O
4
A: Can questions be duplicate if the duplicate is on non Stack Exchange site?

BobNot just on the same network. We only mark questions as duplicates if they are on the same site, e.g. a question can exist on both SU and SO wihtout being marked as duplicates. See: What to do with cross-site duplicates? You can comment with a link to that other site, if you want to. If you wish...

 
@Bob and tried to upvote it?
 
Bob
3:44 PM
@Griffin could probably be tidied up a bit, but it looks alright
questions don't have to be long as long as they are clear
@Griffin note: the SO question you link to discusses the programmer's side, not the user
this is one reason we don't close cross-site dupes
often they aren't actually dupes
 
@Bob In this case though it seems to be answered by the creator of the virtual keyboard thing correct?
Jw because if so I'll just rephrase him and point to the question.
 
Bob
@Griffin there is no the virtual keyboard
there are many virtual keyboards
 
I'm talking about the one he referenced in his answer.
The Florence Virtual Keyboard guy.
 
Bob
an answer applying to multiple questions does not mean the questions are identical.
 
Yeah. That's why I want to answer by rephrasing his. Just making sure it's a valid answer. You were talking about how it's from the programmers side. Didn't want my answer to be too skewed.
I yolod and answered it anyway.
 
Bob
4:20 PM
!!zalgo HE COMES
@allquixotic Cavil's still snoozing...
 
google I/O
star it or something :/
 
4:35 PM
@djsmiley2k Great, what new pretentious broken technology are they going to sell us this year (that drops out with bluetooth)?
oh, I get it, $500,000 worth of high-res displays looking like 3d
!!tell 21884793 zalgo HE COMES
 
@Bob H̓̏̅ͣ̉̎ͯ̾̒ͤ̅̄́҉̵̯͖̮̘͞ͅĘ̾̿ͪ̈́ͫ̆͊̚͟͟͞͏̠̳̞̗ ̴̢̻͎͉͉͈͙͎ͥ͛̃̆̿̄̆̈́ͮ̈́̑̎̄͗̉̎̕͢Ċ̒̾̅̓ͫ͊ͫ̐̇͑̉ͤ̉̂҉͉̯̩̯͉̲̠̟͓̀́Ơ̧̛̥̟͕͗̃̄̿̏̈͑̄̔̆ͫͩ̍̿̔̾ͥ̾‌​̯̝̹͎͇̫̩̰̖̬͉̭̲͓̻M̢̌ͣ͊̉ͥͬ̓ͮͣ͏̣̭͔͍͇̞͍̙̪̼E̢̹̼͇̣̘̲͉̥͈̠ͭͫ̑̇ͩ̎̂S͕͕͉̤͔̙̾̓͛̿ͫ̂̍͒̔͊̓̿̈́ͫ̌ͦ̇͞‌​̣̩͖͓͚͔
3
 
@allquixotic You forgot "...that they're going to drop support for in 3 years 'cause it's not really taking off like they'd hoped"
 
Bob
@allquixotic I have absolutely no idea what's going on anymore :(
sigh yet another rebuild of the zfs module on the live env... in for another wait
 
@djsmiley2k There. You got an "or something".
 
@Iszi yup
 
Bob
4:44 PM
@allquixotic I'm thinking my next step is to just abandon all this EFI stuff and just stick with GRUB & MBR & BIOS :\
this is getting annoying. I'm tantalisingly close, but all I get is a blank screen - how do you even troubleshoot that?!
 
@Bob you could quite easily just use linux-md software RAID-5 and deal with the RAID write hole when it comes (and it would definitely !!zalgo COMES sooner or later; power failure, kernel panic, whatever)
everything you need for linux-md + xfs is built into the kernel and it can install / and /boot on it no problem
or use raid-2 or something
 
Bob
@allquixotic eww
 
there are no easy solutions when you have 3 disks, unfortunately
to use all of them I mean
 
Bob
I'm thinking just chuck the boot partition on the flash drive
 
raid1+hs
 
Bob
4:46 PM
and I'll keep an image in the zfs pool
if the drive dies I can easily restore the image
 
that works. and what would you use as boot? xfs?
 
Bob
@allquixotic fat32? :P
or ext2 maybe
 
no, at least have a journal
 
Bob
boot's just gonna be a tiny partition with GRUB on it
@allquixotic it should be read-only
 
@Bob and your kernel, and initramfs
any time you upgrade linux-image-generic it's going to write to it
 
Bob
4:47 PM
@allquixotic Nup, GRUB has enough support for ZFS to not need that... supposedly
 
?
so you can put kernel and initramfs on /?
 
Bob
there's a special ZFS build of GRUB
 
hmm
TIL
okay, so all /boot would have is grub stage2... which would have some kind of a zfs driver
sounds legit
 
Bob
> Recent GRUB releases assume that the /boot/grub/grubenv file is writable by the stage2 module. Until GRUB gets a ZFS write enhancement, the GRUB modules should be installed to a separate filesystem in a separate partition that is grub-writable.
ha
that was 2012, no idea what the status is now
they also included some hacks to work around it (remove some lines of script that write there)
but that's if I can't get the EFI stub working
it gets me into an ZFS-compatible prompt... just won't auto-mount and boot :(
 
5:01 PM
:( When you don't get upvotes cuz you ain't as cool.
 
you guys watching I/O?
he's going on about always on maps
and it turns the display off :D
 
Why is expanded card a privileged? What is so special about that?
 
lol
dunno, i'm abouty to unlock mine soon on arqade tho a`o/
 
5:18 PM
Or seeing the upvotes / downvotes...
@djsmiley2k You play Witcher 3 yet?
 
no
no pc games for me
 
It's on console.
 
O
well, still not yet haha
I'm currently playing dragon age 2 on my ps3
such huge backlog
 
And it is wonderful. 36 different endings. Your decisions matter. I called out some priest that was hating on me and 10 hours later he sent guys after me. I was like "What the hell? I did that ages ago?"
I take a good long time to make a decision. Especially with the woman. Currently it's not going well. I told them both I love them because I didn't want to hurt their feelings. Sometimes the game can be a jerk and force you to make quick decisions.
 
Bob
@allquixotic Yea, I think it's time to give up.
Pretty sure this thing is just trolling me now.
 
5:25 PM
Turn job control on?
I dunno. Have no clue what you're doing or what's going on.
 
Bob
That has nothing to do with any of this.
 
@Bob :/
 
Bob
@allquixotic Well, unless you have another suggestion.
At this point, I don't think I could possibly make it worse.
(famous last words)
 
Bob
5:44 PM
@allquixotic Urk... three days so far and I still haven't gotten to lxd :S
 
honestly, lxd will be the least of your worries
it's NOT that hard to use, and it works
I had sadface questionmarks on my head for a few hours, total before lxd became so easy to use that it's just a part of the background, now
me upon installing lxd for the first time:
me upon fixing lxd:
 
Bob
@allquixotic I'm still in that state re ZFS
:(
 
unlimited photo storage... hmmm
why am i paying for google drive again? :D
 
Bob
 
I liked the arctic fox you used to have.
 
Bob
5:55 PM
Huh?
 
A long time ago your avatar used to be an arctic fox if I remember correctly.
It was pretty.
 
Bob
Which one? I have lots :P
 
Today it's scheduled the beginning of a strike
Today my coworkers decided to have lunch at a nice restaurant and forgot to tell me
 
Bob
"forgot"
 
I just noticed how empty the office was, and someone told me they left and didn't intend to come back
 
6:03 PM
btw @JourneymanGeek, puppy is back up, and according to ZFS there was no data loss at all
@ThatBrazilianGuy are you a loyalist? :P
 
@bob yeah, I don't know how much it was intentional, and how much it is because I and other guy sit past a corner and the rest of the team sit together
Or maybe because I silenced the unnoficial Telegram group that's supposed to contain urgent work stuff but is 75% inane stuff
It's like another Facebook
@allquixotic hahahahahaha
 
A crafted text message can crash the iPhone
 
@Dra
 
Bob
o.O
 
@DragonLord so yesterday
@Bob Yes. It was very pretty. And why aluminum tape?
 
6:21 PM
onclick=\"$('#loader').show(); javascript: return confirm('This will regenerate search results');
the dollar escaped because php
but other than that, is that allowed, two commands in one single onClick?
 
Bob
there are multiple reasons that's horrible
the first is, use of onclick and related is generally discouraged. addEventListener (or jquery on) called from the script itself is often better
also, why is there a random javascript: there?
 
because the internets said so :D
it's meant to 1. ask teh user to confirm it
2. display the loading gif
 
Bob
in this case, assuming it's a very simple app that'll never be extended, onclick is somewhat acceptable
and assuming you don't have much client-side code
 
it's very simple internal thing
 
Bob
but the random javascript: is just... bad
 
6:27 PM
it's just that
 
Bob
it reeks of code randomly copy-pasted, it's not necessary, and I dont think it even works there
 
how to pop up a confirmation box?
well it works... :D
just the gif neverl oads
loads* and yeah, it IS copy/pasted.
 
Bob
get rid of the javascript:
at best it's treated as a label by the interpreter
 
ok that's gone,
button still works correctly at least :d
 
Bob
also pretty sure you haven't escaped the $ correctly
 
6:37 PM
yeah wasn't the $, was the "
:D
 
 
1 hour later…
7:44 PM
Huh... Hola Better Internet is effectively a botnet:
http://lifehacker.com/hola-better-internet-sells-your-bandwidth-turning-its-1707496872
 
8:04 PM
So, I wrote some macros a few weeks ago, and my temp gig is ending, so they want instructions on how to use it.
The easy part was showing screenshots of state before and after each macro is used.
But now someone points out they need instructions on how to get to the macro.
This is in Word, so it may not be trivial to put a button in a workbook that they can click on.
There's some Ctrl+F9 do-hicky, but I haven't figured it out.
*yet
 
@MichaelFrank I round out about the service (Abd similar ones) a few days ago and it sounded extremely suspicious
 
I don't understand what would be the most "user-friendly"way to access a macro in Word.
Like, drop in and play.
 
> Like almost every free VPN, using it comes with a tradeoff, whether it’s in slow speeds, limited bandwidth, or your browsing history being used for advertising, but in this case the adage that “if you’re not paying for it, you’re the product” is literally true
After I learned about the service, I've seen a lot of people using it at home, work and their phones
(I consider 4 people in a week, all non techies, a lot)
 
I kind of like the Macro Workbook approach in a shared directory, so that users will always have the updated version, as opposed to the file in your %APPDATA%, but still the macro should be easy to access. I guess there's always View -> Macros -> ...
But then, every time you run a macro, that pop up menu closes.
oh cool, there's an Organizer menu from Macros that let's you copy modules over.
 
crl
Hi, I'm wanting to count the number of commas over many texts, on windows, I've done find /c "," *.txt but it lists the count per files, I'd like the total sum
 
8:16 PM
hi all
 
@KD8NXH Hey
 
,greet @KD8NXH
 
9:09 PM
a box elsewhere isn't exactly expensive...
 
9:45 PM
heh... Called a user that had a job logged about some software that wasn't working correctly. Apparently the software fixed itself, but then she mentioned that her desktop has been randomly restarting multiple times a day for about a week.
 
.
 
10:07 PM
Sigh.
hey my brakes work again, that's odd... Anyway, the engine cuts out every 3-4miles but meh i'll carry on.
 
That sounds somewhat inconvenient.
 
11:09 PM
@MichaelFrank oh yeah, the tack-on issues... "Hey, thanks for fixing my problem about XYZ! Can you fix ABC too?"
I shudder to think of how many broken issues people live with from day to day
 
11:45 PM
@allquixotic Thanks
 
00:00 - 15:0015:00 - 00:00

« first day (1756 days earlier)      last day (2011 days later) »