« first day (1 day earlier)      last day (46 days later) » 

8:26 AM
Hello :-)
I have been making some tests and I have good news.
Reading and testing about UART, it transmit 10bits for each (8bit) byte of data: First it transmit a "10" and then the data.
Also, it transmit first the less significant bits and after the most.

Example: x05 will be transmitted as 10-10100000
With this in mind, the screenshot of your oscilloscope transmit following to the servo:

10-10101010 10-10101010 10-10000000 10-11000000 10-11011000 10-00000111

In numbers:

x55 x55 x01 x03 x1B xE0

Adding semantic:

0x55 0x55 (initial tag)
0x01: Servo ID (1)
0x03: Size of the data (by the doc, this includes from the size to the check-sum)
0x1B: Read Input voltage request
0xE0: checksum = ~(id+length+params) = ~(0x01+0x03+0x1B) = ~(0x1F) = 0xE0
Then I tried to send those values through the RaspberryPi, and the oscilloscope give me the exact signal you shown.
However the servo is still not responding, so I am wondering the following issues:
- The servo has burn, due to any mistake during the test.
- The servo expect 12V signal (HV version). I expect the signal to be 5V even if the input voltage is 12V. Trying 12V bus imply burning the servo in case it expect 5V.
- Any other error in the electronic (?)
11 hours later…
8:07 PM
When you have a moment, could I ask you try to connect higher voltage to the board?

1) Disconnect the servo (as it is not HV)
2) Connect a higher source to the board, e.g. 8V should not be a risk for the board
3) Send some signal (rotate or what-ever).

4) See if the signal is 5V or 8V?

« first day (1 day earlier)      last day (46 days later) »