« first day (709 days earlier)      last day (729 days later) » 
00:00 - 16:0016:00 - 23:00

12:00 AM
Shift-clicking in the Finder is weird. At least in icon view.
standard table view is sensible
 
12:16 AM
@bmike Will take a look.
 
 
5 hours later…
5:28 AM
So the Notification Center app seems to be where a fair bit of the Mountain Lion magic happens… and it appears to be utterly unscriptable, Automator unfriendly, and without obvious hooks.
Why Twitter sharing belongs in Notification Center I have no idea.
 
because iOS did that.
 
hmm…
 
erm
iOS will do that
yeaaaaaah NDA! :D
sharing via the drawer is new in iOS 6. Both Twitter and Facebook (and maybe the equivalent Chinese services?).
 
This is why I don't want developer access. Yes, I'm at a disadvantage compared to people who know the APIs, but anything I can discover by poking around I don't need to be afraid to share with the world.
 
it's ok, everyone breaks the NDA anyway
like TUAW :D
 
5:35 AM
In iOS, it doesn't seem like a monumentally stupid place to tweet. On the Mac…
But here's @jtbandes. Thanks for the heads up about NSSharingService
 
@DanielLawson I did find that you can set a hot corner to activate NC using AppleScript
Also you're welcome :)
So I'm thinking, you could just set up the hot corner and use some kind of script (see the link I posted) to move the mouse and activate it
 
p.s. want to tweet fast? Use Wren
 
You can trigger NC with a hotkey, and AppleScript can send key codes
 
For bonus points, unset the hot corner after activating it.
That works too.
Wren is pretty. Why haven't I heard of it before?
 
Because you don't listen to our podcast.
 
5:37 AM
That's probably why.
/me goes to the corner of shame
 
excellent
 
So one can activate NC via AppleScript. One can click absolute coordinates via AppleScript. This might be workable yet, but it's UGLY.
Damn it Apple, release your new app with a Scripting Dictionary.
And some good Automator Actions for good measure
 
Isn't Applescript going the way of the Dodo? Something about it not working on Sandboxed apps?
 
@DanielLawson well, you can use System Events from AppleScript to click on arbitrary UI items using the accessibility framework. I'm just not sure if you can get at whichever app hosts NC.
(I had thought it was the Dock, but I played around for a few minutes and couldn't find any of the NC elements)
 
/System/Library/Core Services/NotificationCenter.app hosts NC
 
5:40 AM
...oh
well.
in that case, hang on
 
(and the fact that I can type that without looking it up says I've been spending too much time there today)
 
(really? that's weird, because I'd think the dock has to deal with the swipe gesture)
 
Are Launchpad and Mission Control both in the Dock?
 
I think so
 
they are dockable, yes
 
5:42 AM
@JasonSalaz no, the question is whether Dock.app manages them.
 
Launchpad's its own app, and it can be invoked by gestures
/Applications/Launchpad.app
 
ummm
I doubt either of them are managed by the Dock
 
Dock used to control the Dashboard, I think it still lmight
 
Exposé was managed by the Dock process.
Right
 
Mission Control has an app too, but I kind of doubt that the app actually does the window moving.
 
5:43 AM
Right
But Dock could monitor for gestures then hand off control to Notification Center.app
Actually, that seems pretty trivial
 
could be
but I would think the same process would handle the NC animation as handles the switch-desktop animation
HAHAAH.
 
tell application "System Events"
    tell process "Notification Center"
        click menu bar 1's menu bar item 1
    end tell
end tell
 
Nice!
 
Still I don't' see a way to access any of the ui elements in the actual NC drawer thing.
OH WAIT
getting there.
wait for it.
 
5:51 AM
tell application "System Events"
tell process "Notification Center"
UI elements of window "Window"
end tell
end tell
{static text "Notification Center" of window "Window" of application process "NotificationCenter" of application "System Events", button 1 of window "Window" of application process "NotificationCenter" of application "System Events", button 2 of window "Window" of application process "NotificationCenter" of application "System Events", scroll area 1 of window "Window" of application process "NotificationCenter" of application "System Events"}
 
yeah
click first window's first scroll area's first table's second row's UI element 1's button 1
 
woot!
 
whaaaa? AppleScript can't hold modifier keys while clicking on things?
oh I see
:)
tell application "System Events"
    tell process "Notification Center"
        key down option
        click (first menu bar's first menu bar item)
        key up option
    end tell
end tell
OH DEAR GOD
Tip: NEVER EVER EVER run a script with an unmatched key down option.
 
heh
 
/me just spent several minutes trying to undo that mess
woah
 
6:06 AM
I'm at this, but my tweet button just broke. Maybe time to call it a night:
tell application "System Events"
tell process "Notification Center"
click menu bar 1's menu bar item 1
click first window's first scroll area's first table's second row's UI element 1's button 1
keystroke "spam my Twitter feed"
click button1 of UI element 1 of row 2 of table 1 of scroll area 1 of window "window"
end tell
end tell
 
lol
 
2
A: What hooks exist into Notification Center / twitter so that I can tweet programmatically?

jtbandesApps can hook into the sharing options with the new NSSharingService API. It sounds like custom LaunchBar actions can be made with any UNIX executable file, so you could probably write a small command line tool (or you may need to build an actual app — you'll have to test it out) which activates ...

updated
 
It's disappointing that the mountain lion InstallESD.dmg is just over 4GB
 
It's disappointing your flash drive isn't bigger :-)
 
6:15 AM
I have one that's bigger, but it's too much bigger :P
@DanielLawson I didn't know what you meant by "broke"...now I do. :/
No tweets for me.
 
killall NotificationCenter; open /System/Library/CoreServices/Notification\ Center.app/
and you're back in business
(I think)
But I'm signing off for the night. I'll leave the exploring in your capable hands.
 
I'll give up because I can see the bugginess could drive a man insane.
good night :)
 
I had broken Notification Center entirely somehow the other day.
You couldn't scroll around in it, and one notification was permanently stuck.
and the tweet button disappeared
10.8.1 :D!
 
6:48 AM
@jtbandes Yah. I would (strongly) advise against it.
I did that with the shift key. Lucky for me, I just ran a script (in all caps) that undid it, but boy was it scary for a second!
 
Option is hard because you can't really type...
I'm gonna file a bug regarding that. It's dangerous and easy to do.
0
Q: My Launchpad organization was reset with Mountain Lion. How can I recover it?

jtbandesI had neatly sorted the applications in Launchpad when I was running Lion. But after upgrading to Mountain Lion, none of my custom folders are there any more, and it seems Launchpad is back to the default layout (the first page being all Apple apps). Is there a way to restore the layout I had in...

 
7:00 AM
Well... I thought I had an 8GB USB drive somewhere... but maybe not.
 
@jtbandes Yeah, at least I made the mistake with shift. What did you do to fix it?
 
Scrambled around for a while trying to select text / use the clipboard from the menu, save the script as an app to run it, etc.
 
7:31 AM
Question about the Mountain Lion challenge: What's the 75 rep drawing? 75 Rep total between all Q&A, or on a specific one?
 
Sounds like total.
I had been seeing some minor text rendering bugs in ML... but this takes the cake
 
Moderator advice please, on whether the following will be an acceptable question:
What free and open source software can I use with OS X to verify readability or integrity of every block of a disk?
My concern: avoid favouritism.
Edit: What free and open source software can I use with Mac hardware to verify readability or integrity of every block of a disk?
Incidentally, unless I'm missing something, I can't find any similar question without the FOSS criterion – that's surprising.
 
8:02 AM
… I found a comparable question in Super User so I'm gonna go ahead with the question.
 
8:28 AM
This is bizarrely arbitrary: nytimes.com/2012/07/26/technology/…
 
I think that's what he was going for.
 
Someone here already running mountain lion / safari 6 who could give me a hand debugging something?
 
@balpha <--
 
cool
can you put this in the javascript console:
(function(){"use strict"; var f=function () {}; (function () {var f ={}; f.name="foo"; })(); })()
and let me know if it throws an exception?
 
first I have to figure out if the javascript console is even still accessible...
hmm
I think I did it?
(function(){"use strict"; var f=function () {}; (function () {var f ={}; f.name="foo"; })(); })()
undefined
 
8:43 AM
hmm, so no exception
how about this?
(function(){"use strict"; var f=function () {}; (function () {var f =""; f.name="foo"; })(); })()
 
that's not any different?
oh, never mind
(function(){"use strict"; var f=function () {}; (function () {var f =""; f.name="foo"; })(); })()
TypeError: Attempted to assign to readonly property.
 
excellent!
... in a way
last one:
(function(){"use strict"; var s=""; s.name="foo"; })()
 
same error as last
 
okay, thanks a lot
 
you're welcome
 
8:46 AM
that'll help me fix this
10
Q: Safari is asking if I want to leave the page when saving my edits

vcsjonesWhenever I edit my own answer, and click Save Edits, I get the dialog confirming that I want to leave the page: It should just save my edits as I am trying to save them, not cancel them. This is happening for me on Safari 5.1 / OSX. EDIT: Safari 6.0 now consistently reproduces this problem. ...

 
I know a few people here will be very happy.
 
oh, one more:
(function () {"use strict";function f() {};f.something="foo";})()
 
undefined
 
oh oops, that was the wrong one
(function(){"use strict"; var s=""; s.something="foo"; })()
 
back to the same TypeError
 
8:50 AM
great, thanks again
 
you're welcome
 
@balpha while you are here, presuming you did the Mountain Lion page - presume that the blog challenge is not automated, do you need to poke it to get my name to appear? Thanks :)
Also, great work on the page, I really like the promotion styles
 
sorry, that wasn't me; emmet did that
I'll poke him with your question
 
Cheers :)
 
9:15 AM
@gentmatt my notification center question has 1k views, and 4 votes. Your CW has 2k views, and a bazillion votes.
I've got my "popular question" badge for it, now I want my "good question" one - get voting users!
 
@stuffe I new that was going to happen :)
 
10+ Q&A are still pretty rare here
 
My battery menu question is also very popular. Clearly many people complain...
0
A: What un(der)-documented features have you stumbled upon in Mountain Lion?

gentmattUser prompt for address book access This has only been officially announced for iOS 6 but quietly made it's way into Mountain Lion. Your address book data is located in: /Users/my_name/Library/Application Support/AddressBook So far, I've used a firewall to controll read/write access on a per...

Before Mountain Lion:
 
I only have 1 nice question full stop - getting one in 6 days will be tough
 
Now in Mountain Lion:
 
9:19 AM
Perhaps I should ask if GIMP is Mountain Lion compatible ;)
2
 
@stuffe How long is the contest running? Only one week?
 
Wow, I only have 5 nice answers too - and one of those is THE GIMP
5 days left
The contest starts on Wednesday, Jul 25 12:00 AM UTC and ends on Wednesday, Aug 8 12:00 AM UTC.
 
Ok.
Man, Chrome just crashed again...
it's quite unstable for me so far. This is the forth time in one day.
 
Can you put your Chrome notification issues into the question or as a comment?
you chrome boys.
You should stick with stock ;)
 
Chrome notifications works fine for me.
 
9:22 AM
I love Safari, I don't even have another browser installed, not even for backup ;)
I thought they were dissapearing for you when they notified through chrome?
 
ewww!
 
I stopped using Safari for one reason:
it's stupid stupid stupid reload this page when you click back to it in 5.0 caused me to lose my timesheet
twice
not to mention, Chrome's custom search engines and what not features are SOOOO good
2
 
@stuffe I was a temporary error. After another reboot I haven't experienced any significant issues.
 
Hmmm
ok
@JasonSalaz Yeah, there should be a simple test - if text is entered anywhere on teh page, not safe to drop. Having said that, I have never even really noticed it happening, never mind been bitten by it.
 
@JasonSalaz Firefox can also get this feature via addons.mozilla.org/en-us/firefox/addon/instantfox
 
9:26 AM
oh god
firefox is WORSE
paaaass
 
@JasonSalaz Yes. I know. I really like some extensions, but the scrolling is horrible.
 
You know, there is a genuine Mountain Lion/GIMP question to ask :)
Because there is no X11 in ML, and GIMP needs it.
 
there is too
 
NoScript, Https everywhere, Ghostery, Flashgot, Instantfox, .... <3 These extensions are much more powerful in Firefox than in Chrome (if available).
 
3
Q: X11 Install in ML

Daniel LawsonIn my newly-installed Mountain Lion system, when I try to run an app that relies on X11, I get the following error message: Apple's Web Page indicates that this is not the expected behavior: X11 install on demand X11 on Mountain Lion now uses install on demand. When you first launch an...

 
9:28 AM
ha!
For the purposes of debugging potential promotion issues.
Does anyone know what will happen if I simply retag an old question as Mountain Lion?
 
┐('~`;)┌
 
Wonder if it will trigger the requirements for the promotion? Cos if it does, it needs squashing
 
@stuffe Twitter will break down again.
 
I broke my twitter already, in notification center.
Start a tweet, hit escape, etc voila - it's broken!
 
works4me
 
9:33 AM
NC closes, and when you reopen the button is dead
 
@stuffe I know now in more detail what happened yesterday. (about NC)
I wanted to restart/reinitialize the NC center and looked for the process in the Activity Monitor. But I only found the process notifyd.
The NC process Notification Center wasn't even running. I just discovered it.
So that's why the reboot helped in my case. As I said: It wasn't working for Chrome at all.
 
Ping me please?
 
@stuffe Bacon ipsum dolor
@stuffe capicola jerky drumstick ribeye ham bresaola
@stuffe Tri-tip chuck short ribs sausage jerky, filet mignon meatloaf pancetta brisket.
@stuffe Pig leberkas pork chop chuck. Chuck ball tip leberkas t-bone biltong andouille tongue drumstick brisket short ribs turducken ribeye.
 
thanks
Just screencaptured it
 
For anybody using screenshots. Remember that you can take one from the terminal without the background shadow using: screencapture -wxra ~/Desktop/screencap.png
 
9:44 AM
does it only happen with browser desktop notifications?
 
The only other thing I have seen put anything in there is mail, and that works fine.
 
@stuffe What's the problem here?
 
watch safari's notification disappear
 
The notification is alert style. It should stay until acknowledged.
Only banner styles should dissapear on their own.
 
alert's shouldn't disappear from NC at all
 
9:46 AM
And regardless of it is banner or alert style, the most recent 5 should stay in NC, and they all dissapear, not just as the actual notification, but also from NC
 
Ok. Yeah, I also encounter the latter.
 
OK, who is on messages? That should populate NC also.
 
Me.
 
ID?
 
I'll DM you my email.
 
9:49 AM
ta
I just received all that 4 times by the way on all my stuff!
 
Ha! That's funny. It reminds of this:
 
10:20 AM
Thanks @gentmatt, I got 2 screencasts of different bugs and added them to the questions.
Also, if anyone wants to swap iMessage IDs, mine should be easily guessable being xxx xxx(notreallyxxx, but a 3 letter short name)@myprofilename.net
 
11:18 AM
1
Q: Unable to run Office with same product key

MachineI'd bought MS Office which was allowed to use on 3 Mac OSX with same product key. It was/is working fine when I'd installed it on 1st Macbook Pro. When I'd installed it on my iMac then MS Word, PowerPoint and Excel are working fine with same product key but MS Office is not working and getting al...

 
 
3 hours later…
2:05 PM
@gentmatt There's some official sources for you.
 
@stuffe is that notification in Mountain Lion a notification from Ask Different Chat? Or from some other part of Stack Exchange?
 
2
A: Why do some Macs not support Power Nap in Mountain Lion?

Daniel LawsonOnly the MacBook Air (Mid 2011 or newer), MacBook Pro with Retina display are supported for Power Nap. The reason for this is An SMC update is required to gain all the functionality of Power Nap, and these are the only models Apple has chosen to actively write the firmware updates to support the ...

 
Does anyone else find that the disc for Ubuntu 12.04 desktop (i386) fails to start Mac hardware? Here with a MacBookPro5,2 the boot process seems to stall – every time – but not at the same point every time.
 
3:01 PM
@DanielLawson That last paragraph which you have added is very good. Thanks!
 
That question seems to be hard for people to wrap their minds around what you are seeking...
 
Basically I'm asking if the lacking support for this feature is a hardware limitation or not.
 
That's how I read it.
 
Do you want to edit it? Feel free to do so :)
 
I might try answering it first.
short and sweet - yes it's a hardware limitation.
(and I'm not complaining at all - just observing)
 
3:10 PM
I doubt that it's heat tough.
It's rather the spinning drives in HDDs.
In the MBP the HDD/SSD is located where the Macbook Pro is the coolest.
(At least this is true for the 15" unibody MBP.)
Daniel's argument that the user share that has upgraded to SSDs is too little is the most convincing so far - IMO.
 
It's not heat
It's power consumption ;-)
(which is why I'll probably put my hat into that ring)
 
Aha, interesting. Well, I'm curious to hear what you have to say.
 
how's mountain lion treating you guys? should i upgrade or should i hold off?
 
UPGRADE!
 
any problems with apps and compatibility?
 
3:17 PM
Some Notification Center bugs, but other than that is running great for me.
 
i can't afford any major downtime!!
 
Don't upgrade
 
ok i'll upgrade tonight.
 
@hanleyhansen Which one do you have?
 
how long did it take?
@gentmatt lion
@bmike why not?
 
3:18 PM
(don't ever change anything when you can't afford major downtime)
4
 
No, which apps?
 
@gentmatt nothing crazy. but i need xcode and vmware fusion to be working.
 
Now - I would say install Mountain Lion onto an external drive and migrate things to it overnight.
No need for a bootable backup when you still have a bootable Lion on your internal drive.
 
and then the stuff like skype etc
 
Uuuh. I can't say anything about VMWare fusion. I also don't use skype....
 
3:19 PM
That way you can go through all your apps to see which ones are cranky.
 
@bmike might go that route
i do web development and ios developement so i need vmware fusion to access my visual studio instance for a project i am working on.
 
Most mainstream things are well known what bugs are around (MS Office, Adobe, virtualization, etc...) so you won't waste a lot of time guessing why things are wonky. Most app store apps are great since the devs there are ahead of the curve on testing with new OS.
It's been painless for most, but when you have a critical work machine, think nothing of running an OS that's two years old. Not broken, don't fix it.
 
@bmike yeah that makes sense. i'll google around for vmware fusion issues before committing.
 
Oh - and the update on my Air took 20 minutes. Start to finish.
 
@bmike that's not bad
@bmike do you see any speed improvements? i just ordered an ssd. i'm thinking of installing my ssd and making sure that's all worked out before even thinking about ML
 
3:23 PM
I'm speedier with notification center and Power Nap - the machine is so fast I'm never waiting for it even on Lion.
It's the maxed out 11 inch model from before the last upgrade.
I'd upgrade to Mountain Lion on your internal drive first.
 
i have the MBP from early 2011 so from what i've read i won't have Power Nap right?
@bmike before the ssd?
 
yup x2
 
@bmike fail to the power nap
looks like my version is ok: blogs.vmware.com/teamfusion/2012/07/…
 
Woo hoo 10K! Now I have access to mod tools… wait a minute
4
 
Congratulations @DanielLawson
 
3:33 PM
thanks!
 
0
Q: How can I clear the JavaScript console in the Safari 6 developer tools?

Nathan GreensteinIn previous versions of Safari the JavaScript console in the Developer Tools (aka Web Inspector) had a little 'clear' button at the bottom that emptied out console items, which was useful for getting rid of clutter between debug sessions. As of Safari 6, the new Dev Tools don't seem to have such...

This is seriously driving me nuts.
Especially since the Chrome dev release is soooo unstable I've resorted to Safari for debugging :/
(/rant)
Aaaaand, someone answered it! cmd-k. I had no idea...
 
question why the hell does my mac storage graph list backups as taking up 359gb fo space??
 
@NathanGreenstein Uhh. Chrome Stable is also quite buggy in ML. It has crashed on me already like 10 times in a day.
 
@gentmatt Weird. Chrome dev has been stable on ML for months, just this last version got crashy.
shrugs
 
Lol.
 
3:42 PM
why is backup taking up so much damn space?!?! are timemachine backups stored on the computer until the timemachine drive is available?
 
@hanleyhansen Generally not, unless you have TM set to back up to the internal disk
 
@NathanGreenstein i don't. it's backing up to my buffalo but my internal drive says it has 358.6 GB worth of backups
how do i check my timemachine drive settings?
 
System Prefs -> Time Machine
 
yeah i'm there but it only lists my buffalo
 
Then that's the only place it thinks it's backing up to
Weird
 
3:45 PM
anywhere else i can look? what location would it be backing up to if it were backing up on my internal drive?
 
Afaik it usually backs up to another partition if it's the internal drive
 
only one partition here
 
Hmm. My suggestion would be to run something like DaisyDisk or GrandPerspective and see if you find any big backup images.
If not, I'd assume System Info is misreporting for some reason.
 
i'll give that a shot. thanks.
 
3:46 PM
@NathanGreenstein what should i do if that's the case?
 
I'd just ignore it
 
ok. hopefully GrandPerspective gives me some useful info.
 
3:58 PM
@DanielLawson Your answer it already very good. I'm just waiting to hear more - the bounty just started today :)
I'm especially thankful to @GrahamPerrin for linking the forum posts where they got PowerNap to work on the 2010 MBA. forums.macrumors.com/showthread.php?t=1411893
 
00:00 - 16:0016:00 - 23:00

« first day (709 days earlier)      last day (729 days later) »